Suchergebnisse

Suchergebnisse 1-20 von insgesamt 23.

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • "Wie man Fragen richtig stellt" ? Wann soll ich das getan haben? Das, was ich gepostet habe war eine Information. Da ich keine Rubrik dazu gefunden habe, habe ich ... Kritik ... benutzt.

  • mit einem neuen User hat das nichts zu tun. Die einmal so (über den Autostart-Mechanismus) gestartete Programme überleben ein Logout, werden dann erneut gestartet. Da hilft nur Suchen und killen oder rebbot. Das Ganze hat ist auch kein Effekt der nur bei openSuSE auftritt. Ich kann das auch mit Manjaro und Mint reproduzieren. Inzwischen habe ich mich bei bugzilla.suse.com angemeldet. Vielleicht findet sich jemand, der das untersucht. Möglicherweise ist das ein systemd-Problem, denn die nicht gek…

  • es ist sicher nicht unüblich, dass jemand eine falsche Rubrik wählt, um einen Fakt zu schildern. So etwas wie "Fehler oder Fehlverhalten" habe ich hier nicht gefunden. Dafür ist so ein Forum wohl auch gar nicht vorgesehen. Auch nach dieser "Warnung" weiß ich es nicht. Unverständlich ist auch, warum ich ein umfangreiches Script posten soll, wenn sich der Effekt bereits mit einem 5-Zeiler vollständig zeigen lässt. Soll ich hier veralbert werden? Auch geht es nicht darum, dass irgendwelche Prozesse…

  • Gerade weil eben alle Distris das gleiche Verhalten zeigen, ist das wohl nicht die große Sicherheitslücke, auf die du gestoßen sein willst. Das hätte, wie ich meine, niemals so lange unentdeckt bleiben können. Wenn es denn so wäre. Kannst du dir vorstellen, das Software in hunderten elektronischer Vermittlunsstellen ohne Probleme über viele Jahre stabil lief, nur in einer liefen die Gebührenzähler manchmal rückwärts? Diese stand auch noch mehrere Tausend Kilometer weit weg und wir konnten daran …

  • du hast mein Anliegen überhaupt nicht verstanden. Selbstverständlich gibt es die /etc/inittab nicht mehr. Kann mich aber noch gut an so etwas wie Zitat von xterm: „respawn :Der Prozess wird jedesmal neu gestartet, sobald er beendet ist. (Typisches Beispiel ist Getty) “ erinnern. "Dort sind lediglich die Runlevel definiert" ist also falsch. "Es wäre wohl sinnvoller für solche Startjobs einfach ein paar Unitfiles zu schreiben und die Arbeit gleich systemd erledigen zu lassen." Warum sagst du mir d…

  • Mit einem Script, das ~/.config/autostart/ aufgerufen wird, starte ich mehrere Anwendungen (tcl-Scripte). Das Script sorgt dafür, dass, ähnlich der inittab-Funktion "Programm nach dem Beenden neu starten" nach einem Exit oder Kill, das Anwenderprogramm wieder neu gestartet wird. Aus einem Terminal heraus gestartet gibt es auch keine Probleme. Sobald es jedoch als Autostart-Programm aufgerufen wird, bleiben die Prozesse erhalten, auch wenn der betreffende User abgemeldet ist. Beim Wiederanmelden …

  • Zitat von Berichtigung: „Das langweilt. Für eine Profi hast du noch ziemlich seltsame Flausen im Kopf. “ Richtig, meine seltsamen Flausen waren, den Fehler zu finden. Ein Profi wird sich nie damit abfinden, einen Fehler nicht gefunden zu haben. Da macht man auch offensichtlich sinnlose Dinge, wie in SuSE-Leap15.0 ein Boot-Script einzubauen, das "udevadm monitor" im Hintergrund ausführt und das Ergebnis in eine Datei schreibt oder (noch verrückter) in openSuSE-Leap15.0 eine virtuelle Maschine mit…

  • Zitat von Berichtigung: „Ich bin jetzt raus. Good luck. “ da freue ich mich aber. Solche Antworten wie von dir, braucht doch ohnehin niemand.

  • Zitat von Berichtigung: „Wenn es ein reines Udev- Problem ist UND zwei "baugleiche Teile" VERSCHIEDEN reagieren, “ sie reagieren keineswegs unterschiedlich. Es ist völlig egal, ob der eine oder der andere USB-RS232-Converter am PC ist. Es müssen 2 sein, damit überhaupt eine Gerätedatei erstellt wird. Das ist immer die /dev/ttyUSB1 (188 1 ) . Übrigens laufen bei mir virtuelle Maschinen (Manjaro und Mint ). Dort kann ich die USB-RS232-Converter "durchreichen" und auch benutzen. Zitat von Berichtig…

  • es ist schon denkbar, dass systemd solche Meldungen ausgibt. Hat sich denn systemd zwischen der 42.3 und der 15.0 so geändert? Auch kann ich nicht verstehen, warum man in Linux-Mint solche doppelten Meldungen nicht sieht, die haben aber auch schon die Version 237 und nicht 234. Die von der 42.3 reiche ich nach.

  • openSuSE Leap15.0 zeigt beim Booten sehr viele Meldungen doppelt an. So z.B. Started Login Service Started Login Service Started Modem Manager Started Modem Manager und weiter. Im log ( /var/log/boot.log) erscheint aber immer nur ein solcher Eintrag. Kann man davon ausgehen, dass die Anzeige der Boot-Messages auf dem Monitor falsch ist?

  • @Alero: Zitat von xterm: „Da du alles selber gebaut hast frage ich mich, ob die beiden RS232 USB Adapter Unterschiede aufweisen. “ Was ist denn an " (baugleiche) Adapter an den USB-Ports vorhanden sind." nicht zu verstehen? Die Adapter haben ich nicht selbst gebaut, einen nur eingelötet. Hier geht es ja auch überhaupt nicht um meine Hard- und Software. In openSuSE42.3 funktioniert ja auch alles und wie ich geschrieben habe, auch mit Leap15. Da muss ich aber zusätzlich einen USB->RS232 Schnittste…

  • das BIOS kennt die hinter einem USB-HUB angesteckten Ports und Baugruppen nicht, dazu bedarf es erst eines Betriebssystems. Folglich kann ich da nicht "rmfummeln", ich kann nur den Adapter (auf der einen Seite USB, auf der anderen eine Stiftleiste mit RS232-Sigalen) in einen anderen USB-Port stecken. Rumfummeln kann ich in der (meiner) Software. Die findet heraus, welcher Adapter ( /dev/ttyUSB0, /dev/ttyUSB1 .... ) mit dem ATMega16-Mikrocontoller verbunden ist, denn der sendet nach Aufforderung …

  • dieser Titel ist nicht ganz richtig. Es wird aber nur dann eine Gerätedatei /dev/ttyUSBx angelegt, sobald 2 (baugleiche) Adapter an den USB-Ports vorhanden sind. Über einen USB->RS232-Adapter steuere ich eine Baugruppe (Eigenbau mit atmega16 ) zum Ein-/Ausschalten von externen Geräten (Drucker, Router, Switch .... ) Unter openSuSE 13.1 ,.... Leap42.1 ... bis 42.3 traten auch keine Probleme auf. (mit der Leap42.3 funktioniert das auch heute noch) Auch unter Leap15 funktioniert das, aber nur wenn …

  • Zitat von root-tut-nicht-gut: „Danke den Entwicklern, dass sie dich auf den richtigen Weg zwingen, und lerne es korrekt.“ Es ist also ein Feature, wenn man im kdm-Login-Menü dem Menüpunkt "Anmeldung auf Fremdrechner" klickt, dort keine Namen oder IP-Adressen eingeben kann, zurück schaltet auf "Lokale Anmeldung" und auch dort keine Passworteingabe möglich ist ? Hältst du es für richtigen, mit solchen Sackgassen den Linux-Benutzer auf den "richtigen Weg" zu zwingen? Auf solche Ratschläge kann ich …

  • Zitat von root-tut-nicht-gut: „Mal ne blöde Frage: Warum machst du das?“ ganz einfach, weil ich das schon immer so gemacht habe. So konnte ich mich auf meinem alten PC, der jetzt ohne Monitor läuft anmelden oder aber eine 2. Session mit dem gleichen oder einem andern User auf dem gleichen PC starten. Da musste ich nichts zusätzlich installieren. Mit den von dir genannten Dingen habe ich mich daher nicht beschäftigt, werde es mal versuchen. Auch wird die "Anmeldung auf Fremdrechner" auch bei der …

  • Zitat von root-tut-nicht-gut: „Laufen jetzt zwei X-server, oder ein X-Server mit zwei Displays?“ Das kann ich nicht auseinander halten. So sieht eine Auszug aus ps -Af |grep Xorg aus: Quellcode (4 Zeilen) Der Prozess mit der ID 1329 ist der, der DISPLAY :0 gestartet hat und auch das grafische Login möglich machte. Den Server für DISPLAY :1 habe ich manuell gestartet. Unter OpenSuSE 12.2 wird damit ein weiteres Login-Menü angeboten. Die Umschaltung geht dann mit <Ctrl><Alt><F7> bzw <Ctrl><Alt><F8…

  • was habe ich da geschrieben? /usr/bin/Xvnc das sollte /usr/bin/Xorg heißen. Mit so einer Zeile ( siehe Frage ) kann ich in der 12.2 eine zwei lokale ( Umschaltbar mit F7 <-> F8 ) bzw. eine lokale- und eine remote- Session aufbauen. Im Logfile der 13.1 für die 2. Session finde ich nur die Zeile XDM: too many retransmissions als mögliche Fehlermeldung

  • Mit meiner OpenSuSE 12.2 -Installation kann ich mich problemlos auf meinem alten PC mit einer 10.3-Installation anmelden. Mit dem Befehl: sudo /usr/bin/Xvnc -br :1 vt8 -once -query localhost korrigiert : sudo /usr/bin/Xorg -br :1 vt8 -once -query localhost wird auch eine 2. ( 12.2 ) X-Session gestartet. Das alles funktioniert bei der 13.1 nicht, mehr noch, nach dem Versuch aus dem Login-Menü einen anderen PC zu kontaktieren, funktioniert bei mir auch die lokale Anmeldung nicht. Das geht erst nac…

  • vorab Anwort

    xterm - - System - Einrichten & Verwalten

    Beitrag

    etwas Zeit muss man mir schon geben, um einen gemachten Vorschlag zu verstehen, auszuführen (oder auch nicht) Die Installation von 12.1 (ohne die 10.3 zu vernichten ) ist dann doch nicht ganz so einfach. Der von mir genannte Daemon ist ein Server, der meine Relais-Schalter, gesteuert über ein Parallelport, bedient. Ohne die wird kein Router, kein Drucker, keine externe Festplatte ... eingeschaltet. Anders ausgedrückt, es geht am Anfang nichts so wie im alten System. Hinzu kommt , dass ich im gra…