Anmeldung auf Fremdrechner

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Anmeldung auf Fremdrechner gibt es 12 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Anmeldung auf Fremdrechner

    Mit meiner OpenSuSE 12.2 -Installation kann ich mich problemlos auf meinem alten PC mit einer 10.3-Installation anmelden.

    Mit dem Befehl:

    sudo /usr/bin/Xvnc -br :1 vt8 -once -query localhost

    korrigiert :

    sudo /usr/bin/Xorg -br :1 vt8 -once -query localhost

    wird auch eine 2. ( 12.2 ) X-Session gestartet.

    Das alles funktioniert bei der 13.1 nicht, mehr noch, nach dem Versuch aus dem Login-Menü einen anderen PC zu kontaktieren, funktioniert bei mir auch die lokale Anmeldung nicht.

    Das geht erst nach einem reboot oder killen des Prozesses "/usr/bin/Xorg ..." wieder

    Gibt es dafür eine Lösung?

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von xterm () aus folgendem Grund: Schreibfehler

    Für den Inhalt des Beitrages 66910 haftet ausdrücklich der jeweilige Autor: xterm

  • xterm schrieb:

    Das geht erst nach einem reboot oder killen des Prozesses "/usr/bin/Xorg ..." wieder

    Eines vorab:
    Hab keine Ahnung von vnc (bei mir läuft ssh ohne GUI)

    Aber als erstes würde ich mal in der /var/log/Xorg.0.log nach irgendwelchen Fehlern Ausschau halten.

    Und zu den beiden Linux-Versionen: Die laufen nur intern, damit wird nichts extern aufgerufen? Da es keine Updates (siehe z.B. letzte kritische Sicherheitslücke von openssl vom 08.04.2014) mehr gibt.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 66913 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Kann es sein, dass du nicht so genau weißt, was du mit dem "vnc ...." Befehl tust?
    Wie könnte eine zweite Instanz eines X servers (ist das wirklich eine zweite Instanz? oder nur ein zweites Display?) die Anmeldung auf dem primären Display beeinflussen?
    Was hast du dir dazu alles zurechtgebogen?

    Für den Inhalt des Beitrages 66917 haftet ausdrücklich der jeweilige Autor: root-tut-nicht-gut

  • was habe ich da geschrieben?

    /usr/bin/Xvnc das sollte /usr/bin/Xorg heißen. Mit so einer Zeile ( siehe Frage ) kann ich in der 12.2 eine zwei lokale ( Umschaltbar mit F7 <-> F8 ) bzw. eine lokale- und eine remote- Session aufbauen.

    Im Logfile der 13.1 für die 2. Session finde ich nur die Zeile

    XDM: too many retransmissions

    als mögliche Fehlermeldung

    Für den Inhalt des Beitrages 66922 haftet ausdrücklich der jeweilige Autor: xterm

  • root-tut-nicht-gut schrieb:

    Laufen jetzt zwei X-server, oder ein X-Server mit zwei Displays?
    Das kann ich nicht auseinander halten. So sieht eine Auszug aus ps -Af |grep Xorg aus:

    Quellcode

    1. root 1329 1258 3 08:37 tty7 00:00:08 /usr/bin/Xorg -br :0 vt7 -nolisten tcp -auth /var/lib/kdm/AuthFiles/A:0-s54CJb
    2. root 3987 1 0 08:40 ? 00:00:00 sudo /usr/bin/Xorg -br :1 vt8 -once -query 192.168.1.12
    3. root 3989 3987 0 08:40 tty8 00:00:00 /usr/bin/Xorg -br :1 vt8 -once -query 192.168.1.12


    Der Prozess mit der ID 1329 ist der, der DISPLAY :0 gestartet hat und auch das grafische Login möglich machte.

    Den Server für DISPLAY :1 habe ich manuell gestartet. Unter OpenSuSE 12.2 wird damit ein weiteres Login-Menü angeboten. Die Umschaltung geht dann mit <Ctrl><Alt><F7> bzw <Ctrl><Alt><F8>

    In der 13.1 wir wahrscheinlich das DISPLAY :1 erzeugt, es wird aber kein Login-Menü angezeigt und der Bildschirm beleibt schwarz. Die Umschaltung mit F7 <-> F8 funktioniert aber.

    Konsolenausgaben bitte in Code-Tags, siehe Beitrag "Wichtig, vor dem Posten bitte erst lesen"

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Sauerland ()

    Für den Inhalt des Beitrages 66967 haftet ausdrücklich der jeweilige Autor: xterm

  • Mal ne blöde Frage: Warum machst du das?
    Wäre es nicht einfacher schlicht "vncviewer" zu nehmen und die Ports sauber weiterzuleiten?

    Und mal generell: Es ist normal, dass man am X-Server mehrere Sessions haben kann. (nicht nur zwei auf f7 und f8 )
    Für jede Anmeldung wird ein Display eröffnet ( hostadresse:0, :1, :2 usw).
    Traditionell liegt auf strg+alt+f7 die erste graphische Konsole. (Bei openSUSE läuft auf strg+alt+f10 noch die Anzeige des Kernelringpuffers, aka dmesg).

    openSUSE hat als Standard den VNCviewer tightVNC*

    Wenn ein X-Server startet (und nicht anders konfiguriert ist), öffnet er auf f7 eine graphische Konsole und sorgt dann für einen Loginschirm dort. Damit ist das Display Nummer 0 vom localen X-Server belegt.

    TightVNC tut nichts anderes, als das Display 1 (nicht 0) zu öffnen und via Netz verfügbar zu machen.
    Und das ist es, was du wohl wirklich willst.

    Damit kann man sich graphisch auf entfernten Rechnern anmelden und arbeiten.

    Das hat noch nichts mit DesktopSharing zu tun. Da will man ja ein laufendes Display mit anderen Teilen.
    (also meist Display 0 über das Netz öffnen).

    Lies mal hier ein wenig.

    Als Client, der so ziemlich mit jeder Verbindung umgehen kann, empfehle ich "Remmina"

    Für den Inhalt des Beitrages 66975 haftet ausdrücklich der jeweilige Autor: root-tut-nicht-gut

  • root-tut-nicht-gut schrieb:

    Mal ne blöde Frage: Warum machst du das?
    ganz einfach, weil ich das schon immer so gemacht habe. So konnte ich mich auf meinem alten PC, der jetzt ohne Monitor läuft anmelden oder aber eine 2. Session mit dem gleichen oder einem andern User auf dem gleichen PC starten. Da musste ich nichts zusätzlich installieren.

    Mit den von dir genannten Dingen habe ich mich daher nicht beschäftigt, werde es mal versuchen.
    Auch wird die "Anmeldung auf Fremdrechner" auch bei der 13.1 im Login-Menü angeboten, funktioniert aber nicht. Auf dem Standard-PC brauchte ich so nicht einmal einen Account, um mich auf einem anderen anzumelden.
    Das kam zwar sehr selten vor, war aber sehr günstig. Da dieser Menüpunkt weiterhin existiert, vermute ich, dass die Funktion nicht generell beseitigt werden sollte.
    Irgendwie hat da jemand etwas "verschlimmbessert", denn (durch automatische Updates ? ) kann ich auch bei der 12.2 unter "Anmeldung auf Fremdrechen" keine IP-Adresse mehr eingeben.

    Das scheint also ein genereller Fehler neuerer kdm-Versionen zu sein.

    Schön ( oder auch nicht schön), wenn das jemand bestätigen oder widerlegen könnte.

    Für den Inhalt des Beitrages 66981 haftet ausdrücklich der jeweilige Autor: xterm

  • Da wurde nichts "verschlimmbessert".

    Du hast es bislang falsch gemacht.
    Mit erheblichen Verlust an Sicherheit hat es trotzdem funktioniert.

    Danke den Entwicklern, dass sie dich auf den richtigen Weg zwingen,
    und lerne es korrekt.

    Für den Inhalt des Beitrages 66988 haftet ausdrücklich der jeweilige Autor: root-tut-nicht-gut

  • root-tut-nicht-gut schrieb:

    Danke den Entwicklern, dass sie dich auf den richtigen Weg zwingen,
    und lerne es korrekt.

    Es ist also ein Feature, wenn man im kdm-Login-Menü dem Menüpunkt
    "Anmeldung auf Fremdrechner" klickt, dort keine Namen oder IP-Adressen eingeben kann, zurück schaltet auf "Lokale Anmeldung" und auch dort keine Passworteingabe möglich ist ?

    Hältst du es für richtigen, mit solchen Sackgassen den Linux-Benutzer auf den "richtigen Weg" zu zwingen?
    Auf solche Ratschläge kann ich gern verzichten.

    Für den Inhalt des Beitrages 66997 haftet ausdrücklich der jeweilige Autor: xterm