Grub 2 nach Windows Start verschwunden

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Grub 2 nach Windows Start verschwunden gibt es 29 Antworten auf 3 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Ich wette, dass der vorgeschlagene Weg von Rentner65 nicht funktioniert.
    Das ist Quatsch.

    Deinen Stick wirst du erst booten können, wenn dein "UEFI secure" das zulässt.
    Es ist u.a. die Aufgabe von "UEFI secure" solche "Einbruchsversuche" zu unterbinden.
    Nur, was bereits legitimiert ist, kann gebootet werden.
    Daher der Name "secure boot"....

    Probiere folgendes:
    Schalte im UEFI (dsa vormalige BIOS) das "Secure" aus.
    Boote mit deiner Installations DVD oder mit einem Linux Bootmedium deiner Wahl (falls das mit secure boot umgehen kann).

    Bei der Installation des Grubs MUSST du angeben, dass das ein UEFI Secure boot System ist.
    (wird NICHT erkannt).

    Lies aber vorher diese Erklärung, wie openSUSE UEFI secure boot handelt.
    Das gilt im Wesentlichen auch für 13.1

    Wenn du drin bist, mache doch bitte trotzdem ein "fdisk -l" und poste das Ergebnis hier.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von root-tut-nicht-gut ()

    Für den Inhalt des Beitrages 67451 haftet ausdrücklich der jeweilige Autor: root-tut-nicht-gut

  • Naja, es ist ja so, dass das BIOS durch UEFI ersetzt wurde und bei UEFI ein komplett anderes Partitionsschema verwendet wird. So fällt z. B. die Beschränkung auf 4 primäre Partitionen weg und wenn ich das richtig verstehe, dann wird der Bootmanager bei UEFI auf die EFI-Systempartition installiert welche in der GPT als Bootpartition eingetragen ist. Man kann zwar im UEFI Menü auf so einen BIOS Kompatibilitätsmodus umschalten, aber das nützt nix, weil ja erstens gar kein MBR vorhanden ist und demnach dann alle Systeme im BIOS Modus neu installiert werden müssten und die Platte auch komplett neu partitioniert werden müsste. Selbst wenn das nicht der Fall wäre, müsste man Windows trotzdem neu installieren, weil Secure-Boot, was ja bei der UEFI Installation aktiviert ist nur im UEFI Modus funktioniert und Windows ohne nicht mehr starten würde.
    Ich sag ja, ich muss mich da mal ausführlich damit auseinandersetzen...Alles irgendwie nicht mehr so einfach, wie es mal war.

    Für den Inhalt des Beitrages 67452 haftet ausdrücklich der jeweilige Autor: Florian_Röhrer

  • @root-tut-nicht-gut
    Secure Boot war bei der Linux Installation aktiviert, da hab ich extra drauf geachtet.
    Ich finds aber komisch, dass der mir vom Stick mit der OpenSuse DVD bootet, nicht aber wenn da drauf
    Super Grub2 Disk ist. Und mit der OpenSuse DVD ist es ja anscheinend nicht mehr möglich, den Bootloader zu reparieren.

    Für den Inhalt des Beitrages 67453 haftet ausdrücklich der jeweilige Autor: Florian_Röhrer

  • OK, ich klink mich dann mal aus und hoffe dir kann jemand anderes weiter helfen.

    Hand

    Für den Inhalt des Beitrages 67454 haftet ausdrücklich der jeweilige Autor: Rentner65

  • Nur zur weiteren Verwirrung:
    UEFI mit secure boot benötigt eine GPT (GlobaluniqueidentificationPartitionTable).
    Die kann im ersten Block 128 Partitionen haben (mit jeweils einigen Exabyte ).
    Oder 127 Partitionen UND einen Zeiger auf eine weiteren Block mit wieder 128 Partitionen.
    Im Prinzip also unbegrenzt viele Partitionen.

    Die erste Partition im ersten Block IST eine althergebrachte Partitionstablle MIT einem MBR.
    Auch wenn das natürlich dann nicht mehr verwendet wird.
    Das Booten läuft ja ganz anders.
    Diese Umstandskrämerei ist wieder der BackswardCompatibility geschuldet: Man verhindert damit, dass alte Werkzeuge, wie "fidsk" eine scheinbar leere Platte finden.
    Stattdessen finden die eine herkömmliche Partitionstabelle, die jedoch ein Flag gesetzt hat, das "fdisk" und Konsorten warnt:
    Finger weg! Ich bin was aus der Zukunft......

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von root-tut-nicht-gut ()

    Für den Inhalt des Beitrages 67455 haftet ausdrücklich der jeweilige Autor: root-tut-nicht-gut

  • eben weil der "Supergrub Stick" NICHT eingetragen ist, deine openSUSE DVD aber schon.
    Dir fehlt nur noch das Teilchen, dass in /boot/EFI die korrekten Einträge zu stehen haben.
    (Und nein: ich hab keine Idee, wie das zuging, obwohl du auf "UEFI Secure" geachtet hast)

    Für den Inhalt des Beitrages 67456 haftet ausdrücklich der jeweilige Autor: root-tut-nicht-gut

  • hmm, ich dank euch trotzdem allen für eure Mühen. Ich denk wohl, ich werd morgen erst mal ausprobieren mir Super Grub2 Disk auf ne Disc zu brennen und davon zu booten, damit ich dann innerhalb von OpenSuse den Bootloader wieder herstellen kann. Sollte das nicht funktionieren, werd ich wohl alles nochmal von vorn installieren müssen.
    Sollte mir Windows dann wieder ohne Grund den Bootloader zerschiesen, muss ich mir wohl ernsthaft überlegen Windows ganz zu entfernen, kann ja wohl nicht sein sowas.

    Für den Inhalt des Beitrages 67457 haftet ausdrücklich der jeweilige Autor: Florian_Röhrer

  • Wenn es ein "richtiges" Uefi ist, soll man von jeder Partition aus Uefi booten können.

    Durch Drücken der Taste F12 (oder einer anderen) kommt man in das Bootmenü von Uefi.
    Ich habe mein Wissen durch Lesen ohne praktische Erfahrung.
    Und ich werde mir Uefi erst antun, wenn es nicht mehr anders geht.
    Ich denke Deine Systeme sind alle noch vorhanden und betriebsfähig.
    dann eine 260 MB EFI-Systempartition

    Dort sollte ein Ordner für das leidige System und ein Ordner "opensuse" sein.
    Das sind die Booteinträge für das Uefi.
    Von dort sollte das Uefi Deine Partition mit Opensuse starten können.

    Für den Inhalt des Beitrages 67475 haftet ausdrücklich der jeweilige Autor: Kanonentux