Grafikfehler in Firefox

Hinweis: In dem Thema Grafikfehler in Firefox gibt es 17 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Und das ist echt nur im Firefox? Weil, ich hätte spontan auf fehlerhafte Hardware getippt.


    Ich wäre eher bei Grafiktreiber. Wenn es da nicht rund läuft, kann es das Rendering beim Browser zerhauen. Da bekommst die schönsten Effekte, bei anderen Anwendungen sieht alles ganz normal aus.


    flo

    Auch zu finden bei der Mailingliste opensuse-de sowie im IRC als User grossing in den Netzwerken freenode und oftc - querys sind erlaubt, die Antwort kann dauern ;)


    Der Channel zum Forum: ##os-forum auf irc.freenode.net
    Per webchat http://webchat.freenode.net/##os-forum


    Alle von mir genannten Befehle sind als User auszuführen, außer ich schreibe explizit dazu "als root ausführen"!


    Meine Homepage

    Für den Inhalt des Beitrages 71633 haftet ausdrücklich der jeweilige Autor: grossing

  • wrohr
    Schau einmal die beiden Links in meinem letzten Post, vielleicht gehts mit den Firefox Einstellungen?

    Danke, werde es testen. Wie gesagt, mir ist das nur auf Intel Grafikhardware aufgefallen. Auf Notebooks mit Nvidia oder AMD Grafik tritt der Fehler anscheinend nicht auf.


    grüsse
    wrohr

    Erst wenn der letzte FTP Server kostenpflichtig, der letzte GNU-Sourcecode verkauft, der letzte Algorithmus patentiert, der letzte Netzknoten kommerzialisert ist, werdet Ihr merken, dass Manager nicht programmieren können.

    Für den Inhalt des Beitrages 71650 haftet ausdrücklich der jeweilige Autor: wrohr

  • Sorry, war etwas beschäftigt und hab bis jetzt keine Zeit gehabt.
    Hier die gewünschten Ausgaben:


    Code
    Florian@linux-vaio:~> zypper se -si firefox
    Daten des Repositories laden ...
    Installierte Pakete lesen ...
    S | Name | Typ | Version | Arch | Repository
    --+------------------------------------+-------+-----------+--------+---------------------
    i | MozillaFirefox | Paket | 31.0-33.1 | x86_64 | openSUSE-13.1-Update
    i | MozillaFirefox-branding-openSUSE | Paket | 21-2.1.2 | x86_64 | openSUSE-13.1-Oss
    i | MozillaFirefox-translations-common | Paket | 31.0-33.1 | x86_64 | openSUSE-13.1-Update


    Code
    Florian@linux-vaio:~> /sbin/lspci -nnk | grep -iA3 vga
    00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09)
    Subsystem: Sony Corporation Device [104d:90b7]
    Kernel driver in use: i915
    Kernel modules: i915


    Code
    Florian@linux-vaio:~> firefox
    (process:10194): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed


    Code
    Florian@linux-vaio:~> firefox -ProfileManager
    (process:10213): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
  • @wrohr


    Was ich komisch finde, ist, dass das Problem erst seit einiger Zeit auftritt und halt auch wirklich nur im Firefox. Vielleicht hat sich da ja bei nem Firefox Update ein Bug eingeschlichen, oder so.
    Bei mir verschwinden die Grafikfehler übrigens nicht, wenn ich die Maus bewege...Ich hab auch das Gefühl, dass die ganze Sache verstärkt auf Websites mit hellen Hintergründen auftritt.


    Und zum Thema Grafiktreiber: Ich hab in meinem Laptop so eine Kombination aus Intel Grafik und NVIDIA.
    Weiß da vielleicht auch zufällig jemand, wie ich die proprietären NVIDIA Treiber verwenden kann. Ich hab das nämlich mal versucht und da hats mir meinen x-Server zerschossen, das geht wegen der Kombihardware irgendwie nicht so einfach. Darf auch gern so sein, dass dann nur noch die NVIDIA Karte verwendet wird.


    Flo


  • Auch einmal versucht?



    Und zum Thema Grafiktreiber: Ich hab in meinem Laptop so eine Kombination aus Intel Grafik und NVIDIA.
    Weiß da vielleicht auch zufällig jemand, wie ich die proprietären NVIDIA Treiber verwenden kann. Ich hab das nämlich mal versucht und da hats mir meinen x-Server zerschossen, das geht wegen der Kombihardware irgendwie nicht so einfach. Darf auch gern so sein, dass dann nur noch die NVIDIA Karte verwendet wird.


    Geht nur mit bumblebee:
    http://en.opensuse.org/SDB:NVIDIA_Bumblebee
    Das deutsche Wiki ist zum Thema bumblebee noch falsch.

  • Oder, falls möglich, die Intelkarte im BIOS deaktivieren. Dann kannst Du den Grafiktreiber aus dem Standard NVIDIA Repository verwenden.

  • Sauerland Ok, ja dann werd ich wohl mal ein neues Backup erstellen und dann die Sache mit bumblebee mal ausprobieren, danke für den Tipp. Die beiden links von dir hab ich auch auspropiert, leider keine Besserung...