Gelöst: Spielkonsolen Emulatoren bei SUSE

Hinweis: In dem Thema Gelöst: Spielkonsolen Emulatoren bei SUSE gibt es 15 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • HALLO,
    ich hab gestern mal versucht mir etwas gegen die Langeweile bei langen Zugfahrten oder Flughafenaufenthalten zu besorgen und mir zu dem Zweck ein par Emulatoren angeschaut.


    Ich hab es aber nicht hinbekommen sie ordentlich zu installieren bzw. zu konfigurieren,


    Als erstes wäre da der Visual Boy Advance.
    Da sagt er mir bei der Installation von dieser Seite hier:
    http://pkgs.org/opensuse-facto….2-115.32.x86_64.rpm.html


    Das hier:



    Dann habe ich nach einem N64 Emulator für Linux gesucht.
    Aber nicht geschafft ihn zu installieren.
    http://software.opensuse.org/package/mupen64plus


    Edit: Habs grade fast geschafft.
    Da kam das hier:
    Habs bei 1Cklick Install versucht bei beiden...


    Code
    An error occurred while initializing the software repository.
    Details:
    home:derselbst: [|] Valid metadata not found at specified URL
    Verlauf:
    - Unbekannter Fehler beim Lesen von 'http://download.opensuse.org/repositories/home:/derselbst/openSUSE_13.1/'
    - Die Systemverwaltung ist durch die Anwendung mit dem PID 3001 (zypper) gesperrt.
    Schließen Sie diese Anwendung, bevor Sie es erneut probieren.
    Erneut versuchen?


    Dann habe ich Projekt64 mit Wine installiert was auch wunderbar geklappt hat.
    Nur kann ich es nicht auf Vollbild schalten.
    das springt dann immer wieder sofort raus.



    Ich hätte aber generell lieber die Linux Versionen für 64 und Advance weil die dann sicher stabiler laufen da sie ja dafür ausgelegt sind.


    Viellicht ist ja ein RetroGamer oder Gamer generell anwesend?


    LG und guten Morgen

    Dankbar für jede Hilfe,Tipps,Tricks die einem das Leben erleichtern
    Laptop: IBM Lenovo X200 Core2 Duo P8600 2,4GHz, 4Gb ddr3,64Bit

    4 Mal editiert, zuletzt von M.Sunface ()

    Für den Inhalt des Beitrages 72817 haftet ausdrücklich der jeweilige Autor: M.Sunface

  • sudo zypper addrepo http://download.opensuse.org/r…ulators/openSUSE_Factory/ opensuse-emulators


    Fängt ja schon gut an, ein Factory-Repo.


    Tip:
    Lass die Finger von den sogenannten 1-Klickern.

  • Wie soll ichj das denn jetzt machen die Beehle von SUSE sind für mich noch neu.
    Bitte kann es mir jemand vorkauen. Ich bemü mich auch alles bald selber drauf zu haben.


    http://software.opensuse.org/package/mupen64plus


    Natürlich brauch ich 32Bit von der 13.1


    Nur wie installier ich das?

    Dankbar für jede Hilfe,Tipps,Tricks die einem das Leben erleichtern
    Laptop: IBM Lenovo X200 Core2 Duo P8600 2,4GHz, 4Gb ddr3,64Bit

    Für den Inhalt des Beitrages 72825 haftet ausdrücklich der jeweilige Autor: M.Sunface

  • Wie soll ichj das denn jetzt machen die Beehle von SUSE sind für mich noch neu.
    Bitte kann es mir jemand vorkauen. Ich bemü mich auch alles bald selber drauf zu haben.


    Solche Seiten vermeiden.

    Code
    http://pkgs.org/opensuse-factory/opensuse-emulators/VisualBoyAdvance-1.7.2-115.32.x86_64.rpm.html


    Dafür musst Du Dich schon etwas mit Deinem System befassen, und wie man sieht, tauchen ja auch Abhängigkeitskonflikte auf.

    Code
    Problem: libpng14.so.14, benötigt von VisualBoyAdvance-1.7.2-115.32.i586, wird von keinem Repository angeboten
    Lösung 1: VisualBoyAdvance-1.7.2-115.32.i586 nicht installieren
    Lösung 2: VisualBoyAdvance-1.7.2-115.32.i586 beschädigen durch Ignorieren einiger Abhängigkeiten
    Wählen Sie aus den obigen Lösungen mittels Nummer oder brechen Sie a(b). [1/2/b] (b):


    Da bleibt nur Lösung b.



    Und nur dort suchen:
    http://software.opensuse.org/131/de
    Und nur die zu Deiner Distribution (openSUSE 13.1 anscheinend in 32 bit) passenden rpms installieren.


    Kein Factory-Repo, kein /home -Repo einbinden und die 1-Klicker auch vermeiden.
    Wenn, dann das Repo richtig einbinden und auch Prioritäten nicht vergessen.
    Zum Thema Prioritäten hab ich noch vor kurzem etwas geschrieben.


    Daher poste einmal:

    Code
    zypper lr -uP
  • Dankbar für jede Hilfe,Tipps,Tricks die einem das Leben erleichtern
    Laptop: IBM Lenovo X200 Core2 Duo P8600 2,4GHz, 4Gb ddr3,64Bit

    Für den Inhalt des Beitrages 72833 haftet ausdrücklich der jeweilige Autor: M.Sunface

  • Zitat

    3 | opensuse-emulators | opensuse-emulators | Ja | Nein | 99 | http://download.opensuse.org/repositories/Emulators/openSUSE_Factory/


    Wie ich schon gesagt habe:

    Kein Factory-Repo, kein /home -Repo einbinden und die 1-Klicker auch vermeiden.


    Lösche das Repo, Du wirst sonst irgendwann Probleme bekommen.


    Dann klick Dich durch bist Du die URL des Repos sehen kannst. Sind 4 oder 5 Klicks, die sich lohnen. Dann kannst Du schauen, was in dem Repo noch vorhanden ist.
    Und immer die zu Deiner Distribution passende nehmen. Bitte auch die Prioritäten nicht vergessen.


    Wobei:
    Weniger an Repos ist oft mehr.

  • Mit diesem Einklicker (Klick) von software.openSUSE.org wird das passende Repositorium aufgerufen, sowie hinzugefügt und mupen64plus installiert.

    Für den Inhalt des Beitrages 72846 haftet ausdrücklich der jeweilige Autor: tomfa-ng

  • Ja das wahr das Packet in dem OneClick Link.
    Das hat bei mir beim Installieren über den Manager Fehler ausgelöst.


    Und ich hab empfohlen bekommen es per Hand zu machen.


    Sprich auf die Suse Page Mumpen suchen.
    Den Emulator anklicken dann unter deiner SUSE Version auf die Packete klicken.
    Dann ganz Links nur auf Emulatoren klicken,
    Dann den Link obenen mit den Downloads anclicken dann ganz Rechts in dem Kasten auf deine Version klicken dann die repo per Hand installieren.


    Die Links Poste ich gleich mal nach wenn ich es installiert habe.
    Dann bekommt ihr ne Anleitung von mir ^^

    Dankbar für jede Hilfe,Tipps,Tricks die einem das Leben erleichtern
    Laptop: IBM Lenovo X200 Core2 Duo P8600 2,4GHz, 4Gb ddr3,64Bit

    Für den Inhalt des Beitrages 72853 haftet ausdrücklich der jeweilige Autor: M.Sunface

  • Ja das wahr das Packet in dem OneClick Link.
    Das hat bei mir beim Installieren über den Manager Fehler ausgelöst.


    Nein, da liegst du falsch. Wenn ich den Einklicker von mir anklicke, dann wird auch das passende Repositorium zu openSUSE 13.1 angelegt und mupen64plus für diese Version von openSUSE installiert. Du hast aber den Einklicker für openSUSE Factory verwendet, daher die ganzen „Fehler“.


    Sprich auf die Suse Page Mumpen suchen.


    Ja.

    Den Emulator anklicken dann unter deiner SUSE Version auf die Packete klicken.
    Dann ganz Links nur auf Emulatoren klicken,
    Dann den Link obenen mit den Downloads anclicken dann ganz Rechts in dem Kasten auf deine Version klicken dann die repo per Hand installieren.


    Nicht wirklich. Bei http://software.opensuse.org/package/mupen64plus unter openSUSE 13.1 klickst du auf „Möglicherweise instabile Pakete anzeigen“, dort klickst du dann in der Reihe wo Emulators aufgeführt ist auf „1 Click Install“ und schon geschieht das, was ich zuvor beschrieben habe.


    Ein anderer Weg wäre, das Repositorium Emulators in der passenden Ausführung zur Version von openSUSE hinzuzufügen (in diesem Fall openSUSE 13.1) und das Paket mupen64plus über Zypper oder YaST installieren.
    Repositorium hinzufügen:

    Code
    zypper ar -f -n "Repositorium für Emulatoren" http://download.opensuse.org/repositories/Emulators/openSUSE_13.1/ Emulatoren


    Das Paket mupen64plus über Zypper installieren:

    Code
    zypper in mupen64plus


    und alles ist gut.


    Dann bekommt ihr ne Anleitung von mir ^^


    Darauf bin ich mal gespannt.

    Für den Inhalt des Beitrages 72854 haftet ausdrücklich der jeweilige Autor: tomfa-ng