[Gelöst] Canon PIXMA MX870 Drucker- und Scannertreiber Installation schlägt fehl bei 13.2

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema [Gelöst] Canon PIXMA MX870 Drucker- und Scannertreiber Installation schlägt fehl bei 13.2 gibt es 16 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • [Gelöst] Canon PIXMA MX870 Drucker- und Scannertreiber Installation schlägt fehl bei 13.2

    Hallo zusammen,

    ich habe vor einigen Jahren auf OpenSuse 12.1 den Drucker- und Scannertreiber cnijfilter-mx870series-3.30-1-i386-rpm und scangearmp-mx870series-1.50-1-i386-rpm installiert und der Drucker/Scanner hat die ganze Zeit auch tadellos funktioniert. Ich benutze ihn als Netzwerkdrucker und habe bislang immer einen Upgrade und nie eine Neuinstallation des Betriebssystems durchgeführt.
    OpenSuse 13.2 habe ich nun auf eine leere Disk neu installiert (64-bit Variante wie vorher ab 12.1 auch schon). Bei der Installation der Treiber für den Drucker (es gibt wohl keine Neueren als die von März 2010) tritt jetzt allerdings ein Fehler auf, siehe beigefügte Error-Datei. Als Beispiel habe ich auch das Installationsskript für den Druckertreiber beigefügt.
    ich vermute, von Canon gibt es kurzfristig keine Abhilfe. Bleibt die Frage wo ich die offenbar fehlenden Dateien herbekomme und wie ich sie in meine Installation einbauen kann, d.h. reicht einfaches Kopieren in ein Verzeichnis oder müssen die installiert werden?
    Ohne funktionierenden Drucker habe ich wirklich ein Problem, bin daher für jede Hilfe dankbar.

    Danke und Gruß, Erich
    Dateien

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von erich_s ()

    Für den Inhalt des Beitrages 77993 haftet ausdrücklich der jeweilige Autor: erich_s

  • Ordnung muss sein!

    Zunächst mal was anderes:
    Dieser thread gehört zur Rubrik "Hardware & Treiber" ;)

    Nachtrag:
    Und was mir eben auffällt.. Du hast ein 64bit-System installiert und verwendest den i386-Treiber!
    Probier mal den x86_64-Treiber.

    Für den Inhalt des Beitrages 77994 haftet ausdrücklich der jeweilige Autor: linux-freund

  • Folgende Möglichkeiten hast du.
    1. Statt „rpm -Uvh Paket“ nimmst du „zypper in Paket“.
    2. Du installierst openSUSE in der x86-Version.
    3. Du installierst dir die passenden 32-Bit Pakete
    4. Du versuchst es mit gutenprint.
    5. Du nutzt Turboprint2 und Vuescan.


    Zu Punkt 3:
    Entweder suchst du einzeln nach den benötigten Pakete

    Quellcode

    1. zypper se -s --provides libatk-1.0.so.0

    und installierst diese dann, oder du versuchst es gleich mit

    Quellcode

    1. zypper in libatk-1.0.so.0

    , oder alle auf einen Schlag:

    Quellcode

    1. zypper in libatk-1.0.so.0 libgdk-x11-2.0.so.0 libgdk_pixbuf-2.0.so.0 und so weiter

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von tomfa-ng ()

    Für den Inhalt des Beitrages 77998 haftet ausdrücklich der jeweilige Autor: tomfa-ng

  • Sorry dass...

    ..ich den Beitrag ins falsche Forum gesetzt habe aber jetzt da Kommentare da sind möchte ich ihn nicht mehr löschen. Kann evtl. ein Moderator ihn verschieben?

    Zum Thema: Ich hätte auch gerne die 64-bit Treiber installiert, aber das scheint Teil des Problems zu sein. Anscheinend gibt es von Canon keine neueren Treiber als die 32-bit Variante von 2010. Ich habe jedenfalls keine gefunden. Die Nachinstallation der fehlenden 32-bit Pakete scheint mir die sinnvollste Lösungsmöglichkeit zu sein (ich glaube nicht dass Canon kurzfristig 64-bit Versionen der Treiber bereitstellen wird, ich werde aber trotzdem nachfragen). Es sind ja eine ganzer Reihe Pakete, kann ich die von tomfa-ng in Punkt 3 genannten Befehle in einer Art "Treiber-32-nachinstall.sh" zusammenfassen? Wie müsste das aussehen (ein Beispiel würde mir helfen)? Die in den Punkten 4 und 5 genannten Programme kenne ich nicht, werde mir das aber anschauen.

    Danke und Gruß, Erich

    Für den Inhalt des Beitrages 78004 haftet ausdrücklich der jeweilige Autor: erich_s

  • Als Alternative kann ich dir noch den turboprint-Treiber von Zedonet empfehlen. Funktioniert mit (fast) allen Canon-Druckern und zum Testen gibt es auch eine Version. Der kommerzielle Treiber kostet kleines Geld und behebt alle Probleme mit dem Drucker. Ich nutze ihn selber schon seit Jahren und Treiberprobleme unter Linux sind mir seither fremd.

    Für den Inhalt des Beitrages 78006 haftet ausdrücklich der jeweilige Autor: Alero

  • Du hättest schon längst alles fertig haben können, ohne Skript. Die benötigten RPM-Pakete, welche du bei Canon heruntergeladen hast, sammelst du am besten in einem (dafür vorgesehenen) eigenen Ordner und installierst diese mit Zypper, könnte dann (über Root/su) so aussehen:

    Quellcode

    1. rechner:/home/erich/Pakete/Canon # zypper in cnijfilter-mx870series-3.30-1.i386.rpm scangearmp-mx870series-1.50-1.i386.rpm cnijfilter-common-3.30-1.i386.rpm scangearmp-common-1.50-1.i386.rpm
    2. Loading repository data...
    3. Reading installed packages...
    4. Paketabhängigkeiten auflösen ...
    5. The following 27 NEW packages are going to be installed:
    6. cnijfilter-common cnijfilter-mx870series gdk-pixbuf-query-loaders-32bit gtk2-tools-32bit libatk-1_0-0-32bit libcairo2-32bit libcanberra0-32bit
    7. libcanberra-gtk0-32bit libcanberra-gtk2-module-32bit libgdk_pixbuf-2_0-0-32bit libgio-2_0-0-32bit libgraphite2-3-32bit libgtk-2_0-0-32bit libharfbuzz0-32bit
    8. libjasper1-32bit libpango-1_0-0-32bit libpangox-1_0-0-32bit libpixman-1-0-32bit libpng12-0-32bit libtiff3-32bit libvorbisfile3-32bit libxcb-render0-32bit
    9. libxcb-shm0-32bit libXft2-32bit pango-tools-32bit scangearmp-common scangearmp-mx870series
    10. 27 new packages to install.
    11. Overall download size: 6,6 MiB. Already cached: 0 B After the operation, additional 20,6 MiB will be used.
    12. Fortfahren? [j/n/? zeigt alle Optionen] (j): n
    Alles anzeigen


    Oder (ich hatte gerade nichts Besseres zu tun) erlöse dich gleich und führe

    Quellcode

    1. su -c "zypper in https://dl.dropboxusercontent.com/u/2656949/canon/cnijfilter-common-3.30-1.i386.rpm https://dl.dropboxusercontent.com/u/2656949/canon/cnijfilter-mx870series-3.30-1.i386.rpm https://dl.dropboxusercontent.com/u/2656949/canon/scangearmp-common-1.50-1.i386.rpm https://dl.dropboxusercontent.com/u/2656949/canon/scangearmp-mx870series-1.50-1.i386.rpm"

    aus.

    Für den Inhalt des Beitrages 78013 haftet ausdrücklich der jeweilige Autor: tomfa-ng

  • Das geht doch einfacher. Bei mir ist der Sammelordner für lokal gespeicherte Pakete als Repository mit dem schönen Namen »rpm« eingebunden, damit sind dort gespeicherte Pakete auch für Yast verfügbar. LibreOffice (das Original, nicht die von Suse verbogene Version) wird auf gleiche Weise installiert. Hat sich außerordentlich bewährt.

    Falk

    Für den Inhalt des Beitrages 78042 haftet ausdrücklich der jeweilige Autor: Falk2

  • Falk2 schrieb:

    Das geht doch einfacher. Bei mir ist der Sammelordner für lokal gespeicherte Pakete als Repository mit dem schönen Namen »rpm« eingebunden, damit sind dort gespeicherte Pakete auch für Yast verfügbar. LibreOffice (das Original, nicht die von Suse verbogene Version) wird auf gleiche Weise installiert. Hat sich außerordentlich bewährt.

    Falk

    Das wäre dann zum Beispiel mit

    tomfa-ng schrieb:

    Die benötigten RPM-Pakete, welche du bei Canon heruntergeladen hast, sammelst du am besten in einem (dafür vorgesehenen) eigenen Ordner und installierst diese mit Zypper,

    möglich, diesen Ordner gleich über YaST als ein lokales Repositorium einzubinden. Ich möchte/wollte jetzt aber nicht jede Möglichkeit hier einzeln haargenau erklären.

    Für den Inhalt des Beitrages 78043 haftet ausdrücklich der jeweilige Autor: tomfa-ng

  • Es gibt spezielle Installationsanleitungen für die Canon Treiber (Drucker/Scannner)

    Hallo,

    vielen Dank für die Hilfe, ich werde mich jetzt mal an die Arbeit machen. Bzgl. Antwort 7 ist es so, dass es eine Installationsanleitung gibt (im Treiberpaket enthalten und leider keine Datei sondern als HTML Seiten). Da heißt es dass man das Paket entpacken (tar) und dann eben die im ursprünglichen Beitrag angehängte install.sh ausführen soll. Für das Scannerpaket gilt das Gleiche. Daher weiß ich nicht was genau die Vorgehensweise in 7 bewirkt.

    Bzgl. Antwort 8: so ein "lokales Repository" habe ich tatsächlich auch und die Canon rpms dort aufbewahrt. Sie sind dort aber sozusagen inaktiv, installiert habe ich die Treiber für Drucker und Scanner seinerzeit gemäß der jeweiligen Installationsanleitung.

    Gruß, Erich

    Für den Inhalt des Beitrages 78156 haftet ausdrücklich der jeweilige Autor: erich_s