[gelöst]Samba fordert keine Benutzerdaten unter Linux an / VLC spielt keine smb-Videos ab

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema [gelöst]Samba fordert keine Benutzerdaten unter Linux an / VLC spielt keine smb-Videos ab gibt es 6 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • [gelöst]Samba fordert keine Benutzerdaten unter Linux an / VLC spielt keine smb-Videos ab

    Schönen guten Abend,

    Ich habe meinen Raspberry Pi als NAS aufgesetzt und möchte nun mittels Samba darauf zugreifen.
    (erstes Projekt mit Linux...)
    Hierfür stehen mir zwei verschiedene Rechner zu Verfügung.

    1. Laptop (openSuse)
    2. Rechner(Win7)

    zu 1.
    Zugriff auf das NAS über Dolphin:
    Ich navigiere durch die Dolphin-Samba-Freigabe auf das NAS und habe zugriff auf die Dateien.
    Jedoch muss ich hierbei keine Benutzerkennung angeben.
    Ich gehe davon aus, dass ich direkt als "Gast" angemeldet werde... da mir der Zugriff auf einen einfachen Dummy-Ordner verweigert wird, sobald "guest ok" auf "no" gesetzt wird.
    (Dummy wird lediglich durch "path = x/y/z" und "guest ok = yes" freigegeben und es wurden keine erweiterten Rechte (chmod oder chgrp) erteilt.
    In den Globalen Einstellungen ist "securety = user")

    zu 2.
    In der Netzwerkumgebung wird das NAS angezeigt, und bevor ich zugriff erhalte, muss ich mich als Benutzer identifizieren.

    Ich möchte natürlich auch dass sich Linux-User zuerst identifizieren müssen, bevor Sie zugriff bzw. einsicht in die Dateien erhalten.

    Wie ist das machbar?

    Ich habe jetzt schon einen Tag damit verbracht Tut´s zu durchforsten, jedoch leider ohne Ergebnis.

    Danke schonmal im voraus!
    greetz

    Soulmachine

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Soulmachine () aus folgendem Grund: Gelöst

    Für den Inhalt des Beitrages 82006 haftet ausdrücklich der jeweilige Autor: Soulmachine

  • Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Sauerland ()

    Für den Inhalt des Beitrages 82007 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Dank dir...

    ich habe jetzt die "security = server" gesetzt funktioniert alles wie gewollt. Zuerst Benutzerabfrage --> wenn i.O. --> Auflistung des Ordnerinhaltes. Zugriff auf Bild- und Musikdateien möglich, jedoch leider nicht auf Videodateien.
    Sobald Gastzugang aktiv ist, ist dies jedoch möglich.

    -----------EDIT-----------
    Verwendeter Player = VLC (jedoch verhält sich auch Kaffeine genauso)
    -----------------------------

    Ich gehe davon aus, dass es sich um ein Berechtigungsproblem der User handelt, jedoch komm ich einfach nicht dahinter was genau falsch ist.

    Hat jemand eine Idee?
    greetz

    Soulmachine

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Soulmachine () aus folgendem Grund: Zusätzliche Infos

    Für den Inhalt des Beitrages 82011 haftet ausdrücklich der jeweilige Autor: Soulmachine

  • Ich habe nun wieder "security = user" gesetzt.

    Weiterhin erscheint (wie gewollt) die Passwortabfrage unter Linux und Win7.

    Meine ursprüngliche Vermutung, dass es sich um ein Berechtigungsproblem handelt, hat sich zerschlagen, da ich mich ohne Probleme vom PC (Win7) einloggen und die Datei wiedergeben kann.

    Evtl. hat es ja etwas mit den Einstellungen des bzw. der Player zu tun... oder eben doch mit meinen Samba Einstellungen... wenn "guest ok =yes" gesetzt und die "valid users" auskommentiert werden, funktioniert alles wieder ohne Porbleme...

    Irgendjemand einen Einfall?
    greetz

    Soulmachine

    Für den Inhalt des Beitrages 82015 haftet ausdrücklich der jeweilige Autor: Soulmachine

  • Lösung gefunden!

    Zwar kann ich immer noch nicht nachvollziehen warum es so ist, aber naja... es klappt! ^^

    Das Problem liegt am Player (VLC).

    Um den Zugang nach erfolgreicher Anmeldung auf die Videodateien zu erhalten, müssen die SMB-Login-Daten im VLC hinterlegt werden.

    1. VLC öffnen
    2. Tools
    3. Preferences
    (Alternativ: Strg + P)
    4. Unten Links wird nun "Show settings" auf "All" gestellt.
    Die Darstellung ändert sich
    5. Input / Codecs
    6.Access modules
    7. SMB
    8. "SMB user name" & "SMB password" eingeben
    9. "Save" drücken nicht vergessen ^^

    Wenn nun über Samba-Freigabe auf den Ordner zugegriffen wird, erscheint die User-Abfrage ---> wenn i.O. ---> Auflistung des Ordnerinhaltes.Ausführen einer Videodatei führ nun nichtmehr zu einem Fehler, sonder der Player startet wie gewohnt.
    greetz

    Soulmachine

    Für den Inhalt des Beitrages 82026 haftet ausdrücklich der jeweilige Autor: Soulmachine

  • smb4k wäre eine bessere Lösung, da die Freigabe als lokale Festplatte gehandhabt wird.

    Für den Inhalt des Beitrages 82056 haftet ausdrücklich der jeweilige Autor: toxa

  • Hallo toxa,

    danke dir für den dezenten Hinweis xD
    Dein Denkansatz ist natürlich noch verlockender und bietet mehrere Vorteile.
    (Linuxneuling... bitte verzeih ^^)

    Falls jemand an der sb4k Lösung hat, das Tool gibt´s HIER.

    Schönes Wochenende

    :thumbup:
    greetz

    Soulmachine

    Für den Inhalt des Beitrages 82232 haftet ausdrücklich der jeweilige Autor: Soulmachine