[gelöst] yast2 software Fehler

Hinweis: In dem Thema [gelöst] yast2 software Fehler gibt es 15 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Hi,


    ich bin's dann mal wieder. Kaum das System drauf und schon erste Startschwierigkeiten, nvm :)


    Wenn ich YaST öffne und dann einen Punkt unter Software anklicke, kriege ich beim Laden folgenden Fehler:
    Leeres Ziel in URI: hd:///?device=/dev/disk/by-id/scsi-S__...._8.07-part1


    Ich gehe davon aus, dass es mit irgendeinem Gerät zu tun hat.. nur weiß ich nicht was, weil dazwischen ein Stückchen fehlt.
    Überspringe ich die Fehlermeldung zwei mal, funktioniert es. Jedoch hätte ich es gerne konsistent.


    Apropos Konsistenz, nachdem ich meinen Wlan Stick rauszog (weil auf einmal das Internet weg war und das Wlan Symbol weg war und nicht mehr gefunden wurde), erkannte er meinen Stick nicht mehr. Nach circa 5 Minuten ging es auf einmal wieder.
    Auch scheint mir die Signalstärke von 54% (vorher 100% unter Windows) etwas lasch zu sein.


    Eben kam folgende Benachrichtigung als ich beim Installieren von Packages war (Development-Zeugs, YaST-Updates, ...)
    System management is locked by the application with pid 9344 (/usr/lib/YaST2/bin/y2base). Close this application before trying again.


    Über Hilfe wäre ich sehr dankbar :)

    Einmal editiert, zuletzt von Alero ()

    Für den Inhalt des Beitrages 89990 haftet ausdrücklich der jeweilige Autor: Kababär

  • Also meherer Fragen in einem Beitrag sind nicht sinnig, machen wir hier einmal mit Yast weiter, eröffne für das Wlan einen eigenen Beitrag.


    Poste in Code-Tags:

    Code
    zypper lr -d


    Zitat

    Eben kam folgende Benachrichtigung als ich beim Installieren von Packages war (Development-Zeugs, YaST-Updates, ...)
    System management is locked by the application with pid 9344 (/usr/lib/YaST2/bin/y2base). Close this application before trying again.


    Das bedeutet: Nur ein Programm kann auf Yast bzw. die darunterliegende lib zugreifen, nicht 2 Programme gleichzeitig. Schließe erst das eine Programm.


    Zum Thema Code-Tags und andere Sachen sind unter diesem Post ein paar Links.

  • Und das ist kein "YaST Software Fehler" sondern ein Userfehler.
    Ein Klassiker.

    Für den Inhalt des Beitrages 89994 haftet ausdrücklich der jeweilige Autor: LinuPia

  • Wenn ich YaST öffne und dann einen Punkt unter Software anklicke, kriege ich beim Laden folgenden Fehler:
    Leeres Ziel in URI: hd:///?device=/dev/disk/by-id/scsi-S__...._8.07-part1


    Diese Meldung bezieht sich auf dein Installationsmedium, das nicht mehr gefunden wird, da du es entfernt hast (CD, DVD, USB). Das Repo kannst du auch löschen. Ist nach der Installation überflüssig.


    Eben kam folgende Benachrichtigung als ich beim Installieren von Packages war (Development-Zeugs, YaST-Updates, ...)
    System management is locked by the application with pid 9344 (/usr/lib/YaST2/bin/y2base). Close this application before trying again.


    Es gibt zwei Arten, ein Update zu machen (streng genommen noch viel mehr aber das sei erst einmal dahin gestellt). Ein manuelles und die "Automatik". Wenn du jetzt versuchst, in Yast ein Update zu fahren und die "Automatik" sucht auch in dem Moment nach Updates kommt es zu dieser Meldung. Siehe Sauerlands Ausführung. Entweder du wartest bis die "Automatik" fertig ist oder du untersagst ihr das Suchen nach Updates. Das ist jetzt nur sehr sehr allgemein gehalten.

  • Damit wären schon alle Fragen gelöst, ihr seid echt spitze, danke! :)


    Bis jetzt finde ich Linux sehr gut, es geht auch vieles schneller als in Windows (Beispielsweise Software-Installation aus dem Terminal heraus, zwar muss man die "links" erst suchen, aber dann gehts fiffig.)


    Ich wünsche euch noch 'nen schönen Abend.

    Für den Inhalt des Beitrages 89996 haftet ausdrücklich der jeweilige Autor: Kababär

  • zwar muss man die "links" erst suchen, aber dann gehts fiffig.


    Welche Links?


    Software bitte nur aus einem vertrauenswürdigem Repo installieren, hier gilt:
    Weniger ist mehr
    und
    Es muss nicht immer das Neueste sein.


    PS:
    Je mehr eingebundene Repos, desto höher wird die Wahrscheinlichkeit, das etwas nicht mehr funktioniert.

  • Sorry, da habe ich mich vertan.
    Bisher habe ich Software entweder über Zypper oder direkt über YaST (Dateien mit .ypm-Endungen) installiert bspw. Eclipse.


    Dass man wirklich darauf achten muss, woher eine Software kommt oder ob die Software wirklich die gesuchte ist, habe ich auch gemerkt. Habe über YaST mal alle "vorgeschlagene Software" installiert und da war JDK dabei, leider aber nicht das Original.


    Code
    java -version --alternatives-all
    openjdk version "1.8.0_65"
    OpenJDK Runtime Environment (build 1.8.0_65-b17)
    OpenJDK 64-Bit Server VM (build 25.65-b01, mixed mode)


    Mit dem diesem Java lässt sich ein java mittels javac in der bash nicht starten (Befehl gibt es nicht):


    Ich weiß was zu tun ist, wollte aber nur mal sagen, dass ich schon auf ein solches Problem gestoßen bin, wobei das noch der niedlichste Fall von "falsche Software installiert" ist.

    Für den Inhalt des Beitrages 90006 haftet ausdrücklich der jeweilige Autor: Kababär

  • Stell ich dir doch mal die Frage, ob du auch schon das packman-Repo eingebunden und vernünftig priorisiert hast sowie ein Systemupdate über das genannte Repo durchgeführt hast?


    Poste doch bitte mal folgende Konsolenausgabe in Codetags

    Code
    zypper lr -upd
  • Hey Alero,


    nein, das Package habe ich noch nicht installiert. Wozu ist das?



    Mal eine Zwischenfrage: Ist es möglich, GNU Octave (Signalverarbeitungssoftware) auch zu starten ohne dass man die Bash nicht mehr verwenden kann? Ich starte in der bash 'octave' und dann kann ich nichts mehr in der bash tun solange Octave offen ist.


    MfG und schönes Wochenende.


    edit: heilige Maria. Wieso habe ich die Leap Repo :rolleyes:

    Für den Inhalt des Beitrages 90008 haftet ausdrücklich der jeweilige Autor: Kababär

  • Wie hieß dein Thread? yast2 software fehler? Noch Fragen dazu?


    Lösche das Leap-Repo! Lösche das 13.1-Repo! Binde das Packman-Repo aus den Community-Repos ein. Priorisiere das auf 20, damit es bevorzugt wird!
    Mache ein Systemupdate in der Konsole:


    Code
    zypper clean -a && zypper ref && zypper dup


    Das packman-repo beinhaltet "bessere" Software-Pakete als in den normalen Repos, um es mal salopp auszudrücken.


    Edit: Und lass die Finger von Ein-Klick-Installationen, denn daher kommen deine unpassenden Repos ganz sicher.