Fritz Wlan Stick N v2 wird nicht erkannt/aktiviert

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Fritz Wlan Stick N v2 wird nicht erkannt/aktiviert gibt es 23 Antworten auf 3 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Fritz Wlan Stick N v2 wird nicht erkannt/aktiviert

    Hallo,

    ich möchte mit dem WLan-Stick N v2 von AVM unter opensuse Leap eine Verbindung zur FritzBox herstellen.
    Leider wird der Stick unter kde Plasma 5 weder unter der Konfiguration mit dem Netzwerkmanager, noch mit der Option "wicked" unter den yast-Netzwerkeinstellungen aktiviert. Das Netzwerkmanager-Applet zeigt kein WLan an. Lan wird anstandslos aktiviert und angezeigt.

    Quellcode

    1. lsusb liefert erstmal:
    2. Bus 001 Device 011: ID 057c:62ff AVM GmbH AVM Fritz!WLAN USB (in CD-ROM-mode)

    Im CD-ROM-mode ist das Gerät wohl nicht als WLan-Stick erkennbar.
    Leider ändert sich der CD-ROM-mode nicht automatisch, was ich in verschiedenen Beiträgen gelesen habe.

    Danach habe ich per

    Quellcode

    1. usb_modswitch...
    erreicht, dass

    Quellcode

    1. lsusbjetzt ergibt:
    2. Bus 001 Device 012: ID 057c:8501 AVM GmbH

    Nun habe ich untersucht, ob der Kerneltreiber rt2800usb per modeprobe zu einer Änderung führt. Er wird geladen, aber es tut sich nichts. Jedenfalls habe ich nichts herausgefunden.

    Zuvor habe ich per

    Quellcode

    1. modprobe -c rt5572sta |grep -i "057c.*8501"
    2. und
    3. modprobe -c rt2800usb|grep -i "057c.*8501"

    erhalten, dass der Stick von beiden unterstützt wird.
    Leider konnte ich den original RaLink-Treiber nicht kompilieren, es gab unerklärliche Fehler beim Kompilieren. So habe ich das gelassen.
    Mir ist auch die Frage gekommen, wie ich erreichen kann, dass der Stick gleich zu Anfang dem Rechner im WLan-modus zur Verfügung steht und nicht erst im CD-Rom-Modus.
    Was kann ich noch tun, um den Stick zur Arbeit zu bewegen? Oder habe ich irgendeinen Fehler gemacht?


    Danke,
    Tetomte

    Für den Inhalt des Beitrages 90532 haftet ausdrücklich der jeweilige Autor: tetomte

  • Was sagt als root:

    Quellcode

    1. ifconfig -a

    Quellcode

    1. iwconfig


    Ansonsten einmal den in meiner Signatur verlinkten Beitrag "Netzwerkprobleme" lesen und die entstehende Datei als Anhang hochladen.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 90533 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Quellcode

    1. ifconfi -a:
    2. eth0 Link encap:Ethernet Hardware Adresse 00:30:1B:47:C2:55
    3. inet Adresse:192.168.178.28 Bcast:192.168.178.255 Maske:255.255.255.0
    4. inet6 Adresse: fe80::230:1bff:fe47:c255/64 Gültigkeitsbereich:Verbindung
    5. UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    6. RX packets:128186 errors:0 dropped:0 overruns:0 frame:0
    7. TX packets:82326 errors:0 dropped:0 overruns:0 carrier:0
    8. collisions:0 Sendewarteschlangenlänge:1000
    9. RX bytes:166720723 (158.9 Mb) TX bytes:8088912 (7.7 Mb)
    10. lo Link encap:Lokale Schleife
    11. inet Adresse:127.0.0.1 Maske:255.0.0.0
    12. inet6 Adresse: ::1/128 Gültigkeitsbereich:Maschine
    13. UP LOOPBACK RUNNING MTU:65536 Metric:1
    14. RX packets:1892 errors:0 dropped:0 overruns:0 frame:0
    15. TX packets:1892 errors:0 dropped:0 overruns:0 carrier:0
    16. collisions:0 Sendewarteschlangenlänge:0
    17. RX bytes:522306 (510.0 Kb) TX bytes:522306 (510.0 Kb)
    18. wlan0 Link encap:Ethernet Hardware Adresse 24:65:11:43:C0:27
    19. UP BROADCAST MULTICAST MTU:1500 Metric:1
    20. RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    21. TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    22. collisions:0 Sendewarteschlangenlänge:1000
    23. RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
    Alles anzeigen

    Quellcode

    1. iwconfig:
    2. eth0 no wireless extensions
    3. wlan0 IEEE 802.11abgn ESSID:off/any
    4. Mode:Managed Access Point: Not-Associated Tx-Power=20 dBm
    5. Retry short limit:7 RTS thr:off Fragment thr:off
    6. Encryption key:off
    7. Power Management:off
    8. lo no wireless extensions

    Für den Inhalt des Beitrages 90536 haftet ausdrücklich der jeweilige Autor: tetomte

  • Poste einmal als root:

    Quellcode

    1. journalctl -b | grep firmware

    Quellcode

    1. journalctl -b | grep wlan

    Quellcode

    1. lsmod | grep rt2800


    Du hast aber alles bei abgezogenem Netzwerkkabel versucht?
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 90537 haftet ausdrücklich der jeweilige Autor: Sauerland

  • hi tetomte,

    die Ausgaben sagen im Prinzip nur, ich kenne dich, aber reden werde ich noch lange nicht mit dir.
    Sind denn Treiber von AVM notwendig?

    Warum hast du diesen Stick? Uralt-Computer? Halbwegs neue (Laptops) haben Wlan von Haus aus. Ich habe auch eine FritzBox. Keine Probleme mit irgend was. Nur habe ich keinen dieser Wlan Sticks.
    Wieso also den Wlan-Stick?

    Gruß
    Thomas

    Für den Inhalt des Beitrages 90540 haftet ausdrücklich der jeweilige Autor: ThomasS

  • Quellcode

    1. collectNWData.sh V0.7.5.2a -iGUI-=====>>>Detailergebnisse

    ist zu lang.
    Welche Teile soll ich entfernen, damit es passt?

    Tetomte

    Für den Inhalt des Beitrages 90542 haftet ausdrücklich der jeweilige Autor: tetomte

  • ThomasS schrieb:

    Warum hast du diesen Stick? Uralt-Computer? Halbwegs neue (Laptops) haben Wlan von Haus aus. Ich habe auch eine FritzBox. Keine Probleme mit irgend was. Nur habe ich keinen dieser Wlan Sticks.
    Wieso also den Wlan-Stick?

    Es ist ein alter Rechner ohne eingebaute Wlan-Karte.

    Tetomte

    Für den Inhalt des Beitrages 90544 haftet ausdrücklich der jeweilige Autor: tetomte

  • tetomte schrieb:

    Welche Teile soll ich entfernen, damit es passt?

    Keine, einfach in eine Textdatei kopieren und hier als Anhang posten.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 90546 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Sauerland schrieb:

    Du hast aber alles bei abgezogenem Netzwerkkabel versucht?

    Ich habe soviel gewerkelt, dass ich nicht mehr genau weiß, wann mit Lan, wann ohne.
    Das ist ein guter Hinweis, ich gehe jetzt mal offline und probiere ohne Lan-Kabel nochmal alles aus.

    Bis dahin, danke,
    Tetomte

    Für den Inhalt des Beitrages 90547 haftet ausdrücklich der jeweilige Autor: tetomte

  • @ThomasS
    Der Stick wird erst seit Kernel 3.16 nativ unterstützt, also bei openSUSE seit openSUSE 13.2.
    So alt ist der noch gar nicht.............
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 90548 haftet ausdrücklich der jeweilige Autor: Sauerland