Leap 42.1 Probleme (KDE + anderes)

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Leap 42.1 Probleme (KDE + anderes) gibt es 58 Antworten auf 6 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Leap 42.1 Probleme (KDE + anderes)

    Zur Vorgeschichte:
    Ich bin bei Suse seit V 4.1 (ja ein uralter *g*)
    ... zuletzt hatte ich V 12.1 und bin seit einer Woche auf Leap .... (kein update, sonstern neu installiert !! ) und stark am überlegen einen Downgrade auf 13.1 / 13.2 zu machen ..... und dort dann bis 2018/2019 zu verweilen .....

    Gründe:
    KDE :
    Das Breeze-Dark-Design (dunkle Schrift auf schwarzem HG mit grauem Text grauem +
    Fensterrand) lässt sich nicht ändern -> Lesbarkeit der meisten Fenster : nahe null

    Digitaluhr : egal wie groß man die Kontrolleiste zieht- bei Anzeige von Uhrzeit UND Datum (kurzform) ändert sich die Einzeiligkeit der Uhr nicht.

    Icons Kontrolleiste (Systemabschnitt) = s/w icons für geräteinfo, clipboard, drucker, ...) nicht änderbar
    (ausser dem icon für das clipboard von Schere auf ein optisch mißratenes klemmbrett bleibt alles gleich)

    Icons von anderen Programmen (zb Skype, Kteatime, Autokey, KTimer,.... : ebenso schwarz-weiß und vom Stil her von KDE 1.0, oder werden gar nicht dort angezeigt. - von Iconanimation will ich gar nicht erst reden - gibt es nicht (zb bei Kteatime)

    Icons von Programmen die in die Kontrolleiste gelegt werden : gibt es nicht - ebensowenig als Desktopsymbol (99% der symbole sind nicht vorhanden) - Buttons für dort abgelegte Programme : ebenso nicht vorhanden.

    Fensterleiste - dort gibt es nur einen einzeilligen Fenstertext !! - obwohl 2 Zeilen eingestellt sind - Eine Gruppierung erfolgt nicht - auch wenn man 10x das gleiche Programm startet - da gibt es dann nur einen winzigen, unsichtbaren Button in der Fensterleiste (ohne icon, grau in grau und je nach "Fenstermenge" evtl 4 pixel breit)

    Icons/Symbole in Dolphin : unbekannt - weder in der Menueleiste oben, noch in den Dateien ...

    Buttons (zb im clipboard für aktion, editieren, löschen) -> ebenso leer, bzw transparent oder nur ein schmaler, vertikaler Balken (zb systemeinstellungen)

    Nachdem in den Original-Repros teilweise eine sehr magere Auswahl besteht, habe ich zb für Spiele noch einige Extra-Repros dazugenommen (zb von 13.1) - mit ernüchterndem Resultat

    Spiele die ich schon uner 12.1 hatte und spielte -> nicht installierbar, da bestimmte Bibliotheken gefordert werden, die Leap nicht (aktuell) anbietet - vermutlich wegen der SLES-Basis

    zb:

    libzip.so.4 -> in der Leap-Version ist gerade mal .so.2 "aktuell"
    libboost_system.so.1.59/1.60 -> Leap hat gerade mal V 1.54

    Abstürze von KDE-Programmen : im vergleich zu 12.1 etwa um 500% gestiegen - angefangen von Programmen die IMMER abstürzen (systemeinstellungen), jedes 2te Mal abstürzen (Lautstärkeeinstellungen der aktuellen Anwendungen, bis hin zu relativ planlosen Abstürzen (Dolphin, wenn man dort etwas intensiver arbeiten (muss)

    GTK-Programme (zb Google Chrome) die auf den KDE Passwort-Speicher zugreifen wollen / müssen :
    Eine einzige traurige Lachnummer : erst wird via GTK-Fenster abgefragt (graues Fenster) - dann ein zweites (schön schwarz und kaum lesbar) - dann noch ein drittes mal via GTK und noch ein viertes Mal via KDE Fenster -> 4x Abfrage für den Migrationsassistenten für das KDE-wallet ???? - und das im wechsel ?

    Das ganze erinnert sehr stark als KDE noch in der Alpha-Phase war - und Suse noch auf handlichen 5 CD's daherkam.

    Anbei ein Paar Screenshoots - das einzige was sich beim ausprobieren der installierten Leap-Designs ändert : Transparent der Symbole auf dem Desktop ( von leicht grau auf transparent wie auf dem Screen dazu)

    Installiert sind aktuell nur Programme aus den Leap-Repros + packman, die Spiele die ich via 13.1,13.2,Factory und tumbleweed holen wollte gehen ja nicht zum installieren

    Wer ideen hat das mir leap doch noch gefallen könnte ... ich bin für jede idee offen - aber so unter linus arbeiten und sich "wohlfühlen" ? geht nicht

    Für den Inhalt des Beitrages 91523 haftet ausdrücklich der jeweilige Autor: Cobraxas

  • Bei mir läuft Leap ohne jede Macke.
    Lediglich den proprietären Videotreiber hat es nicht gepackt.
    Was mit egal ist, da der open Source Treiber eh alles gut macht.
    Einschließlich aller Effekte.

    Da du nur lamentierst, bleibt als Tip nur:
    Mische NIEMALS irgendwelche Repos von unterschiedlichen Versioenen!
    Das zerschießt dein System ganz sicher.
    Du wirst also größtenteils selbst Schuld sein.

    Ansonsten wären konkrete Angaben zur Hardware und Installation sinnvoll.
    Lamentieren hilft nicht.

    Für den Inhalt des Beitrages 91524 haftet ausdrücklich der jeweilige Autor: LinuPia

  • Cobraxas schrieb:

    Spiele die ich schon uner 12.1 hatte und spielte -> nicht installierbar, da bestimmte Bibliotheken gefordert werden, die Leap nicht (aktuell) anbietet - vermutlich wegen der SLES-Basis

    zb:

    libzip.so.4 -> in der Leap-Version ist gerade mal .so.2 "aktuell"
    libboost_system.so.1.59/1.60 -> Leap hat gerade mal V 1.54

    Bleib einmal auf dem Boden, die libs gibt es genauso für Leap wie für dein altes openSUSE 12.1, musst nur, wie bei openSUSE 12.1 auch, ein Repo aktivieren.
    Gilt ebenso für openSUSE 13.1 und 13.2.

    Cobraxas schrieb:

    Installiert sind aktuell nur Programme aus den Leap-Repros + packman, die Spiele die ich via 13.1,13.2,Factory und tumbleweed holen wollte gehen ja nicht zum installieren

    Da haben wir ja schon den Übeltäter, so etwas sollte man vermeiden.

    PS:
    Was sollte openSUSE bei dem Release machen, auf ein nicht mehr weiterentwickeltes KDE4 setzen oder halt auf Plasma 5?
    Stell dir einmal die Frage.

    Und wenn es nicht geht, installiere Dir openSUSE 13.1 oder 13.2.
    Dort gibt es aber genauso wenig die oben angemeckerten libs im Standard Repo.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags
    zypper
    Netzwerkprobleme

    Für den Inhalt des Beitrages 91526 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Sauerland schrieb:


    libzip.so.4 -> in der Leap-Version ist gerade mal .so.2 "aktuell"
    libboost_system.so.1.59/1.60 -> Leap hat gerade mal V 1.54
    Bleib einmal auf dem Boden, die libs gibt es genauso für Leap wie für dein altes openSUSE 12.1, musst nur, wie bei openSUSE 12.1 auch, ein Repo aktivieren.
    Gilt ebenso für openSUSE 13.1 und 13.2.
    Ähm ? nee - libboost_system ist in den Haupt-Repros (und leap-Aktuell = V1.54 -> also müsste ich für ein Programm das eine neuere version verlangt, diese Hauptrepro von v 13.1 / 13.2 nehmen -> da Plasma (noch) nicht überzeugt ( Design, Abstürze) wäre es jedoch sinnvoller, einen kompletten Downgrade zu machen - allein von der Systemintegrität

    Cobraxas schrieb:

    Installiert sind aktuell nur Programme aus den Leap-Repros + packman, die Spiele die ich via 13.1,13.2,Factory und tumbleweed holen wollte gehen ja nicht zum installieren

    Da haben wir ja schon den Übeltäter, so etwas sollte man vermeiden.
    ? Die Repros sind nur eingebunden - jedoch noch nichts installiert daraus (wegen den fehlenden Abhängikeiten) - Insofern kann eine zusätzliche "Quelle" - von der jedoch nichts installiert wurde, kein Übeltäter sein ;)
    PS:
    Was sollte openSUSE bei dem Release machen, auf ein nicht mehr weiterentwickeltes KDE4 setzen oder halt auf Plasma 5?
    Stell dir einmal die Frage.

    Und wenn es nicht geht, installiere Dir openSUSE 13.1 oder 13.2.
    Dort gibt es aber genauso wenig die oben angemeckerten libs im Standard Repo.
    Antworten :
    ggf das Release um 2-3 Monate nach hinten schieben für bessere Stabilität ?

    Falsch ->.. siehe oben-> Haupt-Repro = dort liegen diese "netten" Libs - aber Leap mit den kompletten Repros von 13.1 / 13.2 mischen ? oh jeah ... klingt nach einem sehr stabilen systemmischmasch ...

    zudem ist das nur ein "nebensächliches" Problem - das Hauptproblem sind die nicht vorhandenen Symbole/Icons / das grauenvolle Festdesign das sich nicht ändern lässt (nur für GTK änderbar)

    LinuPia schrieb:

    Bei mir läuft Leap ohne jede Macke.
    Lediglich den proprietären Videotreiber hat es nicht gepackt.
    Was mit egal ist, da der open Source Treiber eh alles gut macht.
    Einschließlich aller Effekte.

    Da du nur lamentierst, bleibt als Tip nur:
    Mische NIEMALS irgendwelche Repos von unterschiedlichen Versioenen!
    Das zerschießt dein System ganz sicher.
    Du wirst also größtenteils selbst Schuld sein.

    Wie gesagt - Diesse "beanstandeten" Repros sind nur die Spielerepros - zudem wurde von dort nichts installiert = Abhängikeitsproblem
    und als repro kann man meines wissens nichts zerschießen, solange von dort nicht 1 bit installiert wurde (die repro-beschreibung tut dem system ja nix)
    Lamentieren ? nunja - eher eine etwas frustrierte Fehlerbeschreibung :D

    Ansonsten wären konkrete Angaben zur Hardware und Installation sinnvoll.
    Lamentieren hilft nicht.


    Hardware : Quadcore, AMD, 2 HD's ( 1x system mit 500 MB incl home, 1x 1 GB als backup + Extradaten (zb mp3), extra eingebunden (64 Bit)
    2 Soundkarten (von denen nur eine funktioniert, die andere (auf dem Mainboard integriert) weigert sich (war schon immer) - aber das "juckt" mich wenig - die Hauptkarte ist konfiguriert und läuft tadellos.

    Intallation:
    Bisher nur von der DVD + Community-Repros zu Leap + packman-Leap (also nur die die Yast selber "zusätzlich" holt wenn man die offiziellen Community-Repros abruft zum einbinden

    Etrarepros (nichts installiert - wegen fehlenden Abhängikeiten) (quasi nur zum schauen/suchen meiner "alten" Spiele) :
    download.opensuse.org/reposito…ames/openSUSE_Tumbleweed/
    download.opensuse.org/repositories/games/openSUSE_Factory/
    download.opensuse.org/repositories/games/openSUSE_13.1/
    download.opensuse.org/repositories/games/openSUSE_13.2/

    Für den Inhalt des Beitrages 91529 haftet ausdrücklich der jeweilige Autor: Cobraxas

  • Viele deiner Probleme ergeben sich nicht aus leap, sondern aus plasma 5. Bitte nicht verwechseln.
    Für diese Probleme kann leap nichts! Daher bitte nicht die gesamte Distro verteufeln. Auch bei mir läuft leap mit plasma 5 relativ gut. Klar gibt es noch viele Ecken und Kanten, da Plasma 5 noch stark in der Entwicklung ist.
    Vielleicht wäre es gut gewesen eine Wahlmöglichkeit zwischen kde 4 plasma5 zu haben...

    Für den Inhalt des Beitrages 91530 haftet ausdrücklich der jeweilige Autor: mairo

  • Sehe ich das richtig:
    Du argumentierst gegen gute Ratschläge, aber dein System spinnt einigermaßen.
    Bei anderen geht es einwandfrei.
    Also müssen deine Argumente in jedem Fall richtig sein?

    Aber sonst geht es schon noch halbwegs gut, oder?

    Deine Behauptung, dass gemischte Repos nichts ausmachen würden, hast du weder belegt, noch ist es in der Sache richtig.
    Es genügt ein neues Paket zu installieren, damit in den Libs Mischmasch auftritt.

    Wenn du meinst, dass dein Wissen ausreicht, dann lösche openSUSE, installiere ein anderes, oder nimm gleich ein Apfeltelephon.

    Und wenn du meinst, unsere Ratschläge ignorieren zu müssen, dann lasse das Posten gleich sein.
    Macht ja dann nicht wirklich Sinn.
    DAS sollte doch sogar dir einleuchten, oder?

    Falls du doch nocheimal postest, bitte achte darauf, dass du korrekt zitierst.
    Nicht in die Zitate hineinschreiben.
    Es lohnt sich auch ein etwas Zeit zu investieren, um die Bedienung des Forums zu lernen.

    Für den Inhalt des Beitrages 91531 haftet ausdrücklich der jeweilige Autor: LinuPia

  • Noch einmal:
    Die Versionen, die du anmeckerst, sind weder im OSS von 13.1, 13.2, Leap und 12.1 schon gar nicht.

    Auf gut Deutsch:
    Willste mehr PS musste anderen Motor einbauen!
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags
    zypper
    Netzwerkprobleme

    Für den Inhalt des Beitrages 91532 haftet ausdrücklich der jeweilige Autor: Sauerland


  • Aber das für die installierte Version passende Repo geflissentlich nicht gepostet?
    download.opensuse.org/repositories/games/openSUSE_Leap_42.1/
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags
    zypper
    Netzwerkprobleme

    Für den Inhalt des Beitrages 91533 haftet ausdrücklich der jeweilige Autor: Sauerland

  • LinuPia schrieb:

    Sehe ich das richtig:
    Du argumentierst gegen gute Ratschläge, aber dein System spinnt einigermaßen.
    Bei anderen geht es einwandfrei.
    Also müssen deine Argumente in jedem Fall richtig sein?


    Aber sonst geht es schon noch halbwegs gut, oder?

    Deine Behauptung, dass gemischte Repos nichts ausmachen würden, hast du weder belegt, noch ist es in der Sache richtig.
    Es genügt ein neues Paket zu installieren, damit in den Libs Mischmasch auftritt.


    Wenn du meinst, dass dein Wissen ausreicht, dann lösche openSUSE, installiere ein anderes, oder nimm gleich ein Apfeltelephon.

    Und wenn du meinst, unsere Ratschläge ignorieren zu müssen, dann lasse das Posten gleich sein.
    Macht ja dann nicht wirklich Sinn.
    DAS sollte doch sogar dir einleuchten, oder?

    Falls du doch nocheimal postest, bitte achte darauf, dass du korrekt zitierst.
    Nicht in die Zitate hineinschreiben.
    Es lohnt sich auch ein etwas Zeit zu investieren, um die Bedienung des Forums zu lernen.


    1.) Die Reprobeschreibung / Dateiliste kann man problemlos installieren - auch gemischt -> das ist nur eine infodatei für yast was in der entsprechenden Repro liegt = kein problem

    2.) wie ich schon geschrieben habe ->
    Installation / genutzte Repros = Leap 42.1 only via Community-Einbindung (also nicht einmal extra Leap-42.1 Repros die ggf existieren, aber nicht offiziell sind)

    Nicht Leap-42.1 Repros : nur die aufgelisteten, daraus wurde kein Programm installiert (wegen den fehlenden Abhängikeiten) = waren / sind nur zum schauen wo meine "alten" spiele geblieben sind
    und eine repro, aus der nur die beschreibung auf dem pc "landet" macht meines wissens nichts aus.

    Zumal das icon/ designproblem schon immer war (die look-only repros habe ich erst seit 2 tagen "eingetragen" - nachdem auch tagelanges suchen / probieren nichts am fehlen der icons, bzw am kde-fensterdesign änderte)

    Selbst bei einem neu angelegten user = nix anderes als leere, bzw kde-dunkelfenster

    und ratschläge nehme ich gerne an - sofern diese sich nicht selbst widersprechen ( zb ist libboost_system in der Hauptrepro -> anderesx repro einbinden ? ok - und welches ? Nur weil 2 meiner "alten" Lieblingsspiele nur unter Games/Tumbleweed, Factory oder 13.x liegen ggf diese Hauptrepros auch einbinden & nutzen ?

    ich kann mich zumindest sehr gut erinnern das diese Spiele unter 12.1 problemlos zu installieren waren mit den Standard-Repros
    zudem halte ich von einem solchen mix gar nichts ( habe ich aber auch erwähnt)

    insofern schlage ich auch keine Ratschläge aus, bzw handle gegen besseres Wissen (wie unterstellt)
    Weil das reine "herunterladen" der repro.xml stellt das system nicht in Frage, oder beschädigt dies - egal aus welcher Distri diese stammt (wäre mir zumindest was ganz neues das eine XML zb kde- zerschießt, die davor auch nicht gingen )

    und wie schon gesagt -> das kde problem war schon direkt nach der (neu)installation vorhanden - das meine "alten" spiele (noch nicht *hoff) unter Leap verfügbar sind ... ok

    Für den Inhalt des Beitrages 91539 haftet ausdrücklich der jeweilige Autor: Cobraxas

www.cyberport.de