Zugriff auf den USB Port

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Zugriff auf den USB Port gibt es 9 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • Zugriff auf den USB Port

    Hallo zusammen
    Ich habe auf meinem Rechner SUSE 11.1 installiert und habe ein Problem mit dem Zugriff auf ein USB Gerät.
    Das Gerät ist ein Programmieradapter mit dem Namen USBProg. Um als User Zugriff auf das Gerät zu bekommen muss laut dieser Anleitung embedded-projects.net/index.php?page_id=215 eine Datei unter den Pfad /etc/hal/fdi/policy/20customized.fdi angelegt werden.
    Diese Datei habe ich wie beschrieben angelegt aber ich bekomme immer die Fehlermeldung "I/O Error: could not claim interface 0: Operation not permitted" wenn ich versuche auf das Gerät zuzugreifen. Ich habe auch schon versucht eine neue rules Datei anzulegen mit den Einstellungen SUBSYSTEM="usb", ATTRS{idVendor}=="03eb", ATTRS{idProduct}=="2104", GROUP="users", MODE="0666" aber auch das brachte nicht der erhofften Erfolg. Unter dem Benutzer root funktioniert es ohne Probleme. Woran könnte es noch liegen das ich keine Zugriff auf den USB Port habe?
    Gruß r-forty-five

    Für den Inhalt des Beitrages 7711 haftet ausdrücklich der jeweilige Autor: r-forty-five

  • Hallo Robbie
    Danke erstmal für die Antwort.
    Das mounten eines USB Speicherstick funktioniert bei mir dank automounter
    ohne Probleme. Nur das Problem ist das der USBProg keine Speicherstick ist sondern ein Programmieradapter zu vergleichen vielleicht mit einem Bluetooth Stick. Bei dem einstecken vom Gerät wird im Ordner Media nichts angezeigt. Ich muss das Gerät mit den Befehlen „devices“ „device 0“ in den Updatemodus bringen. Angezeigt wird danach



    (usbprog) devices
    [ 0] * Bus 002 Device 004: 3eb0:2104
    avrispmk2: USBprog with "AVRISP mk2 Clone" firmware


    Im Anschluss kann ich mit dem Befehl update blinkdemo eine neue Firmware auf das Gerät aufspielen. Für das weitere Benutzen vom USBProg brauche ich ebenfalls den Zugriff darauf.
    Hast du noch eine Tipp woran es liegen könnte?
    Gruß r-forty-five

    Für den Inhalt des Beitrages 7727 haftet ausdrücklich der jeweilige Autor: r-forty-five

  • Hallo r-forty-five,

    den Benutzer mal probehalber der Gruppe "disk" hinzufügen?

    Wenn es unter root klappt, wäre vielleicht eine "sudo-Regel" hilfreich, wenn das Problem nicht anderweitig gelöst werden kann.
    Wenn sudo bei Dir eingeschaltet ist, einfach vor dem Befehl den Du als Root eingeben würdest, ein "sudo" voranstellen.

    Es ist aber ganz klar ein Rechte-Problem.
    Solange ich nicht weiß, wo von dem USB-Gerät was genau wohin "eingehangen" wird, kann ich auch nicht sagen, welche Rechte angepasst werden müssen.

    Ich habe beispielsweise mit einem UMTS-Stick manchmal Probleme. Obwohl ich die Rechte von Root auf User geändert habe, wird das irgendwie von Zeit zu Zeit wieder zurückgesetzt.
    Es ist zwar kein großes Problem, weil ich die 2 Befehle zum ändern der Rechte in meiner Bash-Hystorie habe, es ist aber auch lästig.

    Gruß Robbie

    edit: Schau mal in dem Verzeichnis

    Quellcode

    1. /etc/udev/rules.d
    , ob Du dort irgendeine Datei findest, die mit Deinem USB-Gerät übereinstimmt.
    Diese als root mal in einem Editor öffnen

    Quellcode

    1. alt+F2, dann kdesu kate
    eingeben.

    Dort dann mal in der Zeile "Mode" die Zahlen dort (meist 664 oder 0664) in 777 oder entsprechend 0777 ändern

    edit2: Ich lese gerade auf der von Dir gelinkten Seite (ja, Asche auf mein Haupt; das sollte man zuerst machen), dass die Datei in etc nicht "20customized.fdi" heissen soll sondern "20customized"

    Für den Inhalt des Beitrages 7728 haftet ausdrücklich der jeweilige Autor: robbie

  • Hallo Robbie
    Mit dem Befehl sudo Funktioniert das Gerät um eine neue Firmware aufzuspielen. Aber es geht nicht nur um eine neue Firmware aufspielen sondern es wird der Adapter vom Programm AVR Studio angesprochen um über diesen dann ein neues Programm auf eine Mikrocontroller aufzuspielen. Somit reicht es nicht aus ihn mit sudo anzusprechen.
    Ich habe auch dein Tipp mit disk ausprobiert aber das bringt auch keinen Erfolg.
    Mit was für ein Befehl bekommt man heraus wo den der Stick sich einhängt.
    Ist vielleicht ein Log von der Hardware hilfreich?
    Gruß r-forty-five

    Für den Inhalt des Beitrages 7729 haftet ausdrücklich der jeweilige Autor: r-forty-five

  • Änder bitte erstmal die Datei

    Quellcode

    1. /etc/hal/fdi/policy/20customized.fdi
    wie in der Website beschrieben, indem Du das "fdi" am Ende löschst.

    Vielleicht ist das ja das Problem

    Für den Inhalt des Beitrages 7730 haftet ausdrücklich der jeweilige Autor: robbie

  • Hallo
    Da sucht man 3 Tage im Internet nach einer Lösung und findet nichts. Und dann durch Zufall findet man doch noch eine Seite wo die Lösung steht. :-/
    Für alle die das selbe Problem haben hier der Link.
    jan-grosser.de/basteleien/mikr…b87e63363c30b9e28ea3adbee
    Bei mir funktioniert es zwar nur mit dem Befehl
    sudo chmod ugo=rwxrwxrwx /dev/bus/usb/002/023
    aber das ist ja auch egal.
    Die Zahlen 002/023 müssen angepasst werden mit den tatsächlichen Zahlen die man mit dem Befehl devices auslesen kann.
    Danke nochmals an Robbie für die Unterstützung
    Gruß r-forty-five

    Für den Inhalt des Beitrages 7735 haftet ausdrücklich der jeweilige Autor: r-forty-five

  • Hallo r-forty-five,

    dann gratuliere ich mal für die selbstgefundene Lösung und wünsche noch viel spaß hier im Forum

    Liebe Grüße
    Robbie

    Für den Inhalt des Beitrages 7737 haftet ausdrücklich der jeweilige Autor: robbie