Brother Netzwerkscanner unter Tumbleweed

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Brother Netzwerkscanner unter Tumbleweed gibt es 8 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • Brother Netzwerkscanner unter Tumbleweed

    Hallo zusammen, ich versuche vergeblich den Scanner meines Brother MFC-7820N unter Tumbleweed auf meinem Notebook anzusprechen (aktueller Snapshot).
    Der Installer von der Brother Solutions Seite lief ohne Fehlermeldung durch, ein

    Quellcode

    1. brsaneconfig2 -q
    zeigt mir den Scanner unter "Devices on network" an.


    Der Aufruf einer Scannerapplikation (z.B. simplescan) bringt immer die Fehlermeldung, dass kein Scanner gefunden wurde.

    Der Befehl

    Quellcode

    1. scanimage -L
    liefert folgende Meldung (als user und root).

    Quellcode

    1. No scanners were identified. If you were expecting something different, check that the scanner is plugged in, turned on and detected by the sane-find-scanner tool (if appropriate). Please read the documentation which came with this software (README, FAQ, manpages).

    Das Kommando

    Quellcode

    1. brscan-skey -l
    liefert eine leere Ausgabe


    Das Yast Modul Scanner zeigt unter der Spalte "Treiber" den Eintrag "brother2" und unter "Scanner" den Eintrag "Kein Scanner von diesem Treiber erkannt"


    Der Drucker arbeitet problemlos unter Tumbleweed.
    Die Firewall hatte ich zu Testzwecken ausgeschaltet als auch das Netzwerk zur internen Zone erklärt (beides ohne Erfolg).


    Auf meinem Desktop läuft Leap und dort wird der gleiche MFC ohne Probleme erkannt und eingerichtet. Nutze ich auf dem Notebook eine andere Distribution, funktioniert der Scanner ohne Probleme (ausprobiert mit Leap und Ubuntu Mate).
    Das Problem unter Tumbleweed tritt auch mit einer ganz frischen Installation auf.

    Ein schneller Vergleich der installierten Software nach dem Suchbegriffen "scan" und "sane" zwischen dem Leap- und Tumbleweedrechner unter dem Yast Softwaremodul war deckungsgleich.

    Vielleicht hat ja noch jemand von Euch eine Idee
    Anbei noch ein paar weitere Infos

    Brainfuck-Quellcode

    1. S | Name | Typ | Version | Architektur | Repository --+-------------+---------+---------+-------------+---------------
    2. i | brscan-skey | package | 0.2.4-1 | x86_64 | (Systempakete)
    3. i | brscan2 | package | 0.2.5-1 | x86_64 | (Systempakete)

    Quellcode

    1. Linux dallas 4.4.3-1-default #1 SMP PREEMPT Fri Feb 26 09:54:10 UTC 2016 (171b8f1) x86_64 x86_64 x86_64 GNU/Linux

    Allen schon einmal vielen Dank und einen schönen Abend

    Für den Inhalt des Beitrages 93218 haftet ausdrücklich der jeweilige Autor: dampfbetrieben

  • Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 93219 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Hallo,
    In welchen Gruppen ist dein Benutzer? Überprüfe mal die Gruppenzugehörigkeiten.
    Starte mal xsane. Ich hatte mit meinem Scanner von Brother im Netzwerk auch Probleme. Aber mit xsane läuft es.
    Versuche auch mal ggf xsane als root zu starten wenn es als User nicht funktioniert.
    Hilfreich wäre es sicher auch wenn du die Programme im Terminal startest, dort könnten dann eventuelle Probleme ausgegangen werden, z. B. Probleme mit Zugriffsrechten ...
    Gruß

    Für den Inhalt des Beitrages 93221 haftet ausdrücklich der jeweilige Autor: mairo

  • hallo mairo,

    mein Konto ist nur in der Gruppe "users". Das ist er aber identisch zu meiner Leap Installation wo der Scanner funktioniert.
    Sowohl xsane als auch simple-scan starten ohne Fehlermeldung auf der Konsole, geben aber in der GUI den Hinweis, dass kein Gerät gefunden wurde. Das Verhalten ist als root als auch als user identisch.

    Unter /usr/local/Brother/sane/brsanenetdevice2.cfg ist das Gerät gelistet.

    Mir gehen langsam die Ideen aus. Was mich halt stutzig macht, ist, dass der Treiber im Yast Modul gelistet ist, aber keinen Eintrag anzeigt (s.o.).

    @Sauerland Zum Glück ist es nur mein "Spielrechner" auf dem ich häufiger mal etwas neues ausprobiere. Trotzdem bin ich mir recht sicher, dass der Scanner letztes Jahr (gegen Ende) unter Tumbleweed funktioniert hat. Jetzt ist plötzlich Schluss. Vielleicht hat sich da etwas am Unterbau geändert?

    Für den Inhalt des Beitrages 93225 haftet ausdrücklich der jeweilige Autor: dampfbetrieben

  • hmmm, das Problem scheint doch tiefer zu liegen. Ich habe gerade die Treiber per uninstall Skript entfernt und die Treiber per Skript neu installiert. Diesmal habe ich den Scanner per USB-Verbindung einrichten lassen und den Scanner per USB verbunden.

    Quellcode

    1. sudo sane-find-scanner

    findet den Scanner,

    Quellcode

    1. scanimage -L

    findet nichts (genau wie alle grafischen Scan-Programme), auch nicht mit root Rechten. lsusb listet den Scanner aber und in der udev Regel (/etc/udev/rules.d/55-libsane.rules) ist der Scanner in der Liste enthalten und nicht auskommentiert. Meinen Benutzer habe ich zur Gruppe "lp" hinzugefügt
    Unter dem Yast Modul wird der Treiber "brother2" angezeigt aber "Kein Scanner von diesem Treiber erkannt" steht unter Scanner, also genau wie beim Versuch den Netzwerkscanner einzurichten.

    Ich bin ratlos

    Für den Inhalt des Beitrages 93283 haftet ausdrücklich der jeweilige Autor: dampfbetrieben

  • Einen habe ich noch. Habe den Scanner wieder als Netzwerkscanner eingerichtet.

    Mittels

    Quellcode

    1. SANE_DEBUG_DLL=128 scanimage -L
    habe ich endlich scanimage dazu gebracht, mir zu sagen, wo denn der Schuh drückt (dank dieses Posts)

    Quellcode

    1. [dll] load: dlopen() failed (libusb-0.1.so.4: cannot open shared object file: No such file or directory)

    Die Bibliothek ist Teil des Paketes libusb-0_1-4. Ein kurzer Test unter Leap -> Paket installiert. Test unter Tumbleweed -> Paket nicht installiert.Also das Paket unter Tumbleweed installiert und der Scanner läuft wieder als Netzwerkscanner :smilie_hops_011: .

    Hoffe es hilft :)

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von dampfbetrieben ()

    Für den Inhalt des Beitrages 93288 haftet ausdrücklich der jeweilige Autor: dampfbetrieben

  • Nachdem ich zwei Tage alle möglichen Foren durchsucht habe und schon an meinen Berechtigungen gezweifelt habe: Es funktioniert prima mit der neuen libusb-0_1-4!
    Brother MFC J 5720 DW
    Respekt und Danke

    frankhs0

    Für den Inhalt des Beitrages 98825 haftet ausdrücklich der jeweilige Autor: frankhs