NVIDIA Optimus Grafikkarte unter Leap 42.1

Hinweis: In dem Thema NVIDIA Optimus Grafikkarte unter Leap 42.1 gibt es 81 Antworten auf 9 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • @ Kosstamonjan:
    Die Unterschiede zeigen dabei nur an, dass bumblebee funzt. Es sind keine Benchmarks!!! Z. B. werden die 60 fps ohne optirun auf die Bildwiederholfrequenz 60 Hz wohl künstlich herabgesetzt. Für Benchmarking (interne GPU vs. diskrete GPU) bitte andere Programme nutzen. Auch mal bei phoronix schauen.


    Eine Schlussfolgerung für mich ist beispielsweise, dass ich bei einem Neukauf wohl mehr Geld in den Prozessor mit ordentlicher interner GPU stecke und auf eine (billige) diskrete GPU gänzlich verzichte. Spielmätze können/sollten mehr Geld für eine schnelle GPU ausgeben, diskrete Billig-GPU könnten rausgeworfenes Geld sein. Wen es interessiert, Benchmarking-Programme nutzen. Eure Benchmarking-Ergebnisse würden mich auch interessieren.

    3 Mal editiert, zuletzt von Jana ()

    Für den Inhalt des Beitrages 97016 haftet ausdrücklich der jeweilige Autor: Jana

  • Hilft dem TE wenig aber:
    Gestern einen neuen Laptop gekauft, nachgeschaut was für eine Grafikkarte , Intel Skylake, wird zwar erst ab Kernel 4.4 richtig unterstützt, ist aber kein Problem.
    In den Systemeinstellungen von Windows dann noch nachgeschaut, was für ein Lan (Realtek) und Wlan (Intel) und gekauft.

  • Zitat von Sauerland

    Gestern einen neuen Laptop gekauft, nachgeschaut was für eine Grafikkarte , Intel Skylake, wird zwar erst ab Kernel 4.4 richtig unterstützt, ist aber kein Problem.

    Genau das meinte ich ... :D

    Für den Inhalt des Beitrages 97018 haftet ausdrücklich der jeweilige Autor: Jana

  • Gemäß @Jana und @KosstAmojan habe ich mich den Gruppen "bumblebee" und "video" hinzugefügt. Anschließend nochmal neugestartet.
    Ausschalten ebenso wie der Bootvorgang inzwischen fehlerfrei und schnell. Lediglich die "Oh no"-Grafik kommt noch kurz vorm Desktop.


    @JanaHier die Ausgaben deiner Befehle:

    Es erscheint eine animierte Grafik. Beim dritten Befehl schnell, beim letzten Befehl langsamer.


    @KosstAmojan


    Zitat

    Hast Du dann auch ein neues Bootimage erstellen lassen (mkinitrd) ?

    Ja, habe ich gemäß Anleitung gemacht.


    Zitat


    Eine Frage: hast Du die "Bumblebee nvidia Treiber" installiert, oder die
    nvidia Treiber von der nvidia Homepage? eigentlich müsste es in etwa so
    aussehen:

    Ich habe gemäß der Anleitung die Repositories hinzugefügt und die Pakete "X11-video-nvidia" sowie "Bumblebee" installiert (über YAST / Software installieren).


    Zitat


    Bei Dir fehlt als Kernelmodul "nvidia_drm"

    Wie bekomme ich das noch hinzu? Welche Schritte der Anleitung muss ich danach nochmal ausführen? (Es stand nicht in der Anleitung).

    In Nutzung: ASUS X5DIJ | Intel Dual-Core T4300 | Intel GMA 4500M | 4GB RAM | 320GB HDD | Dual-Boot: openSUSE 13.2 x64 + Windows 7 x64
    Im Aufbau: ASUS N750JK | Intel i7-4700HQ | NVIDIA GeForce GTX 850M | 16GB RAM | 240 GB SSD + 1 TB HDD | Dual-Boot: openSUSE Leap 42.1 + Windows 10

    Für den Inhalt des Beitrages 97020 haftet ausdrücklich der jeweilige Autor: Friedrich Kunowski

  • @Sauerland

    Zitat

    zypper se -si kernel nvidia

    liefert:




    Zitat

    zypper lr -d

    liefert:


    Kurze Ergänzung noch zum vorherigen Post: ich habe zwar das Paket "bumblebee" per Yast installiert aber nicht "nvidia-bumblebee", falls das wichtig ist (siehe angehängte Grafik).


    EDIT:

    Zitat

    cat ~/.xsession-errors-\:0

    Das führt er zwar aus, aber es erscheint keine Ausgabe.

  • @Friedrich Kunowski , das nvidia_drm Modul sollte eigenlich automatisch installiert werden - zumindest unter 13.2 (42.1 hab ich nicht, eventuell wird da ein Andrer Weg gegangen?!?). Was für einen Kernel hast Du denn?
    ==> Da war ich wohl zu langsam =)


    @Jana , eine dedizierte Graka kann schon sinn machen, da die IGP ja keinen eigenen Video-speicher (Grafik VRAM) hat und sich diesen dynamisch vom RAM abknappst. Wenn man jetzt zB nur 4GB RAM verbaut hat, die IGP sich 2GB nimmt, hat man nur noch 2GB fürs Restsystem.

  • @Friedrich Kunowski , das sind beides nvidia Treiber. Der eine ist halt direkt vom Bumblebee Projekt, der Andere ein Script, was die Treiber bei nvidia runterläd, patcht und installiert.
    Kannst ja mal beide ausprobieren, vielleicht hast Du mit dem Bumblebee Treiber diesen Fehler nicht mehr.


    Notfalls mal den Kernel auf das Kernel builds for branch stable (standard) umstellen (aktueller Kernel 4.6.4).

  • @KosstAmojan
    - Stimmt, nvidia_drm fehlt tatsächlich bei mir. Habe auch nochmal in den Hardware-Informationen geschaut (an identischer Stelle zu deiner Grafik)
    - Kernel ist laut Wikipedia 4.1 in openSUSE 42.1 (hab ja nix verändert, sondern die aktuellste Version ausm Netz gezogen)


    @Sauerland
    Was sagen dir meine Terminal-Ausgaben zu deinen Befehlen?


    EDIT:


    Zitat

    Notfalls mal den Kernel auf das Kernel builds for branch stable (standard) umstellen (aktueller Kernel 4.6.4).

    Ohgott, ohgott ... Ist das eine Kernelaktualisierung? *schwitz*
    Den Link als Repo hinzufügen bestimmt, und dann?

    In Nutzung: ASUS X5DIJ | Intel Dual-Core T4300 | Intel GMA 4500M | 4GB RAM | 320GB HDD | Dual-Boot: openSUSE 13.2 x64 + Windows 7 x64
    Im Aufbau: ASUS N750JK | Intel i7-4700HQ | NVIDIA GeForce GTX 850M | 16GB RAM | 240 GB SSD + 1 TB HDD | Dual-Boot: openSUSE Leap 42.1 + Windows 10

    Für den Inhalt des Beitrages 97025 haftet ausdrücklich der jeweilige Autor: Friedrich Kunowski

  • @Friedrich Kunowski , Ich glaub, ich hab den "Fehler" entdeckt:


    Du hast das Bumblebee project (Kernel_stable_standard) repo eingebunden. Das dort verwendete bbswitch Kernel Modul ist für den Kernel 4.6.4-3 Du hast aber noch Kernel 4.1.27-24.1installiert. Das dürfte es sein.



    P.S.: oder alternativ, wenn Du keinen neueren Kernel möchtest, auf das Repo "Bumblebee project (openSUSE_Leap_42.1)" wechseln statt Bumblebee project (Kernel_stable_standard)
    P.P.S.: sehe grade, das dort hinterlegte Kernelmodul ist für Kernel 4.1.12 - dann lieber auf den neuen Kernel wechseln.