42.1 UEFI Dual-Boot Win10 auf einem Acer F5-571 installieren

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema 42.1 UEFI Dual-Boot Win10 auf einem Acer F5-571 installieren gibt es 7 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • 42.1 UEFI Dual-Boot Win10 auf einem Acer F5-571 installieren

    Hallo Zusammen
    Ich habe einen neuen Acer Aspire F15 F5-571-58NI gekauft und dem installierten Windows10 die Partition um 600GB verkleinert, für ein Dual-Boot mit opensuse Leap 42.1. Das Bios ist sehr bescheiden, keine Grafik. Mögliche relevante Einstellungen sind Boot-Modus: (MBR)/UEFI, Secure Boot: Ja/(Nein) und TPM: Ja/(Nein). In der Boot Reihenfolge muss das DVD-Laufwerk an die oberste Stelle, sonst wird die Installations-DVD nie gebooted. Das F12 Boot-Menu wurde vom Windows Boot-Manager irgend wie abgeschaltet.
    Alle Opensuse Installationen laufen in einen Loop, booted DVD, installieret und rebooted wieder die Installations-DVD. Es existieren keine UEFI / Windows-Menu Einträge, aber gemäss BLKID sind alle Partitionen angelegt. - Das habe ich in den Varianten mit und ohne Secure Boot, mit und ohne TPM, mit Installation ab Net- und DVD-Disk, mit und ohne Update-Repositorys und mit Root-Partition = BTRFS und EXT4 durchgespielt. Es looped immer!
    Dann habe ich nochmals UEFI studiert und im Win10 ein Menupunkt erfasst:
    bcdedit /set {bootmgr} path \EFI\opensuse\shim.efi
    bcdedit /create /d "OpsenSuse LEAP 42.1" /application bootsector
    bcdedit /set {defe8511-e19e-11e5-a168-54ab3a59c3a4} device partition=\Device\HarddiskVolume1
    bcdedit /set {defe8511-e19e-11e5-a168-54ab3a59c3a4} path \EFI\opensuse\shim.efi
    bcdedit /displayorder {defe8511-e19e-11e5-a168-54ab3a59c3a4} /addlast
    Hat wunderbar funktioniert und ich habe im Windows-Bootmanager meinen Suse Eintrag.
    Nur wenn ich ihn starte endet das ganz auf "Datei: \EFI\opensuse\shim.efi, Status: 0xc000007b" und etwas wie "Datei nicht vorhanden".

    Hat das schon jemals jemand zum Laufen gebracht?
    Oder kennt jemand noch eine andere Variante zum Installieren?
    Vielen Dank im Voraus

    Für den Inhalt des Beitrages 98980 haftet ausdrücklich der jeweilige Autor: ronef

  • Muss gleich los, deswegen nur ganz kurz:
    Wenn in der Boot-Prioritäten-Liste DVD an erster Stelle steht und eine DVD/CD drin ist, bootet er immer von der DVD. Also am Besten nach der Installation die DVD entnehmen oder die Festplatte auf Nr 1 legen und beim Booten das Medium manuell auswählen.

    Für den Inhalt des Beitrages 98982 haftet ausdrücklich der jeweilige Autor: Thund3r

  • Vielen Dank für die schnelle Antwort.
    Du hast schon recht. Seit ich 2 Einträge im WinBootmenu habe kommt dieses auch immer. Aber ich kann auf keine Art und Weise das installierte opensuse starten, weil es keinen UEFI Eintrag dafür gibt.

    Für den Inhalt des Beitrages 98985 haftet ausdrücklich der jeweilige Autor: ronef

  • Wohin hast du bei der openSUSE Installation den Grub schreiben lassen?
    Der gehört in EFI Partition.

    Das könnte man nun mit der EFI Shell erledigen.
    Ich denke aber, es wäre sicherer und sicher einfacher,
    wenn du die Installation einfach wiederholst,
    und dabei darauf achtest, dass der Grunb Bootloader nach /boot/EFI/... geschrieben wird.
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 98997 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • Hallo Berichtigung,

    ich habe die Installation einfach laufen lassen und kann dir nicht sicher sagen wo GRUB installiert wurde.

    Berichtigung schrieb:

    Der gehört in EFI Partition.
    Meinst du damit die SDA1, FAT, Partition (im Gegensatz zur /boot/EFI/ in der Root-Partition)?

    Berichtigung schrieb:

    und dabei darauf achtest, dass der Grunb Bootloader nach /boot/EFI/... geschrieben wird.
    Nochmals installieren ist kein Problem, habe ich schon ein dutzend mal gemacht.
    Aber wo und wie kann ich den Speicherort des GRUB Bootloaders ändern bzw. eingeben?

    Für den Inhalt des Beitrages 99026 haftet ausdrücklich der jeweilige Autor: ronef

  • Es ist egal WO diese Partition liegt.
    Es muss nur die richtige sein.

    Von deiner Firmware wird diese EFI Partition angesprungen.
    Dort liegen alle Loader für alle installierten Betriebssysteme.
    Es finden sich dort -nach Spezifikation- für jedes OS ein Unterverzeichnis.

    Du suchst also DIE EFI Partition, in der auch deine Win OSloader rumlungern.
    Das ist meist die erste EFI Partition der ersten Platte, aber eben halt nur "meist".

    Und Grub soll dorthin samt seinem OSloadereien, buntimierten Hintergründen etc. p.p.
    Grub soll auch das OS-Menu ausgeben.
    (Muss alles nicht so, würd ich abba empfehlen.)

    Und JA: Das wird als /boot/EFI angezeigt....
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 99027 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • Hallo Thund3r und Berichtigung, ich habe jetzt ein paar Tage getestet und gebastelt.


    Betreffend "/boot/EFI/"; das ist die ESP-Partition vom UEFI, welche in opensuse am Mountpoint /boot angehängt wird. Der EFI-Ordner ist zuoberst in der ESP-Partition.

    Wenn ich aber kein Linux starten kann, muss ich das im Windows anschauen. Als richtiger Administrator, assign z.B. als I: sieht dann so aus:
    ---------------------------------
    Datenträger in Laufwerk I: ist ESP
    Volumeseriennummer: E488-CE00
    Verzeichnis von I:\
    10.10.2016 14:18 <DIR> EFI
    01.10.2016 14:09 <DIR> Temp
    --------------------------------und darunter kommt gleich nochmals ein Boot!
    Verzeichnis von I:\EFI\Boot
    05.10.2016 12:25 1'188'192 bootx64.efi
    ------------------------------- ( Es ist nicht einfach )
    Verzeichnis von I:\EFI\opensuse
    13.10.2016 22:52 1'155'520 shim.efi
    13.10.2016 22:52 1'159'776 MokManager.efi
    13.10.2016 22:52 975'736 grub.efi
    usw. -------------------------

    Betreffend der "Boot-Prioritäten-Liste" im BIOS, ist auch unbefriedigend. Ungeändert ist der Windows-Bootmanager an 1. Stelle!
    Das ACER F12 Boot-Menu kommt nur zum Vorschein wenn das UEFI leer ist. Danach kommt der Windows-Bottmanager auch nicht, weil es nur einen Start-Eintrag gibt. Also musst du die DVD booten indem du Windows-reboot klickst und gleichzeitig die Shifttaste drückst. Dann booted Windows 10 direkt ins "Reparaturmenu", wo du unter "Andere Geräte" dann die DVD auswählen kannst.
    Nur wenn du das mit opensuse 42.1 machst, kommt immer "Netzwerk ist nicht konfiguriert!" und es kommt das YAST-Netzwerkgerät. Da kannst du aber eingeben was du willst, der "Realtek PCIe GBE Family Controller" lässt sich "mit diesem Windows-Start von opensuse nicht konfigurieren".
    Lösen kann man es nur mit der DVD an 1. Stelle in der BIOS-Bootreihenfolge. -- Ja, opensuse hat ein fehlerloses Netzwerk, Realtek ist kein Thema und es installiert.
    (P.S. mit Ubuntu gibt es diese Probleme nicht. Nur das was jetzt kommt geht auch bei Ubuntu nicht.)
    Es installiert sich selber, und die Programme und Order in der ESP-Partition. Aber es nichts ins UEFI NVRAM, kein Bootmanager Aufruf, kein Bootmenu-Eintrag und schon gar nicht einen Einmal-Boot-Aufruf um die Installation abzuschliessen!
    ====>>> das UEFI NVRAM wird mit und ohne Secure Boot nicht geschrieben <<<<<<<=====

    Ich konnte mangels Linux den efibootmgr nicht testen, aber mit dem bcdedit (Windows) konnte ich im NVRAM schreiben, löschen usw. ohne Probleme.
    Aber ich habe jetzt zuviel Zeit in diesen Mist investiert, meine Tochter bekommt jetzt einen reinen Windows 10 Laptop!!!!!

    Vielen Dank an Thund3r und Berichtigung für eure Mühe
    ronef

    Für den Inhalt des Beitrages 99097 haftet ausdrücklich der jeweilige Autor: ronef

  • Thema wurde als erledigt markiert und ist damit geschlossen. Bei Fragen oder Ergänzungen PN an das Team.

    Für den Inhalt des Beitrages 99491 haftet ausdrücklich der jeweilige Autor: Alero