Gemeinsamer Ordner und USB-Stick Nutzung für Host unter Virtualbox

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Gemeinsamer Ordner und USB-Stick Nutzung für Host unter Virtualbox gibt es 10 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Gemeinsamer Ordner und USB-Stick Nutzung für Host unter Virtualbox

    Ich bin sehr zufriedener Opensuse 42.1 Leap Nutzer und brauche leider aber wegen der ein oder anderen Spezialsoftware manchmal Win7.
    Jetzt möchte ich als ziemlicher Virtualbox Newbie Win7 in der Virtualbox nutzen. Installation hat soweit alles funktioniert, nur Zugriff auf den gemeinsamen Ordner und USB-Sticks bekomme ich absolut nicht hin. Bitte daher um Hilfe...

    Was ich bisher an Vorbereitungen getroffen habe:

    - Installation von Virtualbox (Version 5.0.26-31.1-x86_64) aus dem Standard OpenSuse Paket
    - mit Virtualbox wurden ebenso "virtualbox-host-kmp-default" / "virtualbox-host-source" / "virtualbox-qt" / "virtualbox-webserv" angekreuzelt und mitinstalliert
    - kernel-devel, make und gcc waren auch schon standardmäßig installiert
    - Virtualbox Guest Tools aus dem Opensuse Paket habe ich nicht mit installiert (habe irgendwo gelesen, dass es damit Probleme gibt)
    - Benutzer- und Gruppenverwaltung: Mein Account um die Gruppen "vboxusers" / "vboxguest" / "vboxsf" ergänzt
    - Von der Oracle Seite die Datei Oracle_VM_VirtualBox_Extension_Pack-5.0.26-108824.vbox-extpack runtergeladen
    - Virtualbox gestartet und unter Einstellungen -> Zusatzpakete das Extension Pack installiert

    Ergebnis:
    - Leider sind die USB-Einstellungen in meinem Win7-Guest (selbst USB 1.1) immer noch ausgegraut
    - Einen gemeinsamen Ordner konnte ich zwar in den Einstellungen hinzufügen bzw. den Pfad angeben, dieser wird aber, wenn ich die virtuelle Maschine starte, nicht angezeigt. Wenn die Maschine läuft und ich unten auf das Ordnersysmbol in der Steuerungsleiste klicke, kommt eine Meldung: "VirtualBox-Warnung: Die Virtualbox-Gasterweiterungen sind anscheinend für diese VM nicht verfügbar, ...)

    Für den Inhalt des Beitrages 99098 haftet ausdrücklich der jeweilige Autor: Martin85

  • Zur USB-Freigabe steht auf dieser Seite:


    #########
    VirtualBox comes with openSUSE and should work out-of-the-box. From openSUSE 11.4 on USB devices attached to the host can be used in guest operating systems after removing the '#' character in the last 2 lines of /etc/udev/rules.d/60-vboxdrv.rules. After a reboot USB support will work. Please consider the security risks this might cause.
    #########

    und:

    #########
    In OpensuSE 12.2 modify the file /etc/udev/rules.d/10-vboxdrv.rules, and comment out the last 2 lines which mention ACTION=="remove".A reboot after that is required.

    #########

    Da bei mir im Ordner /etc/udev/rules.d keine Datei mit dem Namen 60-vboxdrv.rules vorhanden war, habe ich diese aus dem Ordner /usr/lib/udev/rules.d/dort hinein kopiert.



    Dann habe ich diese Datei, welche sich jetzt auch im Pfad /etc/udev/rules. d befindet, entsprechend geändert:

    #########
    In OpensuSE 12.2 modify the file /etc/udev/rules.d/10-vboxdrv.rules, and comment out the last 2 lines which mention ACTION=="remove".A reboot after that is required.
    #########


    Somit sieht meine Datei jetzt so aus:


    Quellcode

    1. KERNEL=="vboxdrv", NAME="vboxdrv", OWNER="root", GROUP="vboxusers", MODE="0660"
    2. #
    3. #these lines below give access permission to vboxusers to properly work with usb nodes, but enabling them could be security risk (bnc#664520) !!
    4. #if you can live with this security problem put these lines below in to the new file /etc/udev/rules.d/60-vboxdrv.rules so they will stay enabled also after package update
    5. #SUBSYSTEM=="usb_device", ACTION=="add", RUN+="/usr/lib/udev/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass} vboxusers"
    6. #SUBSYSTEM=="usb", ACTION=="add", ENV{DEVTYPE}=="usb_device", RUN+="/usr/lib/udev/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass} vboxusers"
    7. SUBSYSTEM=="usb_device", ACTION=="remove", RUN+="/usr/lib/udev/VBoxCreateUSBNode.sh --remove $major $minor"
    8. SUBSYSTEM=="usb", ACTION=="remove", ENV{DEVTYPE}=="usb_device", RUN+="/usr/lib/udev/VBoxCreateUSBNode.sh --remove $major $minor"
    Das heißt, ich habe vor Zeile 7 und 8 das "#" entfernt.

    Leider ohne Erfolg, was die Freigabe von USB-Datenträger angeht :(


    Und dann zum Thema gemeinsamer Ordner:

    #########
    To install the latest version from terminal follow these steps:
    1. sudo zypper rm virtualbox-guest-kmp-default virtualbox-guest-tools virtualbox-guest-x11
    2. sudo zypper in kernel-devel gcc make
    3. (Virtualbox menu)->Devices->Install Guest Additions. Then:

      sudo /media/VBOXADDITIONS_*/VBoxLinuxAdditions.run
    #######

    Punkt 1 und 2 durchgeführt bzw. 1 war nicht nötig, wie oben beschrieben und 2 war ebenfalls schon standardmäßig vorhanden.
    Muss ich den Befehl sudo .... anpassen? Bei mir kommt nur ein "Kommando nicht gefunden"
    Also auch hier bin ich nicht weiter gekommen :(

    Für den Inhalt des Beitrages 99329 haftet ausdrücklich der jeweilige Autor: Martin85

  • Poste als User:

    Quellcode

    1. groups



    Martin85 schrieb:

    Muss ich den Befehl sudo .... anpassen? Bei mir kommt nur ein "Kommando nicht gefunden"
    Also auch hier bin ich nicht weiter gekommen
    Was du bei Dir siehst, siehst nur Du, wir nicht.............

    PS:
    USB-Sticks, USB-Festplatten und auch DVD werden nicht mehr in /media eingebunden, daher stimmt der Befehl auch nicht:

    Quellcode

    1. sudo /media/VBOXADDITIONS_*/VBoxLinuxAdditions.run



    Und es wird wieder nur ein Teil einer verlinkten Seite gelesen!

    Das hier wäre wahrscheinlich für dich zielführend:
    VirtualBox - openSUSE

    Hatte ich aber auch geschrieben:

    Sauerland schrieb:

    Und folgend.......
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 99333 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Sauerland schrieb:

    Poste als User:

    Quellcode

    1. groups
    hier die Ausgabe:

    Quellcode

    1. martin@linux-2ehy:~> groups
    2. users vboxsf vboxguest vboxusers
    3. martin@linux-2ehy:~>


    Sauerland schrieb:


    Was du bei Dir siehst, siehst nur Du, wir nicht.............
    PS:
    USB-Sticks, USB-Festplatten und auch DVD werden nicht mehr in /media eingebunden, daher stimmt der Befehl auch nicht:

    Quellcode

    1. sudo /media/VBOXADDITIONS_*/VBoxLinuxAdditions.run


    Und es wird wieder nur ein Teil einer verlinkten Seite gelesen!

    Das hier wäre wahrscheinlich für dich zielführend:
    VirtualBox - openSUSE

    Im Grunde genommen habe ich die ganze Seite, die Du mir verlinkt hast, gelesen. Nur ich habe halt nicht alle Punkte verstanden bzw. umsetzen können


    Ich bin einfach der Reihe nach vorgegangen:

    Installing the latest Version of the Guest Additions
    To install the latest version from terminal follow these steps:
    1. sudo zypper rm virtualbox-guest-kmp-default virtualbox-guest-tools virtualbox-guest-x11 - #check#
    2. sudo zypper in kernel-devel gcc make - #check#
    3. (Virtualbox menu)->Devices->Install Guest Additions. Then: sudo /media/VBOXADDITIONS_*/VboxLinuxAdditions.run - #keine Ahnung, was ich stattdessen eingeben soll#

    so, dann geht’s weiter:


    Allowing Normal Users to Access Shared Folders
    By default only the root user will be able to access Shared Folders mounted from the host system (usually these appear under /media). To allow ordinary users access to these folders:
    1. Open the User and Group Management module in YaST and add each user you want to grant permission to the vboxsf group - #check#
    2. Have the affected users logout and log back in, they should now be able to access Shared Folders. - #welche shared folders? Wo finde ich diese? Wenn ich einen Ordner (z.B. auf einer separaten Partition) anlege und im Virtualbox-Menü als solches definiere, kann ich außerhalb der Box sowieso drauf zugreifen#
    3. You might have a permission error when opening the directory /media. A quick fix is to change the permission of that directory. - #wo finde ich das directory /media? Etwa run/media? Dort kann ich auf alle Laufwerke und Ordner zugreifen, welche aufgeführt werden

    4. chmod o+rx /media #probiere ich erst gar nicht aus, da bereits 2. und 3. für mich unverständlich ist



    und weiter:


    OSE version usb support (rpm package from the distro)
    Note that this is a security risk, see the bug 664520.
    That said to enable usb support for the package that came from the openSUSE repos make sure the user is a member of the vboxusers group.
    Do the following.
    Copy /usr/lib/udev/rules.d/60-vboxdrv.rules to /etc/udev/rules.d - #Habe ich schon oben vorgenommen, siehe Beitrag oben

    cp -v /usr/lib/udev/rules.d/60-vboxdrv.rules /etc/udev/rules.d
    Uncomment those lines with SUBSYSTEM in it.#Alles "#" vor den Zeile mit "Subsystem" gelöscht
    printf '%s\n' 'g/^#SUBSYSTEM/s/^#//' w | ed -s /etc/udev/rules.d/60-vboxdrv.rules
    Reboot.
    This is not needed if you downloaded and installed the package from virtualbox.org.
    - # Datei 60-vboxdrv.rules im Ordner /usr/lib/udev/rules.d/ vorhanden aber nicht im /etc/udev/rules.d , daher Datei aus usr in etc kopiert und die letzten zwei Zeilen (siehe oben) editiert

    Für den Inhalt des Beitrages 99359 haftet ausdrücklich der jeweilige Autor: Martin85

  • Martin85 schrieb:

    Installation von Virtualbox (Version 5.0.26-31.1-x86_64) aus dem Standard OpenSuse Paket

    Martin85 schrieb:

    OSE version usb support (rpm package from the distro)
    Ist das nicht zu verstehen?


    Martin85 schrieb:

    - # Datei 60-vboxdrv.rules im Ordner /usr/lib/udev/rules.d/ vorhanden aber nicht im /etc/udev/rules.d
    Dann hast du dies aber nicht gemacht:

    Martin85 schrieb:

    Do the following.
    Copy /usr/lib/udev/rules.d/60-vboxdrv.rules to /etc/udev/rules.d - #Habe ich schon oben vorgenommen, siehe Beitrag oben
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 99361 haftet ausdrücklich der jeweilige Autor: Sauerland

  • #Update#
    soeben nachgeschaut,USB funktioniert jetzt. ^^ Habe in der Datei 60-vboxdrv.rules nachträglich alle # entfernt, bei denen SUBSYSTEM steht. Ganz oben in der Anleitung steht nämlich nur, dass man in den letzten zwei Zeilen das # wegnehmen soll

    Sehr schön. Habe nämlich heute schon - etwas umständlich - einige Daten und Programme in meine Virtuelle Maschine übertragen, in dem ich alles vorher auf dem Rechner als ISO gepackt habe und dann als CD/DVD Laufwerk ins virtuelle System eingebunden habe. Das ging lustigerweise, auch wenn nur "one way" :D

    Bleibt nur noch das Problem mit dem gemeinsamen Ordner

    Für den Inhalt des Beitrages 99362 haftet ausdrücklich der jeweilige Autor: Martin85

  • Da ich eh alles über ssh mache, hab ich keine shared Folder eingerichtet, kann ich dir nicht mehr helfen.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 99365 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Martin85 schrieb:


    Sauerland schrieb:

    Was du bei Dir siehst, siehst nur Du, wir nicht.............
    PS:
    USB-Sticks, USB-Festplatten und auch DVD werden nicht mehr in /media eingebunden, daher stimmt der Befehl auch nicht:

    Quellcode

    1. sudo /media/VBOXADDITIONS_*/VBoxLinuxAdditions.run

    Und es wird wieder nur ein Teil einer verlinkten Seite gelesen!

    Das hier wäre wahrscheinlich für dich zielführend:
    VirtualBox - openSUSE

    Ich bin einfach der Reihe nach vorgegangen:

    Installing the latest Version of the Guest Additions
    To install the latest version from terminal follow these steps:
    1. sudo zypper rm virtualbox-guest-kmp-default virtualbox-guest-tools virtualbox-guest-x11 - #check#
    2. sudo zypper in kernel-devel gcc make - #check#
    3. (Virtualbox menu)->Devices->Install Guest Additions. Then: sudo /media/VBOXADDITIONS_*/VboxLinuxAdditions.run - #keine Ahnung, was ich stattdessen eingeben soll#

    so, dann geht’s weiter:


    Allowing Normal Users to Access Shared Folders
    By default only the root user will be able to access Shared Folders mounted from the host system (usually these appear under /media). To allow ordinary users access to these folders:
    1. Open the User and Group Management module in YaST and add each user you want to grant permission to the vboxsf group - #check#
    2. Have the affected users logout and log back in, they should now be able to access Shared Folders. - #welche shared folders? Wo finde ich diese? Wenn ich einen Ordner (z.B. auf einer separaten Partition) anlege und im Virtualbox-Menü als solches definiere, kann ich außerhalb der Box sowieso drauf zugreifen#
    3. You might have a permission error when opening the directory /media. A quick fix is to change the permission of that directory. - #wo finde ich das directory /media? Etwa run/media? Dort kann ich auf alle Laufwerke und Ordner zugreifen, welche aufgeführt werden

    4. chmod o+rx /media #probiere ich erst gar nicht aus, da bereits 2. und 3. für mich unverständlich ist



    Vielen Dank erst einmal für die Hilfestellung. Das funktionierende USB hat jetzt schon erheblich zur Arbeitserleichterung mit meiner virtuellen Maschine beigetragen.

    Trotzdem will ich ja nicht dumm sterben, daher würde ich noch gern wissen, wie denn beim Punkt 3. von Installing the latest Version of the Guest Additions der Befehl nun richtig heißen sollte, wenn du schon sagst, dass er nicht stimmt.
    Genauso würde ich mich sehr über eine kleine Hilfestellung für Laien zum Punkt 2. und 3. von Allowing Normal Users to Access Shared Folders freuen


    Danke auch an Boreas für den Lösungsansatz mit den shared folders

    Für den Inhalt des Beitrages 99386 haftet ausdrücklich der jeweilige Autor: Martin85