Wlan Einrichten auf einem iMac

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Wlan Einrichten auf einem iMac gibt es 11 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Wlan Einrichten auf einem iMac

    Hallo ihr Lieben,
    wie bekomme ich mein WLan am laufen denn ohne gibt es kein Internet bei mir.....


    Meine Rechner _ Daten:

    iMac 21,5 Zoll, Ende 2012
    Prozessor: 2,7 GHz Intel Core i5
    Speicher: 8 GB 1600 MHz DDR3
    Startvolumen: Macintosh HD
    Grafikkarte: NVIDIA GeForce GT 640M 512 MB

    Drahtlose Kommunikation
    • Wi-Fi
    • Drahtloser 802.11n Wi-Fi Netzwerkbetrieb2, kompatibel mit IEEE 802.11a/b/g

    • Bluetooth
    • Bluetooth 4.0


    Zu Linux:
    Die jetzige Aktuelle Version Leap 42,2

    Die Linux Version habe ich erfolgreich auf meine USB - Festplatte installieren können, nur leider mein Wlan nicht, eine erstmalige Kabelgebunden Anbindung an meine Fritzbox ist leider aufgrund der Entfernung nicht möglich...über 10 m.....

    Habe mir die Treiber,
    broadcom-wl-kmp-default-6.30.223.248_k4.8.8_1.g7b7d4ed-10.47.i586.rpm
    broadcom-wl-kmp-pae-6.30.223.248_k4.8.8_1.g7b7d4ed-10.47.i586.rpm
    broadcom-wl-6.30.223.248-10.46.src.rpm
    broadcom-wl-kmp-default-6.30.223.248_k4.8.8_1.g7b7d4ed-10.46.i586.rpm
    Heruntergeladen und auf CD Gebrannt.

    Jetzt weis ich nicht genau ob es die richtigen Trier sind und leider gibt es anscheinend "fast Täglich" neue Treiber für Broadcom WL auf der packman Seite...

    Des Weiteren habe ich keine Ahnung wie ich die Treiber richtig ins System Installiere...

    Hier einige Infos aus dem Terminal:


    Quellcode

    1. linux-0adk:~ # hwinfo --netcard
    2. 24: PCI 300.0: 0200 Ethernet controller
    3. [Created at pci.374]
    4. Unique ID: rBUF.lN_Y5+Bh5JD
    5. Parent ID: hoOk.oVN5qN79ob4
    6. SysFS ID: /devices/pci0000:00/0000:00:1c.2/0000:03:00.0
    7. SysFS BusID: 0000:03:00.0
    8. Hardware Class: network
    9. Model: "Broadcom NetXtreme BCM57766 Gigabit Ethernet PCIe"
    10. Vendor: pci 0x14e4 "Broadcom"
    11. Device: pci 0x1686 "NetXtreme BCM57766 Gigabit Ethernet PCIe"
    12. SubVendor: pci 0x14e4 "Broadcom"
    13. SubDevice: pci 0x1686
    14. Revision: 0x01
    15. Driver: "tg3"
    16. Driver Modules: "tg3"
    17. Device File: eth0
    18. Memory Range: 0xb1800000-0xb180ffff (ro,non-prefetchable)
    19. Memory Range: 0xb1810000-0xb181ffff (ro,non-prefetchable)
    20. IRQ: 18 (no events)
    21. HW Address: 10:dd:b1:9b:9b:79
    22. Link detected: no
    23. Module Alias: "pci:v000014E4d00001686sv000014E4sd00001686bc02sc00i00"
    24. Driver Info #0:
    25. Driver Status: tg3 is active
    26. Driver Activation Cmd: "modprobe tg3"
    27. Config Status: cfg=no, avail=yes, need=no, active=unknown
    28. Attached to: #14 (PCI bridge)
    29. 26: PCI 400.0: 0280 Network controller
    30. [Created at pci.374]
    31. Unique ID: YmUS.Rhl+krPOZL7
    32. Parent ID: Z7uZ.qKGbnWMZrM5
    33. SysFS ID: /devices/pci0000:00/0000:00:1c.3/0000:04:00.0
    34. SysFS BusID: 0000:04:00.0
    35. Hardware Class: network
    36. Model: "Apple AirPort Extreme"
    37. Vendor: pci 0x14e4 "Broadcom"
    38. Device: pci 0x4331 "BCM4331 802.11a/b/g/n"
    39. SubVendor: pci 0x106b "Apple Inc."
    40. SubDevice: pci 0x00f4 "AirPort Extreme"
    41. Revision: 0x02
    42. Driver: "bcma-pci-bridge"
    43. Driver Modules: "bcma"
    44. Memory Range: 0xb1900000-0xb1903fff (rw,non-prefetchable)
    45. IRQ: 19 (no events)
    46. Module Alias: "pci:v000014E4d00004331sv0000106Bsd000000F4bc02sc80i00"
    47. Driver Info #0:
    48. Driver Status: bcma is active
    49. Driver Activation Cmd: "modprobe bcma"
    50. Config Status: cfg=no, avail=yes, need=no, active=unknown
    51. Attached to: #15 (PCI bridge)
    52. linux-0adk:~ #
    Alles anzeigen


    Quellcode

    1. linux-0adk:~ # hwinfo --netcard --wlan | grep -Ei 'Model |vendor|device '
    2. Vendor: pci 0x14e4 "Broadcom"
    3. SubVendor: pci 0x14e4 "Broadcom"
    4. Device File: eth0
    5. Vendor: pci 0x14e4 "Broadcom"
    6. SubVendor: pci 0x106b "Apple Inc."

    und noch


    Quellcode

    1. linux-0adk:~ # systemctl status network.service
    2. ● wicked.service - wicked managed network interfaces
    3. Loaded: loaded (/usr/lib/systemd/system/wicked.service; enabled; vendor preset: disabled)
    4. Active: active (exited) since Fri 2016-11-25 18:20:24 CET; 1min 46s ago
    5. Process: 1241 ExecStart=/usr/sbin/wicked --systemd ifup all (code=exited, status=0/SUCCESS)
    6. Main PID: 1241 (code=exited, status=0/SUCCESS)
    7. Tasks: 0 (limit: 512)
    8. CGroup: /system.slice/wicked.service
    9. Nov 25 18:20:22 linux-0adk systemd[1]: Starting wicked managed network interfaces...
    10. Nov 25 18:20:24 linux-0adk wicked[1241]: lo up
    11. Nov 25 18:20:24 linux-0adk systemd[1]: Started wicked managed network interfaces.
    12. linux-0adk:~ #
    Alles anzeigen

    Der Befehl hwinfo --wlan ergab kein Ergebnis.


    Ich hoffe ihr könnt mir Helfen, bitte mit einer Schritt für Schritt Anleitung..........

    Wie schon Erwähnt, ich komme nicht ins Internet somit kann ich mir nicht unter Linux 42.2 etwas Downloaden, sondern ich muss das Mac System starten damit ins Netzt mir etwas Laden dann auf CD oder DVD Brennen Linux Leap Starten und per CD oder DVD die Treiber Installieren.....

    Mit Code geht es genau so im Terminal ausführen in LiebreWrite Speichern auf CD Brennen und im Mac System hier dann Posten...

    Mit freundlichen Grüßen


    Norbert

    Das ist jetzt aber ein langer Text geworden.....

    Für den Inhalt des Beitrages 100610 haftet ausdrücklich der jeweilige Autor: NorbertH

  • Dazu haben wir schon einen endlosen Thread gehabt

    1. beschaff dir eine langes TP-Kabel (20 m kosten auch fast nichts) oder leih dir eins - dann hast du wenigstens eine ordentliche Installationsmöglichkeit
    2. beschafft dir einen uneingeschränkt Linux-kompatiblen USB-WLAN-Stick- meine Billigdinger aus der Bucht funktionieren alle. Zwar nicht schnell aber für den Anfang reicht es.
    hier mal einen Link - das erstere der Produkte läuft bei mir auch irgendwo.
    150Mbit/s-High-Gain-WLAN-USB-Adapter - TP-Link
    TL-WN722N | eBay
    There's no place like 127.0.0.1

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von wurzel99 ()

    Für den Inhalt des Beitrages 100611 haftet ausdrücklich der jeweilige Autor: wurzel99

  • Man könnte sogar die allerunmöglichste Variante wählen, und
    tatsächlich dieses Gerät zum Router tragen.

    Aber egal, welch seltsame Geräte ich habe, -is ja schliesslich ein angebissener Apfel- hat das einfach zu gehen,
    ohne dass ich unter Last zu gehen hätte.

    Man könnt sich übrigens die benötigen Pakete sogar mit anderem Rechner runterladen.
    Aber da müsste man sogar gehen und noch Sticks, oder gar schwere Datenträger rumtragen.
    Wir sind doch keine Datenträger!

    Unerträglich.
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 100613 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • NorbertH schrieb:

    Habe mir die Treiber,
    broadcom-wl-kmp-default-6.30.223.248_k4.8.8_1.g7b7d4ed-10.47.i586.rpm
    broadcom-wl-kmp-pae-6.30.223.248_k4.8.8_1.g7b7d4ed-10.47.i586.rpm
    broadcom-wl-6.30.223.248-10.46.src.rpm
    broadcom-wl-kmp-default-6.30.223.248_k4.8.8_1.g7b7d4ed-10.46.i586.rpm
    Poste:

    Quellcode

    1. uname -a
    Und es wird dir geholfen.Denn ich glaube nicht, das du da kernel 4.8 am laufen hast.......
    Und auch nicht 32 bit, es sei denn, du benutzt noch openSUSE 13.2, die aber im Januar nicht mehr mit Updates versorgt wird.
    Und die obigen broadcom-wl sind auch nicht von Packman.......

    Edit:
    Könnte doch von Packman sein, Factory/Tumbleweed.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags
    zypper
    Netzwerkprobleme

    Für den Inhalt des Beitrages 100619 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Sauerland

    Quellcode

    1. uname -a
    2. Linux Linux-0adk 4.4.27-2-default #1 SMP Thu Nov 3 14:59:54 UTC 2016 (5c21e7c) x86_64 x86_64 x86_64 GNU/LInux


    Es kann nur noch an den Treibern liegen und wie ich die richtig zu Instalieren habe.

    Mit freundlichen Grüßen
    Norbert

    Benutze bitte Code-Tags für Konsolenausgaben

    Für den Inhalt des Beitrages 100620 haftet ausdrücklich der jeweilige Autor: NorbertH

  • NorbertH schrieb:

    broadcom-wl-kmp-default-6.30.223.248_k4.8.8_1.g7b7d4ed-10.47.i586.rpm

    uname -a
    Linux Linux-0adk 4.4.27-2-default #1 SMP Thu Nov 3 14:59:54 UTC 2016 (5c21e7c) x86_64 x86_64 x86_64 GNU/LInux
    Das System hätte dir das schon sauber installiert,
    wenn du via Kabel vorher an's Netz gegangen wärst.
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Berichtigung ()

    Für den Inhalt des Beitrages 100621 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • Hier die Treiber:
    broadcom-wl-kmp-default-6.30.223.271_k4.4.27_2-39.13.x86_64.rpm
    broadcom-wl-6.30.223.271-39.13.x86_64.rpm

    Speicher die beiden Dateien in einem Verzeichnis in deinem /home, z.B. Programme.

    Öffne eine Konsole, wechsle in das Verzeichnis Programme:

    Quellcode

    1. cd ~/Programme
    Wede mit su - root und installiere die beiden Pakete:



    Quellcode

    1. zypper in broadcom-wl broadcom-wl-kmp-default
    Gehe danach in Yast---Netzwerkgeräte---Netzwerkeinstellungen im Reiter Global und stelle Methode für den Netzwerkaufbau von wicked auf Netzwerkmanager um.

    Starte neu und richte dein Netzwerk mit dem Plasmoid unten Rechts in der Kontrollleiste ein.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags
    zypper
    Netzwerkprobleme

    Für den Inhalt des Beitrages 100622 haftet ausdrücklich der jeweilige Autor: Sauerland

  • In deinem Thread


    Mit OpenSuse auf dem iMac ins Internet nur wie ?


    schrieb ich folgendes:

    ThomasS schrieb:

    Hi,

    ich habe nicht mehr den Inhalt der letzten 66 Beiträge im Kopf. Also, WLAN geht nicht. Warum auch immer.
    Und du möchtest Elementary OS nutzen, um hier Fehlerausgaben zu posten????
    Hast du es denn schon mal mit LAN probiert. Ist das gleiche wie mit ohne Kabel, jedoch im Unterschied dazu mit Kabel? (Ethernet)
    Wenn das gehen sollte, wäre es für alle Beteiligten einfacher.

    Falls du schon Versuche mit Kabel unternommen hast, ignoriere mich.

    Thomas
    War möglicherweise zu locker formuliert. Deswegen bist du auch nicht darauf eingegangen.
    Aber probiert hast du es wohl doch nicht.

    wurzel99 schrieb:

    1. beschaff dir eine langes TP-Kabel (20 m kosten auch fast nichts) oder leih dir eins - dann hast du wenigstens eine ordentliche Installationsmöglichkeit
    Sogar 100m sind mit Ethernetkabeln locker möglich.

    Berichtigung schrieb:

    Man könnte sogar die allerunmöglichste Variante wählen, und
    tatsächlich dieses Gerät zum Router tragen.
    Das geht ja auch in diese Richtung, aber nur bei einer kurzen Leitung. Bei 100m brauchst du auch ein 100m langes Stromkabel ;) Oder einen vollen Akku.

    Berichtigung schrieb:

    Das System hätte dir das schon sauber installiert,
    wenn du via Kabel vorher an's Netz gegangen wärst.
    Siehste mal...

    Auch immer schön auf die Versionsnummern und auf die Architektur achten... (Berichtigung und Sauerland)

    Für den Inhalt des Beitrages 100626 haftet ausdrücklich der jeweilige Autor: ThomasS

  • NorbertH schrieb:

    "Du siehst dich selbst als Anfänger aber lässt die (fast) nichts raten."

    Ich bin ein Anfänger undein kleiner Dickkopf.....
    Wie man in dieser Situation mit mit diesem Persönlichkeitsprinzip hier x gutwillige Helfer beschäftigen kann ..

    Berichtigung schrieb:

    soifz
    ich formuliere es mal so:

    Als Linux-User ist man in jeder Richtung frei (hat sowas gerade jemand anders hier noch geschrieben.. ??). Du hast auch die Freiheit, absoluten Blödsinn zu machen und dich gegen allen Rat und Goodwill zu verhalten. Dann trägst du natürlich auch die Verantwortung und musst mit deinen Problemen selbst fertig werden. Das kannste dann nicht bei anderen abladen.


    Für mich ist bei solchem Verhalten EdV - Ende der Veranstaltung.
    ---
    Das mindeste wäre, dass du deinen Appel mal mit nem Kabel ins Netz bringst.
    There's no place like 127.0.0.1

    Für den Inhalt des Beitrages 100637 haftet ausdrücklich der jeweilige Autor: wurzel99

  • Seid ihr jetzt fertig?

    Eine der Lösungen hab ich gepostet.

    Es gäbe auch noch:
    Broadcom Wireless – Linupedia

    Sowie Umstellung auf Netzwerkmanager:
    Umstellung von YaST/ifup auf den NetworkManager – Linupedia
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags
    zypper
    Netzwerkprobleme

    Für den Inhalt des Beitrages 100638 haftet ausdrücklich der jeweilige Autor: Sauerland

www.cyberport.de