KaOS und UEFI

Hinweis: In dem Thema KaOS und UEFI gibt es 25 Antworten auf 3 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • upgedated und downgeloaded und weitere absonderliche Wortkonstrukte sind reinstes Denglisch und haben weder mit der einen noch mit der anderen Sprache etwas zu tun ;)
    Zum Aufrufen der Links bitte anklicken:
    --------------------
    Wie man Fragen richtig stellt!
    --------------------
    Konsolenausgaben sind inkl. der Eingaben in Codetags zu posten!
    --------------------
    Datenrettung mit grml-linux-live-cd
    --------------------
    Thema als erledigt markieren

    Für den Inhalt des Beitrages 103013 haftet ausdrücklich der jeweilige Autor: Alero

  • Ups, mir schwirrt der Kopf. Danke für die vielen Ideen. Ich habe jetzt mal folgendes probiert, was aber nicht funktioniert. :(

    Auf /dev/sdb4 habe ich eine esp mit 512 MB eingerichtet (esp- und boot-flag mit gparted) und auf /dev/sdb3 KaOS installiert. Ohne esp macht der installer garnicht weiter (KaOS v16.11). Am Ende der Installation kam die Fehlermeldung, dass Grub nicht installiert werden kann oder so ähnlich. Es wurden u.a. ein paar Pfade angezeigt, die wahrscheinlich nicht da waren. Ich habe nichts geblickt. Dann habe ich auf schließen geklickt. Achja, in der Zusammenfassung schien es keinen Fehler zu geben. Nur, dass der Bootloader nach /dev/sda installiert wird hat mich irritiert. Nach hin- und herüberlegen habe ich gedacht, es wird wohl nur der SuSE-Bootloader überschrieben. Das könnte ich korrigieren.

    Also SuSE gebootet, Yast, Bootloader geladen, abgespeichert, neu geladen........ KaOS war drin. Geht doch, dachte ich. Irrtum.
    Meldung vom SuSE-Grub: Ich soll zuerst den Kernel laden. Hä???
    Pfad von /dev/sdb3 nach /dev/sdb4 (esp mit /boot) geändert. Gleiche Meldung.

    Und nun?

    Achja, bisher hat mir noch niemand die Frage beantwortet, ob die esp überall sein kann, oder ob es unbedingt die erste Partition einer Festplatte sein muss.
    Hauptsystem: ASUS Z170 A - i5 6600K mit intergr. Grafik HD 530 - 16 GB DDR4 - TechniSat SkyStar 2 (DVB-S2) (PCI-alte Rev.) - 2 x SSD (sda/sdb) - 2 x HD (sdc/sdd) - ext. HD per USB - SATA-DVD und IDE->USB-DVD (beide intern) - iiyama xub3490wqsu 34" 21:9 (3440x1440 matt) - Canon Pixma iP4000 und MX925 - HP Scanjet G4050 - Yamaha Verstärker mit Plattenspieler
    Freundin: Terra (Wortmann) i3 4160 mit intergr. Grafik - 8 GB RAM DDR3
    WZ-HTPC: i3 4130 mit intergr. Grafik - 8 GB RAM DDR3 - TechniSat SkyStar 2 (DVB-S2) (PCI-alte Rev.) - Logitech K400
    Lenovo T61: Core2Duo 2.2 Ghz - 4GB RAM

    Für den Inhalt des Beitrages 103253 haftet ausdrücklich der jeweilige Autor: Wolle1956

  • Die ESP kann beliebig sein. Warum willst du denn überhaupt eine 2. ESP? Wenn du ein funktionierendes UEFI-System hast, hast du ja schon eine (sdax ?). Wie Berichtigung bereits schrieb, wird nichts überschrieben. Die UEFI-Bootnummern zu den Verzeichnissen in der ESP siehst du mit dem Befehl # efibootmgr.

    Die Platte, auf die KaOS installiert wird, sollte mit GPT partitioniert sein.

    Ich habe KaOS vor über einem Jahr installiert. Das Installationsprogramm wurde seitdem weiter entwickelt. Die Plausibilität wegen des /boot-Verzeichnisses gab es damals noch nicht.

    Zum aktuellen Stand: Befindet sich der KaOS-Kernel in einer ESP? Das könnte der Grund sein, daß grub von openSUSE den Kernel nicht findet.

    Viele Grüße
    Bequiimão

    Für den Inhalt des Beitrages 103271 haftet ausdrücklich der jeweilige Autor: Bequimão

  • Bequimão schrieb:

    Die ESP kann beliebig sein. Warum willst du denn überhaupt eine 2. ESP? Wenn du ein funktionierendes UEFI-System hast, hast du ja schon eine (sdax ?). Wie Berichtigung bereits schrieb, wird nichts überschrieben.
    Also wie ich schon schrieb, ich habe eine esp mit /boot/efi für die bereits installierten Systeme auf sda1, wobei hier nur /efi mit fat32 formatiert ist. Hmmmmm......
    grübel......

    Das bedeutet, dass /efi (fat32) im jeweiligen System im /boot (ext4) gemountet wird, und die Systeme scheiben ihren efi-Kram nach efi und grub, Kernel etc nach boot im root-Verzeichnis ihres Systems.
    Soweit richtig?

    Jetzt kommt KaOS daher und will eine esp unter /boot und nicht unter /boot/efi. Das würde bedeuten, dass KaOS sowohl den efi-Kram als auch grub etc , und den Kernel mit allem anderen auf /dev/sda1 ablegt, was deine letzte Frage unten beantwortet.
    Ist das auch richtig?

    Dann legt im meinem Fall nur KaOS seine Daten im /boot auf die esp und alle anderen Systeme im /boot auf ihrer Partition.
    Richtig? Dann wird wohl nichts überschrieben.

    Dann darf aber kein weiteres System kommen, das es genau wie KaOS macht. Ich glaube nicht, dass dann nichts im /boot überschrieben wird.
    Richtig?

    Und was mache ich jetzt?
    Falls ich mit allem richtig liege, müsste ich die bestehende esp ändern, so dass /boot auf sda1 auch fat32 hat.
    Dann bei KaOS die esp auf sda1/boot und bei allen anderen auf sda1/boot/efi mounten.

    Wie bekomme ich das ohne Risiko (ohne Neuinstallation aller Systeme) hin?
    Die UEFI-Bootnummern zu den Verzeichnissen in der ESP siehst du mit dem Befehl # efibootmgr.
    Mit diesem Befehl lösche ich auch nicht mehr vorhandene Systeme aus dem EFI-BIOS.
    Die Platte, auf die KaOS installiert wird, sollte mit GPT partitioniert sein.
    Ja, das ist klar.
    Ich habe KaOS vor über einem Jahr installiert. Das Installationsprogramm wurde seitdem weiter entwickelt. Die Plausibilität wegen des /boot-Verzeichnisses gab es damals noch nicht.
    Stimmt. Aber Calamares ist trotzdem nix. Meine Meinung.
    Zum aktuellen Stand: Befindet sich der KaOS-Kernel in einer ESP? Das könnte der Grund sein, daß grub von openSUSE den Kernel nicht findet.
    Tja, s.o., KaOS will das anscheinend so. :)
    SuSE-Grub suchte aber auf sdb3, ich hab's geändert mit "e" im SuSE-Grub auf sdb4, da liegt der KaOS-Kernel nämlich. Aber SuSE-Grub findet ihn trotzdem nicht.
    Hauptsystem: ASUS Z170 A - i5 6600K mit intergr. Grafik HD 530 - 16 GB DDR4 - TechniSat SkyStar 2 (DVB-S2) (PCI-alte Rev.) - 2 x SSD (sda/sdb) - 2 x HD (sdc/sdd) - ext. HD per USB - SATA-DVD und IDE->USB-DVD (beide intern) - iiyama xub3490wqsu 34" 21:9 (3440x1440 matt) - Canon Pixma iP4000 und MX925 - HP Scanjet G4050 - Yamaha Verstärker mit Plattenspieler
    Freundin: Terra (Wortmann) i3 4160 mit intergr. Grafik - 8 GB RAM DDR3
    WZ-HTPC: i3 4130 mit intergr. Grafik - 8 GB RAM DDR3 - TechniSat SkyStar 2 (DVB-S2) (PCI-alte Rev.) - Logitech K400
    Lenovo T61: Core2Duo 2.2 Ghz - 4GB RAM

    Für den Inhalt des Beitrages 103325 haftet ausdrücklich der jeweilige Autor: Wolle1956

  • Hallo Wolle,

    nein, an der ESP ändert sich nichts. Sie wird einmal /boot/efi gemounted, einmal nach /boot.
    Du kannst dich auch gerne selbst über efibootmgr informieren, z.B. im Wiki von ubuntuuser.de.

    Ich sehe zwei Möglichkeiten:

    1) Einen Eintrag für die neue ESP mit # efibootmgr --create im UEFI-BIOS einrichten. Der Installer Calamares müßte auch wohl diesen Befehl absetzen. Du würdest dann die genaue Fehlermeldung sehen.

    2) Kernel, Initramfs aus der ESP nach /boot kopieren,
    Von einem anderen Linux nach KaOS chrooten,
    grub installieren (wie ich in einem vorigen Post geschrieben habe)
    grub-mkconfig bzw. update-grub ausführen,
    Mountpoint für /boot aus der /etc/fstab entfernen,
    evtl. das Initramfs neu erzeugen.

    # chroot anwenden ist sehr eine gute Übung. Damit brauchst du kein "Überschreiben" von irgendwas mehr zu befürchten, sondern kannst bei Bedarf den Bootloader wieder herstellen.

    Viele Grüße
    Bequimão

    Für den Inhalt des Beitrages 103367 haftet ausdrücklich der jeweilige Autor: Bequimão

  • Bequimão schrieb:

    Hallo Wolle,

    nein, an der ESP ändert sich nichts. Sie wird einmal /boot/efi gemounted, einmal nach /boot.
    Du kannst dich auch gerne selbst über efibootmgr informieren, z.B. im Wiki von ubuntuuser.de.
    Das ganze Thema (U)EFI habe ich dort schonmal versucht zu kapieren. Es ist wohl schon etwas älter, denn die Probs, die ich hatte (oder habe), waren dort nicht zu finden. :(
    Ich sehe zwei Möglichkeiten:

    1) Einen Eintrag für die neue ESP mit # efibootmgr --create im UEFI-BIOS einrichten. Der Installer Calamares müßte auch wohl diesen Befehl absetzen. Du würdest dann die genaue Fehlermeldung sehen.
    Das Zweite, die Fehlermeldung habe ich gesehen, aber nichts nachvollziehen können.
    2) Kernel, Initramfs aus der ESP nach /boot kopieren,
    Aber /boot ist doch die esp.....?????? Oder kapiere ich irgendwas immernoch nicht?
    Von einem anderen Linux nach KaOS chrooten,
    grub installieren (wie ich in einem vorigen Post geschrieben habe)
    grub-mkconfig bzw. update-grub ausführen,
    Mountpoint für /boot aus der /etc/fstab entfernen,
    evtl. das Initramfs neu erzeugen.
    # chroot anwenden ist sehr eine gute Übung. Damit brauchst du kein "Überschreiben" von irgendwas mehr zu befürchten, sondern kannst bei Bedarf den Bootloader wieder herstellen.
    Das ist reichlich kompliziert für mich. Aber inzwischen hat die Installation und das Booten mit openSUSE-Grub geklappt:

    Einfach gar keine esp angeben -> Meldung wegklicken -> weiter installieren -> fertig -> SUSE booten -> Yast/Bootloader aufrufen und abspeichern -> reboot -> KaOS wählen: läuft fehlerlos (glaube ich). Da ist dann /boot keine esp und somit Kernel etc am richtigen Platz.

    Warum allerdings Kaffeine (2.0.5) unter KaOS die Systemlautstärke (nicht die von Kaffeine) beim Start immer auf voll stellt, will mir nicht in den Kopf. :(
    Das nur am Rande.....

    Danke für die Hilfe und Denkanstöße an alle, die sich hier die größte Mühe mit mir geben.

    Da ich viele Distris teste, muss das für mich einfacher gehen. Aber für den Dauergebrauch eignet sich KaOS eh nicht für mich: kein deutsches Forum.
    Hauptsystem: ASUS Z170 A - i5 6600K mit intergr. Grafik HD 530 - 16 GB DDR4 - TechniSat SkyStar 2 (DVB-S2) (PCI-alte Rev.) - 2 x SSD (sda/sdb) - 2 x HD (sdc/sdd) - ext. HD per USB - SATA-DVD und IDE->USB-DVD (beide intern) - iiyama xub3490wqsu 34" 21:9 (3440x1440 matt) - Canon Pixma iP4000 und MX925 - HP Scanjet G4050 - Yamaha Verstärker mit Plattenspieler
    Freundin: Terra (Wortmann) i3 4160 mit intergr. Grafik - 8 GB RAM DDR3
    WZ-HTPC: i3 4130 mit intergr. Grafik - 8 GB RAM DDR3 - TechniSat SkyStar 2 (DVB-S2) (PCI-alte Rev.) - Logitech K400
    Lenovo T61: Core2Duo 2.2 Ghz - 4GB RAM

    Für den Inhalt des Beitrages 103463 haftet ausdrücklich der jeweilige Autor: Wolle1956

www.cyberport.de