Nach Installatio: Kodi findet keine Codecs

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Nach Installatio: Kodi findet keine Codecs gibt es 15 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Nach Installatio: Kodi findet keine Codecs

    Hallo allerseits,
    habe Kodi installiert. Kodi kann aber nichts apsielen weil es scheinbar keine Codecs findet.
    Was habe ich übersehen?
    Umgebung: Tumbleweed Linux 4.8.4-1-default #1 SMP PREEMPT Sat Oct 22 11:24:48 UTC 2016 (402d8c1)

    Kodi log output
    11:04:24 T:139743586007360 NOTICE: DVDPlayer: Opening: 7tv_app_update_de_960x540.mp4
    11:04:24 T:139743586007360 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
    11:04:24 T:139742627600128 NOTICE: Creating InputStream
    11:04:24 T:139742627600128 NOTICE: Creating Demuxer
    11:04:24 T:139742627600128 NOTICE: Opening stream: 0 source: 256
    11:04:24 T:139742627600128 NOTICE: Creating video codec with codec id: 28
    11:04:24 T:139742627600128 ERROR: Unsupported video codec
    11:04:24 T:139742627600128 WARNING: OpenStream - Unsupported stream 0. Stream disabled.
    11:04:24 T:139742627600128 ERROR: Get - failed to get stream
    11:04:24 T:139742627600128 WARNING: CDVDMessageQueue(audio)::Put MSGQ_NOT_INITIALIZED
    11:04:24 T:139742627600128 WARNING: CDVDMessageQueue(video)::Put MSGQ_NOT_INITIALIZED
    11:04:24 T:139742627600128 ERROR: CDVDDemuxFFmpeg::ParsePacket() unable to open codec -22
    11:04:24 T:139742627600128 ERROR: Previous line repeats 749 times.
    11:04:24 T:139742627600128 NOTICE: CDVDPlayer::OnExit()
    11:04:24 T:139742627600128 NOTICE: DVDPlayer: eof, waiting for queues to empty
    11:04:24 T:139743586007360 NOTICE: CDVDPlayer::CloseFile()
    11:04:24 T:139743586007360 NOTICE: DVDPlayer: waiting for threads to exit
    11:04:24 T:139743586007360 NOTICE: DVDPlayer: finished waiting
    11:04:24 T:139743586007360 NOTICE: CDVDPlayer::CloseFile()
    11:04:24 T:139743586007360 NOTICE: DVDPlayer: waiting for threads to exit
    11:04:24 T:139743586007360 NOTICE: DVDPlayer: finished waiting

    Weiterhin werden auch keine Audio codecs gefunden.

    Hat einer eine Idee wo das Problem liegen könnte?
    Codecs sind installiert. DVB TV mit Kaffeine läuft.

    Peter

    Für den Inhalt des Beitrages 103032 haftet ausdrücklich der jeweilige Autor: elux

  • Hallo Sauerland,

    nachfolgend die gewünschte Ausgabe von Zypper.

    Peter


    Konsolenausgaben bitte in Codetags und nicht als txt-File!
    Dateien
    • zypper.txt

      (13,21 kB, 9 mal heruntergeladen, zuletzt: )

    Für den Inhalt des Beitrages 103035 haftet ausdrücklich der jeweilige Autor: elux

  • 1. Konsolenausgaben bitte immer in Code-tags, nicht als Anhang.
    2. Du hast packman 2x eingebunden.
    3. Das gemacht: Restricted Formats installieren
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 103038 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Hallo Sauerland,

    ja richtig. packman war 2x eingebunden. Habe ich korrigiert. Danke.

    Dann Kodi deinstalliert und wieder installiert. Der Fehler bleibt.

    Restricted Formats sind bereits installiert (packman repo).
    Diese funktionieren auch z. B. mit Kaffeine.

    Peter

    Für den Inhalt des Beitrages 103040 haftet ausdrücklich der jeweilige Autor: elux

  • Brainfuck-Quellcode

    1. zypper se -si ffmpeg
    2. Repository-Daten werden geladen...
    3. Installierte Pakete werden gelesen...
    4. S | Name | Typ | Version | Arch | Repository
    5. --+--------+-------+-----------+--------+-----------
    6. i | ffmpeg | Paket | 3.2.2-4.1 | x86_64 | Packman
    Sie haben recht. Unsupported ffmpeg ?

    Im kodi.log ist auch noch diese Medlung zu sehen.
    FFmpeg version: 2.8.8
    NOTICE: WARNING: unsupported ffmpeg version detected

    Ich hatte es bisher so verstanden das kodi eine interne ffmpeg verwendet.
    Das kodi exe ist statisch. Das heißt die verwendete ffmeg ist im kodi.bin
    und nicht die shared version.

    Korrektur: Auf Update warten?

    Dieser Beitrag wurde bereits 5 mal editiert, zuletzt von elux ()

    Für den Inhalt des Beitrages 103042 haftet ausdrücklich der jeweilige Autor: elux

  • Du hast wahrscheinlich die Version 3 von ffmpeg installiert, installiere die Version 2.8 und alle dazugehörigen libs (libav usw).
    Aus dem spec zum installieren für dich (ich hab nur den Teil mit den Versionen ausgewählt, -devel müssen natürlich nicht installiert werden):

    Quellcode

    1. BuildRequires: pkgconfig(gnutls)
    2. BuildRequires: pkgconfig(libass) >= 0.9.7
    3. BuildRequires: pkgconfig(libavcodec) = 56.60.100
    4. BuildRequires: pkgconfig(libavdevice) = 56.4.100
    5. BuildRequires: pkgconfig(libavfilter) = 5.40.101
    6. BuildRequires: pkgconfig(libavformat) = 56.40.101
    7. BuildRequires: pkgconfig(libavutil) = 54.31.100
    8. BuildRequires: pkgconfig(libbluray) >= 0.7.0
    9. BuildRequires: pkgconfig(libcdio)
    10. BuildRequires: pkgconfig(libcec) >= 3.0.0
    11. BuildRequires: pkgconfig(libcurl)
    12. BuildRequires: pkgconfig(libdca)
    13. BuildRequires: pkgconfig(libmicrohttpd)
    14. BuildRequires: pkgconfig(libmodplug)
    15. BuildRequires: pkgconfig(libmpeg2)
    16. BuildRequires: pkgconfig(libmpg123)
    17. BuildRequires: pkgconfig(libnfs)
    18. BuildRequires: pkgconfig(libpcre)
    19. BuildRequires: pkgconfig(libpcrecpp)
    20. BuildRequires: pkgconfig(libplist)
    21. BuildRequires: pkgconfig(libpng)
    22. BuildRequires: pkgconfig(libpulse)
    23. BuildRequires: pkgconfig(librtmp)
    24. BuildRequires: pkgconfig(libssh)
    25. BuildRequires: pkgconfig(libswresample) = 1.2.101
    26. BuildRequires: pkgconfig(libtiff-4)
    27. BuildRequires: pkgconfig(libudev)
    28. %if %{with enable_opengl}
    29. BuildRequires: pkgconfig(libva)
    30. %endif
    31. BuildRequires: pkgconfig(libxml-2.0)
    32. BuildRequires: pkgconfig(libxslt)
    33. BuildRequires: pkgconfig(mad)
    34. BuildRequires: pkgconfig(nettle)
    35. BuildRequires: pkgconfig(ogg)
    36. BuildRequires: pkgconfig(python)
    37. BuildRequires: pkgconfig(samplerate)
    38. %if !%{noX_build}
    39. BuildRequires: pkgconfig(sdl2)
    40. %endif
    41. BuildRequires: pkgconfig(smbclient)
    42. BuildRequires: pkgconfig(sqlite3)
    43. BuildRequires: pkgconfig(taglib) >= 1.8
    Alles anzeigen
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 103044 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Hallo Sauerland,

    im kodi.log sind folgende Meldungen zu sehen

    FFmpeg version: 2.8.8
    NOTICE: WARNING: unsupported ffmpeg version detected

    Die incompatible Version ist also ffmpeg 2.8.8 ?

    Für den Inhalt des Beitrages 103045 haftet ausdrücklich der jeweilige Autor: elux

www.cyberport.de