Anlegen von virtuellen Hosts / Apache

Hinweis: In dem Thema Anlegen von virtuellen Hosts / Apache gibt es 9 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • Anlegen von virtuellen Hosts / Apache

    Guten Tag,

    ich habe das Problem beim Anlegen von virtuellen Hosts, dass immer nur der Name "admin.meinedomain.de" angezeigt wird. Die anderen vrituellen Domains werden nicht angezeigt.

    Folgendes habe ich geändert:
    listen.con:

    Quellcode

    1. Listen 80
    2. <IfDefine SSL>
    3. <IfDefine !NOSSL>
    4. <IfModule mod_ssl.c>
    5. Listen 443
    6. </IfModule>
    7. </IfDefine>
    8. </IfDefine>
    9. NameVirtualHost *:80
    Alles anzeigen
    vhosts.conf in /etc/apache2/vhosts.d


    Quellcode

    1. <VirtualHost *:80>
    2. ServerName administration.meinedomain.de:80
    3. DocumentRoot /srv/www/htdocs/vhosts/administration.meinedomain.de
    4. <Directory /srv/www/htdocs/vhosts/administration.meinedomain.de>
    5. Options Indexes FollowSymLinks MultiViews
    6. AllowOverride All
    7. <IfModule !mod_access_compat.c>
    8. Require all granted
    9. </IfModule>
    10. <IfModule mod_access_compat.c>
    11. Order allow,deny
    12. Allow from all
    13. </IfModule>
    14. </Directory>
    15. ErrorLog /var/log/apache2/administration.meinedomain.de-error_log
    16. LogLevel warn
    17. CustomLog /var/log/apache2/administration.meinedomain.de-access_log combined
    18. ServerSignature On
    19. </VirtualHost>
    20. <VirtualHost *:80>
    21. ServerName test.meinedomain.de:80
    22. DocumentRoot /srv/www/htdocs/vhosts/test.meinedomain.de
    23. <Directory /srv/www/htdocs/vhosts/test.meinedomain.de>
    24. Options Indexes FollowSymLinks MultiViews
    25. AllowOverride All
    26. <IfModule !mod_access_compat.c>
    27. Require all granted
    28. </IfModule>
    29. <IfModule mod_access_compat.c>
    30. Order allow,deny
    31. Allow from all
    32. </IfModule>
    33. </Directory>
    34. ErrorLog /var/log/apache2/test.meinedomain.de-error_log
    35. LogLevel warn
    36. CustomLog /var/log/apache2/test.meinedomain.de-access_log combined
    37. ServerSignature On
    38. </VirtualHost>
    Alles anzeigen
    Es wird beim Aufruf der Domain test.meinedomain.de nur die administration.meinedomain.de angezeigt. Ich hatte auch schon einen dritten Eintrag - jedoch mit dem gleichen Ergebnis.

    Auch habe ich die Dateien anfangs für jeden Subdomain-Namen einzeln mit dem Namen (administration.meinedomain.de.conf usw.) gehabt. Auch hier das gleiche Ergebnis. Es wird nur der administration.meinedomain.de angezeigt.

    Den Domainnamen habe ich auf Anweisung geändert - ist natürlich nicht der tatsächliche.

    Könnt Ihr mir hier weiterhelfen? Wenn andere config Dateien benötigt werden, gebt mir Bescheid.

    Danke im Voraus

    mfg

    Reiner

    Für den Inhalt des Beitrages 103394 haftet ausdrücklich der jeweilige Autor: rebelhig61

  • Ich mag ja gerne helfen.
    Aber mit so dünnen Informationen, kann euch niemand helfen.

    Und schön, dass der Kollege so schnell wieder aus dem Urlaub zurück ist.
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 103396 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • Die DNS Einträge wurden, soweit mir mitgeteilt wurde, vorgenommen. Es wurde auf die IP Adresse der Eintrag "*.meinedomain.de" vorgenommen. Ohne die vhost Einträge konnte ich auch jeden Namen vor den Domainnamen setzen und hatte unseren Server erreicht.

    Müssen die Einträge auch noch auf dem Server eingetragen werden?

    Für den Inhalt des Beitrages 103397 haftet ausdrücklich der jeweilige Autor: rebelhig61

  • Wir brauchen Fakten, keine Prosa.

    Fragen wir nach Domaineinträgen, dann wollen wir das Ergebniss von ping, oder besser dig, notfalls auch nslookup für alle Domainnamen sehen.
    "Soweit ich weißt hat da irgendjemand irgendwas irgendwie gemacht" hilft uns nicht, dir erst recht nicht.
    Linux hat alle Tools, um solche fragen mit Resultaten nicht mit Meinungen zu beantworten.

    Außderdem fehlen grundlegende Informationen.
    Welches OS in welcher Version? (Jede Distri hat ihren eigenen Weg mit Programmen umzugehen)
    In welchen Dateien sind diese Vhost definiert?
    Wurden sie für den Apache enabled?

    Basics halt.
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 103399 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • Danke für die Antwort.
    Als OS haben wir:
    - SUSE Linux Enterprise Server 12 (x86_64)
    - Version = 12
    - Patchlevel = 1

    DIG gibt mir die richtige IP Adresse des Servers zurück, sowohl als *.meinedomain.de wie auch mit den einzelnen Subdomains.
    DIG *.meinedomain.de:
    ;; ANSWER SECTION
    *.meinedomain.de 3600 IN A 81.200.xxx.xxx
    DIG administration.meinedomain.de
    administartion.meinedomain.de 3600 IN A 81.200.xxx.xxx

    Die besagten Einträge für die vhosts habe ich ausschließlich in den oben genannten Dateien vorgenommen.

    Wie kann ich feststellen, ob diese für den Apache enabled wurden?

    Bisher hatte ich mit Debian gearbeitet und keine Probleme gehabt. Dort gab es a2ensite, welches es in dieser SUSE Version nicht gibt.

    mfg

    Reiner

    Für den Inhalt des Beitrages 103402 haftet ausdrücklich der jeweilige Autor: rebelhig61

  • Debian hat zwei Verzeichnisse für die jeweiligen Domains. Einmal das sites-available und einmal das sites-enabled
    Das a2ensite setzt lediglich einen Link in sites-enabled.
    Der Rest funktioniert einfach via Includes, die sich in den jeweiligen Confs befinden.

    Bei openSUSE genügt es die jeweilige conf- Datei für die einzelnen Vhosts einfach in das Verzeichnis /etc/vhosts.d zu legen.
    Nach einem Apacherestart sollten sie dann tun.
    Diese Vhosts werden dann ebenfalls via Includes von Apache beim Start eingelesen.
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 103406 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • _Oh!!!
    Ich habe gerade erst gesehen, dass in der ServerName Directive der Port mit Doppelpunkt angegeben ist.
    Das ist Totalquatsch. Steht ja schon in der Section. Einfach löschen.
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 103407 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • Es funktioniert jetzt. Ich habe in meiner vhosts.conf noch folgende Änderungen vorgenommen:


    Quellcode

    1. <VirtualHost *:80>
    2. ServerName meinedomain.de
    3. ServerAlias meinedomain.de
    4. DocumentRoot /srv/www/htdocs
    5. </VirtualHost>
    6. <VirtualHost *:80>
    7. ServerName administration.meinedomain.de
    8. ServerAlias administration.meinedomain.de
    Danke für die Antworten.

    mfg
    Reiner

    Für den Inhalt des Beitrages 103433 haftet ausdrücklich der jeweilige Autor: rebelhig61

www.cyberport.de