Leap 42.2 Bildschirm flackert manchmal beim Schließen von Fenstern oder beim Scrollen

Hinweis: In dem Thema Leap 42.2 Bildschirm flackert manchmal beim Schließen von Fenstern oder beim Scrollen gibt es 8 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • Leap 42.2 Bildschirm flackert manchmal beim Schließen von Fenstern oder beim Scrollen

    Ich habe Weihnachten Leap 42.2 installiert. Neuinstallation der Systempartition von DVD bei Beibehaltung meiner home-Partition, die ich schon durch mehrere Suse-Versionen geschleppt habe, zuletzt 13.2.

    Soweit läuft alles zu meiner vollen Zufriedenheit, bis auf ein Problem:

    Wenn ich zu meinem zweiten Nutzer wechsle, kommt es etwa bei jedem fünften Start vor, dass beim Scrollen in Firefox alles flackert. Aber auch die anderen Fenster flackern, vor allem beim Schließen. Das ganze System wird instabil und fror mir schon mehrmals ein. Inzwischen reagiere ich so, dass ich, sobald ich merke, diesmal habe ich wieder einen Flackerstart erwischt, gleich den PC herunterfahre. Beim Herunterfahren flackert es dann noch mal stark. Nach dem Neustart ist alles wieder in Ordnung, allerdings ist es jetzt einmal vorgekommen, dass es nach dem Neustart gleich wieder mit dem Flackern losging. Zweiter Neustart brachte dann wieder Normalität, aber das ist natürlich kein Zustand.

    Da mir das Problem zuerst im Firefox auffiel, habe ich den komplett deinstalliert, dann auf beiden Nutzern in .mozilla/firefox den Ordner /firefox komplett gelöscht, Firefox neu installiert und nur drei Dateien, die für meine Lesezeichen und Passwörter, wieder neu reinkopiert. An Erweiterungen habe ich nur eine einzige, Noscript, neu installiert. Ich habe jetzt also einen fast jungfräulichen Firefox. Leider tritt das Problem aber weiter auf, zum Beispiel auch, wenn ich zuerst Dolphin aufmache. Ich bin inzwischen ziemlich sicher, dass es nichts mit Firefox zu tun hat.

    Da das Problem aber nur bei meinem zweiten Nutzer auftritt, habe ich einen dritten Nutzer angelegt. In diesen dritten Nutzer habe ich dann nur meine Daten vom runderneuerten Firefox rüberkopiert, weil meine Lesezeichen brauche ich nunmal, und den Ordner von jdownloader. Etwa fünf Starts blieb dieser neue dritte Nutzer flackerfrei, jetzt eben trat das Problem aber doch wieder auf. Ich habe nach dem Neuanlegen dieses neuen Nutzers keine Veränderungen an den Einstellungen der Arbeitsfläche vorgenommen.

    Ich starte immer mit meinem Hauptnutzer. Wenn ich dann später in einen der jetzt zwei anderen Nutzer wechsle, tritt das Problem entweder sofort nach dem Wechsel auf, oder es tritt gar nicht auf. Das heißt, entweder, es flackert gleich beim Scrollen oder Fensterschließen, oder es flackert über Stunden gar nicht. Auch wenn ich x-mal mit Strg+alt+f7 und Str+alt+f8 hin und her wechsle, passiert nichts mehr. Es scheint nur auf den ersten Start des zweiten Nutzers anzukommen, wenn der gelingt, bleibt alles okay.

    Soweit die Prosa, jetzt noch ein paar Fakten:

    Leap 42.2 mit Kernel 4.4.46-11-default
    Plasma 5.8.3
    Qt Version 5.6.1

    Da meist danach gefragt wird, hier mal gleich meine Repos:

    Brainfuck-Quellcode

    1. thomas@linux-vs38:~> zypper lr -d
    2. Repository-Prioritäten treten in Kraft: (Siehe 'zypper lr -P' für Details)
    3. 20 (erhöhte Priorität) : 1 Repository
    4. 99 (Standard-Priorität) : 4 Repositorys
    5. # | Alias | Name | Aktiviert | GPG-Überprüfung | Aktualisierung | Priorität | Typ | URI | Dienst
    6. ---+---------------------------------+---------------------------------------------------------+-----------+-----------------+----------------+-----------+--------+--------------------------------------------------------------------------+-------
    7. 1 | download.opensuse.org-non-oss | Haupt-Repository (NON-OSS) | Ja | (r ) Ja | Ja | 99 | yast2 | http://download.opensuse.org/distribution/leap/42.2/repo/non-oss/ |
    8. 2 | download.opensuse.org-non-oss_1 | Aktualisierungs-Repository (Nicht-Open-Source-Software) | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/update/leap/42.2/non-oss/ |
    9. 3 | download.opensuse.org-oss | Haupt-Repository (OSS) | Ja | (r ) Ja | Ja | 99 | yast2 | http://download.opensuse.org/distribution/leap/42.2/repo/oss/ |
    10. 4 | download.opensuse.org-oss_1 | Hauptaktualisierungs-Repository | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/update/leap/42.2/oss |
    11. 5 | openSUSE-42.2-0 | openSUSE-42.2-0 | Nein | ---- | ---- | 99 | yast2 | cd:///?devices=/dev/disk/by-id/ata-HL-DT-ST_DVDRAM_GH22NS50_K3LB4MD4822 |
    12. 6 | packman.inode.at-suse | Packman Repository | Ja | (r ) Ja | Ja | 20 | rpm-md | http://packman.inode.at/suse/openSUSE_Leap_42.2/ |
    13. 7 | repo-debug | openSUSE-Leap-42.2-Debug | Nein | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/distribution/leap/42.2/repo/oss/ |
    14. 8 | repo-debug-non-oss | openSUSE-Leap-42.2-Debug-Non-Oss | Nein | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/distribution/leap/42.2/repo/non-oss/ |
    15. 9 | repo-debug-update | openSUSE-Leap-42.2-Update-Debug | Nein | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/update/leap/42.2/oss/ |
    16. 10 | repo-debug-update-non-oss | openSUSE-Leap-42.2-Update-Debug-Non-Oss | Nein | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/update/leap/42.2/non-oss/ |
    17. 11 | repo-source | openSUSE-Leap-42.2-Source | Nein | ---- | ---- | 99 | NONE | http://download.opensuse.org/source/distribution/leap/42.2/repo/oss/ |
    18. 12 | repo-source-non-oss | openSUSE-Leap-42.2-Source-Non-Oss | Nein | ---- | ---- | 99 | NONE | http://download.opensuse.org/source/distribution/leap/42.2/repo/non-oss/ |
    19. thomas@linux-vs38:~>
    Alles anzeigen

    Jetzt bin ich für gute Ratschläge dankbar!

    Für den Inhalt des Beitrages 105355 haftet ausdrücklich der jeweilige Autor: tom2345

  • FALLS! es ein Laptop ist mit Radeon Karte gehe in Systemeinstellungen - Anzeige und Monitor - Compositor - Ausgabemodul. Schalte das auf xrender. Fertig. Falls es ein Laptop mit Radeon ist ... ansonsten weiter mit Sauerland.
    Zum Aufrufen die Links bitte anklicken:

    Wie man Fragen richtig stellt!
    --------------------
    Konsolenausgaben sind inkl. der Eingaben in Codetags zu posten!
    --------------------
    Datenrettung mit grml-linux-live-cd
    --------------------
    Thema als erledigt markieren

    Für den Inhalt des Beitrages 105360 haftet ausdrücklich der jeweilige Autor: Alero

  • Sorry, dass ich das nicht gleich gepostet habe, es ist kein Notebook, sondern ein Desktopsystem. mit Grafikkarte von NVIDIA:

    Quellcode

    1. thomas@linux-vs38:~> /sbin/lspci -nnk | grep -EiA3 'vga|3d|display'
    2. 01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF119 [GeForce GT 520] [10de:1040] (rev a1)
    3. Subsystem: CardExpert Technology Device [10b0:1401]
    4. Kernel driver in use: nouveau
    5. Kernel modules: nouveau
    6. thomas@linux-vs38:~>

    Für den Inhalt des Beitrages 105362 haftet ausdrücklich der jeweilige Autor: tom2345

  • OK, dann vergiss den oben angeführten Beitrag von mir. Es kann sein, das deine Karte Probleme mit dem Nouveau Treiber hat. Warum installierst du nicht den Nvidia? Also den, der zur Karte gehört? Binde dir das Nvidia-Repo ein und installiere den Treiber. Ich meine das deine Probleme damit behoben sein sollten.
    Zum Aufrufen die Links bitte anklicken:

    Wie man Fragen richtig stellt!
    --------------------
    Konsolenausgaben sind inkl. der Eingaben in Codetags zu posten!
    --------------------
    Datenrettung mit grml-linux-live-cd
    --------------------
    Thema als erledigt markieren

    Für den Inhalt des Beitrages 105363 haftet ausdrücklich der jeweilige Autor: Alero

  • Okay, der NVIDIA-Treiber ist eine Option. Unter 13.2. hatte ich mit dem Probleme und war eigentlich froh, als ich den deinstalliert hatte und mein System auch ohne den proprietären Treiber prima lief. Ich werde mich heute Abend dann also mal hinsetzen und den NVIDIA-Treiber wieder installieren - es sei denn, bis dahin postet jemand noch eine Idee, was ich sonst noch tun kann, um den nouveau weiter einsetzen zu können. Ich werde mich leider bis dahin nicht mehr melden können, muss weg.

    Für den Inhalt des Beitrages 105364 haftet ausdrücklich der jeweilige Autor: tom2345

  • Ich hatte bei mir nach Installation von openSUSE 42.2 bemerkt, dass Videos nicht ruckelfrei abspielbar sind (z. B. ARD-Mediathek) und auch sonst ruckelte beim scrollen der Bildschirm leicht, obwohl sich das kaum bemerkbar machte.

    Systemeinstellungen - Anzeige und Monitor - Compositor - "Composer beim start aktivieren" Häkchen raus genommen und schon lief bei mir alles wieder rund.
    Keine ruckeligen scrolls, kein ruckeliges Video, alles bestens. (Hatte ich aber auch damals bei 13.1 und 13.2 auch schon raus genommen.)

    Vielleicht hilft dir das ja. Ich hab allerdings nicht umsonst noch "Wissenstand Anfänger" eingetragen.
    Andere habe bestimmt bessere Lösungen.

    Mein System:
    openSuse 42.2 - KDE - plasma 5 - Desktop PC (kein Notebook) - nvidia Grafikkarte - "mesa-dri-nouveau" nicht installiert, da openSUSE-Installation schreibt, daß Nouveau DRI/3D Treiber als Experimentell eingestuft wird (Ich habe keinen zusätzlicher NVIDIA-Treiber installiert. Alles standardmäßig von der openSUSE Installation.)

    Für den Inhalt des Beitrages 105383 haftet ausdrücklich der jeweilige Autor: mikado

  • Vielen Dank erst mal an alle für die Ratschläge. Ich habe jetzt den nvidia-Treiber installiert. Ob das Flackern damit dauerhaft wegbleibt, möchte ich noch ein paar Tage abwarten, bevor ich den Thread als gelöst markiere. Das Flacker-Problem trat ja auch vorher nicht bei jedem Start auf sondern gefühlt etwa alle zwei, drei Tage.

    Besonderen Dank auch an mikado, deinen Vorschlag hätte ich gerne erst mal ausprobiert, um beim nouveau bleiben zu können, leider hatte ich aber zwischenzeitlich schon den NVIDIA installiert.

    Leider auch deshalb, weil ich seitdem ein neues Problem habe: "Die Bildschirmsperre ist gestört und die Sitzung kann nicht wieder frei gegeben werden...."
    Aber das ist ein neues Problem, dazu mache ich gleich einen neuen Thread auf.

    Hier möchte ich nur noch in ein paar Tagen abschließend berichten, ob das Flacker-Problem jetzt wirklich weg ist.

    Für den Inhalt des Beitrages 105427 haftet ausdrücklich der jeweilige Autor: tom2345

  • Nachdem das Flackerproblem nach Installation des NVIDIA-Treibers jetzt über eine Woche lang nicht mehr aufgetreten ist, bin ich sicher, dass das Problem gelöst ist. Ich habe nun den Thread als "erledigt" markiert und bedanke mich noch einmal bei Alero, Sauerland und mikado für die guten Ratschläge!

    Für den Inhalt des Beitrages 105851 haftet ausdrücklich der jeweilige Autor: tom2345

www.cyberport.de