kein bootfähiges System nach Installation, merkwürdige Partitionen, Windows8

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema kein bootfähiges System nach Installation, merkwürdige Partitionen, Windows8 gibt es 47 Antworten auf 5 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • kein bootfähiges System nach Installation, merkwürdige Partitionen, Windows8

    Nach vielen abgebrochenen Versuchen mit Ubuntu Distros, die vielleicht wg. onboard Nvidia Grafik nicht gelang, bin ich mit Opensuse weiter gekommen, vielleicht weil ich damit den Grafiktreiber (Nuevo o.ä.?) ablehnen konnte. Allerdings kommt nach der Installation kein Auswahlfenster zw. Opensuse und Windows sondern bootet automatisch Windows. Mit den letzten Versuch habe ich an den Einstellungen für Partitionen und MBR nichts geändert. Die Partitionen habe ich nachher mit G-Parted angeschaut und die sehen komisch aus:
    /dev/sd1 1MB
    /dev/sd2 ntfs 350MB 237MB
    /dev/sda3 ntfs 58, GB 21, GB boot
    extended 16843 GB lba
    nicht zugeteilt 1MB
    /dev/sda5 ! btrfs 40GB
    nicht zugeteilt nicht zugeteilt 1 MB
    /dev/sda6 ! xfs 12849 GB
    /dev/sda4 linux swap 5,8 GB

    Ich habe ein PHenom4 mit 8GB RAM, ein 250GB HDD, und ein DVD Laufwerk, beide auf SATA.Ich habe ein normales BIOS, kein UEFI.

    Ich bin bereit Opensuse für das 3. Mal zu installieren, aber vielleicht soll ich mit G-Parted die Partitionen neu anlegen, aber wie!!!
    Und was mach ich mit den zwei Häckchen/Einstellungen für /MBR/BOOTCODE/ROOT??

    Ich habe sicher schon 20 Stunden versenkt und viel gelesen, aber ich werde nicht schlaue.
    Ich wäre für Hilfe sehr dankbar!

    Für den Inhalt des Beitrages 105370 haftet ausdrücklich der jeweilige Autor: ianize

  • Hi,

    nehme die GParted-CD und lösche /dev/sda4, 5 und 6
    Fahre Win10 runter. Also richtig, nicht Suspend to ram bzw. to disc.
    Dann OpenSuse installieren. Welche Version hast du denn vor zu installieren?
    Die Partitionen /dev/sda1, 2 und 3 werden nicht berührt. Das wird während des Installationsprozess auch angezeigt.

    Die extended / erweiterte Partition steht dann für OpenSuse zur Verfügung, Das root -Verzeichnis, also nur der Slash /, kann ruhig doppelt so groß gewählt werden.
    Der Bootloader wird schon richtig während der Installation geschrieben. Hoffe ich, denn ich habe gar kein Win10.

    Thomas

    Für den Inhalt des Beitrages 105372 haftet ausdrücklich der jeweilige Autor: ThomasS

  • OK, ich versuche es heute abend. Ich hatte ein RescueCD, aber da habe ich die notwendige Kenntnisse nicht. Vielen Dank!
    Meinst Du ich soll die Partitions so lassen?

    Für den Inhalt des Beitrages 105373 haftet ausdrücklich der jeweilige Autor: ianize

  • ThomasS schrieb:

    Fahre Win10 runter. Also richtig, nicht Suspend to ram bzw. to disc.
    Ich meine mal was von einem "Schnellstarter" oder so bei Win10 gehört zu haben. Auch sowas nicht, so richtig runterfahren.


    ianize schrieb:

    Meinst Du ich soll die Partitions so lassen?
    Das was ich meinte, schrieb ich doch im Post 3.

    Du kannst ja auch mal Apfelmanns Vorschlag versuchen. Wenn es klappt geht es schneller.
    Allerdings würde die Größe der / Partition bei 40GB bleiben. 80GB wären schon besser, da OpenSuse Leap 42.2 Schnappschüsse von / anlegt.
    Ich habe mal Leap 42.2 geraten. Du behältst die Info ja für Dich.
    Du hast ja Win8! Das mit Win10 habe ich wohl noch aus einem anderen Thread im Kopf gehabt.
    Macht auch keinen Unterschied für mich. Ich habe auch kein Win8.

    Thomas

    Für den Inhalt des Beitrages 105375 haftet ausdrücklich der jeweilige Autor: ThomasS

  • Sorry, ich habe deinem Post übersehen, bevor ich geantwortet habe. Ich habe die 42.2 x86_64 Version.
    Das mit dem Windows herunterfahren habe ich raus: shutdown in commandozeile schreiben.
    Dann versuche ich zuerst supergrubdisc.
    Wenn das nicht hilft dann G-parted. Also die letzten Partitionen löschen (4,5,6) und keine neue anlegen oder formattieren? Wenn Thomas schreibt, dass die Rootpartion doppelt so groß sein soll, dann klingt es, als ob ich doch die Partitionen anlegen soll. Das ist mir zu oft misslungen!

    Und wie ist es mit den zwei befürchteten Kästchen wg. MBR/Bootcode/Rootpartition und enable/disable?

    Jetzt fehlt mir noch was ein. Ich habe BCD EasyBoot in Windows installiert und auch ausprobiert. Der hat zu dem Windows auch ein Linux Bootoption hinzugefügt, aber diese Option fand ja nichts. Da befürchte ich, dass ich da was jetzt im Weg habe, oder wird Opensuse bei einer Neuinstallation das überschreiben? Soll ich versuchen, das BCD Programm zu deinstallieren? Reicht das?

    Für den Inhalt des Beitrages 105376 haftet ausdrücklich der jeweilige Autor: ianize

  • ianize schrieb:

    Und wie ist es mit den zwei befürchteten Kästchen wg. MBR/Bootcode/Rootpartition und enable/disable?
    Das wäre meine Antwort dazu.

    ThomasS schrieb:

    Der Bootloader wird schon richtig während der Installation geschrieben. Hoffe ich, denn ich habe gar kein Win10.
    Einfach machen lassen. Bei Win7 ging es noch vor ein paar Jahren.


    ianize schrieb:

    Ich habe BCD EasyBoot in Windows installiert und auch ausprobiert. Der hat zu dem Windows auch ein Linux Bootoption hinzugefügt, aber diese Option fand ja nichts.
    Diesen Boot-Manager kenne ich nicht. Grub2 macht es doch (normalerweise) perfekt.
    Wenn du den BCD Bootmanager deinstalliertst, hoffe ich, du machst nichts irreparabel kaputt.
    Ansonsten, siehe Apfelmann Post2.

    Für den Fall der Fälle, hast du eine Win8 Installations-CD? Nur für den absoluten Notfall.........

    Für den Inhalt des Beitrages 105377 haftet ausdrücklich der jeweilige Autor: ThomasS

  • Das Windows 10 öfter nicht richtig herunter fährt liegt am Hiberboot. Dieses hat Microsoft eingeführt, damit Windows schneller startet (Das wird dem Nutzer damit vorgegaukelt). Das kann man in der Registry aber wieder deaktivieren.

    "HiberbootEnabled deaktivieren
    Rechtsklick auf die Fahne
    Auf Ausführen gehen und regedit eingeben
    auf
    HKEY_LOCAL_MASCHINE\SYSTEM\CurrentControlSet\Control\SessionManager\Power
    gehen
    den Schlüssel HiberbootEnabled raussuchen und den dword Wert von 1 auf 0 ändern
    Das wars!"

    Für den Inhalt des Beitrages 105381 haftet ausdrücklich der jeweilige Autor: Z_O_O_M

  • Danke für den Tipp, dass ich über Regedit die Hibernate ausschalten konnte.
    Leider bootet nichts mehr. Es gab auch am Schluss Fehlermeldungen die mit Grub zu tun hatten. Ich habe es bei den 2 Kästchen in beiden Richtungen probiert: Bootcode in MBR und Bootcode in root. Jetzt startet auch mein Windows nicht mehr. Supergrubdisc findet nur Windows und keine Grub. Beim Fdisk -l steht 'boot' beim sda3, die erweiterte Partition, die in /, /home/ und swap unterteilt ist. Root ist sda6.
    Vielleicht muss ich etwas bei den erweiterten Bootoptionen ändern, aber was????
    Hat jemand eine Idee?
    Wenn ich wüsste, wie ich bei der Installation den Ubuntu Grafiktreiber ausschalten könnte, und später den nvidia holen, würde evtl. das wieder versuchen. Opensuse ist der einzige der es mir anbietet.

    Für den Inhalt des Beitrages 105397 haftet ausdrücklich der jeweilige Autor: ianize

  • Also ehrlich, diesen Satz verstehe ich nicht.

    ianize schrieb:

    Wenn ich wüsste, wie ich bei der Installation den Ubuntu Grafiktreiber ausschalten könnte, und später den nvidia holen, würde evtl. das wieder versuchen. Opensuse ist der einzige der es mir anbietet.
    Ubuntu ist doch kein Grafikkarten bzw. Chip Hersteller!

    ianize schrieb:

    Jetzt startet auch mein Windows nicht mehr.
    Für den Fall der Fälle fragte ich doch: Hast du eine Win8-Installations CD/DVD? (Post 7)


    ianize schrieb:

    Supergrubdisc findet nur Windows und keine Grub
    Na, das ist doch schon was. Dann brauchst du doch keine Neuinstallation von Windows durchzuführen.
    Supergrubdisc findet nur Betriebssysteme die bootbar sind oder sein sollten. Nicht Grub. Der soll ja neu geschrieben werden.

    ianize schrieb:

    Beim Fdisk -l steht 'boot' beim sda3,
    Ist doch deine Win8 Partition. Die willst du ja behalten und davon logischerweise booten. Deswegen. Deswegen ist das Flag auf "boot" gesetzt. Korrekt.

    Apfelmanns Vorschlag mit Supergrubdisk führt nicht immer zum Erfolg - aber oft.
    Versuche mal die von mir vorgeschlagenen Vorgehensweise aus Post 3.
    Akzeptiere einfach die 40GB wenn du dich nicht an den Partitionierung während der Installation traust. Das könnte später mal ein Thema werden.....
    Es sollte funktionieren.

    Also:
    1. Mache dein Win8 wieder bootbar, mit Supergrubdisk.
    2. Lösche die Partitionen wie ich in Post 3 geschrieben habe.
    3. Installiere OpenSuse mit den Standardeinstellungen des Partionierers.
    4. Rückmeldung......... :)

    Gruß
    Thomas

    Für den Inhalt des Beitrages 105407 haftet ausdrücklich der jeweilige Autor: ThomasS

www.cyberport.de