Kein Sound mit ASUS Xonar Phoebus (C-Media CM8888)

Hinweis: In dem Thema Kein Sound mit ASUS Xonar Phoebus (C-Media CM8888) gibt es 22 Antworten auf 3 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Fenriswolf schrieb:

    ....
    Hinweis: wenn ich auf HDMI wechsle, gibt's sofort Sound
    ....
    Du hast zwei Soundkarten.

    Einmal onboard, einmal auf der GraKa.

    Beide tun einfach.
    Was nicht tut, ist lediglich, dass der User die Boxen in die richtigen Buchsen stöpselt.
    (Was bei manchen Kisten nicht geht, wenn nicht alle Anschlüsse nach außen geführt werden. Billigheimer, schlecht konfiguriert.)

    Du kannst das entweder mit pavucontrol lösen, oder umstöpseln.
    (Bei pulse mag in der Konsole auch ein pactl set-default nötig sein; aber stell es erst mal mit pavucontrol richtig ein; das sollte sich das mittlerweile merken)
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 106380 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • Neu

    Sauerland schrieb:

    Quellcode

    1. aplay -l

    Als User und als root ausgeführt ergibt was?

    Quellcode

    1. (für user + root) aplay -l
    2. **** Liste der Hardware-Geräte (PLAYBACK) ****
    3. Karte 0: HDMI [HDA ATI HDMI], Gerät 3: HDMI 0 [HDMI 0]
    4. Sub-Geräte: 1/1
    5. Sub-Gerät #0: subdevice #0
    6. Karte 0: HDMI [HDA ATI HDMI], Gerät 7: HDMI 1 [HDMI 1]
    7. Sub-Geräte: 1/1
    8. Sub-Gerät #0: subdevice #0
    9. Karte 0: HDMI [HDA ATI HDMI], Gerät 8: HDMI 2 [HDMI 2]
    10. Sub-Geräte: 1/1
    11. Sub-Gerät #0: subdevice #0
    12. Karte 0: HDMI [HDA ATI HDMI], Gerät 9: HDMI 3 [HDMI 3]
    13. Sub-Geräte: 1/1
    14. Sub-Gerät #0: subdevice #0
    15. Karte 0: HDMI [HDA ATI HDMI], Gerät 10: HDMI 4 [HDMI 4]
    16. Sub-Geräte: 1/1
    17. Sub-Gerät #0: subdevice #0
    18. Karte 0: HDMI [HDA ATI HDMI], Gerät 11: HDMI 5 [HDMI 5]
    19. Sub-Geräte: 1/1
    20. Sub-Gerät #0: subdevice #0
    21. Karte 1: CMedia [HDA C-Media], Gerät 0: CMI8888 Analog [CMI8888 Analog]
    22. Sub-Geräte: 1/1
    23. Sub-Gerät #0: subdevice #0
    24. Karte 1: CMedia [HDA C-Media], Gerät 1: CMI8888 Digital [CMI8888 Digital]
    25. Sub-Geräte: 1/1
    26. Sub-Gerät #0: subdevice #0
    Alles anzeigen
    in diesem Ubuntu-Forum bin ich auf einen Befehl gestoßen, der dann des rätsels Lösung brachte (Soundausgabe erfolge über (nicht vorhandenes) Modem)
    dieser Befehl bei mir gibt folgende Ausgabe

    Quellcode

    1. fuser -v /dev/dsp* /dev/snd/* /dev/seq*
    2. Specified filename /dev/dsp* does not exist.
    3. Specified filename /dev/seq* does not exist.
    4. USER PID ACCESS COMMAND
    5. /dev/snd/controlC0: wolf 2299 F.... pulseaudio
    6. /dev/snd/controlC1: wolf 2299 F.... pulseaudio
    Kann ich davon ausgehen, dass das soweit ok ist und die fehlenden Dateien ignorieren?

    Berichtigung schrieb:

    Fenriswolf schrieb:

    ....
    Hinweis: wenn ich auf HDMI wechsle, gibt's sofort Sound
    ....
    Du hast zwei Soundkarten.
    Einmal onboard, einmal auf der GraKa.

    Beide tun einfach.
    Was nicht tut, ist lediglich, dass der User die Boxen in die richtigen Buchsen stöpselt.
    (Was bei manchen Kisten nicht geht, wenn nicht alle Anschlüsse nach außen geführt werden. Billigheimer, schlecht konfiguriert.)

    Du kannst das entweder mit pavucontrol lösen, oder umstöpseln.
    (Bei pulse mag in der Konsole auch ein pactl set-default nötig sein; aber stell es erst mal mit pavucontrol richtig ein; das sollte sich das mittlerweile merken)
    Dieser Post bringt mich voran wie 2Tage Kreisverkehr...
    1. Habe ich wenn du so willst drei Karten: Onboard, GraKa und die DEDIZIERTE (wird ja im Eröffnungspost auch erwähnt welche)
    2. "Unterstellungen" sind unter aller Sau! du kennst meine Soundconfig nicht und bist einfach mal so der Meinung ich bin zu blöd es richtig anzuschließen... Dann frag nach, was ich schon alles getan habe (oder auch nicht)
    PS: es ist alles richtig angeschlossen... Karte funktioniert auch, da unter Windoof keine Probleme

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Fenriswolf ()

    Für den Inhalt des Beitrages 106427 haftet ausdrücklich der jeweilige Autor: Fenriswolf

  • Neu

    Ist die Karte gemutet:
    Alles auf 0:

    Quellcode

    1. Card hw:1 'CMedia'/'HDA C-Media at 0xefd00000 irq 17'
    2. Mixer name : 'C-Media CMI8888'
    3. Components : 'HDA:13f68888,104384d5,00101500'
    4. Controls : 41
    5. Simple ctrls : 16
    6. Simple mixer control 'Master',0
    7. Capabilities: pvolume pvolume-joined pswitch pswitch-joined
    8. Playback channels: Mono
    9. Limits: Playback 0 - 127
    10. Mono: Playback 127 [100%] [0.00dB] [on]
    11. Simple mixer control 'Headphone',0
    12. Capabilities: pvolume pswitch
    13. Playback channels: Front Left - Front Right
    14. Limits: Playback 0 - 109
    15. Mono:
    16. Front Left: Playback 109 [100%] [0.00dB] [on]
    17. Front Right: Playback 109 [100%] [0.00dB] [on]
    18. Simple mixer control 'Headphone Amp',0
    19. Capabilities: pvolume
    20. Playback channels: Front Left - Front Right
    21. Limits: Playback 0 - 2
    22. Mono:
    23. Front Left: Playback 0 [0%] [0.00dB]
    24. Front Right: Playback 0 [0%] [0.00dB]
    25. Simple mixer control 'PCM',0
    26. Capabilities: pvolume
    27. Playback channels: Front Left - Front Right
    28. Limits: Playback 0 - 255
    29. Mono:
    30. Front Left: Playback 255 [100%] [0.00dB]
    31. Front Right: Playback 255 [100%] [0.00dB]
    32. Simple mixer control 'Front',0
    33. Capabilities: pvolume pswitch
    34. Playback channels: Front Left - Front Right
    35. Limits: Playback 0 - 127
    36. Mono:
    37. Front Left: Playback 127 [100%] [0.00dB] [on]
    38. Front Right: Playback 127 [100%] [0.00dB] [on]
    39. Simple mixer control 'Surround',0
    40. Capabilities: pvolume pswitch
    41. Playback channels: Front Left - Front Right
    42. Limits: Playback 0 - 127
    43. Mono:
    44. Front Left: Playback 0 [0%] [-127.00dB] [off]
    45. Front Right: Playback 0 [0%] [-127.00dB] [off]
    46. Simple mixer control 'Center',0
    47. Capabilities: pvolume pvolume-joined pswitch pswitch-joined
    48. Playback channels: Mono
    49. Limits: Playback 0 - 127
    50. Mono: Playback 0 [0%] [-127.00dB] [off]
    51. Simple mixer control 'LFE',0
    52. Capabilities: pvolume pvolume-joined pswitch pswitch-joined
    53. Playback channels: Mono
    54. Limits: Playback 0 - 127
    55. Mono: Playback 0 [0%] [-127.00dB] [off]
    56. Simple mixer control 'Side',0
    57. Capabilities
    58. : pvolume pswitch
    59. Playback channels: Front Left - Front Right
    60. Limits: Playback 0 - 127
    61. Mono:
    62. Front Left: Playback 0 [0%] [-127.00dB] [off]
    63. Front Right: Playback 0 [0%] [-127.00dB] [off]
    64. Simple mixer control 'Line',0
    65. Capabilities: cswitch cswitch-exclusive
    66. Capture exclusive group: 0
    67. Capture channels: Front Left - Front Right
    68. Front Left: Capture [off]
    69. Front Right: Capture [off]
    70. Simple mixer control 'Mic',0
    71. Capabilities: cvolume cswitch cswitch-exclusive
    72. Capture exclusive group: 0
    73. Capture channels: Front Left - Front Right
    74. Limits: Capture 0 - 46
    75. Front Left: Capture 0 [0%] [-16.00dB] [off]
    76. Front Right: Capture 0 [0%] [-16.00dB] [off]
    77. Simple mixer control 'Mic Boost',0
    78. Capabilities: volume
    79. Playback channels: Front Left - Front Right
    80. Capture channels: Front Left - Front Right
    81. Limits: 0 - 3
    82. Front Left: 0 [0%] [0.00dB]
    83. Front Right: 0 [0%] [0.00dB]
    84. Simple mixer control 'IEC958',0
    85. Capabilities: pswitch pswitch-joined
    86. Playback channels: Mono
    87. Mono: Playback [off]
    88. Simple mixer control 'IEC958 Default PCM',0
    89. Capabilities: pswitch pswitch-joined
    90. Playback channels: Mono
    91. Mono: Playback [on]
    92. Simple mixer control 'Aux',0
    93. Capabilities: cvolume cswitch cswitch-exclusive
    94. Capture exclusive group: 0
    95. Capture channels: Front Left - Front Right
    96. Limits: Capture 0 - 46
    97. Front Left: Capture 0 [0%] [-16.00dB] [off]
    98. Front Right: Capture 0 [0%] [-16.00dB] [off]
    99. Simple mixer control 'Auto-Mute Mode',0
    100. Capabilities: enum
    101. Items: 'Disabled' 'Enabled'
    102. Item0: 'Enabled'
    Alles anzeigen
    Wenn das mit pavucontrol nicht zu lösen ist, versuch es mal mit alsamixer. Als User ausführen. Vor allem der Masterregler.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 106428 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Neu

    Sorry. Da hab ich zu oberflächlich gelesen,
    und mich von deiner nicht sehr klaren Aussage, dass "es mit Umstecken gehe", blenden lassen.
    Das war dumm.

    Und doch: Ich kenne deine Konfiguration.
    Ich habe nämlich die Ausgaben der Befehle sorgfältig gelesen.
    (die sind immer aussagekräftiger, denn das Geschreibsel drumrum)

    Und nein, du hast zwei Soundkarten, NICHT drei.
    Denn werden nur zwei erkannt.

    Du wirst sie auch nicht zum Laufen bringen, da sie schon von ALSA nicht unterstützt wird.
    Das könntest du dir nur komplett händisch selbst schnitzen (und dann der Gemeinde zur Verfügung stellen),
    oder warten bis sie irgendwann doch unterstützt wird.
    Siehe hier.

    Der Chip ist wohl einfach zu neu, oder der Leidensdruck noch nicht hoch genug.
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 106429 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • Neu

    Sauerland schrieb:

    Ist die Karte gemutet:
    Alles auf 0:

    Quellcode

    1. Card hw:1 'CMedia'/'HDA C-Media at 0xefd00000 irq 17'
    2. Mixer name : 'C-Media CMI8888'
    3. Components : 'HDA:13f68888,104384d5,00101500'
    4. Controls : 41
    5. Simple ctrls : 16
    6. Simple mixer control 'Master',0
    7. Capabilities: pvolume pvolume-joined pswitch pswitch-joined
    8. Playback channels: Mono
    9. Limits: Playback 0 - 127
    10. Mono: Playback 127 [100%] [0.00dB] [on]
    11. Simple mixer control 'Headphone',0
    12. Capabilities: pvolume pswitch
    13. Playback channels: Front Left - Front Right
    14. Limits: Playback 0 - 109
    15. Mono:
    16. Front Left: Playback 109 [100%] [0.00dB] [on]
    17. Front Right: Playback 109 [100%] [0.00dB] [on]
    18. Simple mixer control 'Headphone Amp',0
    19. Capabilities: pvolume
    20. Playback channels: Front Left - Front Right
    21. Limits: Playback 0 - 2
    22. Mono:
    23. Front Left: Playback 0 [0%] [0.00dB]
    24. Front Right: Playback 0 [0%] [0.00dB]
    25. Simple mixer control 'PCM',0
    26. Capabilities: pvolume
    27. Playback channels: Front Left - Front Right
    28. Limits: Playback 0 - 255
    29. Mono:
    30. Front Left: Playback 255 [100%] [0.00dB]
    31. Front Right: Playback 255 [100%] [0.00dB]
    32. Simple mixer control 'Front',0
    33. Capabilities: pvolume pswitch
    34. Playback channels: Front Left - Front Right
    35. Limits: Playback 0 - 127
    36. Mono:
    37. Front Left: Playback 127 [100%] [0.00dB] [on]
    38. Front Right: Playback 127 [100%] [0.00dB] [on]
    39. Simple mixer control 'Surround',0
    40. Capabilities: pvolume pswitch
    41. Playback channels: Front Left - Front Right
    42. Limits: Playback 0 - 127
    43. Mono:
    44. Front Left: Playback 0 [0%] [-127.00dB] [off]
    45. Front Right: Playback 0 [0%] [-127.00dB] [off]
    46. Simple mixer control 'Center',0
    47. Capabilities: pvolume pvolume-joined pswitch pswitch-joined
    48. Playback channels: Mono
    49. Limits: Playback 0 - 127
    50. Mono: Playback 0 [0%] [-127.00dB] [off]
    51. Simple mixer control 'LFE',0
    52. Capabilities: pvolume pvolume-joined pswitch pswitch-joined
    53. Playback channels: Mono
    54. Limits: Playback 0 - 127
    55. Mono: Playback 0 [0%] [-127.00dB] [off]
    56. Simple mixer control 'Side',0
    57. Capabilities
    58. : pvolume pswitch
    59. Playback channels: Front Left - Front Right
    60. Limits: Playback 0 - 127
    61. Mono:
    62. Front Left: Playback 0 [0%] [-127.00dB] [off]
    63. Front Right: Playback 0 [0%] [-127.00dB] [off]
    64. Simple mixer control 'Line',0
    65. Capabilities: cswitch cswitch-exclusive
    66. Capture exclusive group: 0
    67. Capture channels: Front Left - Front Right
    68. Front Left: Capture [off]
    69. Front Right: Capture [off]
    70. Simple mixer control 'Mic',0
    71. Capabilities: cvolume cswitch cswitch-exclusive
    72. Capture exclusive group: 0
    73. Capture channels: Front Left - Front Right
    74. Limits: Capture 0 - 46
    75. Front Left: Capture 0 [0%] [-16.00dB] [off]
    76. Front Right: Capture 0 [0%] [-16.00dB] [off]
    77. Simple mixer control 'Mic Boost',0
    78. Capabilities: volume
    79. Playback channels: Front Left - Front Right
    80. Capture channels: Front Left - Front Right
    81. Limits: 0 - 3
    82. Front Left: 0 [0%] [0.00dB]
    83. Front Right: 0 [0%] [0.00dB]
    84. Simple mixer control 'IEC958',0
    85. Capabilities: pswitch pswitch-joined
    86. Playback channels: Mono
    87. Mono: Playback [off]
    88. Simple mixer control 'IEC958 Default PCM',0
    89. Capabilities: pswitch pswitch-joined
    90. Playback channels: Mono
    91. Mono: Playback [on]
    92. Simple mixer control 'Aux',0
    93. Capabilities: cvolume cswitch cswitch-exclusive
    94. Capture exclusive group: 0
    95. Capture channels: Front Left - Front Right
    96. Limits: Capture 0 - 46
    97. Front Left: Capture 0 [0%] [-16.00dB] [off]
    98. Front Right: Capture 0 [0%] [-16.00dB] [off]
    99. Simple mixer control 'Auto-Mute Mode',0
    100. Capabilities: enum
    101. Items: 'Disabled' 'Enabled'
    102. Item0: 'Enabled'
    Alles anzeigen
    Wenn das mit pavucontrol nicht zu lösen ist, versuch es mal mit alsamixer. Als User ausführen. Vor allem der Masterregler.
    ich hab jetzt alle regler mal auf Anschlag gestellt. immernoch ohne effekt. wenn ich z.B. n Video an mache und bei pavu schaue, gibts auch n ausschlag. Aber es kommt nichts raus :/


    Berichtigung schrieb:

    Sorry. Da hab ich zu oberflächlich gelesen,
    und mich von deiner nicht sehr klaren Aussage, dass "es mit Umstecken gehe", blenden lassen.
    Das war dumm.

    Und doch: Ich kenne deine Konfiguration.
    Ich habe nämlich die Ausgaben der Befehle sorgfältig gelesen.
    (die sind immer aussagekräftiger, denn das Geschreibsel drumrum)

    Und nein, du hast zwei Soundkarten, NICHT drei.
    Denn werden nur zwei erkannt.

    Du wirst sie auch nicht zum Laufen bringen, da sie schon von ALSA nicht unterstützt wird.
    Das könntest du dir nur komplett händisch selbst schnitzen (und dann der Gemeinde zur Verfügung stellen),
    oder warten bis sie irgendwann doch unterstützt wird.
    Siehe hier.

    Der Chip ist wohl einfach zu neu, oder der Leidensdruck noch nicht hoch genug.
    ich habe nichts von umstecken geschrieben, aber du darfst mir gerne zeigen, wie du einen Klinkenstecker in eine HDMI-Buchse bekommst.. Viele Monitore haben mittlerweile Soundausgabe...
    und Onboardsound ist bei mir im BIOS deaktiviert, daher werden nur zwei erkannt.

    muss ALSA muss diesen Chipsatz auch unterstützen? es wurde direkt im Kernel implementiert: hier (vendor: 13f6 device:5011)
    wie schon geschrieben, andere haben diese Soundkarte ohne großartige Konfiguration zum laufen bekommen

    Für den Inhalt des Beitrages 106438 haftet ausdrücklich der jeweilige Autor: Fenriswolf

  • Neu

    Fenriswolf schrieb:

    und bei pavu schaue, gibts auch n ausschlag
    Unter welchem Tab?
    Mach mal einen Screenshot.
    Kannst dafür shutter nehmen.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 106440 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Neu

    mal? :D
    ich nutze nichts anderes... die Karte hat einen extra Ausgang für KH. Aber auch die anderen funktionieren nicht. Wenn ich die Kopfhörer in eine andere Buchse als die dafür vorgesehene ("HP" statt "Front") bietet mir pavu nur noch S/PDIF als Ausgang an.

    Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von Fenriswolf ()

    Für den Inhalt des Beitrages 106458 haftet ausdrücklich der jeweilige Autor: Fenriswolf

www.cyberport.de