Bildschirmhelligkeit nicht änderbar

Hinweis: In dem Thema Bildschirmhelligkeit nicht änderbar gibt es 7 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • Bildschirmhelligkeit nicht änderbar

    Hallo zusammen,

    ich habe letzte Woche wegen einer neuen Festplatte mein System auf meinem Laptop neu aufgesetzt (Leap 42.2).
    Seit dem kann ich meine Bildschirmhelligkeit nicht mehr verändern, weder mit den Tasten noch über die Energieverwaltung.
    Ich vermute es hängt mit dem Grafiktreiber zusammen, da das Gerät zusätzlich permanent sehr heiß ist und der Lüfter durchgehend unter Volllast läuft.
    Ich habe schon einiges probiert, mit dem proprietären fglrx-Treiber kommt nach dem Booten nur ein schwarzer Bildschirm, der Radeon-treiber funktioniert ebenfalls nicht, laut dem Xorg.0.log-File kommt die Fehlermeldung No Device Found.
    Hat vielleicht jemand ne Idee wie das in den Griff bekomme? Der Akku ist deshalb nämlich immer super schnell tot und der Rechner stockt gelegentlich, da er scheinbar immer unter hoher Last läuft.
    Vorher hatte ich auch OpenSUSE drauf, glaube Leap 42.1, da lief auch alles ohne Probleme.
    GraKa ist ne Radeon R5 330M.

    Für den Inhalt des Beitrages 109099 haftet ausdrücklich der jeweilige Autor: tobsen44

  • fglrx ist tot!

    Ältere Karten laufen nur mit dem freien Radeon Treiber, neuere mit amd-gpu.

    Poste:

    Quellcode

    1. /sbin/lspci -nnk | grep -EiA3 'vga|3d|display'

    Quellcode

    1. uname -a

    Quellcode

    1. cat /proc/cmdline
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 109101 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Danke für die schnelle Antwort!

    Quellcode

    1. tobias@linux-bw4j:~> /sbin/lspci -nnk | grep -EiA3 'vga|3d|display'
    2. 00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:5916] (rev 02)
    3. Subsystem: Hewlett-Packard Company Device [103c:81ee]
    4. Kernel modules: i915
    5. 00:04.0 Signal processing controller [1180]: Intel Corporation Skylake Processor Thermal Subsystem [8086:1903] (rev 02)
    6. --
    7. 01:00.0 Display controller [0380]: Advanced Micro Devices, Inc. [AMD/ATI] Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330] [1002:6660] (rev 83)
    8. Subsystem: Hewlett-Packard Company Device [103c:81ee]
    9. Kernel modules: radeon, amdgpu
    10. 02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller [10ec:8136] (rev 07)




    Quellcode

    1. tobias@linux-bw4j:~> uname -r
    2. 4.11.3-2.g596757c-default

    Quellcode

    1. tobias@linux-bw4j:~> cat /proc/cmdline
    2. BOOT_IMAGE=/boot/vmlinuz-4.11.3-2.g596757c-default root=UUID=d57e0ebc-25f1-42a3-976a-899e2b43c02d ro resume=/dev/sdb3 splash=silent quiet showopts nomodeset

    Für den Inhalt des Beitrages 109105 haftet ausdrücklich der jeweilige Autor: tobsen44

  • nomodeset ist bei Intel und dem freien Radeon Treiber nicht gut, es hält die Treiber vom laden ab und damit wird nur ein rudimentärer Treiber (vesa,fbdev) geladen.

    Das log lese ich heute nachmittag.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 109113 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Ich habe noch mal Leap neu aufgesetzt, das hat leider keine Veränderung gebracht.
    Jetzt habe ich aus Spaß mal Tumbleweed installiert, siehe da, läuft alles ohne Probleme.
    Ich habe leider keine Ahnung, wo da jetzt der Fehler war, da ich ja zuvor mit Leap auch keine Probleme hatte.
    Trotzdem danke an alle für die Hilfe.

    Für den Inhalt des Beitrages 110105 haftet ausdrücklich der jeweilige Autor: tobsen44

www.cyberport.de