Eintrag einer statischen Netzwerk-Route "beschädigt" dhcp-Konfiguration des Netzwerkdevices

Hinweis: In dem Thema Eintrag einer statischen Netzwerk-Route "beschädigt" dhcp-Konfiguration des Netzwerkdevices gibt es 11 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Eintrag einer statischen Netzwerk-Route "beschädigt" dhcp-Konfiguration des Netzwerkdevices

    Hallo!
    Ich scheitere momentan daran, eine Netzwerk-Route permanent zu machen (so dass sie über einen Reboot hinaus erhalten bleibt).

    Was funktioniert:
    Ich habe (noch) ein OpenSuse 13.2 - System mit einer Ethernet-Karte "enp2s0" und "default"-Konfiguration über DHCP.
    Über diese kann ich alle Hosts im lokalen Netz erreichen. Einen Default-Gateway oder so habe ich nicht eingestellt:

    Quellcode

    1. wau:/home/douglas/Dokumente # route
    2. Kernel IP Routentabelle
    3. Ziel Router Genmask Flags Metric Ref Use Iface
    4. 133.98.0.0 * 255.255.0.0 U 0 0 0 enp2s0


    Jetzt möchte ich über das selbe Device einen Router eintragen, der es mir erlaubt ein anderes Netz zu erreichen, was auch klappt:

    Quellcode

    1. wau:/home/douglas/Dokumente # ip route add 192.168.129.0/24 via 133.98.2.220 dev enp2s0
    2. wau:/home/douglas/Dokumente # route
    3. Kernel IP Routentabelle
    4. Ziel Router Genmask Flags Metric Ref Use Iface
    5. 133.98.0.0 * 255.255.0.0 U 0 0 0 enp2s0
    6. 192.168.129.0 133.98.2.220 255.255.255.0 UG 0 0 0 enp2s0
    Jetzt kann ich Hosts aus beiden Netzen erreichen - alles schön.


    Jetzt versuchte ich das permanent zu machen. Zunächst über Yast:
    Netzwerkgeräte -> Netzwerkeinstellungen -> Routing -> Hinzufügen: Ziel:192.168.129.0 Genmask: 255.255.255.0 Gateway: 133.98.2.220 Gerät: enp2s0
    Nach dem Reboot ging gar nicht mehr: enp2s0 hatte laut ifconfig keine IP4-Addresse mehr, und die Routing-Tabelle war auch leer. Also rückgängig gemacht, das Ganze.


    Dann habe ich versucht die Route selbst in /etc/sysconfig/network/routes einzutragen:
    192.168.129.0/24 133.98.2.220 - enp2s0 # route zu przyby

    Neu gestartet - gleiches Ergebnis.


    Fragen:
    Wie macht man es, ohne sich seine dhcp device-Konfiguration kaputt zu machen?
    Ich kann natürlich den ip route Befehl nach dem Hochfahren ausführen lassen - aber wie macht man es richtig?

    Für den Inhalt des Beitrages 109792 haftet ausdrücklich der jeweilige Autor: angu

  • Mit meinem spärlichen Netzwerkwissen gebe ich folgenden Rat:
    Die Route gehört nicht auf Dein System, sondern auf den Gateway.
    Dort bekommen die Pakete dann die Umleitung mitgeteilt oder je nach DHCP Integration wird das vom DHCP an die Clients weitergereicht.
    Im einfachen Fall steht da also irgendwo Dein Router/Modem mit Web Konfigurationsoberfläche und dort trägst Du die Routen ein.
    Gibt es keine bunte GUI auf dem Gateway, dann (erst) landest Du wieder bei der Frage, die Du gestellt hast. Allerdings bezogen auf das Gateway, nicht auf das Opensuse System.

    Für den Inhalt des Beitrages 109958 haftet ausdrücklich der jeweilige Autor: Tar Zahn

  • Hi,

    wenn du statische IP-Adressen vergeben willst...musst du im Router die DHCP-Funktion abschalten und dann dort die entsprechenden Adressen festlegen.

    Diese müssen dann im YAST auch eingerichtet werden... für jede Schnittstelle => eine für LAN und eine für WLAN

    Viel Glück !

    LG SUSEDJAlex
    Uhrzeit richtig einstellen

    openSUSE Leap sowie Arch LInux in Nutzung

    Für den Inhalt des Beitrages 110003 haftet ausdrücklich der jeweilige Autor: SUSEDJAlex

  • Man kann sehr wohl statische IP- Konfigurationen mit DHCP mischen.
    Man sollte dabei aber dem DHCP- Server einen klar definierten Bereich für die DHCP-Konfigs zuweisen
    und halt genügend Platz im Segment für die Kisten mit statischer Konfig.
    Da kann dann auch nix passieren.
    Sollte auch bei billigen Homeroutern einstellbar sein.
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 110005 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • Natürlich muss es möglich sein dhcp mit statischen Routen zu mischen. Ist ja auch schon bewiesen - denn das Routing funktioniert ja wenn ich die Route per Hand setze.Die Frage lautet also wie bringe ich suse in der Konfiguration dazu, dhcp normal zu benutzen, und trotzdem die statische Route zu akzeptieren.

    Da es sich um unterschiedliche Router für unterschiedliche Zwecke handelt macht das auch Sinn:
    Die meisten Hosts benötigen nur dhcp, nur ein einziger muss das andere Netz kennen. Die Route nur auf dem Gateway einzutragen reicht alleine natürlich nicht aus,
    denn woher soll mein System wissen, dass das Netz hinter dem Router überhaupt existiert - genau dazu dient ja ein Routingeintrag.

    Ich kann natürlich die Route einfach als cronjob eintragen, oder als skript nach dem hochfahren "irgendwo" ausführen.
    Aber ich hätte halt gern gewusst wie man es richtig macht.

    Für den Inhalt des Beitrages 110171 haftet ausdrücklich der jeweilige Autor: angu

  • Poste:

    Quellcode

    1. ls -al /etc/sysconfig/network
    Ich habe alles statisch mit wicked und es sind die Dateien
    ifcfg-eth0
    ifroute-eth0
    ifcfg-lo
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 110177 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Quellcode

    1. wau:/home/douglas/Dokumente # ls -al /etc/sysconfig/network/
    2. insgesamt 60
    3. drwxr-xr-x 1 root root 164 14. Jun 15:38 .
    4. drwxr-xr-x 1 root root 762 10. Jan 09:50 ..
    5. -rw-r--r-- 1 root root 8693 12. Jun 15:02 config
    6. -rw-r--r-- 1 root root 8212 12. Jun 15:02 dhcp
    7. -rw-r--r-- 1 root root 163 14. Sep 2015 ifcfg-enp2s0
    8. -rw------- 1 root root 173 14. Sep 2015 ifcfg-lo
    9. -rw-r--r-- 1 root root 21738 6. Okt 2014 ifcfg.template
    10. drwxr-xr-x 1 root root 100 14. Sep 2015 if-down.d
    11. drwxr-xr-x 1 root root 150 14. Sep 2015 if-up.d
    12. drwx------ 1 root root 0 25. Sep 2014 providers
    13. -rw-r--r-- 1 root root 113 14. Jun 10:28 routes
    14. drwxr-xr-x 1 root root 234 14. Sep 2015 scripts
    Alles anzeigen
    In der Zwischenzeit habe ich folgendes herausbekommen:
    - Bei Suse gibts NetworkManager und Wickedd :-), ersteres für grafische Benutzeroberflächen/Laptops - ich benutze also wicked.
    - Wicked wird benutzt seit 13.2 und konnte das (statische Route bei dhcp ohne defaultroute) laut Bug 907495 noch nie. (Obwohl es vorher Jahrelang funktionierte wurde der Bug nicht als solcher anerkannt :-[)
    - Mit NetworkManager geht es einwandfrei (Es gibt sogar eine Option zum Ignorieren der Defaultroute über DHCP)

    Jetzt habe ich es mal auf einem 42.2-System probiert:
    - da ist die Lage schon besser - DHCP funktioniert trotz eingetragener statischer Route (diesmal in ifroute-eth0 - eingetragen durch yast),
    aber leider ist die route trotzdem nicht gesetzt, denn wickedd schmeißt folgende Fehlermeldung:

    Quellcode

    1. Jun 19 17:06:19 linux-1io5 wickedd[993]: __ni_rtnl_send_newroute(ipv4 192.168.129.0/24 via 133.98.2.220 dev eth0 type unicast table main scope universe protocol boot): ni_nl_talk failed [Unspecific failure]

    Da ich sowieso updaten muss, würde es völlig reichen, wenn es unter 42.x funktioniert.

    Für den Inhalt des Beitrages 110179 haftet ausdrücklich der jeweilige Autor: angu

  • Also es scheint wohl im Moment noch ein Fehler in Wicked zu sein, der zu o.g. Fehlermeldung und damit zum nicht funktionieren des
    Routungeintrags führt.

    Der beste "Workaround" scheint mir darim zu bestehen, das route-Kommando in /etc/init.d/after.local einzutragen.
    Die Datei ist zwar nicht explizit für Netzwerkrouten vorgesehen, funktioniert aber.

    Für den Inhalt des Beitrages 110244 haftet ausdrücklich der jeweilige Autor: angu

  • Ich würde es erst einmal mit einer unterstützten openSUSE Version versuchen.......

    Es könnte ja sein, das es dort klappt.....
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 110247 haftet ausdrücklich der jeweilige Autor: Sauerland

www.cyberport.de