Https mit Apache2 und Letsencrypt konfigurieren

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Https mit Apache2 und Letsencrypt konfigurieren gibt es 16 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Https mit Apache2 und Letsencrypt konfigurieren

    Hallo zusammen!

    Man hat ja oft so viele Talente, aber meins endet bei dem Versuch einen Webserver mittels certbot mit der Fähigkeit von https zu versehen.

    Gegeben ist ein Server mit openSuse Leap 42.2 und einem apache2 Webserver.

    Der Webserver wurde, da ich schon einige Zeit da herumprobiere, komplett neu und lupenrein leer neu aufgesetzt.
    Alle Konfigurationsdateien sind also im Ur-Zustand nach der Installation.

    Die Firewall lässt Verbindungen mit HTTPS zu.

    Die mit certbot erstellten Zertifikate liegen auch vor.

    Shell-Script

    1. - Congratulations! Your certificate and chain have been saved at
    2. /etc/certbot/live/meineDomain.de/fullchain.pem. Your cert will
    3. expire on 2017-09-13. To obtain a new or tweaked version of this
    4. certificate in the future, simply run certbot again. To
    5. non-interactively renew *all* of your certificates, run "certbot
    6. renew"
    Was ist jetzt noch zu tun?

    Ich bin ehrlich gesagt, je länger ich suche, immer ratloser, zumal sich die apache2-Konfiguration ja bei openSuse auch über eine gefühlte Million Dateien erstreckt.
    Wer kann mich auf den richtigen Weg schubsen?

    Gruß, Pete
    __________________________
    Normale Menschen sind die schlimmsten Terroristen.

    Für den Inhalt des Beitrages 109844 haftet ausdrücklich der jeweilige Autor: TheFan1968

  • Nun. Es wäre schön, wenn es so einfach funktionieren würde..
    Ich habe die Konfiguration so auch angelegt, aber der Server verweigert die Verbindung

    Der Port 443 ist closed, sagt nmap

    Quellcode

    1. Starting Nmap 6.47 ( http://nmap.org ) at 2017-06-16 09:07 CEST
    2. Nmap scan report for - (91.205.173.87)
    3. Host is up (0.032s latency).
    4. Not shown: 992 filtered ports
    5. PORT STATE SERVICE
    6. 22/tcp open ssh
    7. 80/tcp open http
    8. 110/tcp open pop3
    9. 143/tcp open imap
    10. 443/tcp closed https
    11. 993/tcp open imaps
    12. 995/tcp open pop3s
    13. 3306/tcp open mysql
    Alles anzeigen


    Und ja, in der Firewall, die auch aktiv ist, ist HTTPS als erlaubter Service eingetragen.

    Der Server ist erreichbar, aber eben nicht über https.

    Was können, außer der Firewall, Ursachen dafür sein?


    Quellcode

    1. authz_host actions alias authn_file authz_groupfile auth_basic
    2. authz_user autoindex cgi dir include log_config mime negotiation
    3. setenvif status asis headers imagemap info rewrite vhost_alias
    4. reqtimeout authn_core socache_shmcb socache authz_core nss php
    5. version tidy ssl
    __________________________
    Normale Menschen sind die schlimmsten Terroristen.

    Für den Inhalt des Beitrages 109889 haftet ausdrücklich der jeweilige Autor: TheFan1968

  • Und ich welcher Zone hast du den SSL- Port freigeschaltet?
    Und in welcher Zone sitzt der Webserver?
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 109895 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • Der SSL-Port 443 ist in der internen und natürlich der externen Zone freigegeben und über Port 80 ist der Server auch erreichbar, also sitzt der auch wo er hingehört. ;)
    __________________________
    Normale Menschen sind die schlimmsten Terroristen.

    Für den Inhalt des Beitrages 109897 haftet ausdrücklich der jeweilige Autor: TheFan1968

  • Sauerland schrieb:

    Firewall mal deaktivieren, gehts dann?

    Wenn du an der config vom Indianer rumgefummelt hast, Indianer neu gestartet?
    Ohne Firewall zeigt nmap folgendes Ergebnis:

    Quellcode

    1. Host is up (0.030s latency).
    2. Not shown: 990 closed ports
    3. PORT STATE SERVICE
    4. 22/tcp open ssh
    5. 25/tcp filtered smtp
    6. 80/tcp open http
    7. 110/tcp open pop3
    8. 143/tcp open imap
    9. 465/tcp filtered smtps
    10. 587/tcp filtered submission
    11. 993/tcp open imaps
    12. 995/tcp open pop3s
    13. 3306/tcp open mysql
    Alles anzeigen
    Port 80 nach wie vor erreichbar.

    Ja, der Indianer wird nach jeder Bearbeitung neu gestartet.

    Inzwischen habe ich auch mal die beiden vordefiniierten Regeln für http und https aus der Firewall gelöscht und explizit die Ports 443 und 80 als offen definiert.
    Das Ergebnis war dann wieder ein offener Port 80 und ein closed 443.

    Da bin ich nun echt ratlos.
    __________________________
    Normale Menschen sind die schlimmsten Terroristen.

    Für den Inhalt des Beitrages 109981 haftet ausdrücklich der jeweilige Autor: TheFan1968

  • Bitteschön:

    Quellcode: www.eishockeytabelle.de.conf

    1. # Template for a VirtualHost with SSL
    2. # Note: to use the template, rename it to /etc/apache2/vhost.d/yourvhost.conf.
    3. # Files must have the .conf suffix to be loaded.
    4. #
    5. # See /usr/share/doc/packages/apache2/README.QUICKSTART for further hints
    6. # about virtual hosts.
    7. # NameVirtualHost statements should be added to /etc/apache2/listen.conf.
    8. #
    9. # This is the Apache server configuration file providing SSL support.
    10. # It contains the configuration directives to instruct the server how to
    11. # serve pages over an https connection. For detailing information about these
    12. # directives see http://httpd.apache.org/docs/2.4/mod/mod_ssl.html
    13. #
    14. # Do NOT simply read the instructions in here without understanding
    15. # what they do. They're here only as hints or reminders. If you are unsure
    16. # consult the online docs. You have been warned.
    17. #
    18. <IfDefine SSL>
    19. <IfDefine !NOSSL>
    20. ##
    21. ## SSL Virtual Host Context
    22. ##
    23. ##
    24. ## SSL Virtual Host Context
    25. ##
    26. <VirtualHost _default_:443>
    27. # General setup for the virtual host
    28. DocumentRoot "/srv/www/vhosts/ehtab"
    29. ServerName www.eishockeytabelle.de:443
    30. ServerAdmin eishockeytabelle@skritptbu.de
    31. ErrorLog /var/log/apache2/ehtab_error_log
    32. TransferLog /var/log/apache2/ehtab_access_log
    33. # SSL Engine Switch:
    34. # Enable/Disable SSL for this virtual host.
    35. SSLEngine on
    36. # You can use per vhost certificates if SNI is supported.
    37. SSLCertificateFile /etc/certbot/live/eishockeytabelle.de/cert.pem
    38. SSLCertificateKeyFile /etc/certbot/live/eishockeytabelle.de/privkey.pem
    39. #SSLCertificateChainFile /etc/apache2/ssl.crt/vhost-example-chain.crt
    40. # Per-Server Logging:
    41. # The home of a custom SSL log file. Use this when you want a
    42. # compact non-error SSL logfile on a virtual host basis.
    43. CustomLog /var/log/apache2/ssl_request_log ssl_combined
    44. </VirtualHost>
    45. </IfDefine>
    46. </IfDefine>
    Alles anzeigen
    __________________________
    Normale Menschen sind die schlimmsten Terroristen.

    Für den Inhalt des Beitrages 109989 haftet ausdrücklich der jeweilige Autor: TheFan1968

  • Du willst als CertFile fullchain.pem
    und du willst wahrscheinlich nicht __default__:443
    (Die Certs sind per definitionem an die Domain gebunden. default macht einfach keinen Sinn)

    Ist SSL definiert?
    (Kannst ja mal schlampig die IFDEFs auskommentieren.)
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 109990 haftet ausdrücklich der jeweilige Autor: Berichtigung