Wie zweite Partition dauerhaft ins System einbinden?

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Wie zweite Partition dauerhaft ins System einbinden? gibt es 45 Antworten auf 5 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Wie zweite Partition dauerhaft ins System einbinden?

    Hallo,
    habe erst Leap 42.3 aufgespielt. Habe dabei meine Festplatte in zwei Partitionen aufgeteilt. Die zweite Partition wurde nicht dauerhaft eingehängt. Mache das nun immer manuell.
    Meine Frage: Wie hänge ich nun auch die zweite Partition dauerhaft in mein System ein? Wie war das nochmals?
    Bzw. wichtig ist mir auch noch, wo hänge ich die im Wurzelverzeichnis am besten ein z.B. unter /mnt oder /media oder ist das gar völlig egal?
    Grüße, Micky

    Für den Inhalt des Beitrages 111291 haftet ausdrücklich der jeweilige Autor: Micky

  • Benutze Yast---System----Partitionierer, erstelle aber vorher ein Verzeichnis, in das du die Platte einhängst. Ebenso darauf achten, das du die Platte nicht formatierst.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 111292 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Dem mount Befehl ist es völlig egal, wo du das einhängst.
    Ein Mountpoint ist ein beliebiges Verzeichnis.
    Es muss lediglich existieren.

    Dort dürfen sogar irgendwelche Unterverzeichnisse oder Dateien liegen.
    Die sind halt -solange der Mount aktiv ist- schlicht unerreichbar und nicht sichtbar.

    (Allerdings verweigern manche "FuserMountDateisysteme" dann das Mounten oder spucken eine Warnung aus.
    Meist kann man die dann mit irgendeinem "--mir-egal-mach-es-trotzdem" Switch dennoch "übermounten")
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 111293 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • Hallo, vielen Dank schon mal für die Antworten. War mir gar nicht bewusst, dass ich das Verzeichnis selber erstellen kann. Dachte immer ich muss auf bereits bestehende zurückgreifen.
    Habe nun das neue Verzeichnis in /home/neuesVerzeichnis angelegt.
    In dem neuen Verzeichnis kann ich aber nur als "root" Unterverzeichnisse etc. erstellen.
    Wie ändere ich das? So dass ich nicht immer das Rootpasswort eingeben muss?

    Für den Inhalt des Beitrages 111294 haftet ausdrücklich der jeweilige Autor: Micky

  • indem du beim Mountbefehl die entsprechenden Optionen angibst.
    Du willst irgend sowas, wie (noauto,user) oder einfach nur (user), oder, oder, oder....

    Sage, was du __genau___ willst. Wer soll, wann, wo was mounten dürfen.
    Wer darf unmounten, wer darf da reinkritzeln?

    Und poste die entsprechende Zeile deiner /etc/fstab
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 111295 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • Hallo,
    da ich als einziger das Notebook benutze, sollte jeder user alles dürfen.
    Ich habe die Partition über den Yast-Partitionierer gemountet.
    OK, habe nun gesehen, dass es dort in den Fstab-Optionen gewisse Wahlmöglichkeiten gibt, von denen ich keine angewählt habe, also auch nicht die "schreibgeschützte Option", obwohl dies nun der Fall ist.
    Wenn ich in der Konsole als superuser (su) bzw. root /etc/fstab abfragen möchte, kommt komischerweise "keine Berechtigung"?

    Für den Inhalt des Beitrages 111296 haftet ausdrücklich der jeweilige Autor: Micky

  • Micky schrieb:

    OK, habe nun gesehen, dass es dort in den Fstab-Optionen gewisse Wahlmöglichkeiten gibt, von denen ich keine angewählt habe, also auch nicht die "schreibgeschützte Option", obwohl dies nun der Fall ist.
    Wenn ich in der Konsole als superuser (su) bzw. root /etc/fstab abfragen möchte, kommt komischerweise "keine Berechtigung"?
    Komplette Ausgabe incl. der kompletten!!!! Eingabezeile in Code-Tags!!!! posten.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 111297 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Du musst nichts abfragen.
    Die /etc/fstab ist eine schlichte Textdatei, wie so ziemlich jede Konfigurationsdatei aller *nices.
    Man kann die ganz einfach lesen.

    Shell-Script

    1. # anzeigen mit dem Pager "less"
    2. less /etc/fstag
    3. # "q" beendet die Anzeige
    4. # mit dem GlobalRegularExpressionPrinter grep
    5. # einfach die Zeile rausfischen, die den String "sda3" enthält
    6. grep sda3 /etc/fstab
    7. # für Windowslooser
    8. write /etc/fstab
    9. # drölfundneunzig Milliarden andere Möglichkeiten ab hier nicht erwänht.
    Alles anzeigen
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 111298 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • Hallo, anbei die Ausgabe:

    Quellcode

    1. Passwort:
    2. linux-qf:~ # /etc/fstab
    3. -bash: /etc/fstab: Permission denied
    4. linux-qf:~ # ^C
    5. linux-qf:~ #

    Für den Inhalt des Beitrages 111299 haftet ausdrücklich der jeweilige Autor: Micky

  • Die /etc/fstab ist nun mal kein Programm, sondern eine Textdatei.
    Du rufst aber ein Programm namens /etc/fstab auf. (Also im Verzeichnis /etc/ ein Programm names fstab, um genau zu sein.)

    In allen *nices muss eine Datei, die ausführbar ist, das executable Flag in den Rechten haben.

    Shell-Script

    1. looser@computer:~> ls -l /etc/fstab
    2. -rw-r--r-- 1 root root 218 28. Jul 15:02 /etc/fstab
    Und hier sehen wir, dass diese Datei in ihren Rechten keinerlei x hat.
    Der erste - Bindestrich sagt, dass es sich um eine normale Datei handelt. Danach kommen je drei Zeichen für die Rechte vom Besitzer, der Gruppe, und die Anderen (also alle anderen). Diese drei Rechte sind rwx read, write, execute.
    Die dürfen alle "readen" also lesen, aber nur der Besitzer, nämlich root, darf darin auch rumkratzen. Ausführen kann das nicht einmal root. Nix execute. Fehlende Rechte werden mit - dargestellt. Und das erste Zeichen gibt den Typ an. - == normale Datei, l == ein Link, d == Directory. (Es gibt noch mehr, (bcp....)

    Folgerichtig antwortet dir das System also, dass die Rechte fehlen, nämlich das executable "Recht".
    Ist doch logisch, oder? 8)

    Ich hatte, dir aber schon gepostet, wie du dir das anzeigen lassen kannst.
    Probiere es mal damit.

    Und man kann einfach aus der Konsole kopieren mit der Maus.
    (<strg><umschalt><c> == Kopieren, <strg><umschalt><v> == Einfügen mit der Tastatur. (Markieren kann man mit der Tastatur auch; aber das lernen wir erst in der Oberstufe)

    Nochmal langsam meinen vorherigen Post lesen,
    dann entsprechend handeln.
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 111300 haftet ausdrücklich der jeweilige Autor: Berichtigung

www.cyberport.de