WLAN verbindet nicht WPA2 PSk

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema WLAN verbindet nicht WPA2 PSk gibt es 11 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • WLAN verbindet nicht WPA2 PSk

    Hallo,

    ich habe ein Upgrade von opensuse 13.2 auf opensuse tumbleweed gemacht.

    Mit 13.2 hat WLAN einwandfrei funktioniert, jetzt kann ich mich nicht mehr verbinden. Wenn ich im Network Manager mit meinem Netzwerk (WPA2 Personal Verschlüsselung) verbinde, wird immer wieder das Password verlangt, obwohl ich sicher das richtige eingegeben habe.

    Im wpa_supplicant.log erscheint folgende Fehlermeldung:
    wlan0: SME: Trying to authenticate with 90:f6:52:ff:ba:87 (SSID=xxxxx' freq=2437 MHz)
    wlan0: Trying to associate with 90:f6:52:ff:ba:87 (SSID=xxxxx' freq=2437 MHz)
    wlan0: Associated with 90:f6:52:ff:ba:87
    wlan0: CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
    wlan0: WPA: Failed to get random data for SNonce
    wlan0: CTRL-EVENT-DISCONNECTED bssid=90:f6:52:ff:ba:87 reason=1 locally_generated=1
    wlan0: WPA: 4-Way Handshake failed - pre-shared key may be incorrect
    wlan0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="xxxxx"" auth_failures=1 duration=10 reason=WRONG_KEY
    wlan0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="xxxxx" auth_failures=2 duration=20 reason=CONN_FAILED

    Die wirkliche SSID enthält ein Sonderzeichen (-), was aber nicht das Problem sein dürfte, da es mit 13.2 funktioniert hat.

    Wenn ich am Router die Verschlüsselung ausschalte, kann ich mich ohne Probleme verbinden.

    Ich habe einen Intel Wifi Link 5100 in meinen Laptop verbaut.

    Mit iwlist wlan0 scan kann ich auch alle in der Umgebung befindlichen Netzwerke sehen.

    Ich habe auch schon folgende Optionen versucht.
    /etc/modprobe.d/50-iwlwifi.conf
    options iwlwifi 11n_disable=1
    options iwlwifi bt_coex_active=0

    Danke schon mal für Eure Tips,
    bernie70

    Für den Inhalt des Beitrages 113145 haftet ausdrücklich der jeweilige Autor: bernie70

  • bernie70 schrieb:

    ich habe ein Upgrade von opensuse 13.2 auf opensuse tumbleweed gemacht.
    Ist aber nicht so vorgesehen.

    Und benutze bitte für Konsolenausgaben Code-Tags.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 113146 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Hallo Sauerland,

    vielen Dank für die Antwort. Hier der Output des Scripts:

    Quellcode

    1. bernie@Sonne:/tmp> ./raspiNetInfo.sh -s NW-Home
    2. This program comes with ABSOLUTELY NO WARRANTY; This is free software, and you are welcome to redistribute it under certain conditions
    3. raspiNetInfo.sh V0.2.10, 2016-04-09/15:05:21 - 0438a0328a2212a997c37915bb97d67120e7fd02
    4. --- RNI010I: Starte Datensammlung und Netzwerkuntersuchung. Das kann u.U. ein paar Minuten dauern ...
    5. connect: Das Netzwerk ist nicht erreichbar
    6. jna RNI013E: Ping von 8.8.8.8 nicht erfolgreich
    7. jna RNI013E: Ping von www.google.com nicht erfolgreich
    8. !!! RNI023W: Keine IP bei eth0: gefunden
    9. !!! RNI023W: Keine IP bei wlan0: gefunden
    10. jna RNI008E: Kein DNS Nameserver definiert
    11. jna RNI011E: Es ist kein Standardgateway definiert
    12. --- uname -a
    13. Linux Sonne 3.16.7-53-default #1 SMP Fri Dec 2 13:19:28 UTC 2016 (7b4a1f9) i686 i686 i386 GNU/Linux
    14. --- [ -d /home/pi/.xbmc ]
    15. no
    16. --- ip a s | egrep "(eth|wlan)
    17. 2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    18. link/ether @@:@@:@@:@@:@@ brd @@:@@:@@:@@:@@
    19. 3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
    20. link/ether @@:@@:@@:@@:@@ brd @@:@@:@@:@@:@@
    21. --- cat /etc/resolv | grep -i "nameserver"
    22. --- cat /etc/network/interfaces
    23. cat: /etc/network/interfaces: Datei oder Verzeichnis nicht gefunden
    24. --- cat /etc/hosts
    25. 127.0.0.1 localhost
    26. 127.0.0.1 localhost
    27. --- ip r s | egrep "(eth|wlan)"
    28. --- ip n s
    29. --- lsusb | grep -v "root hub" | grep -i "wire"
    30. --- iwconfig (eth und wlan)
    31. wlan0 IEEE 802.11abg ESSID:off/any
    32. --- /etc/wpa_supplicant/wpa_supplicant.conf
    33. [sudo] Passwort für root:
    34. ctrl_interface=/var/run/wpa_supplicant
    35. ctrl_interface_group=wheel
    36. network={
    37. ssid="@@@@@@@@"
    38. psk=60bab73ad29d6a87b57a711b70e51c54c6a898b5616e381e18219f36efb5f806
    39. }
    40. --- grep wpa_action /var/log/messages | tail -n 15
    41. 2015-01-25T23:15:36.094203+01:00 Sonne dbus[589]: [system] Activating via systemd: service name='fi.w1.wpa_supplicant1' unit='wpa_supplicant.service'
    42. 2015-01-25T23:15:37.063252+01:00 Sonne dbus-daemon[589]: dbus[589]: [system] Successfully activated service 'fi.w1.wpa_supplicant1'
    43. 2015-01-25T23:15:37.063278+01:00 Sonne dbus[589]: [system] Successfully activated service 'fi.w1.wpa_supplicant1'
    44. 2015-01-25T23:18:11.647687+01:00 Sonne dbus[606]: [system] Activating via systemd: service name='fi.w1.wpa_supplicant1' unit='wpa_supplicant.service'
    45. 2015-01-25T23:18:11.658517+01:00 Sonne dbus-daemon[606]: dbus[606]: [system] Activating via systemd: service name='fi.w1.wpa_supplicant1' unit='wpa_supplicant.service'
    46. 2015-01-25T23:18:12.642551+01:00 Sonne dbus-daemon[606]: dbus[606]: [system] Successfully activated service 'fi.w1.wpa_supplicant1'
    47. 2015-01-25T23:18:12.643322+01:00 Sonne dbus[606]: [system] Successfully activated service 'fi.w1.wpa_supplicant1'
    48. 2015-01-26T17:27:53.932147+01:00 Sonne dbus-daemon[587]: dbus[587]: [system] Activating via systemd: service name='fi.w1.wpa_supplicant1' unit='wpa_supplicant.service'
    49. 2015-01-26T17:27:53.942729+01:00 Sonne dbus[587]: [system] Activating via systemd: service name='fi.w1.wpa_supplicant1' unit='wpa_supplicant.service'
    50. 2015-01-26T17:27:53.951077+01:00 Sonne dbus[587]: [system] Successfully activated service 'fi.w1.wpa_supplicant1'
    51. 2015-01-26T17:27:53.952854+01:00 Sonne dbus-daemon[587]: dbus[587]: [system] Successfully activated service 'fi.w1.wpa_supplicant1'
    52. 2015-01-26T17:30:55.383877+01:00 Sonne dbus-daemon[596]: dbus[596]: [system] Activating via systemd: service name='fi.w1.wpa_supplicant1' unit='wpa_supplicant.service'
    53. 2015-01-26T17:30:55.383908+01:00 Sonne dbus[596]: [system] Activating via systemd: service name='fi.w1.wpa_supplicant1' unit='wpa_supplicant.service'
    54. 2015-01-26T17:30:55.387615+01:00 Sonne dbus-daemon[596]: dbus[596]: [system] Successfully activated service 'fi.w1.wpa_supplicant1'
    55. 2015-01-26T17:30:55.388175+01:00 Sonne dbus[596]: [system] Successfully activated service 'fi.w1.wpa_supplicant1'
    56. --- RNI016I: Vor dem Publizieren von der Logdatei raspiNetInfo.log immer kontrollieren, dass keine sensitiven Daten enthalten sind
    57. bernie@Sonne:/tmp>
    Alles anzeigen

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von bernie70 ()

    Für den Inhalt des Beitrages 113148 haftet ausdrücklich der jeweilige Autor: bernie70

  • Ihr lernt es nie, oder? Was meinst du wohl, was Sauerland mit seiner Bemerkung ausdrücken wollte? Von 13.2 auf Tumbleweed ... :pinch:
    Da kommt dann so etwas bei heraus ...

    1. connect: Das Netzwerk ist nicht erreichbar
    2. jna RNI013E: Ping von 8.8.8.8 nicht erfolgreich
    3. jna RNI013E: Ping von google.com nicht erfolgreich
    4. !!! RNI023W: Keine IP bei eth0: gefunden
    5. !!! RNI023W: Keine IP bei wlan0: gefunden
    6. jna RNI008E: Kein DNS Nameserver definiert
    7. jna RNI011E: Es ist kein Standardgateway definiert

    Und ...
    Kernel 3.16.7-53
    gehört zu openSUSE 13.2. Und du hast nach eigenen Aussagen auf Tunbleweed gewechselt. Mit anderen Worten, du hast hier gewaltigen Bockmist verzapft. Setz das System neu auf. Das will sich keiner antun, dir da rauszuhelfen. Zumindest ich nicht.

    Für den Inhalt des Beitrages 113150 haftet ausdrücklich der jeweilige Autor: Alero

  • Hallo alero, hallo sauerland,

    ich bin nach den Anweisungen auf dieser Seite (Online Upgrade) vorgegangen:
    openSUSE:Tumbleweed upgrade

    Wenn die Seite nicht von Euch wäre, hätte ich es auch nicht gemacht.

    Das Upgrade lief auch ohne Probleme und Fehlermeldungen durch, das System startet auch (inkl. Datenbanken, etc.). Lediglich die WPA2-Verschlüsselung macht Probleme, WLAN ohne Verschlüsselung funktioniert ja.

    LG,
    bernie70

    P.S.: Ich hätte mir auch einen etwas höflicheren Umgangston erwartet

    Für den Inhalt des Beitrages 113176 haftet ausdrücklich der jeweilige Autor: bernie70

  • bernie70 schrieb:

    Wenn die Seite nicht von Euch wäre, hätte ich es auch nicht gemacht.
    Nö, sry, die Seite ist nicht von uns. Muss ich dich enttäuschen. Die ist von Suse. Und das ist wieder ein ganz anderes paar Schuhe.

    Für den Inhalt des Beitrages 113179 haftet ausdrücklich der jeweilige Autor: Alero

  • Hallo alero,

    wusste nicht, das Ihr "nichts" miteinander zu tun habt.

    Nichts desto trotz hat mir Dein Hinweis "3.16.7-53 gehört zu opensuse 13.2" weitergeholfen. Ich habe übersehen, dass offensichtlich der Bootloader nicht upgedated wurde. Ich habe das jetzt händisch nachgezogen und nach dem boot mit dem Kernel 3.16.7-53 funktioniert WLAN inkl. WPA2 sofort.


    Danke und LG,

    bernie70

    Für den Inhalt des Beitrages 113180 haftet ausdrücklich der jeweilige Autor: bernie70