skype

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema skype gibt es 22 Antworten auf 3 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Agnes schrieb:

    Es gibt jetzt die Version skypeforlinux 8.10.0.4-1.
    Die kann aber wegen Prüfsummenfehlers nicht installiert werden.

    Weiß jemand von euch, was da los ist?
    Was soll dort denn los sein? Es ist normal wenn kein öffentlicher Schlüssel für ein Repositorium oder Paket vorliegt.

    Quellcode

    1. zypper in https://repo.skype.com/latest/skypeforlinux-64.rpm
    2. Loading repository data...
    3. Reading installed packages...
    4. Resolving package dependencies...
    5. The following NEW package is going to be installed:
    6. skypeforlinux
    7. 1 new package to install.
    8. Overall download size: 84.4 MiB. Already cached: 0 B. After the operation, additional 207.3 MiB will be used.
    9. Continue? [y/n/...? shows all options] (y):
    10. Retrieving package skypeforlinux-8.10.0.4-1.x86_64 (1/1), 84.4 MiB (207.3 MiB unpacked)
    11. skypeforlinux-64.rpm:
    12. Header V4 RSA/SHA1 Signature, key ID df7587c3: NOKEY
    13. V4 RSA/SHA1 Signature, key ID df7587c3: NOKEY
    14. skypeforlinux-8.10.0.4-1.x86_64 (Plain RPM files cache): Signature verification failed [4-Signatures public key is not available]
    15. Abort, retry, ignore? [a/r/i] (a): a
    16. Problem occurred during or after installation or removal of packages:
    17. Installation aborted by user
    18. Please see the above error message for a hint.
    Alles anzeigen
    Statt so wie ich, hättest du bei
    skypeforlinux-8.10.0.4-1.x86_64 (Plain RPM files cache): Signature
    verification failed [4-Signatures public key is not available]
    Abort, retry, ignore? [a/r/i] (a): a
    das „i“ auswählen können.

    Oder du machst es von vornerein anders:

    Brainfuck-Quellcode

    1. zypper --no-gpg-checks in https://repo.skype.com/latest/skypeforlinux-64.rpm
    2. Loading repository data...
    3. Reading installed packages...
    4. Resolving package dependencies...
    5. The following NEW package is going to be installed:
    6. skypeforlinux
    7. 1 new package to install.
    8. Overall download size: 84.4 MiB. Already cached: 0 B. After the operation, additional 207.3 MiB will be used.
    9. Continue? [y/n/...? shows all options] (y):
    10. Retrieving package skypeforlinux-8.10.0.4-1.x86_64 (1/1), 84.4 MiB (207.3 MiB unpacked)
    11. skypeforlinux-64.rpm:
    12. Header V4 RSA/SHA1 Signature, key ID df7587c3: NOKEY
    13. V4 RSA/SHA1 Signature, key ID df7587c3: NOKEY
    14. skypeforlinux-8.10.0.4-1.x86_64 (Plain RPM files cache): Signature verification failed [4-Signatures public key is not available]
    15. Accepting package despite the error. (--no-gpg-checks)
    16. Checking for file conflicts: .............................................................................................................................................................[done]
    17. (1/1) Installing: skypeforlinux-8.10.0.4-1.x86_64 ........................................................................................................................................[done]
    18. Additional rpm output:
    19. warning: /var/cache/zypper/RPMS/skypeforlinux-64.rpm: Header V4 RSA/SHA1 Signature, key ID df7587c3: NOKEY
    Alles anzeigen

    Für den Inhalt des Beitrages 114558 haftet ausdrücklich der jeweilige Autor: tomfa-ng

  • tomfa-ng schrieb:

    Was soll dort denn los sein? Es ist normal wenn kein öffentlicher Schlüssel für ein Repositorium oder Paket vorliegt.
    Bisher lief das skypeforlinux Update per Gnome-Paketaktualisierung immer ohne Fehler durch.
    Ich habe es jetzt so gemacht:

    Shell-Script

    1. # zypper update
    2. Loading repository data...
    3. Reading installed packages...
    4. The following 134 package updates will NOT be installed:
    5. MozillaFirefox MozillaFirefox-translations-common OpenPrintingPPDs OpenPrintingPPDs-ghostscript
    6. OpenPrintingPPDs-hpijs OpenPrintingPPDs-postscript alsa-plugins-pulse autofs btrfsmaintenance
    7. btrfsprogs btrfsprogs-udev-rules deja-dup deja-dup-lang drm-kmp-default-4.9.33_k4.4.92_31-7.4
    8. exfat-utils extundelete ffmpeg ffmpegthumbnailer flac fuse fuse-exfat gcab gcab-lang
    9. gedit-plugin-code-assistance genisoimage ghex ghex-lang gimp-help gimp-help-de gimp-save-for-web
    10. gimp-save-for-web-lang gsmartcontrol gstreamer-plugins-libav gstreamer-plugins-ugly
    11. gstreamer-plugins-ugly-lang gtk3-engine-unico hfsutils jfsutils libFLAC++6 libFLAC8 libavcodec56
    12. libavcodec57 libavdevice57 libavfilter6 libavformat56 libavformat57 libavresample3 libavutil54
    13. libavutil55 libbtrfs0 libfallocate0 libffmpegthumbnailer4 libfreebl3 libfuse2 libgcab-1_0-0
    14. libgexiv2-2 libgphoto2-6 libgphoto2-6-lang libgstadaptivedemux-1_0-0 libgstbadaudio-1_0-0
    15. libgstbadbase-1_0-0 libgstbadvideo-1_0-0 libgstbasecamerabinsrc-1_0-0 libgstcodecparsers-1_0-0
    16. libgstgl-1_0-0 libgstmpegts-1_0-0 libgstphotography-1_0-0 libgsturidownloader-1_0-0 libgtkhex-3-0
    17. libmad0 libmjpegutils-2_0-0 libmpg123-0 libnilfs0 libnilfscleaner0 libnilfsgc0 libpostproc53
    18. libpostproc54 libpulse-mainloop-glib0 libpulse0 libquicktime0 librasqal3 libreiserfscore0
    19. librevenge-0_0-0 librevenge-stream-0_0-0 libsoftokn3 libswresample1 libswresample2 libswscale3
    20. libswscale4 libtwolame0 libwpd-0_10-10 libwpg-0_3-3 libzbar0 liferea liferea-lang me-tv me-tv-lang
    21. meld meld-lang mjpegtools mozilla-nspr mozilla-nss mozilla-nss-certs mpg123-openal mpg123-pulse
    22. mpv mpv-bash-completion mpv-zsh-completion nautilus-deja-dup nautilus-search-tool
    23. nautilus-search-tool-lang nilfs-utils p7zip pulseaudio pulseaudio-bash-completion pulseaudio-lang
    24. pulseaudio-module-bluetooth pulseaudio-module-gconf pulseaudio-module-lirc pulseaudio-module-x11
    25. pulseaudio-module-zeroconf pulseaudio-utils python-nautilus reiserfs seamonkey
    26. seamonkey-translations-common smtube transmission-common transmission-gtk transmission-gtk-lang
    27. usb_modeswitch usb_modeswitch-data xsane
    28. The following 13 packages are going to be upgraded:
    29. ImageMagick alsa-utils google-chrome-stable libMagickCore-7_Q16HDRI4 libMagickWand-7_Q16HDRI4
    30. libfftw3-3 libfftw3_threads3 libgksu2-0 libgksu2-0-lang libgksu2-bin libsamplerate0 skypeforlinux
    31. youtube-dl
    32. 13 packages to upgrade.
    33. Overall download size: 138.1 MiB. Already cached: 0 B. After the operation, additional 1.7 MiB will
    34. be used.
    35. Continue? [y/n/...? shows all options] (y):
    36. Retrieving package libgksu2-0-2.0.13~pre1-4.1.x86_64 (1/13), 24.2 KiB ( 64.1 KiB unpacked)
    37. Retrieving delta: ./x86_64/libgksu2-0-2.0.13~pre1-3.3_4.1.x86_64.drpm, 4.3 KiB
    38. Retrieving: libgksu2-0-2.0.13~pre1-3.3_4.1.x86_64.drpm .......................................[done]
    39. Applying delta: ./libgksu2-0-2.0.13~pre1-3.3_4.1.x86_64.drpm .................................[done]
    40. Retrieving package libgksu2-bin-2.0.13~pre1-4.1.x86_64 (2/13), 39.8 KiB (112.1 KiB unpacked)
    41. Retrieving delta: ./x86_64/libgksu2-bin-2.0.13~pre1-3.3_4.1.x86_64.drpm, 7.9 KiB
    42. Retrieving: libgksu2-bin-2.0.13~pre1-3.3_4.1.x86_64.drpm .....................................[done]
    43. Applying delta: ./libgksu2-bin-2.0.13~pre1-3.3_4.1.x86_64.drpm ...............................[done]
    44. Retrieving package libgksu2-0-lang-2.0.13~pre1-4.1.noarch (3/13), 34.3 KiB (149.9 KiB unpacked)
    45. Retrieving delta: ./noarch/libgksu2-0-lang-2.0.13~pre1-3.3_4.1.noarch.drpm, 5.9 KiB
    46. Retrieving: libgksu2-0-lang-2.0.13~pre1-3.3_4.1.noarch.drpm ..................................[done]
    47. Applying delta: ./libgksu2-0-lang-2.0.13~pre1-3.3_4.1.noarch.drpm ............................[done]
    48. Retrieving package youtube-dl-2017.11.06-1.1.noarch (4/13), 1.5 MiB ( 1.6 MiB unpacked)
    49. Retrieving: youtube-dl-2017.11.06-1.1.noarch.rpm ...............................[done (390.4 KiB/s)]
    50. Retrieving package google-chrome-stable-62.0.3202.89-1.x86_64 (5/13), 46.8 MiB (175.7 MiB unpacked)
    51. Retrieving: google-chrome-stable-62.0.3202.89-1.x86_64.rpm .......................[done (1.1 MiB/s)]
    52. Retrieving package libfftw3-3-3.3.6-58.1.x86_64 (6/13), 1.3 MiB ( 4.3 MiB unpacked)
    53. Retrieving: libfftw3-3-3.3.6-58.1.x86_64.rpm ...................................[done (704.9 KiB/s)]
    54. Retrieving package libsamplerate0-0.1.9-51.10.x86_64 (7/13), 921.0 KiB ( 1.4 MiB unpacked)
    55. Retrieving: libsamplerate0-0.1.9-51.10.x86_64.rpm ..............................[done (950.7 KiB/s)]
    56. Retrieving package libfftw3_threads3-3.3.6-58.1.x86_64 (8/13), 22.9 KiB ( 79.7 KiB unpacked)
    57. Retrieving: libfftw3_threads3-3.3.6-58.1.x86_64.rpm ..............................[done (1.7 KiB/s)]
    58. Retrieving package alsa-utils-1.1.4-167.1.x86_64 (9/13), 988.1 KiB ( 1.9 MiB unpacked)
    59. Retrieving: alsa-utils-1.1.4-167.1.x86_64.rpm ..................................[done (791.8 KiB/s)]
    60. Retrieving package skypeforlinux-8.10.0.4-1.x86_64 (10/13), 84.4 MiB (207.3 MiB unpacked)
    61. Retrieving: skypeforlinux_8.10.0.4-1.x86_64.rpm ...............................[done (1023.3 KiB/s)]
    62. Warning: Digest verification failed for file 'skypeforlinux_8.10.0.4-1.x86_64.rpm'
    63. [/var/cache/zypp/packages/skype-stable/skypeforlinux_8.10.0.4-1.x86_64.rpm]
    64. expected 9bb79929290818adfda668db22b6d02dd59f2a824c909a846c0556ad6bec93d7
    65. but got 0bbcf73f28381611fe559ae98aff5feeaa9d93842f3c36fbb2f79b776b628ac5
    66. Accepting packages with wrong checksums can lead to a corrupted system and in extreme cases even to a system compromise.
    67. However if you made certain that the file with checksum '0bbc..' is secure, correct
    68. and should be used within this operation, enter the first 4 characters of the checksum
    69. to unblock using this file on your own risk. Empty input will discard the file.
    70. Unblock or discard? [0bbc/...? shows all options] (discard): ?
    71. 0bbc - Unblock using this file on your own risk.
    72. discard - Discard the file.
    73. [0bbc/...? shows all options] (discard): 0bbc
    74. Retrieving package libMagickCore-7_Q16HDRI4-7.0.7.10-330.1.x86_64
    75. (11/13), 1.7 MiB ( 6.4 MiB unpacked)
    76. Retrieving: libMagickCore-7_Q16HDRI4-7.0.7.10-330.1.x86_64.rpm .................[done (903.8 KiB/s)]
    77. Retrieving package libMagickWand-7_Q16HDRI4-7.0.7.10-330.1.x86_64
    78. (12/13), 338.9 KiB ( 1.2 MiB unpacked)
    79. Retrieving: libMagickWand-7_Q16HDRI4-7.0.7.10-330.1.x86_64.rpm .................[done (636.5 KiB/s)]
    80. Retrieving package ImageMagick-7.0.7.10-330.1.x86_64 (13/13), 119.5 KiB (104.0 KiB unpacked)
    81. Retrieving: ImageMagick-7.0.7.10-330.1.x86_64.rpm ............................................[done]
    82. Checking for file conflicts: .................................................................[done]
    83. Warning: Checking for file conflicts requires not installed packages to be downloaded in advance in order to access their file lists. See option '--download-in-advance' in the zypper manual page for details.
    84. The following package had to be excluded from file conflicts check because it is not yet downloaded:
    85. skypeforlinux
    86. ( 1/13) Installing: libgksu2-0-2.0.13~pre1-4.1.x86_64 ........................................[done]
    87. ( 2/13) Installing: libgksu2-bin-2.0.13~pre1-4.1.x86_64 ......................................[done]
    88. ( 3/13) Installing: libgksu2-0-lang-2.0.13~pre1-4.1.noarch ...................................[done]
    89. ( 4/13) Installing: youtube-dl-2017.11.06-1.1.noarch .........................................[done]
    90. ( 5/13) Installing: google-chrome-stable-62.0.3202.89-1.x86_64 ...............................[done]
    91. ( 6/13) Installing: libfftw3-3-3.3.6-58.1.x86_64 .............................................[done]
    92. ( 7/13) Installing: libsamplerate0-0.1.9-51.10.x86_64 ........................................[done]
    93. ( 8/13) Installing: libfftw3_threads3-3.3.6-58.1.x86_64 ......................................[done]
    94. ( 9/13) Installing: alsa-utils-1.1.4-167.1.x86_64 ............................................[done]
    95. Retrieving package skypeforlinux-8.10.0.4-1.x86_64 (1/13), 84.4 MiB (207.3 MiB unpacked)
    96. Retrieving: skypeforlinux_8.10.0.4-1.x86_64.rpm ................................[done (956.3 KiB/s)]
    97. (10/13) Installing: skypeforlinux-8.10.0.4-1.x86_64 ..........................................[done]
    98. (11/13) Installing: libMagickCore-7_Q16HDRI4-7.0.7.10-330.1.x86_64 ...........................[done]
    99. (12/13) Installing: libMagickWand-7_Q16HDRI4-7.0.7.10-330.1.x86_64 ...........................[done]
    100. (13/13) Installing: ImageMagick-7.0.7.10-330.1.x86_64 ........................................[done]
    Alles anzeigen
    skypeforlinux wurde jetzt aber doppelt heruntergeladen.

    Für den Inhalt des Beitrages 114563 haftet ausdrücklich der jeweilige Autor: Agnes

  • Agnes schrieb:

    Bisher lief das skypeforlinux Update per Gnome-Paketaktualisierung immer ohne Fehler durch.
    Dann hättest du es dabei belassen sollen.

    Skype Installation (damit ist mein Beitrag #21 auch hinfällig):
    Für alle die das rpm von skype.com/de/new/ heruntergeladen und dieses über RPM, Zypper oder YaST installiert haben und eine der oben genannten Fehlermeldung(en) („
    Signature
    verification failed [4-Signatures public key is not available]“, „Digest verification failed for file…“) bekommen führen noch folgenden Schritt über Root/su aus:

    Quellcode

    1. rpm --import https://repo.skype.com/rpm/stable/repodata/repomd.xml.key

    Für alle die Skype erst noch installieren wollen, die sollten die folgenden Schritte über Root/su ausführen:

    Quellcode

    1. zypper ar -f -n 'Skype Repositorium' https://repo.skype.com/rpm/stable/ skype

    Brainfuck-Quellcode

    1. zypper in skypeforlinux
    2. Retrieving repository 'Skype Repositorium' metadata -----------------------------------------------------------------------------------------------------------------------------------------[\]
    3. New repository or package signing key received:
    4. Repository: Skype Repositorium
    5. Key Name: Skype Linux Client Repository <se-um@microsoft.com>
    6. Key Fingerprint: D4040146 BE397250 9FD57FC7 1F3045A5 DF7587C3
    7. Key Created: Wed Jun 22 11:36:35 2016
    8. Key Expires: Mon Jun 21 11:36:35 2021
    9. Subkey: 6B4A0000A4EBB320 2016-06-22 [expires: 2021-06-21]
    10. Rpm Name: gpg-pubkey-df7587c3-576a5c23
    11. Do you want to reject the key, trust temporarily, or trust always? [r/t/a/? shows all options] (r): a
    12. Retrieving repository 'Skype Repositorium' metadata ......................................................................................................................................[done]
    13. Building repository 'Skype Repositorium' cache ...........................................................................................................................................[done]
    14. Loading repository data...
    15. Reading installed packages...
    16. Resolving package dependencies...
    17. The following NEW package is going to be installed:
    18. skypeforlinux
    19. 1 new package to install.
    20. Overall download size: 84.4 MiB. Already cached: 0 B. After the operation, additional 207.3 MiB will be used.
    21. Continue? [y/n/...? shows all options] (y):
    22. Retrieving package skypeforlinux-8.10.0.4-1.x86_64 (1/1), 84.4 MiB (207.3 MiB unpacked)
    23. Retrieving: skypeforlinux_8.10.0.4-1.x86_64.rpm ..............................................................................................................................[done (1.2 MiB/s)]
    24. Checking for file conflicts: .............................................................................................................................................................[done]
    25. (1/1) Installing: skypeforlinux-8.10.0.4-1.x86_64 ........................................................................................................................................[done]
    Alles anzeigen
    Sollte es eine neue Version für Skype geben, dann bitte diese nicht (mehr) von Skype.com herunterladen und installieren sondern die hauseigene Paketverwaltung (YaST, Zypper usw.) verwenden.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von tomfa-ng ()

    Für den Inhalt des Beitrages 114577 haftet ausdrücklich der jeweilige Autor: tomfa-ng