HDD Festplatte schaltet sich immer wieder ein

Hinweis: In dem Thema HDD Festplatte schaltet sich immer wieder ein gibt es 24 Antworten auf 3 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • HDD Festplatte schaltet sich immer wieder ein

    Hi,

    wie in diesem Thread von @Sauerland verlinkt, habe ich, wie im wiki.archlinux.org/Hdparm beschrieben, eine udev rule erstellt.

    Quellcode

    1. # cat /etc/udev/rules.d/99-Hdparm.rules
    2. KERNEL=="sdb", SUBSYSTEM=="block", ATTR{queue/rotational}=="1", ACTION=="add", RUN+="/usr/sbin/hdparm -B 127 -S 60 /dev/sdb"

    Die HDD schaltet sich nach 5 Minuten ab, aber alle 30 Minuten immer wieder an.

    Quellcode

    1. # while true; do hdparm -C /dev/sdb; date; sleep 5m; done
    2. /dev/sdb:
    3. drive state is: active/idle
    4. Wed Jan 10 16:27:35 CET 2018
    5. /dev/sdb:
    6. drive state is: standby
    7. Wed Jan 10 16:32:35 CET 2018
    8. /dev/sdb:
    9. drive state is: standby
    10. Wed Jan 10 16:37:35 CET 2018
    11. /dev/sdb:
    12. drive state is: standby
    13. Wed Jan 10 16:42:35 CET 2018
    14. /dev/sdb:
    15. drive state is: standby
    16. Wed Jan 10 16:47:35 CET 2018
    17. /dev/sdb:
    18. drive state is: standby
    19. Wed Jan 10 16:52:35 CET 2018
    20. /dev/sdb:
    21. drive state is: active/idle
    22. Wed Jan 10 16:57:35 CET 2018
    23. /dev/sdb:
    24. drive state is: standby
    25. Wed Jan 10 17:02:35 CET 2018
    26. /dev/sdb:
    27. drive state is: standby
    28. Wed Jan 10 17:07:35 CET 2018
    29. /dev/sdb:
    30. drive state is: standby
    31. Wed Jan 10 17:12:35 CET 2018
    32. /dev/sdb:
    33. drive state is: standby
    34. Wed Jan 10 17:17:35 CET 2018
    35. /dev/sdb:
    36. drive state is: standby
    37. Wed Jan 10 17:22:35 CET 2018
    38. /dev/sdb:
    39. drive state is: active/idle
    40. Wed Jan 10 17:27:35 CET 2018
    41. /dev/sdb:
    42. drive state is: standby
    43. Wed Jan 10 17:32:35 CET 2018
    44. /dev/sdb:
    45. drive state is: standby
    46. Wed Jan 10 17:37:36 CET 2018
    47. /dev/sdb:
    48. drive state is: standby
    49. Wed Jan 10 17:42:36 CET 2018
    50. /dev/sdb:
    51. drive state is: standby
    52. Wed Jan 10 17:47:36 CET 2018
    53. /dev/sdb:
    54. drive state is: standby
    55. Wed Jan 10 17:52:36 CET 2018
    56. /dev/sdb:
    57. drive state is: active/idle
    58. Wed Jan 10 17:57:36 CET 2018
    59. /dev/sdb:
    60. drive state is: standby
    61. Wed Jan 10 18:02:36 CET 2018
    62. /dev/sdb:
    63. drive state is: standby
    64. Wed Jan 10 18:07:36 CET 2018
    Alles anzeigen

    Die Festplatte ist aber gar nicht eingehängt, sondern einfach nur angeschlossen. /dev/sda ist die SSD.

    Quellcode

    1. # mount | grep '/dev/sd'
    2. /dev/sda1 on / type ext4 (rw,relatime,data=ordered)
    3. /dev/sda3 on /home type ext4 (rw,relatime,data=ordered)

    Da die HDD ziemlich laut ist und ich die Partitionen nur von Hand mounten will, soll die Festplatte eigentlich immer auf "standby" bleiben.
    Mit einem Livesystem (System Rescue CD) klappt das dauerhaft, aber nicht unter Leap 42.3.

    Kann mir bitte jemand bei der Fehlerursache suchen helfen?

    Für den Inhalt des Beitrages 116744 haftet ausdrücklich der jeweilige Autor: Agnes

  • Wie? Die rattert, wenn sie nicht eingehängt ist?

    Wenn das wirklich so ist, sach schon ma' "Ciao" zu deinen Daten.
    Da sorgt ja dann - unabhängig vom Betriebssystem - schon die Hardware für verzweifelte Kontaktaufnahmen.

    Nachtrag: Noch mal nachgelesen.
    Warum greifst du explizit zu? Es reicht doch schlicht nichts zu mounten.
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 116749 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • Ich greife auf die Festplatte nicht zu.
    Sie startet unter Leap 42.3 nach hdparm -y nach 30 min. immer wieder von selbst. Seit ich eine SSD besitze, beobachte ich das schon.
    Von heute Morgen bis heute Nachmittag lief die while-Schleife unter System Rescue CD, und die HDD ist permanent auf "standby" geblieben.

    Für den Inhalt des Beitrages 116751 haftet ausdrücklich der jeweilige Autor: Agnes

  • Ein Update:
    Ich habe jetzt mal im Journal geschaut, was passiert, wenn die Festplatte alle 30 Min. immer anläuft.

    Quellcode

    1. # journalctl -f
    2. Jan 12 15:09:06 linux smartd[935]: Device: /dev/sdb [SAT], SMART Usage Attribute: 190 Airflow_Temperature_Cel changed from 77 to 76
    3. Jan 12 15:09:06 linux smartd[935]: Device: /dev/sdb [SAT], SMART Usage Attribute: 194 Temperature_Celsius changed from 23 to 24
    Lässt sich der smartd vielleicht ändern, so dass die "SMART Usage Attribute" nur 1× pro Stunde abgefragt werden, statt alle 30 min.?

    Für den Inhalt des Beitrages 116826 haftet ausdrücklich der jeweilige Autor: Agnes

  • Neu

    Da komme ich leider nicht weiter. Welche Option von smartctl meinst du jetzt?

    Gestern habe ich in der /etc/fstab die beiden Partitionen auf der HDD eingetragen. Eine mit ntfs (Windows Vista) und eine mit ext4 (für größere Downloads/Videos).
    Der Nautilus ist immer geöffnet, aber die Festplatte schaltet sich trotzdem nach 5 Min. ab, wenn ich nicht auf eine Datei zugreife (ein Video läuft).

    Jetzt sollte ich aber herausfinden, was smartd[935]: Device: /dev/sdb alle 30 Minuten macht und wie ich das auf alle 2 Stunden verlängern kann.

    Für den Inhalt des Beitrages 116852 haftet ausdrücklich der jeweilige Autor: Agnes

  • Neu

    man smartctl schrieb:

    -n POWERMODE, --nocheck=POWERMODE
    [ATA only] Specifies if smartctl should exit before performing any checks when the device is in a low-power mode. It may
    be used to prevent a disk from being spun-up by smartctl. The power mode is ignored by default. A nonzero exit status is
    returned if the device is in one of the specified low-power modes (see EXIT STATUS below).

    Note: If this option is used it may also be necessary to specify the device type with the ´-d´ option. Otherwise the
    device may spin up due to commands issued during device type autodetection.


    The valid arguments to this option are:
    never - check the device always, but print the power mode if ´-i´ is specified.

    sleep - check the device unless it is in SLEEP mode.

    standby - check the device unless it is in SLEEP or STANDBY mode. In these modes most disks are not spinning, so if you
    want to prevent a disk from spinning up, this is probably what you want.

    idle - check the device unless it is in SLEEP, STANDBY or IDLE mode. In the IDLE state, most disks are still spinning, so
    this is probably not what you want.
    Falls es ein ATA Plättchen ist.
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 116854 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • Neu

    Berichtigung schrieb:

    man smartctl schrieb:

    -n POWERMODE, --nocheck=POWERMODE
    [ATA only] Specifies if smartctl should exit before performing any checks when the device is in a low-power mode.
    Falls es ein ATA Plättchen ist.

    Quellcode

    1. # smartctl -a /dev/sdb
    2. Model Family: Seagate Barracuda 7200.14 (AF)
    3. ATA Version is: ACS-2, ACS-3 T13/2161-D revision 3b
    4. SATA Version is: SATA 3.1, 6.0 Gb/s (current: 6.0 Gb/s)
    Wie oder wo soll ich die Option -n standby einfügen? Im Journal finde ich keinen smartctl-Eintrag.

    Sauerland schrieb:

    Du kannst auch noch in /etc/smartd.conf nach DEVICESCAN schauen, was dort steht.
    Dahinter steht nichts. Ich habe diese Datei auch nicht verändert.

    Für den Inhalt des Beitrages 116858 haftet ausdrücklich der jeweilige Autor: Agnes

www.cyberport.de