zypper upgrade 42.2 -> 42.3 welche Repos deaktivieren / löschen

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema zypper upgrade 42.2 -> 42.3 welche Repos deaktivieren / löschen gibt es 15 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • zypper upgrade 42.2 -> 42.3 welche Repos deaktivieren / löschen

    Ich habe einen Beitrag zum upgrade 42.2 auf 42.3 mit zypper gelesen. Dort hat Sauerland dem Poster Vorschläge gemacht, wie er vorgehen soll:
    opensuse-forum.de/post-add/39118/?quoteMessageID=112968
    Ich bin mir unsicher, besser gesagt ziemlich unerfahren, welche Repos ich vorab deaktivieren / löschen soll.
    Vielleicht könnte jemand mir Tipps geben

    Brainfuck-Quellcode

    1. Die Repository-Prioritäten sind ohne Effekt. Alle aktivierten Repositorys teilen sich die gleiche Priorität.
    2. # | Alias | Name | Aktiviert | GPG-Überprüfung | Aktualisierung | Priorität | Typ | URI | Dienst
    3. ---+-------------------------------------+------------------------------------------------------------+-----------+-----------------+----------------+-----------+--------+--------------------------------------------------------------------------------+-------
    4. 1 | graphics | Graphics Project (openSUSE_Leap_42.2) | Ja | (r ) Ja | Nein | 99 | rpm-md | http://download.opensuse.org/repositories/graphics/openSUSE_Leap_42.2/ |
    5. 2 | http-download.opensuse.org-ab81767e | home:canislycan | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/repositories/home:/canislycan/openSUSE_Leap_42.2/ |
    6. 3 | http-opensuse-guide.org-3922766a | libdvdcss repository | Ja | (r ) Ja | Ja | 99 | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_42.2/ |
    7. 4 | http-packman.inode.at-9e5669b9 | Packman Repository | Ja | (r ) Ja | Ja | 99 | rpm-md | http://packman.inode.at/suse/openSUSE_Leap_42.2/ |
    8. 5 | openSUSE-42.2-0 | openSUSE-42.2-0 | Nein | ---- | ---- | 99 | yast2 | hd:///?device=/dev/disk/by-id/usb-SMI_USB_DISK-0:0-part2 |
    9. 6 | openSUSE_Leap_42.2 | openSUSE_Leap_42.2 | Ja | (r ) Ja | Ja | 99 | rpm-md | https://download.opensuse.org/repositories/science/openSUSE_Leap_42.2/ |
    10. 7 | repo-debug | openSUSE-Leap-42.2-Debug | Nein | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/distribution/leap/42.2/repo/oss/ |
    11. 8 | repo-debug-non-oss | openSUSE-Leap-42.2-Debug-Non-Oss | Nein | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/distribution/leap/42.2/repo/non-oss/ |
    12. 9 | repo-debug-update | openSUSE-Leap-42.2-Update-Debug | Nein | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/update/leap/42.2/oss/ |
    13. 10 | repo-debug-update-non-oss | openSUSE-Leap-42.2-Update-Debug-Non-Oss | Nein | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/update/leap/42.2/non-oss/ |
    14. 11 | repo-non-oss | openSUSE-Leap-42.2-Non-Oss | Ja | (r ) Ja | Ja | 99 | yast2 | http://download.opensuse.org/distribution/leap/42.2/repo/non-oss/ |
    15. 12 | repo-oss | openSUSE-Leap-42.2-Oss | Ja | (r ) Ja | Ja | 99 | yast2 | http://download.opensuse.org/distribution/leap/42.2/repo/oss/ |
    16. 13 | repo-source | openSUSE-Leap-42.2-Source | Nein | ---- | ---- | 99 | NONE | http://download.opensuse.org/source/distribution/leap/42.2/repo/oss/ |
    17. 14 | repo-source-non-oss | openSUSE-Leap-42.2-Source-Non-Oss | Nein | ---- | ---- | 99 | NONE | http://download.opensuse.org/source/distribution/leap/42.2/repo/non-oss/ |
    18. 15 | repo-update | openSUSE-Leap-42.2-Update | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/update/leap/42.2/oss/ |
    19. 16 | repo-update-non-oss | openSUSE-Leap-42.2-Update-Non-Oss | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/update/leap/42.2/non-oss/ |
    20. 17 | science | Software for Scientists and Engineers (openSUSE_Leap_42.2) | Ja | (r ) Ja | Nein | 99 | rpm-md | http://download.opensuse.org/repositories/science/openSUSE_Leap_42.2/ |
    Alles anzeigen

    Quellcode

    1. hector@linux-kpwz:~> /sbin/lspci -nnk | grep -EiA3 'vga|3d|display|net'
    2. 00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07)
    3. Subsystem: Hewlett-Packard Company Device [103c:1526]
    4. Kernel driver in use: i915
    5. Kernel modules: i915
    6. 00:02.1 Display controller [0380]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a43] (rev 07)
    7. Subsystem: Hewlett-Packard Company Device [103c:1526]
    8. 00:1a.0 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 [8086:2937] (rev 03)
    9. Subsystem: Hewlett-Packard Company Device [103c:1526]
    10. --
    11. 02:00.0 Network controller [0280]: Ralink corp. RT3090 Wireless 802.11n 1T/1R PCIe [1814:3090]
    12. Subsystem: Hewlett-Packard Company Device [103c:1453]
    13. Kernel driver in use: rt2800pci
    14. Kernel modules: rt2800pci
    15. 85:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller [10ec:8136] (rev 02)
    16. Subsystem: Hewlett-Packard Company Device [103c:1526]
    17. Kernel driver in use: r8169
    18. Kernel modules: r8169
    Alles anzeigen
    ----
    openSuse Leap 42.3 KDE HP620 Laptop

    Für den Inhalt des Beitrages 116745 haftet ausdrücklich der jeweilige Autor: tomdylan

  • Alle Repos deaktivieren und auch das aktualisieren ausschalten außer:

    Packman
    OSS
    non-OSS
    OSS-Update
    non-OSS Update

    Dort dann die URL von 42.2 auf 42.3 ändern.

    Dann kannst du upgraden.
    Kann klappen, muss aber nicht.
    Ich installiere immer neu unter Beibehaltung des alten /home. Erspart Ärger.



    PS:
    Ein Repo zu aktivieren, aber die Aktualisierung zu deaktivieren wird über kurz oder lang zu Fehlern führen, da zypper noch meint, es gäbe in dem Repo Version a, dies aber schon lange gelöscht und durch Version b ersetzt ist.

    Also:
    Entweder das Repo deaktivieren oder das Repo aktivieren und aktualisieren.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 116748 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Vielen Dank!
    Ich versuche's gleich mit zypper -dup

    Wenn du als "alter Hase" eher eine Neuinstallation bevorzugst;

    Sauerland schrieb:

    Ich installiere immer neu unter Beibehaltung des alten /home. Erspart Ärger.
    Wäre es nicht besser für mich auch diesen Weg zu gehen? Kann man neuinstallieren, ohne dass /home überschrieben wird? oder kopierst du im Anschluss an die Neuinstallation /home von der Sicherung wieder zurück?
    ----
    openSuse Leap 42.3 KDE HP620 Laptop

    Für den Inhalt des Beitrages 116754 haftet ausdrücklich der jeweilige Autor: tomdylan

  • tomdylan schrieb:

    Kann man neuinstallieren, ohne dass /home überschrieben wird?
    Ja, musst nur bei der Partitionierung darauf achten.

    Vorher solltest du aber auch ein Backup machen, /etc sichern und evtl. auch Datenbanken, Webserver usw.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 116756 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Upgrade auf 42.3 per zypper war erfolgreich, herzlichen Dank!

    Ich vermute, dass ich jetzt die andren Repos auf 42.3 umbenennen und wieder aktivieren muss, oder?

    Ich werde noch ein paar Anwendungen testen und, wenn mir nichts auffällt, den Thread schließen
    ----
    openSuse Leap 42.3 KDE HP620 Laptop

    Für den Inhalt des Beitrages 116773 haftet ausdrücklich der jeweilige Autor: tomdylan

  • tomdylan schrieb:

    ch vermute, dass ich jetzt die andren Repos auf 42.3 umbenennen und wieder aktivieren muss, oder?
    Auf 42.2 stehen lassen wäre absolut kontraproduktiv.

    Für den Inhalt des Beitrages 116787 haftet ausdrücklich der jeweilige Autor: Alero

  • Ich wollte den Thread schon schließen, da stellte ich fest, dass meine Video Player (VLC, Kaffeine etc.) keine Bilder mehr zeigen.
    Ich gehe davon aus, dass nach dem Upgrade irgendetwas, was zur Darstellung von Videodateien erforderlich ist, nicht mehr aktuell ist.

    Irgendwelche Hinweise?
    ----
    openSuse Leap 42.3 KDE HP620 Laptop

    Für den Inhalt des Beitrages 116892 haftet ausdrücklich der jeweilige Autor: tomdylan

  • tomdylan schrieb:

    Ich wollte den Thread schon schließen, da stellte ich fest, dass meine Video Player (VLC, Kaffeine etc.) keine Bilder mehr zeigen.
    Ich gehe davon aus, dass nach dem Upgrade irgendetwas, was zur Darstellung von Videodateien erforderlich ist, nicht mehr aktuell ist.

    Irgendwelche Hinweise?
    Restricted Formats installieren
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 116893 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Danke für den Link!
    Da ich das packman repository schon hatte, bin ich direkt zur Installation der diversen Codes gegangen:

    Quellcode

    1. linux-kpwz:/home/hector # zypper install -f libxine2-codecs ffmpeg lame gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-bad-orig-addon gstreamer-0_10-plugins-base gstreamer-0_10-plugins-ffmpeg gstreamer-0_10-plugins-good gstreamer-0_10-plugins-good-extra gstreamer-0_10-plugins-ugly gstreamer-0_10-plugins-ugly-orig-addon dvdauthor gstreamer-plugins-bad gstreamer-plugins-bad-orig-addon gstreamer-plugins-base gstreamer-plugins-good gstreamer-plugins-good-extra gstreamer-plugins-libav gstreamer-plugins-qt5 gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon vlc smplayer x264 x265 vlc-codecs ogmtools

    Repository-Daten werden geladen...
    Installierte Pakete werden gelesen...

    Eigentlich hat alles geklappt, nur ein Paket konnte nicht gefunden werden:

    Paket 'gstreamer-0_10-plugins-ugly-orig-addon' nicht gefunden.

    Ist diese Referenz vielleicht veraltet?
    Sollte ich dieses gstreamer-ugly(!) Ding versuchen irgendwoher zu holen?

    Jedenfalls gaben die Videoplayer nur den Ton, jedoch keine Bilder wieder.

    Ich habe das System neugestartet und dann funktionierten die Video-Player tadellos.

    Der Upgrade auf 42.3 hat somit Dank der Hilfe von Sauerland Alero & Freunde geklappt!
    ----
    openSuse Leap 42.3 KDE HP620 Laptop

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von tomdylan ()

    Für den Inhalt des Beitrages 116895 haftet ausdrücklich der jeweilige Autor: tomdylan