Probleme nach Umstieg von 13.1/KDE4 auf 42.3/KDE5

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Probleme nach Umstieg von 13.1/KDE4 auf 42.3/KDE5 gibt es 22 Antworten auf 3 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Probleme nach Umstieg von 13.1/KDE4 auf 42.3/KDE5

    Hallo,


    Ich bin endlich mit meine Desktoprechner und Server von openSuse13.1/Evergreen auf Leap 42.3 umgestiegen.
    Dabei bin ich leider auf ein paar nervige Probleme gestoßen. Vielleicht hat ja jemand eine Lösungsidee dazu.
    BTW: Falls ich das falsche Unterforum erwischt haben sollte, bitte verschieben. Da es aber im wesentlichen
    um Probleme mit der geänderten Arbeitsumgebung handelt, dachte ich , es wäre hier richtig aufgehoben

    • kmail:
      • Read-Status von IMAP-Account wird nicht synchronisiert. D.h. Wenn eine Mail von einem anderen Client (z.B. Tablett oder Handy) als gelesen markiert wird, wird dies nicht übernommen. \
        Konfiguration des Accounts:
        • (x) Download all messages for offline use. (<-- Soll so sein)
        • (x/ ) Enable server-side subscriptions (scheint keinen Unterschied zu machen)
        Konfiguration der Mailordener:
        • (x) Share unread state with all users. (damit wird ein read immerhin von kmail auf die anderen Clients übertragen, aber nicht umgekehrt)
        Mit kmail aus KDE4.? war dies noch kein Problem

      • Das kmail-SysTray Icon zeigt nicht mehr die Zahl der ungelesenen Mails an. Wie stellt man dies wieder an. Der einsame schwarze Punkt ist doch viel zu leicht zu übersehen. Ein rote Zahl wäre viel hilfreicher.



    • kmail/okular (und vermutlich andere)
      • Wenn ich in kmail eine Mail in einen anderen Ordner verschiebe sollte ja ein Popup-Menü erscheinen, dass mir die Wahl zwischen 'Move' und 'Copy' lässt. Es erscheint auch, verschwindet aber sofort wieder, so dass ich keine Chance habe etwas anzuklicken. Dasselbe passiert in okular, wenn ich dort eine Text selektieren möchte. Ich kann nicht im Popup-Menü auswählen, dass ich ihn ins Clipboard kopieren möchte.
        Beides ging unter KDE4 noch problemlos

    • KDE5 allgemein
      • Gibt es eine Möglichkeit, den Modifier zur Auswahl von Menüs zu ändern? Ich hätte gerne 'Alt' als normalen Modifier für Shortcuts, da es bei 'Control' zu viele Überschneidungen gibt:
        • 'Control-C' ist Cancel aber auch 'Copy',

        • 'Control-A ist 'Beginnng of line' aber auch 'select all' etc.
        Ich hätte gerne Control für Editing Shortcuts (im terminal oder im xemacs) und Alt für alles was auf Applikationsebene läuft (auch wenn das nicht immer 100%ig zu trennen ist). Das war schon bei KDE4 ein Problem.
      • Gibt es eine vernünftiges Set von Icons, für den Sys-Tray, das nicht nur aus flachen Strichzeichnungen besteht? Wenn ja, wo bekomme ich es?
      • Wie bekommen ich Menüs für einzelen Applikationsordner in Panel. Unter KDE4 ging das wenigstens noch mittels Lancelot. Das scheint aber nicht mehr für KDE5 weiterentwickelt zu werden. Ich hätte gerne z.B. ein Menü nur mit den installierten Browser. Ein Menü mit Einträgen für konsolen auf verschiedenen anderen Rechnern im Netz, usw. Sich immer durch App-Menü -> Applications -> Terminals -> Rechnername zu klicken, ist doch etwas nervig und unelegant. Un alle Terminals und Browsers in Pannel zu ziehen, spamt das Panel doch ziemlich zu. Bis KDE3 ging dies noch mit "Boardmitteln" bei KDE4 immerhin mit Lancelot. Aber wie geht sowas bei KDE5?
    Ich glaub, das waren erst einmal die wichtigsten Nerv-Faktoren.

    Vielen Dank im Voraus

    Bis dann

    R"udiger Goetz

    Für den Inhalt des Beitrages 118370 haftet ausdrücklich der jeweilige Autor: rgoetz

  • Es wäre besser wenn du für jedes Problem ein Thema eröffnen tust. Sonst wird das unübersichtlich

    Da du nicht gesagt hast auf welchen Weg du die Umstellung vorgenommen hast, müsste man die Glaskugel heraus kramen und hinein gucken.

    Vielen Dank !

    LG SUSEDJAlex
    Uhrzeit richtig einstellen

    openSUSE Leap sowie Arch LInux in Nutzung

    Für den Inhalt des Beitrages 118371 haftet ausdrücklich der jeweilige Autor: SUSEDJAlex

  • Hallo,

    Sorry, ich wollte nicht gleich mit einer Welle von Themen starten.
    Soll ich es noch aufsplitten?

    Ich habe i.d.R. auf meine Rechner immer zwei root Partitionen. eine fürs aktuelle System und einer für ein experimentelles. Letzteres habe ich auch für die Neu-Installation von 42.3 genutzt. Aktuell habe ich also parallel 13.1 und 42.3 auf dem Rechner, nutze aber inzwischen nahezu ausschließlich 42.3

    Bis dann

    R"udiger

    Für den Inhalt des Beitrages 118372 haftet ausdrücklich der jeweilige Autor: rgoetz

  • Ich hatte auch Probleme nach dem Umstieg von 13.2 nach Leap, bei mir lag es am /home.
    Dies wird bei einer Neuinstallation ohne formatieren immer eingebunden.

    Ich hab dann neu installiert, /home auch neu angelegt und formatiert und alle relevanten Daten und configs!, die ich vorher gesichert habe, hinterher wieder ins neue /home kopiert.
    Seitdem keine Probleme.

    Lege einen neuen User an, logge dich dort ein, funktioniert es dann?

    Iconssets gibt es im Yast, bzw. sind die bei einigen Themes dabei.......
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 118375 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Habe ich eigentlich gemacht. Ich bin mit einem neuen User (mit gleicher uid/gid aber anderem Home-Verzeichnis) gestartet.
    Später habe ich dann einuge cobfig rüber kopiert (.cshrc, .alias, .emacs, .xeamcs, .login, .Xmodmap, ) aber nichts KDE spezifisches.

    ABer danke für den Tipp.

    Bis dann

    R"udiger

    PS: Ich habe natürlich KDE auch im neuen Accout an meine Vorlieben abgepasst (Focus-follow-mouse, kein click-to-raise, Fenster-buttons um organisert, Shortcuts angepasst etc.)

    Für den Inhalt des Beitrages 118377 haftet ausdrücklich der jeweilige Autor: rgoetz

  • Wieso?

    Ich habe ein anderes home-Verzeichnis und andere root-Partition. Wie soll da Information zwischen den "User" fließen? DEr "neue" User sieht ja keine der congigs des alten.

    Bis dann

    R"udiger

    Für den Inhalt des Beitrages 118380 haftet ausdrücklich der jeweilige Autor: rgoetz

  • Weil Linux im Dateisystem keine Usernamen, sondern UserIDs speichert.

    Wenn User "heinz" auf Installation A die UserID 1 hat und in Installtaion B die ID 2,
    und
    User "paul" auf Installation A die UserID 2 und Installation B die ID 1,
    dann
    arbeitet User "heinz" in der Installation B mit dem Home vom dortigen User "paul".
    Und umgekehrt.

    Nicht der Username ist wichtig, sondern die UserID.
    Deshalb gibt es extra den Befehl id Lies dazu man id
    Diese IDs finden sich in der immer lesbaren /etc/passwd
    Und es gibt sogar ein Programm, damit man solche "Systemdatenbanken" lesen kann. getent <welche DB> <was>
    Ein getent passwd heinz könnte heinz helfen seine Probleme zu verstehen.


    Ein man getent erzählt dir, welche Systemdatenbanken es gibt.

    Man kann übrigens sogar seinen Useraccount mit merheren Namen anlegen.
    Einfach die entsprechende Zeile in der /etc/passwd verdoppeln, und den Usernamen in einer Zeile ändern.
    Könnt ihr gerne ausprobieren, solltet davon aber für den normalen Betrieb weitesten Abstand nehmen.
    Das wollen viele Tools gar nicht verstehen, aber es ist zulässig.
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 118382 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • Hallo,

    War mir alles klar. Noch mal zu Setup:


    Ich habe drei Partitionen:
    root1 mit openSuSe13.1
    root2 mit openSuSE42.3
    /home mit den Home-Verzeichnissen

    Dann gibt es zwei (!) home-Verzeichnisse:

    ls -ln

    drwxr-xr-x 85 1001 100 12288 Feb 7 14:36 ruediger
    drwxr-xr-x 38 1001 100 12288 Feb 7 14:36 goetz

    System 1 (openSuSE 13.1) hat in der /etc/passwd:
    goetz:x:1001:100:Ruediger Goetz:/home/ruediger:/bin/tcsh

    System 2 (openSuSE 42.3) hat in der /etc/passwd:
    goetz:x:1001:100:Ruediger Goetz:/home/goetz:/bin/tcsh



    Also noch mal die Frage:

    Wie sollen configs von /home/ruediger den Account von goetz von System 2 mit Home-Verzeichnis /home/goetz beeinflussen (/home/goetz ist bei der Installation von openSuse42.3 neu angelegt worden!)

    BTW: Ich bin schon seit Jahren so vorgegangen beim Update auf eine neue Version (so ca seit SuSE 6.4 und davor linuxppc, mkLinux, ...)

    Ich denke eher, dass die Probleme irgendwo in der neuen Konfiguration lauern.

    Bis dann

    R"udiger

    Für den Inhalt des Beitrages 118383 haftet ausdrücklich der jeweilige Autor: rgoetz

  • Für das Home der User hast du in diesem Fall recht.

    Aber schön ist das nicht.
    Denn beide User können beide Homes verwüsten, was bei dir wohl eher nicht vorkommt.
    Aber dennoch garantiert dir niemand, dass z.B. in /tmp so manche Einstellung irgendwelcher Programme nicht übergreift.
    Dort finden sich Einstellungen von "Userdaemons", die natürlich kraft uid aus Sicht des Systems nicht zu unterscheiden sind. Die werden dann halt von zwei ziemlich verschiedenen Versionen beackert.
    Wird das /tmp nicht bei jedem Boot gelöscht, hast du damit eine Quelle für sehr subtile Fehler, die wohl außerordentlich schwierig zu finden sind.
    (Ich halte die Wahrscheinlichkeit, dass dich das trifft, für ziemlich gering. Aber auszuschließen ist das nicht.)

    Und verwende bitte für Befehle und deren Ausgaben Code-Tags. Im Editor der </> Button.
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 118388 haftet ausdrücklich der jeweilige Autor: Berichtigung