Tumbleweed: Dateien veschwinden spontan

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Tumbleweed: Dateien veschwinden spontan gibt es 31 Antworten auf 4 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Tumbleweed: Dateien veschwinden spontan

    Liebes Forum,

    Tumbleweed, aktuell gehalten (inkl. Kernel), / und /home jeweils ext4 auf separaten Partitionen.

    erstmals Ende Dezember, Mitte Januar und gestern Abend sind von der /home Dateien verschwunden. Dabei werden Verzeichnisse komplett geleert, die Verzeichnisstruktur bleibt aber erhalten. Manchmal bleiben Dateien mit 0 byte stehen, oder es gibt ein Muster, dass alle Dateien > 50 Kbyte mit 0 Byte stehen, die Dateien < 50 Kbyte aber erhalten bleiben.

    Alle Verzeichnisse, in denen das passiert, bzw. alle Dateien mit 0 Byte haben dann ein charakteristisches Datum (z.B.18.02.18 22:45). Die Wiederherstellung der Daten erfolgt händisch aus einem korrupten Déjà Dup Archiv, was kompliziert ist und mich an meiner Backupstrategie bzw. Déjà Dup zweifeln lässt.

    Mein Frau glaubt an einen Virus. Aber das halte ich für unwahrscheinlich. Ich glaube, Baloo könnte dafür in Frage kommen, denn mit dem Verschwinden der Dateien war immer eine höhere Latenz und Festplattenaktivität beobachtet worden, wie sie mit dem Baloo File Indexer einhergeht. Das habe ich auch in der Task-Liste gesehen. Ausserdem scheint die Löschung systematisch zu erfolgen: Es sind nur sichtbare Verzeichnisse betroffen und scheinbar in alphabetischer Reihenfolge. Zum Glück betrifft die Löschung auch nicht die ganze Festplatte.

    Leider finde ich im Netz keinerlei Hinweise, auch bei bugs.kde.org nicht. Wie komme ich hier weiter? Ich überlege, die Daten zu sichern und das System neu aufzusetzen.

    Danke für sachdienliche Hinweise

    Für den Inhalt des Beitrages 118435 haftet ausdrücklich der jeweilige Autor: altamira

  • Welche Repositories hast du denn eingebunden und wie hältst du dein System auf dem aktuellen Stand (Update)?

    Für den Inhalt des Beitrages 118437 haftet ausdrücklich der jeweilige Autor: Trekkie00

  • Hallo Trekkie00,

    1) Aktualisierung mit zypper up (bzw. via Softwareupdater in der Taskleiste) und regelmässiges zypper dup (ca. 1 x Woche)
    2) Standard-(TW-)Repos, zusätzlich wenige Spezialrepos wie: mozilla, ecsos, packman. Alle natürlich in der Tumbleweed-Version.

    Für den Inhalt des Beitrages 118438 haftet ausdrücklich der jeweilige Autor: altamira

  • Update bei Tumbleweed läuft nicht über
    zypper up, sondern ausschließlich über
    zypper dup
    Kann auch in Tumbleweed Dokumentation nachgelesen werden und sollte jemanden der das einsetzt auch bekannt sein.
    Eigentlich hätte ich hier gerne die Ausgabe von z. B.
    zypper lr -uP
    gesehen, um tatsächlich alle Details zu sehen (URL, Prioritäten usw). Auch das sollte jemand, der ein System für erfahrene Nutzer einsetzt, bei der Fragestellung eigentlich wissen. Deine Angabe gibt so gut wie Null Information.

    Mein Tipp : Neuinstallation der stabilen aktuellen 43er Version von openSUSE. Aber vorher alle wichtigen Daten und Konfigurationsdateien sichern.

    Für den Inhalt des Beitrages 118439 haftet ausdrücklich der jeweilige Autor: Trekkie00

  • Hallo Trekkie00

    Danke für die Rückmeldung. Das System ist ein Produktivsystem, von daher ist Dein Tipp, von Tumbleweed zurück auf 43.3 zu gehen, sicher richtig. Mit TW bin ich halt jahrelang gut gefahren... Wäre ein Neuanfang mit der neuen 15.0 nicht die bessere Option?

    zypper lr -uP

    konnte ich nicht machen, weil ich nicht an dem Linux-Rechner sitze.

    Mich interessiert vor allem, warum einfach Dateien verschwinden.

    Viele Grüsse

    Für den Inhalt des Beitrages 118442 haftet ausdrücklich der jeweilige Autor: altamira

  • Ist sehr schwierig zu beantworten. Die Gründe dafür können sehr vielfältig sein. Vielleicht ein selbst erstelltes fehlerhaftes Skript das automatisch ausgeführt wird, Zugriff eines zweiten Users der nicht ganz genau weiß, was er tut o.ä. Fehler im Kernel oder Dateisystemtreiber würde ich ausschließen wollen. In dem Fall würden die mailing Listen überlaufen.
    Die Frage ob ein Einstieg mit der 15er Version besser wäre würde ich in verneinen. Installiere die aktuelle 43er und Upgrade dann auf 15. Anleitungen dazu findest du einige. Ist nicht wirklich schwierig.

    Für den Inhalt des Beitrages 118443 haftet ausdrücklich der jeweilige Autor: Trekkie00

  • altamira schrieb:

    Wäre ein Neuanfang mit der neuen 15.0 nicht die bessere Option?
    Das was jetzt erhältlich ist, ist eine frühe Beta-Version. Bis es offiziell veröffentlicht wird, dauert noch bis Mai.
    Also auch meine Empfehlung, nimm OpesSuse 42.3. Ist bis Januar 2019 unterstützt.

    Für den Inhalt des Beitrages 118452 haftet ausdrücklich der jeweilige Autor: ThomasS

  • Sauerland schrieb:

    defekte Hardware?
    Hab ich mir auch überlegt, aber dann sollte davon auch / betroffen sein. Ich denke da ist was anderes faul.

    Für den Inhalt des Beitrages 118454 haftet ausdrücklich der jeweilige Autor: Trekkie00

  • Erst ma gucken, was da lost ist.
    Das klingt für mich eher, wie ein Problem mit dem Filesystem.

    Mach ma ein fsck.ext4 /dev/xxx
    Dafür darf das FS nicht gemountet sein:
    (Im folgenden ist "xxx" mit der passenden Bezeichnung zu ersetzen)

    Shell-Script

    1. # erst ma root werden
    2. su
    3. # in Runlevel 3 gehen
    4. init 3
    5. # jetzt als root anmelden
    6. # es erscheint der login prompt
    7. # root tippen, enter drücken
    8. # uns Spasswort blind eingeben.
    9. umount /dev/xxx
    10. fsck.ext4 /dev/xxx
    Alles anzeigen
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 118457 haftet ausdrücklich der jeweilige Autor: Berichtigung