Uefi Linux bootet nicht selbständig

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Uefi Linux bootet nicht selbständig gibt es 45 Antworten auf 5 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Uefi Linux bootet nicht selbständig

    Hallo,

    ich habe folgendes Problem.
    Linux bootet nicht selbstständig, das heißt, wenn ich keine CD mit Bootloader im CD-Laufwerk habe, kann ich Linux nicht booten. Es wird immer das auf einer anderen SSD installierte Windows gebootet.
    Wenn ich bei dem CD Bootloader von HDD booten auswähle, wird der grafische Linux Bootloader geladen und ich kann zwischen Linux und Windows auswählen.
    Im BIOS habe ich die Linux SSD bereits als erstes Bootmedium hinterlegt.
    Secure-boot ist aktiv, da sonst auch Windows nicht bootet.
    Auf beiden SSDs ist eine EFI-Partition angelegt.
    Wie gehe ich am besten vor, um GRUB 2 als Bootloader zu verwenden, und dort dann bei Bedarf Windows booten zu können?

    Für den Inhalt des Beitrages 119367 haftet ausdrücklich der jeweilige Autor: wacken

  • Überprüfe mal folgende Einstellungen im UEFI:
    Unter den Einstellungen für SATA sollte AHCI aktiviert sein - nicht RAID on!
    Außerdem sicherstellen, das CSM deaktiviert ist.
    be tolerant - not ignorant
    Alle Hunde sind schwarz.
    Es gibt einen Hund der nicht weiß ist.

    Für den Inhalt des Beitrages 119393 haftet ausdrücklich der jeweilige Autor: Boreas

  • wacken schrieb:

    Linux bootet nicht selbstständig, das heißt, wenn ich keine CD mit Bootloader im CD-Laufwerk habe, kann ich Linux nicht booten.
    Das deutet darauf hin, dass Linux bei aktiviertem CSM installiert wurde (muss aber nicht zwangsläufig sein).
    Wie sich das BIOS verhält, ist herstellerabhängig - es gibt hier keine klare einheitliche Regelung. Beispielsweise gibt es die Variante, das es unzulässig ist von einer Festplatte zu booten bei aktivierten CSM. Um dennoch zu booten, muss das Installationsmedium (CD oder USB-Stick) erreichbar sein. Der Bootloader des Mediums erkennt dann das OS der Festplatte, die ja bei aktiviertem CSM mit Linux bespielt wurde. Daher kann man genau von dieser jetzt auch booten. Natürlich ist bei diesem Beispiel es nicht möglich Windows 10 zu starten, da dieses nur bei deaktiviertem CSM zulässig ist. Dies ist im Übrigen eine vereinfachte Darstellung - die ganze Sache ist sehr komplex und überschreitet bei Weitem meinen Horizont. Übrigens, auch wenn Du denkst, Du hast CSM deaktiviert muss das nicht sein. Es gibt BIOS-Varianten, die selbstständig CSM aktivieren, je nachdem ob beim Bootprozess ein Bootloader an einem festgelegten Ort gefunden wird order eben nicht. Leider ist das alles nicht ganz trivial.
    be tolerant - not ignorant
    Alle Hunde sind schwarz.
    Es gibt einen Hund der nicht weiß ist.

    Für den Inhalt des Beitrages 119397 haftet ausdrücklich der jeweilige Autor: Boreas

  • Installiert habe ich Linux bei deaktiviertem CSM, zumindest habe ich es nicht extra aktiviert, da mir die Problematik bewusst war.
    Ich habe damals, bei der Installation auch schon geprüft, ob bei der Installation CSM aktiv war, kann man in Linux später noch feststellen, weiß jetzt aber nicht mehr wo. Bei der Installation musste ich auch einen Schlüssel für Secure-Boot festlegen.
    Ob ich das jetzt, aber richtig ausgelesen habe, oder ob sich das nach der Installation zum fertigen System doch noch ändert ist mir nicht klar.

    Kann ich aus folgendem (Wenn ich CSM aktiviere bootet auch Linux nicht. Es wurde eine EFI-Partition bei der Installation von Linux angelegt) nicht schließen, dass CSM bei der Installation deaktiviert war?
    Wenn meine Rückschlüsse nicht richtig sind, wie kann ich Linux/EFI-Partition verändern, dass ich von dem System booten kann?

    Für den Inhalt des Beitrages 119398 haftet ausdrücklich der jeweilige Autor: wacken

  • wacken schrieb:

    ...wird der grafische Linux Bootloader geladen und ich kann zwischen Linux und Windows auswählen.
    Die Platte mit Window ausbauen. Dann den Rechner nur mit Linux starten. Wenn das funktioniert die Platte mit Windows wieder einbauen.
    Jetzt sollte nur Linux starten. root-Terminal öffnen und update-grub eingeben.
    (Windows sollte nun erkannt werden.) Das Ergebnis hier posten.
    be tolerant - not ignorant
    Alle Hunde sind schwarz.
    Es gibt einen Hund der nicht weiß ist.

    Für den Inhalt des Beitrages 119399 haftet ausdrücklich der jeweilige Autor: Boreas

  • Wenn ich mich richtig erinnere, war die Lösung bei einem Freund:
    Die Reihenfolge der Hd`s im Bios/Uefi zu wechseln.

    Für den Inhalt des Beitrages 119401 haftet ausdrücklich der jeweilige Autor: Kanonentux

  • Ich habe die Windows SSD ausgebaut. Nun bekomme ich bei nicht eingelegter CD direkt eine Warnung, dass kein bootbares Medium vorhanden ist. Dies geschieht sehr schnell( Ich habe das Gefühl, dass nur nach der einen SSD gesucht wird und zusätzlich das CD-Laufwerk geprüft wird. Tauschen der Steckplätze ist leider nicht möglich, da unterschiedliche Anschlüsse).
    Booten mit CD funktioniert wie zuvor.

    Tauschen der Bootreihenfolge hilft nicht.

    Für den Inhalt des Beitrages 119417 haftet ausdrücklich der jeweilige Autor: wacken

  • Versuche Die Hd`s in Yast zu tauschen.
    Yast > Bootlader > Festplattenbootreihenfolge bearbeiten

    Für den Inhalt des Beitrages 119422 haftet ausdrücklich der jeweilige Autor: Kanonentux

  • wacken schrieb:

    Tauschen der Steckplätze ist leider nicht möglich, da unterschiedliche Anschlüsse
    Beschreibe mal ganz sauber wie Deine Hardware beschaffen ist.
    Was meinst Du mit anderem Anschluss? (Ist die SSD mit Windows etwa kein SATA? Oder schon PCI Express?)
    Das BIOS kommt von AMI, Award, Phoenix ... Evtl. ist es vom PC Hersteller angepaßt? Welche Versionsnummer?
    be tolerant - not ignorant
    Alle Hunde sind schwarz.
    Es gibt einen Hund der nicht weiß ist.

    Für den Inhalt des Beitrages 119429 haftet ausdrücklich der jeweilige Autor: Boreas

www.cyberport.de