Tumbleweed benutzt falsche Video Frequenz

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Tumbleweed benutzt falsche Video Frequenz gibt es 42 Antworten auf 5 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Tumbleweed benutzt falsche Video Frequenz

    Hallo miteinander,

    schon wieder ich :)

    Board: ASUS P4S800
    CPU: Intel Pentium4 3.0GHz HyperThreading --- 32bit i586/i686
    RAM: 3x 1GB Kingston DDR400
    Grafik: ATI Rage 128 Ultra
    Monitor: Belinea 101730 (alternativ auch "HP w2007v")


    Nachdem ich nun das Tumbleweed komplett installiert bekomme (mit F5 Kernel "Safe Settings") habe ich große Probleme mit der Video-Darstellung.

    Im Rechner ist eine alte ATI Rage 128 Ultra, die korrekt erkannt wird. Als Monitor ist es ein alter Belinea 101730 LCD-Screen, der ebenfalls korrekt erkannt wird. Das zeigt mir die "Hardware Information". 1280x1024 bei 60Hz (und auch bei 75Hz) sollte überhaupt kein Problem sein.

    Aber sobald ich mit Video "Default" installieren will, zeigt mir der Monitor nur noch "Video Frequenz zu hoch". Wenn ich dann zum Installieren Video auf 1024x768 einstelle, läuft der Monitor in dieser Auflösung korrekt, und ich kann prima installieren (im "Text Mode" kann ich natürlich auch installieren). Ich installiere schon nur ein reines Text-Mode-System als "Server", ohne grafische Oberfläche.

    Dennoch: sobald ich das installierte System das erstemal starten will, bekomme ich als einziges zu sehen "Video Frequenz zu hoch"!!!

    Wo kann ich in der Installation die Video-Parameter für 1280x1024 geeignet "konservativ" einstellen?

    Das System läuft derzeit "ohne eigenen Bildschirm", aber per ssh/slogin komme ich problemlos rein.

    Ein vorab installiertes openSUSE 11.2 (ich weiß, uralt), läuft völlig korrekt in hoher Auflösung 1280x1024 und steuert in X/KDE alles einwandfrei. Sogar ein an diese Grafikkarte angeschlossener HP-Monitor "w2007v" wird korrekt erkannt und völlig richtig mit 1680x1050 Auflösung lauffähig bedient.

    Wie kann ich im Textmodus statt im Grafikmodus booten?

    Was tun mit Tumbleweed? Warum stellt das flasch ein?

    Da ich über slogin "von ferne" reinkomme, kann ich auch das textbasierte YAST benutzen. Was muß ich tun?

    Vielen Dank für jeden guten Tipp,
    eimmas

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von eimmas ()

    Für den Inhalt des Beitrages 120645 haftet ausdrücklich der jeweilige Autor: eimmas

  • Es gibt Unterschiede zwischen dem reinen Textmodus und dem graphischen Modus.

    Startest du den Rechner im multi-user.target (Init3)?
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 120646 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Sauerland schrieb:

    Es gibt Unterschiede zwischen dem reinen Textmodus und dem graphischen Modus.

    Startest du den Rechner im multi-user.target (Init3)?
    Die Unterschiede sind klar. Dennoch scheint GRUB (oder wer auch immer) beim Booten Grafikkarte/Display vom ersten Moment an mit falschen Parametern anzusteuern (egal ob textmode oder grafikmode). Das bleibt dann so. Die ATI kann bis 1600x1200, aber der Belinea kann das nicht, der kann bis 1280x1024 bei 60/75. Tumbleweed erkennt den Monitor, aber was ist mit GRUB?

    Ich habe keine Chance, in irgendeiner Weise derzeit Startoptionen/-varianten auszuprobieren, gleich nach den BIOS-Messages ist Schluss. Ab dann nur noch "VIDEO FREQUENZ ZU HOCH" (die Meldung kommt vom Belinea selber, der im übrigen dann schwarz bleibt).

    So...

    Man muß ja das Problem einkreisen. Eines habe ich gefunden: Bei der Installation muß ich die Boot-Konfiguration ausdrücklich ändern, der AUTODETECT von GRUB2 macht den ersten Mist (GRUB2 erkennt bei dieser ATI Modi bis 1600x1200 und scheint letzteres einzustellen, aber logischerweise kann der Belinea das nicht). Wenn ich dort ausdrücklich 1024x768 eintrage (denn mit 1280x1024 geht auch das nicht), dann kriege ich einen vernünftigen Bootvorgang. Jetzt installiere ich damit gerade neu auf die Testdisk und bin gespannt, was dann der Login-Manager, der ja schon X ist, dann an Auflösung macht.

    Ihr hört von mir...
    eimmas

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von eimmas ()

    Für den Inhalt des Beitrages 120647 haftet ausdrücklich der jeweilige Autor: eimmas

  • So... ein bißchen weiter...

    Ich muß GRUB im Textmodus starten (640x480), dann bootet alles OK, und ich bekomme normale login-tty's.

    Wenn ich im Grafikmodus starte, dann fangen die tty's an, permanent die Grafikkarte neu einztustellen, was zu einem permanenten Blinken führt. Geht so nicht.

    Ich hatte testeshalber die ATI Rage 128 Ultra ausgetauscht gegen eine noch ältere ATI All-in-Wonder PCI-Karte (grottenlangsam), mit der konnte ich dann problemlos an der Konsole KDE starten mittels "startx". Und es kommt die völlig korrekte Auflösung von 1280x1024 bei 75Hz. So sollte das sein (außer, daß die Karte eben extrem langsam ist).

    ATI Rage 128 Ultra wieder drin, und "startx" führt wieder zu einer offensichtlich falschen Auflösung. Jetzt meldet der Monitor dabei wieder "Video Frequenz zu hoch". Ich gehe davon aus, daß jetzt wieder 1600x1200 versucht werden.

    So... wo kann ich das X-System so einstellen, daß er gesichert nur die 1280x1024 bei 60 oder 75Hz ansteuert?

    Dann gibt es auch erstmal wieder Ruhe vor mir... :)

    Vielen Dank,
    eimmas

    PS
    Immer diese alten Rechner, jajajajaja... bloß... openSUSE 11.2 macht/e das alles korrekt und ohne Probleme...

    Für den Inhalt des Beitrages 120648 haftet ausdrücklich der jeweilige Autor: eimmas

  • Also...

    ein Tag weiter (vertan?).

    GRUB2 muß im Textmodus starten, andernfalls gibt's Probleme mit jeglicher Grafik-Einstellung (es schaltet dann im Halbsekundentakt zwischen Konsole tty1 und Grafikkonsole 7 hin und her, und man kann gar nichts machen).

    Das heißt auch leider, ein grafisches Login ist nicht möglich (wäre für mich nicht soooo wichtig).
    Nach vollständigem Eintragen der Monitorparameter unter /etc/X11/xorg.conf.d/ in device, monitor und screen funktioniert X dann aber einwandfrei und super mit 1280x1024 bei 75 Hz.

    WARUM IN DREITEUFELSNAMEN ERKENNT SUSE/TUMBLEWEED DAS NICHT BEIM INSTALLIEREN? Der Monitor wird in der Hardware-Liste mit allen Parametern und Herstellernamen korrekt gelistet.

    openSUSE 11.2 konnte das auch problemlos.

    Trotzdem, so etwas nervt mich. Ehrlich...

    Heutige und endgültige Lösung: Von dem Rechner wurde Tumbleweed verbannt!
    Stattdessen wurde auf dem Rechner OpenBSD mit KDE installiert, schnell, problemlos, sicher und alles läuft auf Anhieb. ALSO... Geht doch!

    eimmas

    Für den Inhalt des Beitrages 120664 haftet ausdrücklich der jeweilige Autor: eimmas

  • Die Geschichte geht weiter...

    Nun habe ich den freigewordenen HP Compaq d530 (mit 4GB) und dem HP w2007v Monitor mit openSUSE Tumbleweed installiert.

    Alles lie problemlos, Installation ohne irgendwelche Parameter, Tumbleweed erkennt das alles korrekt. Auch der Monitor ist während der Installation sauber auf 1680x1050. Sieht richtig gut aus. So soll das eigentlich sein.

    Aaaaaaaber das Problem kam nach dem ersten Systemstart: Botten tut er korrekt mit dem Tumbleweed-Möbius-Band in 1680x1050-Auflösung, alles prima.

    Aber dann... ... ...
    Das grafische Login bleibt schwarz, aber der Mauszeiger ist korrekt da (auf dem schwarzen Screen), läßt sich korrekt bedienen, und dort, wo die login und passwort Felder (zu sehen) sein sollten, verändert er sich auch richtig in den Texteingabe-Cursor.

    Wenn ich mich blind einlogge, scheint auch das zu funktionieren, aber außer dem Mauspfeil gibt es weiterhin nichts zu sehen. Auf einer Textkonsole kann ich nachsehen, daß alle X-Prozesse korrekt laufen. Bildschirmansteuereung und Auflösung sind auch richtig, aber außer der Maus ist alles schwarz. Wenn ich den X-Process dann mit kill "abschiesse", dann blitzt der Bildschirm einmal weiß auf, und danach wieder schwarz mit Mauszeiger (login/password-Felder kann man (nur) am veränderten Mauszeiger erkennen/finden).

    Sowas habe ich noch nie erlebt.

    Was ist denn da los? Was muß ich jetzt noch einstellen?

    Vielen Dank für den nächsten Tipp,
    eimmas

    Für den Inhalt des Beitrages 120665 haftet ausdrücklich der jeweilige Autor: eimmas

  • Bei mir führte die Deinstallation von

    drm-kmp-default

    zum Erfolg.
    Zitat Albert Einstein:
    "Zwei Dinge sind unendlich, das Universum und die menschliche Dummheit,
    aber bei dem Universum bin ich mir noch nicht ganz sicher."

    Für den Inhalt des Beitrages 120667 haftet ausdrücklich der jeweilige Autor: sterun

  • sterun schrieb:

    Bei mir führte die Deinstallation von

    drm-kmp-default

    zum Erfolg.
    Wie/wo deinstalliere ich das?

    Die Grafik im HP/Compaq ist eine Intel 865G, die als HP-D530-sff gebranded ist.

    Installiert ist derzeit:

    intel-gpu-tools
    libdrm2
    libdrm_amdgpu1
    libdrm_intel1
    libdrm_nouveau2
    libdrm_radeon1
    libkms1
    libva-drm2

    Ein drm-kmp-default gibt es im Software-Management nicht.

    Aber irgendwie geht ja die Grafik, sonst würde ich keinen korrekten Mauszeiger sehen. Ich denke, es mag etwas sein mit Parametern für den X11-Server oder den (KDE-)Window-Manager???

    Danke,
    eimmas

    Für den Inhalt des Beitrages 120668 haftet ausdrücklich der jeweilige Autor: eimmas

  • Dieses Problem hat offensichtlich nichts mit Grafikchip und/oder Monitor zu tun. Der Xorg-Server läuft korrekt, ich habe in "50-screen.conf" verschiedene Auflösungen fest eingetragen durchgetestet, sie werden alle korrekt an den Monitor geliefert, immer mit funktionierendem Mauszeiger und sonst nix.

    Das Problem muß ein anderes sein...

    Was ist da los?

    Für den Inhalt des Beitrages 120669 haftet ausdrücklich der jeweilige Autor: eimmas

  • Hallo eimmas,

    ich gehe davon aus, dass du...
    zypper se -si drm intel
    eingegeben hast.

    Wenn ja, ist das Paket (drm-kmp-default), laut deines Ergebnisses, nicht installiert.

    Evtl. ist dieser Link von Nutzen:
    Die richtige Bildschirmauflösung einstellen ... zu Fuß
    Zitat Albert Einstein:
    "Zwei Dinge sind unendlich, das Universum und die menschliche Dummheit,
    aber bei dem Universum bin ich mir noch nicht ganz sicher."

    Für den Inhalt des Beitrages 120670 haftet ausdrücklich der jeweilige Autor: sterun