Qt5 runtime sauber "resetten"

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Qt5 runtime sauber "resetten" gibt es 18 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • CoBo schrieb:

    Download des Installers von qt.io - und ab die Post: da gibt's dann kein Repository, aber das Ding interferiert auch nicht mit der Standard-Version!
    Es gibt aber auch qt Repos......

    Und wenn du ein aktuelles Framework 5 benutzen möchtest ist qt 5.10 Pflicht:
    SDB:KDE repositories - openSUSE

    Aber das zu installieren ist einfach, rückgängig machen hat mich einen halben Nachmittag gekostet.

    Oder du installierst sofort Leap 15.0, das hat qt 5.9.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 120800 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Sauerland schrieb:

    Oder du installierst sofort Leap 15.0, das hat qt 5.9.
    Das könnte gelegentlich die Lösung sein!

    Preisfrage: Läuft VMWare damit?

    Das war mal der Grund warum ich von "Tumbleweed" ("cool - immer das Neueste!") auf "Leap" gewechselt habe: keinen Schritt weiter gehen solange deine wichtigsten "Teile" nicht mitgezogen haben! Und dazu gehört eben VMWare bei mir.

    QtCreator, git & co. sind hingegen ja wohl überall und immer irgendwie zum laufen zu bekommen - wenn man sich nicht (so wie ich!) SEHR viel Mühe gibt sie zu vermurksen! ;)

    Für den Inhalt des Beitrages 120801 haftet ausdrücklich der jeweilige Autor: CoBo

  • So weit ich weiss, läuft vmware mit Kernel 4.16, also sollte Kernel 4.12 kein Problem sein.

    Alternativ:
    Übrigens wird Virtualbox von openSUSE mitgeliefert, ist im OSS Repo.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 120802 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Danke für die vielen Tipps: Da komme ich jetzt sicher wieder weiter! Schritt für Schritt, zumal meine wichtigsten Sachen jetzt ja erst mal wieder laufen (ausser openshot, aber das ist nicht ganz lebenswichtig: hab auch noch Blender...)

    Die Alternative mit Virtualbox habe ich tatsächlich schon vor VMWare ausprobiert, aber da drin kam mein Windows 10 nicht richtig an eine gute OpenGL-Version. Und die brauche ich wiederum weil ich auf dem Rechner Entwicklung für "ParaView" betreibe welches an OpenGL gewisse Anforderungen stellt - und Window ist an diesem Punkt selber ja erschreckend schwach...

    So kann ich jetzt auf dem gleichen Rechner die Entwicklung für zwei Plattformen betreiben, wobei der Sourcecode einfach per git ausgetauscht wird. Funktioniert erstaunlich gut!

    Für den Inhalt des Beitrages 120803 haftet ausdrücklich der jeweilige Autor: CoBo

  • CoBo schrieb:

    Die Alternative mit Virtualbox habe ich tatsächlich schon vor VMWare ausprobiert, aber da drin kam mein Windows 10 nicht richtig an eine gute OpenGL-Version. Und die brauche ich wiederum weil ich auf dem Rechner Entwicklung für "ParaView" betreibe welches an OpenGL gewisse Anforderungen stellt - und Window ist an diesem Punkt selber ja erschreckend schwach...
    ohne etwas zu versprechen: KVM/qemu ist nicht nur in den OS-Repos sondern in sogar in Yast integriert.
    Zwar nicht so verbreitet wie VB aber top-performant. Vielleicht auch für dich geeignet.

    Ich habe damit schon mehrere VMWare-Maschinen ohne Konversion zum Laufen bekommen.
    There's no place like 127.0.0.1

    Für den Inhalt des Beitrages 120806 haftet ausdrücklich der jeweilige Autor: wurzel99

  • Nochmals Danke für alle Tipps die ich hier bekommen habe!

    Inzwischen habe ich die Schritte wie in Posting # 10 alle durchgeführt - und das System läuft immer noch...! Mein ursprüngliches Problem mit Qt-Versionen ist zwar damit nicht gelöst - war aber auch nicht zu erwarten.

    Der Auslöser war ja ein nicht funktionieren wollendes openshot, aber statt dessen habe ich gelernt, meine kleinen Video-Schnitt-Probleme mit Blender zu lösen: Ich wusste zwar dass der das auch "ein wenig" kann, aber nicht dass er es tatsächlich sogar SEHR GUT kann!

    Gelegentlich wird dann ja wohl auch noch der Update auf Version 15 mal fällig - und da werde ich dann mal wieder das Qt-Versionen-Problem angehen. Ansonsten reicht es mir so wie es jetzt "irgendwie" läuft.

    Beim Versionsupdate muss ich dann schauen ob der dann tatsächlich meine vermurkste System-Version (5.6.2) in eine nicht mehr vermurkste 5.9 oder 5.10 "verwandeln" kann - die ich dann auch gleich noch für mein Software-Projekt verwenden kann...

    Für den Inhalt des Beitrages 120964 haftet ausdrücklich der jeweilige Autor: CoBo