Apache 2.4 und mod_auth_dbd

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Apache 2.4 und mod_auth_dbd gibt es 4 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • Apache 2.4 und mod_auth_dbd

    Eigentlich nutzte ich bis Leap 42.3 das Apache Modul apache2-mod_auth_mysql für die Basic Authentifizierung über MySQL. Das lief ganz gut und sehr stabil. Da es dieses Modul mit Leap-15 nicht mehr gibt vursuchte ich mich am "neuen" Standard mod_authn_dbd


    Die benötigten Module sind zwar bereits standardmässig installiert, müssen aber in /etc/sysconfid/apache2 noch zu den Modulen hinzugefügt werden, also habe ich dort "mod_dbd mod_authn_dbd" ergänzt.


    Danach dei Konfiguration von hier übernommen:
    mod_authn_dbd - Apache HTTP Server Version 2.4
    (natürlich mit mysql)


    Anschliessend mäkelte apachectl configtest folgendes:


    AH00526: Syntax error on line 34 of /etc/apache2/vhosts.d/myconfig.conf:
    Can't load driver file apr_dbd_mysql.so

    Ok, stimmt - der ist nicht dabei, also installieren mit:
    zypper in libapr-util1-dbd-mysql

    Danach war der Treiber wie erwartet unter /usr/lib64/apr-util-1/ verfügbar


    ll /usr/lib64/apr-util-1/
    total 80
    -rwxr-xr-x 1 root root 14896 May 15 18:14 apr_crypto_openssl-1.so
    lrwxrwxrwx 1 root root 23 May 15 18:14 apr_crypto_openssl.so -> apr_crypto_openssl-1.so
    -rwxr-xr-x 1 root root 23096 May 15 18:14 apr_dbd_mysql-1.so
    lrwxrwxrwx 1 root root 18 May 15 18:14 apr_dbd_mysql.so -> apr_dbd_mysql-1.so
    -rwxr-xr-x 1 root root 10368 May 15 18:14 apr_dbm_db-1.so
    lrwxrwxrwx 1 root root 15 May 15 18:14 apr_dbm_db.so -> apr_dbm_db-1.so
    -rwxr-xr-x 1 root root 10464 May 15 18:14 apr_ldap-1.so
    lrwxrwxrwx 1 root root 13 May 15 18:14 apr_ldap.so -> apr_ldap-1.so


    Leider mäkelt aber apachectl configtest immer noch

    AH00526: Syntax error on line 34 of /etc/apache2/vhosts.d/myconfig.conf:
    Can't load driver file apr_dbd_mysql.so

    Habe ich was übersehen oder ist das ein Bug den ich via Bugzilla melden sollte?

    Für den Inhalt des Beitrages 120846 haftet ausdrücklich der jeweilige Autor: wn48z

  • Apache 2.4 und mod_auth_dbd

    Pfadprobleme?

    Gesendet von meinem SM-T530 mit Tapatalk

    Für den Inhalt des Beitrages 120847 haftet ausdrücklich der jeweilige Autor: Alero

  • Auf Zeile 34 im Conffile steht:

    DBDriver mysql

    Für den Inhalt des Beitrages 120848 haftet ausdrücklich der jeweilige Autor: wn48z

  • Ich bin insofern weitergekommen, dass das Problem nicht auftritt wenn man libapr-util1-dbd-pgsql installiert und dann
    DBDriver pgsql
    einträgt. Scheint also ein Problem mit libapr-util1-dbd-mysql zu sein. Der Installationsort beider Erweiterungen ist identisch (/usr/lib64/apr-util-1).


    Ich habe mal bei openSuSE einen Bug eröffnet - aber das wird wohl wieder ewig gehen bis da eine Antwort kommt - beim letzten Ticket dauerte es bis zum ersten Feedback 4 Monate :)

    Für den Inhalt des Beitrages 120866 haftet ausdrücklich der jeweilige Autor: wn48z

  • Der Bugfix ist nun seit dem 25.10.2018 in den Update Repos von Leap 15 verfügbar.

    apr-util-1.6.1-lp150.3.3.1

    Für den Inhalt des Beitrages 125896 haftet ausdrücklich der jeweilige Autor: wn48z