Leap 15 will anscheinend keine VirtualBox

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Leap 15 will anscheinend keine VirtualBox gibt es 15 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Leap 15 will anscheinend keine VirtualBox

    Hallo,
    ich wieder einmal. :)

    OpenSUSE Leap 15.0, installiert am Freitag, den 25.05.2018 abends, will scheinbar kein VirtualBox in sich haben. :)

    Folgendes habe ich versucht:

    1. Repo einbinden: http(s)://download.virtualbox.org/virtualbox/rpm/opensuse/42.1/ Virtualbox-Repo (Link auf 13.2). Das hat bei 42.x funktioniert.
    Das Repo wird nicht akzeptiert.

    2. RPM von Oracle downloaded und nach /opt/RPMs/ (lokales Repo-Verzeichnis) kopiert. Das hat bisher auch immer funktioniert.
    Hier wird eine fehlende Abhängigkeit namens libvpx.so.1()(64bit) bemängelt, die nirgens existiert (auch mit Anbieterwechsel erlaubt nicht) . Eine libvpx.so.4 existiert in /usr/lib64/.

    3. Das in SUSE integrierte Virtualbox habe ich noch nie richtig zum Laufen bekommen, das Problem mit USB.
    Ich habe es trotzdem probiert. Hier soll ein Kernel-Downgrade gemacht werden, von 1.12.14-lp150.12.4.1 auf .....11.4. Aber was passiert dann, wenn der Kernel wieder updatet wird?

    Hat jemand eine Idee?
    Soll ich noch ein paar Updates abwarten?
    Ist das sonst noch jemandem aufgefallen?

    Viele Grüße
    Wolle
    Hauptsystem: ASUS Z170 A - i5 6600K mit intergr. Grafik HD 530 - 16 GB DDR4 - TechniSat SkyStar 2 (DVB-S2) (PCI-alte Rev.) - 2 x SSD (sda/sdb) - 2 x HD (sdc/sdd) - ext. HD per USB - SATA-DVD und IDE->USB-DVD (beide intern) - iiyama xub3490wqsu 34" 21:9 (3440x1440 matt) - Canon Pixma iP4000 und MX925 - HP Scanjet G4050 - Yamaha Verstärker mit Plattenspieler
    Freundin: Terra (Wortmann) i3 4160 mit intergr. Grafik - 8 GB RAM DDR3
    WZ-HTPC: i3 4130 mit intergr. Grafik - 8 GB RAM DDR3 - TechniSat SkyStar 2 (DVB-S2) (PCI-alte Rev.) - Logitech K400
    Lenovo T61: Core2Duo 2.2 Ghz - 4GB RAM

    Für den Inhalt des Beitrages 120895 haftet ausdrücklich der jeweilige Autor: Wolle1956

  • Ich würde es mal mit dem offiziellen Leap-15 Virtualbox Repo versuchen:

    Quellcode

    1. zypper ar https://download.opensuse.org/repositories/Virtualization/openSUSE_Leap_15.0/ openSUSE-Leap-15.0-Virtualbox

    Zur Info:
    Show Virtualization / virtualbox - openSUSE Build Service

    Möglicherweise sind die USB Probleme die Du hattest in der offiziellen Version nun nicht mehr vorhanden - ein Versuch schadet nie.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von wn48z ()

    Für den Inhalt des Beitrages 120898 haftet ausdrücklich der jeweilige Autor: wn48z

  • wn48z schrieb:

    Ich würde es mal mit dem offiziellen Leap-15 Virtualbox Repo versuchen:

    Quellcode

    1. zypper ar https://download.opensuse.org/repositories/Virtualization/openSUSE_Leap_15.0/ openSUSE-Leap-15.0-Virtualbox


    Zur Info:
    Show Virtualization / virtualbox - openSUSE Build Service

    Möglicherweise sind die USB Probleme die Du hattest in der offiziellen Version nun nicht mehr vorhanden - ein Versuch schadet nie.
    Ist nicht offitziell, eher semioffiziell....

    Braucht man auch nicht, Virtualbox ist im OSS Repo:


    Quellcode

    1. zypper in virtualbox virtualbox-qt virtualbox-host-kmp-default
    PS:
    Es gibt kein Problem mit USB, man muss nur Hand anlegen:

    From openSUSE 11.4 on USB devices attached to the host can be used in guest operating systems after removing the '#' character in the last 2 lines of /etc/udev/rules.d/60-vboxdrv.rules. After a reboot USB support will work. Please consider the security risks this might cause.

    VirtualBox - openSUSE

    So sieht das dann bei mir aus:

    Quellcode

    1. cat /etc/udev/rules.d/60-vboxdrv.rules
    2. KERNEL=="vboxdrv", NAME="vboxdrv", OWNER="root", GROUP="root", MODE="0600"
    3. KERNEL=="vboxdrvu", NAME="vboxdrvu", OWNER="root", GROUP="root", MODE="0666"
    4. KERNEL=="vboxnetctl", NAME="vboxnetctl", OWNER="root", GROUP="root", MODE="0600"
    5. SUBSYSTEM=="usb_device", ACTION=="add", RUN+="/usr/lib/virtualbox/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass}"
    6. SUBSYSTEM=="usb", ACTION=="add", ENV{DEVTYPE}=="usb_device", RUN+="/usr/lib/virtualbox/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass}"
    7. SUBSYSTEM=="usb_device", ACTION=="remove", RUN+="/usr/lib/virtualbox/VBoxCreateUSBNode.sh --remove $major $minor"
    8. SUBSYSTEM=="usb", ACTION=="remove", ENV{DEVTYPE}=="usb_device", RUN+="/usr/lib/virtualbox/VBoxCreateUSBNode.sh --remove $major $minor"
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 120899 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Das geht aber nur wenn man den "out of the box" Kernel benutzt. Der kommt aber nicht mit meiner Tastaurbeleuchtung klar (und noch andere Gründe) ;) daher hab ich Kernel-Stable, sprich 4.16.12.
    Und da hab ich VB bisher auch noch net zum Laufen bekommen, bin aber noch am basteln. Nu erstmal die anderen Baustellen, gibt noch paar Ungereimtheiten unter 15.0.
    Systeminfo:
    ASUS FX753VE Laptop
    Prozessor: Intel Core i7-7700HQ
    RAM: 16GB
    Festplatte: 2x 1TB HDD + 128GB SSD (alles LVM, außer Hybrid-Partitionen)
    Grafikkarte: integrated Intel® HD Graphics 630
    NVIDIA® GeForce® GTX1050 Ti 4GB
    mit Bumblebee ohne bbswitch
    Betriebssysteme: SSD: Leap 15.0 Plasma 5.12.6 Kernel 4.18.x
    HDDs: Windows 10 (zum zocken) und mehrere Linux-Distries (nativ und in VM's)

    SoC:
    Odroiod C2, Armbian 5.60(Debian 9 (Stretch)) Headless

    Linux is like a wigwam, no windows, no gates and an apache inside dancing samba :thumbsup:

    Für den Inhalt des Beitrages 120900 haftet ausdrücklich der jeweilige Autor: McFlyers

  • McFlyers schrieb:

    Das geht aber nur wenn man den "out of the box" Kernel benutzt. Der kommt aber nicht mit meiner Tastaurbeleuchtung klar (und noch andere Gründe) ;) daher hab ich Kernel-Stable, sprich 4.16.12.
    Und da hab ich VB bisher auch noch net zum Laufen bekommen, bin aber noch am basteln. Nu erstmal die anderen Baustellen, gibt noch paar Ungereimtheiten unter 15.0.
    Index of /repositories/Kernel:/stable:/KMP/standard
    Hier auf Leap 42.3:

    Brainfuck-Quellcode

    1. zypper se -si virtualbox
    2. Metadaten von Repository 'Sauerland-Programme' abrufen ..........................................[fertig]
    3. Cache für Repository 'Sauerland-Programme' erzeugen .............................................[fertig]
    4. Repository-Daten werden geladen...
    5. Installierte Pakete werden gelesen...
    6. S | Name | Typ | Version | Arch | Repository
    7. ---+-----------------------------+-------+--------------------------------+--------+------------------
    8. i+ | virtualbox | Paket | 5.2.12-3.4 | x86_64 | kernel-stable-kmp
    9. i+ | virtualbox-host-kmp-default | Paket | 5.2.12_k4.16.12_1.g39c7522-3.4 | x86_64 | kernel-stable-kmp
    10. i+ | virtualbox-qt | Paket | 5.2.10-399.4 | x86_64 | Virtualization
    11. i+ | virtualbox-websrv | Paket | 5.2.12-3.4 | x86_64 | kernel-stable-kmp
    Alles anzeigen
    virtualbox-qt aus Kernel-stable-kmp funktioniert nicht, daher das aus dem Virtualization Repo.....


    Sollte aber bei Leap 15.0 kein Problem darstellen.....
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 120906 haftet ausdrücklich der jeweilige Autor: Sauerland

  • wn48z schrieb:

    Ich würde es mal mit dem offiziellen Leap-15 Virtualbox Repo versuchen:

    Quellcode

    1. zypper ar https://download.opensuse.org/repositories/Virtualization/openSUSE_Leap_15.0/ openSUSE-Leap-15.0-Virtualbox

    Zur Info:
    Show Virtualization / virtualbox - openSUSE Build Service

    Möglicherweise sind die USB Probleme die Du hattest in der offiziellen Version nun nicht mehr vorhanden - ein Versuch schadet nie.
    Das gibt es nicht mehr: Objekt nicht mehr verfügbar!
    Den gibt es, aber ich glaube, der hat nix mit VBox zu tun:

    Quellcode

    1. http://download.opensuse.org/repositories/Virtualization/openSUSE_Leap_15.0/Virtualization.repo
    Ich werde es mal überprüfen.


    @Sauerland

    Das aus dem OSS-Repo will einen Kernel-Downgrade, schaue bitte nochmal unter Punkt 3.
    Deine Links werde ich mir aber ansehen. Hoffentlich ist das einfaches Englisch. :) Danke.


    McFlyers schrieb:

    Das geht aber nur wenn man den "out of the box" Kernel benutzt. Der kommt aber nicht mit meiner Tastaurbeleuchtung klar (und noch andere Gründe) ;) daher hab ich Kernel-Stable, sprich 4.16.12.
    Und da hab ich VB bisher auch noch net zum Laufen bekommen, bin aber noch am basteln. Nu erstmal die anderen Baustellen, gibt noch paar Ungereimtheiten unter 15.0.
    Den habe ich unter 42.3 und auch noch die 4 Repos KDE5 und Mozilla. Das lief alles bestens (einschl. Oracle VBox) bis eine Woche vor dem Erscheinen von 15.0. Seit dem Update ist kwin kaputt.
    Egal jetzt sind wir bei 15.0, und da wollte ich alles wieder beim Standard belassen.

    Was ist ein Out-of-the-Box-Kernel. Ist das der Vanilla?

    Danke euch und Gruß
    Wolle
    Hauptsystem: ASUS Z170 A - i5 6600K mit intergr. Grafik HD 530 - 16 GB DDR4 - TechniSat SkyStar 2 (DVB-S2) (PCI-alte Rev.) - 2 x SSD (sda/sdb) - 2 x HD (sdc/sdd) - ext. HD per USB - SATA-DVD und IDE->USB-DVD (beide intern) - iiyama xub3490wqsu 34" 21:9 (3440x1440 matt) - Canon Pixma iP4000 und MX925 - HP Scanjet G4050 - Yamaha Verstärker mit Plattenspieler
    Freundin: Terra (Wortmann) i3 4160 mit intergr. Grafik - 8 GB RAM DDR3
    WZ-HTPC: i3 4130 mit intergr. Grafik - 8 GB RAM DDR3 - TechniSat SkyStar 2 (DVB-S2) (PCI-alte Rev.) - Logitech K400
    Lenovo T61: Core2Duo 2.2 Ghz - 4GB RAM

    Für den Inhalt des Beitrages 120907 haftet ausdrücklich der jeweilige Autor: Wolle1956

  • Wolle1956 schrieb:

    Das aus dem OSS-Repo will einen Kernel-Downgrade, schaue bitte nochmal unter Punkt 3.
    Deine Links werde ich mir aber ansehen. Hoffentlich ist das einfaches Englisch. Danke.
    Dann lass es doch downgraden, bei mir läuft es auch......
    Ist übrigens derselbe kernel........

    Und lass die Finger von kernel-stable.......
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 120908 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Sauerland schrieb:

    McFlyers schrieb:

    Das geht aber nur wenn man den "out of the box" Kernel benutzt. Der kommt aber nicht mit meiner Tastaurbeleuchtung klar (und noch andere Gründe) ;) daher hab ich Kernel-Stable, sprich 4.16.12.
    Und da hab ich VB bisher auch noch net zum Laufen bekommen, bin aber noch am basteln. Nu erstmal die anderen Baustellen, gibt noch paar Ungereimtheiten unter 15.0.
    Index of /repositories/Kernel:/stable:/KMP/standardHier auf Leap 42.3:

    Brainfuck-Quellcode

    1. zypper se -si virtualbox
    2. Metadaten von Repository 'Sauerland-Programme' abrufen ..........................................[fertig]
    3. Cache für Repository 'Sauerland-Programme' erzeugen .............................................[fertig]
    4. Repository-Daten werden geladen...
    5. Installierte Pakete werden gelesen...
    6. S | Name | Typ | Version | Arch | Repository
    7. ---+-----------------------------+-------+--------------------------------+--------+------------------
    8. i+ | virtualbox | Paket | 5.2.12-3.4 | x86_64 | kernel-stable-kmp
    9. i+ | virtualbox-host-kmp-default | Paket | 5.2.12_k4.16.12_1.g39c7522-3.4 | x86_64 | kernel-stable-kmp
    10. i+ | virtualbox-qt | Paket | 5.2.10-399.4 | x86_64 | Virtualization
    11. i+ | virtualbox-websrv | Paket | 5.2.12-3.4 | x86_64 | kernel-stable-kmp
    Alles anzeigen
    virtualbox-qt aus Kernel-stable-kmp funktioniert nicht, daher das aus dem Virtualization Repo.....


    Sollte aber bei Leap 15.0 kein Problem darstellen.....
    @Sauerland: Vielen Dank, funst und hat mir Zeit viel erspart!
    Systeminfo:
    ASUS FX753VE Laptop
    Prozessor: Intel Core i7-7700HQ
    RAM: 16GB
    Festplatte: 2x 1TB HDD + 128GB SSD (alles LVM, außer Hybrid-Partitionen)
    Grafikkarte: integrated Intel® HD Graphics 630
    NVIDIA® GeForce® GTX1050 Ti 4GB
    mit Bumblebee ohne bbswitch
    Betriebssysteme: SSD: Leap 15.0 Plasma 5.12.6 Kernel 4.18.x
    HDDs: Windows 10 (zum zocken) und mehrere Linux-Distries (nativ und in VM's)

    SoC:
    Odroiod C2, Armbian 5.60(Debian 9 (Stretch)) Headless

    Linux is like a wigwam, no windows, no gates and an apache inside dancing samba :thumbsup:

    Für den Inhalt des Beitrages 120910 haftet ausdrücklich der jeweilige Autor: McFlyers

  • Hallo auch,

    danke für die vielen Antworten.
    VirtualBox im OSS isr wohl nur etwas für die Profis hier, und das bin ich leider nicht.
    Ich warte mal Updates ab, ob sich da etwas ändert.

    Also erstmal danke.
    Gruß,
    Wolle
    Hauptsystem: ASUS Z170 A - i5 6600K mit intergr. Grafik HD 530 - 16 GB DDR4 - TechniSat SkyStar 2 (DVB-S2) (PCI-alte Rev.) - 2 x SSD (sda/sdb) - 2 x HD (sdc/sdd) - ext. HD per USB - SATA-DVD und IDE->USB-DVD (beide intern) - iiyama xub3490wqsu 34" 21:9 (3440x1440 matt) - Canon Pixma iP4000 und MX925 - HP Scanjet G4050 - Yamaha Verstärker mit Plattenspieler
    Freundin: Terra (Wortmann) i3 4160 mit intergr. Grafik - 8 GB RAM DDR3
    WZ-HTPC: i3 4130 mit intergr. Grafik - 8 GB RAM DDR3 - TechniSat SkyStar 2 (DVB-S2) (PCI-alte Rev.) - Logitech K400
    Lenovo T61: Core2Duo 2.2 Ghz - 4GB RAM

    Für den Inhalt des Beitrages 121053 haftet ausdrücklich der jeweilige Autor: Wolle1956