PXE-Boot crashes beim Laden des Kernels

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema PXE-Boot crashes beim Laden des Kernels gibt es 3 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • PXE-Boot crashes beim Laden des Kernels

    Hallo zusammen,

    ich wollte gerne openSUSE Leap 15.0 per PXELINUX auf mehreren Rechnern installieren. Beim Laden des Kernels sind nur noch bunte Felder mit Zeichen zu sehen, siehe Anhang. Tausche ich den Kernel durch den Kernel von Leap 42.3 aus, wird der Kernel normal geladen, wobei danach natürlich die Installation wegen unpassendes Kernels abbricht.

    Folgende Konfigurationen werden verwendet, wobei diese für Leap 42.3 perfekt funktionieren:

    Shell-Script

    1. # cat install-15.0
    2. default install
    3. label local
    4. localboot 0
    5. label install
    6. kernel linux-15.0
    7. append load_ramdisk=1 initrd=initrd-15.0 splash=0 install=nfs://111.111.11.11/suse/15.0/dvd autoyast=nfs://111.111.11.11/suse/15.0/config/autoyast.xml
    8. #sha256sum linux-15.0
    9. 30874ae145fbbedeb013dd9d55b1b518b11fc488e0de661d430d731e77b247b5 linux-15.0
    10. # sha256sum initrd-15.0
    11. 38e7544178a2a73f063ebb04baf9d6fb914482108d2fb9159d869f94049595c6 initrd-15.0
    Alles anzeigen
    Den richtigen Kernel und die richtige initrd nutze ich bereits, vgl. SHA256-Summe.

    Wo könnte das Problem liegen, wie könnte ich das Problem näher eingrenzen? Vielen Dank für die Mithilfe. Das Problem ist auf verschiedenen Architekturen und PCs reproduizierbar.

    Beste Grüße
    Niklas
    Bilder
    • PXELINUX.png

      414,61 kB, 713×520, 4 mal angesehen
    • BuntesFehlerbild.png

      643,72 kB, 707×525, 6 mal angesehen

    Für den Inhalt des Beitrages 121774 haftet ausdrücklich der jeweilige Autor: phanlipo

  • Das deutet darauf hin, dass du dein Bootimage auf dem PXELINUX nicht anständig konfiguriert hast.

    Leider lässt deine technisch magere, aber Alltagsprosa reiche Beschreibung keine vernünftige Aussage zu.
    Die __exakte__ Beschreibung der PXELINUX Konfiguration wäre nötig
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 121780 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • Welche Informationen würdest du denn gerne haben?

    Shell-Script

    1. # cat /etc/xinetd.d/tftp
    2. # default: off
    3. # description: The tftp server serves files using the trivial file transfer \
    4. # protocol. The tftp protocol is often used to boot diskless \
    5. # workstations, download configuration files to network-aware printers, \
    6. # and to start the installation process for some operating systems.
    7. service tftp
    8. {
    9. socket_type = dgram
    10. protocol = udp
    11. wait = yes
    12. user = root
    13. server = /usr/sbin/in.tftpd
    14. server_args = -s /data/software/autoinstall/tftpboot
    15. disable = no
    16. per_source = 11
    17. cps = 100 2
    18. flags = IPv4
    19. }
    Alles anzeigen

    Die pxelinux.0 Datei habe ich aus dem folgenden Paket extrahiert.

    Shell-Script

    1. # sha256sum pxelinux.0
    2. 6c911d7b93de4830beca906ed2112a9fcf82c356f999d89cbc085d75cdd6bc5f pxelinux.0

    Für den Inhalt des Beitrages 121785 haftet ausdrücklich der jeweilige Autor: phanlipo

  • Ich habe das Problem selbstständig lösen können. Die Benennung des Kernels mit "linux-15.0" macht aufgrund der Endung ".0" ein Problem. Durch Umbenennung zu z. B. "linux-150" funktioniert das Laden des Kernels einwandfrei.

    Vielen Dank für die Mühen.

    Für den Inhalt des Beitrages 122078 haftet ausdrücklich der jeweilige Autor: phanlipo