Mailprogramm geblockt durch Firewall/Proxy?

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Mailprogramm geblockt durch Firewall/Proxy? gibt es 6 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • Mailprogramm geblockt durch Firewall/Proxy?

    Hallo Leute,

    versuche mich nun schon etwas länger an der Einrichtung meiner externen Firewall und scheitere zur Zeit an dem Aufsetzen von Mailprogrammen.
    Ich habe für mein kleines Netzwerk eine externe Firewall (openSuSE 13.2) mit 2 Netzwerkkarten eingerichtet. Eine für das interne Netzwerk (LAN) und eine um ins Internet (WAN) zu gehen. Als Proxy mit definiertem Port benutze ich Squid und habe soweit auch alle Einstellungen getroffen damit auf allen PCs im Netzwerk ins Internet komme (Port-Freigabe, Proxy eingetragen, Firewall-Freigaben).
    Leider kann ich auf den PCs im Netzwerk jedoch keine Mails über Thunderbird empfangen und senden, da ein externer Mailserver nicht erreicht wird... Habe ich vllt irgendwo übersehen Ports freizuschalten? Habe probiert in der SuSEfirwall2 imaps pop3 und smtp ports (993,995,25) freizugeben aber das scheint leider nicht so einfach zu funktionieren.
    Stehe als Anfänger leider etwas auf dem Schlauch und hoffe ihr könnt mir weiterhelfen :)

    Liebe Grüße
    Bernie

    Für den Inhalt des Beitrages 122316 haftet ausdrücklich der jeweilige Autor: Hax0r64

  • squid hat mit Mailprotokollen nichts zu schaffen.

    Da du nicht aussagefähig beschreibst, welche Mailkonton du wo hast, wirst du ein wenig nachlesen müssen.
    Denn Mails werden, je nach Verwendung der beteiligten Programme und Konfiguration auf beiden Seiten mit folgenden Ports abgewickelt:
    (das sind Standardports; man kann sich daran halten, muss aber nicht)
    SMTP: #25 (unverschlüsselt & verschlüsselt) , 465 (nur SSL/TLS verschlüsselt), 587 (je nach Konfiguration beim Provider diverse Verfahren zur Verschlüsselung)
    IMAP: 143
    IMAPS: 993 nur TLS
    POP3: 110
    POP3S: 995 (SSL/TLS)
    und wie gesagt: Das wird wohl so sein, muss aber nicht. Entscheidend ist die tatsächliche Konfiguration deiner Provider.

    Ich nehme an, dass der Squid auf der Linuxkiste läuft, die Router spielt.
    Der kümmert sich hauptsächlich um HTTP*, ggf. wirst du dort FTP noch konfigurieren wollen.

    Was du mit Port-Freigabe, Proxy eingetragen, Firewall-Freigaben meinst, ist völlig unklar.
    Nicht sagen "Habe ich gemacht", sondern "habe in /etc/halligalli die Zeile irgendein=setting zu irgendein=anderesSetting" geändert.

    Um den Verkehr von KarteA zu KarteB weiterzuleiten,
    musst du in deiner Firewall das "Masquerading" einschalten.
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 122318 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • Hallo und danke für die schnelle Antwort!

    Mein Provider geht über IMAPS (Port 993 / SSL) und SMTP (Port 25 / STARTTLS), dies habe ich bei Thunderbird auch so eingestellt.

    Squid läuft auf dem Router, genau. Dort habe ich in etc/sysconfig/SuSEfirewall2 eingetragen:

    Quellcode

    1. FW_SERVICES_EXT_TCP="www 995 993 25"
    2. FW_SERVICES_INT_TCP="nameserver domain www 995 993 25"
    und zudem das Masquerading über einen PC (IP: 192.168.69.43) testweise folgendermaßen gesetzt:

    Quellcode

    1. FW_FORWARD_MASQ="134.2.0.0/16,192.168.69.43,tcp,993,993,134.2.69.3
    2. 134.2.0.0/16,192.168.69.43,tcp,995,995,134.2.69.3
    3. 134.2.0.0/16,192.168.69.43,tcp,25,25,134.2.69.3"
    Leider sagt mir Thunderbird, dass die Verbindung zum Mailserver nicht hergestellt werden kann. Ausgehende Mails über SMTP sind auch nicht möglich. Habe in Thunderbird den HTTP Proxy eingetragen und SSL und SOCKS leer gelassen. Internet funktioniert wie gesagt einwandfrei. Habe ich irgendetwas übersehen?

    Vielen Dank für die Hilfe!

    Für den Inhalt des Beitrages 122328 haftet ausdrücklich der jeweilige Autor: Hax0r64

  • Hax0r64 schrieb:

    Mein Provider geht über
    Welcher Provider?

    PS:
    Yast funktioniert auch als ncurses Version in der Konsole.........
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 122330 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Nochmal: Mail hat NICHTS, aber auch GAR NICHTS mit einem HTTP Proxy zu schaffen.
    Squid kann nur ein paar Protokolle, wie HTTP(S) und FTP.
    KEIN Mailprotokoll.

    Es sollte genügen, wenn die LAN Rechner die Linuxkiste als Gateway eingetragen haben.

    Wenn nicht:
    Beschreibe bitte genau die Topologie des Netzes. (Also welche Rechner in welchen LANs sind wie verkabelt? wo sitzt der WAN Router?)
    Beschreibe exakt, wie welche DNS/DHCP Server wie angesprochen und/oder konfiguriert sind.
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 122331 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • Danke für den tipp mit den DNS/DHCP Einstellungen. Habe bind installiert und die entsprechend Einstellungen im Forwarding bei etc/named.d vorgenommen. Jetzt scheint alles zu funktionieren!
    Vielen Dank für die Hilfe!

    Für den Inhalt des Beitrages 122342 haftet ausdrücklich der jeweilige Autor: Hax0r64

  • Es wird eigentlich schon erwartet, dass man in einem Supportforum sein Problem sorgfältig schildert
    UND
    die Lösung auch sorgfältig postet.

    Das hilft ja auch anderen.
    Was der Zweck einen Supportforums ist.

    Die open source Community lebt nicht vom "Ehy, mach ma für mich!", sondern vom gegenseitigen Geben & Nehmen.
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 122344 haftet ausdrücklich der jeweilige Autor: Berichtigung