Nach Installation von OpenSuse Leap 15.0 kann nur noch im Wiederherstellungsmodus gebootet werden

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Nach Installation von OpenSuse Leap 15.0 kann nur noch im Wiederherstellungsmodus gebootet werden gibt es 27 Antworten auf 3 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Teste mal diesen Treiber:

    Quellcode

    1. zypper in xf86-video-openchrome
    Natürlich als Root...

    Nachtrag:
    Sehe gerade, dass dieser schon installiert ist )-:
    Zitat Albert Einstein:
    "Zwei Dinge sind unendlich, das Universum und die menschliche Dummheit,
    aber bei dem Universum bin ich mir noch nicht ganz sicher."

    Für den Inhalt des Beitrages 123930 haftet ausdrücklich der jeweilige Autor: sterun

  • Ich seh' da keine Driver Zeile...

    Und hast du mal Sauerlands Rat mit LXDE probiert?
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 123951 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • Brainfuck-Quellcode

    1. OpenChrome DDX Version 0.6 Release Note (March 7th, 2017)
    2. ---------------------------------------------------------
    3. OpenChrome DDX is an open source implementation of X.Org Server
    4. DDX (Device Dependent X) graphics device driver for VIA Technologies
    5. UniChrome and Chrome9 IGPs. (Integrated Graphics Processor)
    6. OpenChrome DDX handles only 2D and video acceleration.
    7. Please note that OpenChrome does not support VIA Technologies IGPs
    8. that are related to Trident Microsystems (i.e., Apollo MVP4, PLE133,
    9. and KLE133) or S3 Graphics (i.e., KM266). Here is the project home
    10. page for OpenChrome.
    11. http://www.freedesktop.org/wiki/Openchrome/
    12. Please note that VIA Technologies does not support OpenChrome in any way.
    13. Supported Chipsets
    14. ------------------
    15. - CLE266
    16. - KM400(A) / KN400(A) / P4M800
    17. - K8M800 / K8N800
    18. - PM800 / PN800 / PM880 / CN333 / CN400
    19. - P4M800 Pro / VN800 / CN700
    20. - CX700 / VX700
    21. - P4M890 / VN890 / CN800
    22. - K8M890 / K8N890
    23. - P4M900 / VN896 / CN896
    24. - VX800 / VX820
    25. - VX855 / VX875
    26. - VX900
    27. Supported Features
    28. ------------------
    29. - VGA
    30. - DVI from an integrated TMDS transmitter (CX700, VX700, and VX800
    31. chipsets)
    32. - DVI from Silicon Image SiI 164 and VIA Technologies VT1632(A) TMDS
    33. transmitters
    34. - Flat Panel
    35. - EXA acceleration (RENDER acceleration)
    36. - Xv and XvMC
    37. - Dual monitor support
    38. Unproven Features
    39. -----------------
    40. - Standby resume
    41. - TV out
    42. - KMS support
    43. (Kernel Mode Setting; requires the use of still in
    44. development KMS supporting OpenChrome DRM. See "Where to Obtain
    45. OpenChrome Source Code" section for more details.)
    46. Unimplemented Features
    47. ----------------------
    48. - Hardware cursor support for CLE266, KM400(A) / KN400(A), and
    49. P4M800 chipsets
    50. - DVI via Chrontel TMDS transmitter
    51. - LVDS via VT1631 / VT1636 LVDS transmitter
    52. - External HDMI transmitter
    53. (i.e., Jetway J7F5M-VHE-LF motherboard, VIA Embedded EPIA-P720
    54. motherboard, etc.)
    55. - HDMI support for VX900 chipset
    56. (HDMI is supported via still in development KMS supporting
    57. OpenChrome DRM. See "Where to Obtain OpenChrome Source Code"
    58. section for more details.)
    59. - DisplayPort support for VX900 chipset
    60. OS Support
    61. ----------
    62. - X.Org Server Version 1.7 or later
    63. (It might not work correctly if it is compiled against an older
    64. X.Org Server.)
    65. - Linux Version 2.6.32 or later
    66. (Note: For Linux Version 4.5 or later, you may have to blacklist
    67. vesafb. This is a bug that has not been fixed so far.)
    68. What's New for OpenChrome DDX Version 0.6
    69. -----------------------------------------
    70. OpenChrome DDX Version 0.6 is an improved version of OpenChrome DDX
    71. Version 0.5 with a number of improvements made to the code. OpenChrome
    72. DDX Version 0.6 is written in a way to completely replace Version
    73. 0.2.904 through 0.5.
    74. OpenChrome DDX Version 0.6 has added the following new features.
    75. - First official support for CX700, VX700, and VX800 chipsets
    76. integrated TMDS transmitter (i.e., DVI support)
    77. - Initial support for Silicon Image SiI 164 TMDS transmitter
    78. OpenChrome DDX Version 0.6 has the following improvements.
    79. - Improved FP reinitialization when resuming from standby
    80. (HP 2133 Mini-Note, FIC CE260 / CE261 based netbooks like
    81. Everex CloudBook and Sylvania g netbook)
    82. - Improved automatic detection of display resources
    83. - Improved X Server stability in dual monitor mode
    84. - Automatic active steering of the display controller channel to the
    85. correct display output device
    86. OpenChrome DDX Version 0.6 fixes the following bugs.
    87. - Fix for the disruption of the VT (Virtual Terminal) screen bug
    88. introduced in Version 0.5
    89. - Fix for HP 2133 Mini-Note's PCIe WLAN getting turned off
    90. inadvertently bug introduced in Version 0.5
    Alles anzeigen
    Quelle: /usr/share/doc/packages/xf86-video-openchrome/README

    Daher wären auch die Ergebnisse von:

    Quellcode

    1. grep -Ei -B2 -A2 vesafb /etc/modprobe.d/50-blacklist.conf

    Quellcode

    1. dmesg | grep -Ei "vesa|chrome|open|via|s3"

    Quellcode

    1. grep -Ei "vesa|chrome|open|via|s3" /var/log/Xorg.0.log

    oder statt letzteren auch

    Quellcode

    1. grep -E "EE|WW" /var/log/Xorg.0.log

    eventuell nicht uninteressant.

    Für den Inhalt des Beitrages 123956 haftet ausdrücklich der jeweilige Autor: tomfa-ng

  • hier erst einmal die Antworten:

    linux-81d6:~ #grep -Ei -B2 -A2 vesafb /etc/modprobe.d/50-blacklist.conf
    # list all framebuffer drivers, some of them tend to crash during boot
    # they are either compiled into the kernel, or vesafbis active
    # X works fine without them, rcfbset can load them if really required
    # sed -e '/\/drivers\/video\/.*\.\(o\|ko\)$/{s@^.*/@@;s@\..*$@@;p};d'
    linux-81d6:~ #dmesg | grep -Ei "vesa|chrome|open|via|s3"
    [ 0.000000] ACPI: RSDP 0x00000000000F78C0 000014 (v00VIAK8M)
    [ 0.000000] ACPI: RSDT 0x000000007BEF3040 00002C (v01 VIAK8M AWRDACPI 42302E31 AWRD 00000000)
    [ 0.000000] ACPI: FACP 0x000000007BEF30C0 000074 (v01 VIAK8M AWRDACPI 42302E31 AWRD 00000000)
    [ 0.000000] ACPI: DSDT 0x000000007BEF3180 005396 (v01 VIAK8M AWRDACPI 00001000 MSFT 0100000E)
    [ 0.000000] ACPI: APIC 0x000000007BEF8580 000068 (v01 VIAK8M AWRDACPI 42302E31 AWRD 00000000)
    [ 0.117195] pci 0000:00:01.0: disabling DAC on VIAPCI bridge
    [ 0.120388] pci 0000:00:10.4: VIAVLink IRQ fixup, from 5 to 11
    [ 1.748645]vesafb: mode is 1366x768x32, linelength=5504, pages=0
    [ 1.748655] vesafb: scrolling: redraw
    [ 1.748663]vesafb: Truecolor: size=0:8:8:8, shift=0:16:8:0
    [ 1.748689] vesafb: framebuffer at 0xf0000000, mapped to 0xffffc90000800000, using 4160k, total 4160k
    [ 1.971513] fb0:VESAVGA frame buffer device
    [ 6.289273] sata_via0000:00:0f.0: version 2.6
    [ 6.289550] sata_via0000:00:0f.0: routed to hard irq line 11
    [ 6.329717] scsi host0: sata_via
    [ 6.366943] scsi host1: sata_via
    [ 8.126336] pata_via0000:00:0f.1: version 0.3.4
    [ 8.126556] pata_via0000:00:0f.1: VIAVLink IRQ fixup, from 255 to 10
    [ 8.162377] scsi host2: pata_via
    [ 8.194936] scsi host3: pata_via
    [ 22.294236] audit: type=1400 audit(1534689934.369:6): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/bin/lessopen.sh" pid=481 comm="apparmor_parser"
    [ 23.984534] via_rhine: v1.10-LK1.5.1 2010-10-09 Written by Donald Becker
    [ 24.046739] via-rhine 0000:00:12.0 eth0: VIARhine II at 0xffffc900004d5000, 00:19:db:bc:e4:90, IRQ 10
    [ 24.109746] via-rhine 0000:00:12.0 eth0: MII PHY found at address 1, status 0x786d advertising 01e1 Link 4de1
    [ 25.457723] snd_via82xx 0000:00:11.5: VIAVLink IRQ fixup, from 5 to 11
    linux-81d6:~ #grep -Ei "vesa|chrome|open|via|s3" /var/log/Xorg.0.log
    [ 75.907] Build Operating System: openSUSE SUSE LINUX
    [ 76.045] (**) |-->Screen "vesa" (4)
    [ 76.046] (**) | |-->Device "vesa"
    [ 76.046] (==) No monitor specified for screen "vesa".
    [ 76.201] (WW) Warning, couldn't openmodule vboxvideo
    [ 76.893] (II) LoadModule: "vesa"
    [ 76.893] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
    [ 76.902] (II) Module vesa: vendor="X.Org Foundation"
    [ 76.902] (II) VESA: driver for VESAchipsets: vesa
    [ 77.013] (EE) open/dev/dri/card0: No such file or directory
    [ 77.013] (EE) open/dev/dri/card0: No such file or directory
    [ 77.024] (II) FBDEV(0): hardware: VESAVGA (video memory: 4160kB)
    [ 77.113] (II) UnloadModule: "vesa"
    [ 77.113] (II) Unloading vesa
    [ 78.808] (II) config/udev: Adding input device (unnamed) (/dev/ttyS3)
    [ 78.809] (II) config/udev: Adding input device (unnamed) (/dev/ttyS30)
    [ 78.809] (II) config/udev: Adding input device (unnamed) (/dev/ttyS31)
    linux-81d6:~ #grep -E "EE|WW" /var/log/Xorg.0.log
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    [ 76.083] (WW) The directory "/usr/share/fonts/misc/sgi" does not exist.
    [ 76.201] (WW) Warning, couldn't open module vboxvideo
    [ 76.201] (EE) Failed to load module "vboxvideo" (module does not exist, 0)
    [ 77.013] (EE) open /dev/dri/card0: No such file or directory
    [ 77.013] (WW) Falling back to old probe method for modesetting
    [ 77.013] (EE) open /dev/dri/card0: No such file or directory
    [ 77.024] (EE) Screen 0 deleted because of no matching config section.
    [ 77.134] (EE) AIGLX: reverting to software rendering
    linux-81d6:~ #

    Ich habe mir zwar lxde installiert, ich weiß aber nicht, was das bringen soll. Wenn ich im Bootmenue den Defaultparameter wähle, stürzt der Rechner ab, ich komme gar nicht zu dem Anmeldemenue, bei dem ich lxde auswählen könnte. Es ist übrigens definitiv der Wiederherstellungsmodus, wo es dann auch funktioniert (auch Plasma) hier der entsprechende Eintrag in grub.cfg:

    menuentry 'openSUSE Leap 15.0, mit Linux 4.12.14-lp150.12.16-default (Wiederherstellungsmodus)' --hotkey=3 --class opensuse --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.12.14-lp150.12.16-default-recovery-8817d20a-f2bc-4d7f-9079-bfc59b0e555d' {
    load_video
    set gfxpayload=keep
    insmod gzio
    insmod part_msdos
    insmod ext2
    set root='hd0,msdos2'
    if [ x$feature_platform_search_hint = xy ]; then
    search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos2 --hint-efi=hd0,msdos2 --hint-baremetal=ahci0,msdos2 --hint='hd0,msdos2' 8817d20a-f2bc-4d7f-9079-bfc59b0e555d
    else
    search --no-floppy --fs-uuid --set=root 8817d20a-f2bc-4d7f-9079-bfc59b0e555d
    fi
    echo 'Linux 4.12.14-lp150.12.16-default wird geladen …'
    linux /boot/vmlinuz-4.12.14-lp150.12.16-default root=UUID=8817d20a-f2bc-4d7f-9079-bfc59b0e555d showopts apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe
    echo 'Initiale Ramdisk wird geladen …'
    initrd /boot/initrd-4.12.14-lp150.12.16-default
    }

    und das ist der Eintrag, bei dem es nicht funktioniert

    menuentry 'openSUSE Leap 15.0' --class opensuse --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-8817d20a-f2bc-4d7f-9079-bfc59b0e555d' {
    load_video
    set gfxpayload=keep
    insmod gzio
    insmod part_msdos
    insmod ext2
    set root='hd0,msdos2'
    if [ x$feature_platform_search_hint = xy ]; then
    search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos2 --hint-efi=hd0,msdos2 --hint-baremetal=ahci0,msdos2 --hint='hd0,msdos2' 8817d20a-f2bc-4d7f-9079-bfc59b0e555d
    else
    search --no-floppy --fs-uuid --set=root 8817d20a-f2bc-4d7f-9079-bfc59b0e555d
    fi
    echo 'Linux 4.12.14-lp150.12.16-default wird geladen …'
    linux /boot/vmlinuz-4.12.14-lp150.12.16-default root=UUID=8817d20a-f2bc-4d7f-9079-bfc59b0e555d resume=/dev/disk/by-id/ata-SAMSUNG_HD322HJ_S17AJ90SA68029-part1 splash=silent quiet showopts resume=/dev/disk/by-id/ata-SAMSUNG_HD322HJ_S17AJ90SA68029-part1 splash=silent quiet showopts resume=/dev/disk/by-id/ata-SAMSUNG_HD322HJ_S17AJ90SA68029-part1 splash=silent quiet showopts resume=/dev/disk/by-id/ata-SAMSUNG_HD322HJ_S17AJ90SA68029-part1 splash=silent quiet showopts resume=/dev/disk/by-id/ata-SAMSUNG_HD322HJ_S17AJ90SA68029-part1 splash=silent quiet showopts resume=/dev/disk/by-id/ata-SAMSUNG_HD322HJ_S17AJ90SA68029-part1 splash=silent quiet showopts resume=/dev/disk/by-id/ata-SAMSUNG_HD322HJ_S17AJ90SA68029-part1 splash=silent quiet showopts resume=/dev/disk/by-id/ata-SAMSUNG_HD322HJ_S17AJ90SA68029-part1 splash=silent quiet showopts resume=/dev/disk/by-id/ata-SAMSUNG_HD322HJ_S17AJ90SA68029-part1 splash=silent quiet showopts resume=/dev/disk/by-id/ata-SAMSUNG_HD322HJ_S17AJ90SA68029-part1 splash=silent quiet showopts resume=/dev/disk/by-id/ata-SAMSUNG_HD322HJ_S17AJ90SA68029-part1 splash=silent quiet showopts resume=/dev/disk/by-id/ata-SAMSUNG_HD322HJ_S17AJ90SA68029-part1 splash=silent quiet showopts resume=/dev/disk/by-id/ata-SAMSUNG_HD322HJ_S17AJ90SA68029-part1 splash=silent quiet showopts resume=/dev/disk/by-id/ata-SAMSUNG_HD322HJ_S17AJ90SA68029-part1 splash=silent quiet showopts resume=/dev/disk/by-id/ata-SAMSUNG_HD322HJ_S17AJ90SA68029-part1 splash=silent quiet showopts resume=/dev/disk/by-id/ata-SAMSUNG_HD322HJ_S17AJ90SA68029-part1 splash=silent quiet showopts
    echo 'Initiale Ramdisk wird geladen …'
    initrd /boot/initrd-4.12.14-lp150.12.16-default
    }

    Ich könnte jetzt zwar mit der Brechstange rangehen und den funktionierenden Eintrag über den Defaulteintrag kopieren, aber zum einen Mal weiß ich nicht, ob es da nicht noch andere Seiteneffekte gibt und zum anderen wüsste ich auch ganz gerne, warum es nicht funktioniert.

    Für den Inhalt des Beitrages 124004 haftet ausdrücklich der jeweilige Autor: ChristianB

  • Boote mal mit nomodeset:
    Grub2 zusätzliche Bootparameter einfügen

    Und benutze für Konsolenausgaben bitte separate Code-Tags, siehe unter diesem Text.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 124005 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Hat er schon:

    ChristianB schrieb:

    Die Einführung der zus. Bootparameters nomodeset führt zum gleichen Ergebnis.
    Kann es sein, dass es garnichts mit der Grafik zu tun hat?
    Es muss doch ein aussagekräftiges Protokoll geben.
    Du hast geschrieben, dass der Rechner unter Leap 42.3 lief und seit Leap 15 nicht.
    Hast du ein Upgrade gemacht oder neu installiert?
    Zitat Albert Einstein:
    "Zwei Dinge sind unendlich, das Universum und die menschliche Dummheit,
    aber bei dem Universum bin ich mir noch nicht ganz sicher."

    Für den Inhalt des Beitrages 124006 haftet ausdrücklich der jeweilige Autor: sterun

  • die zwei weiter unten funktionieren auch nicht, allerdings mit einem anderen Fehlerbild.

    Boote mal mit nem alten Kernel.......
    Und poste......…
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 124007 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Noch ein Versuch und schnell getestet:
    Grub - auf den aktuellen (nicht funktionierenden) Eintrag
    "e" zum Editieren
    und mach aus: splash=silent quiet showopts
    ein: splash=verbose
    Speichern und starten

    PS:
    Aber Sauerland geht vor
    Zitat Albert Einstein:
    "Zwei Dinge sind unendlich, das Universum und die menschliche Dummheit,
    aber bei dem Universum bin ich mir noch nicht ganz sicher."

    Für den Inhalt des Beitrages 124008 haftet ausdrücklich der jeweilige Autor: sterun

  • Und was ist mit:

    tomfa-ng schrieb:

    Brainfuck-Quellcode

    1. OS Support
    2. ----------
    3. - X.Org Server Version 1.7 or later
    4. (It might not work correctly if it is compiled against an older
    5. X.Org Server.)
    6. - Linux Version 2.6.32 or later
    7. (Note: For Linux Version 4.5 or later, you may have to blacklist
    8. vesafb. This is a bug that has not been fixed so far.)
    Quelle: /usr/share/doc/packages/xf86-video-openchrome/README
    ?


    ChristianB schrieb:

    linux-81d6:~ #grep -Ei -B2 -A2 vesafb /etc/modprobe.d/50-blacklist.conf
    # list all framebuffer drivers, some of them tend to crash during boot
    # they are either compiled into the kernel, or vesafbis active
    # X works fine without them, rcfbset can load them if really required
    # sed -e '/\/drivers\/video\/.*\.\(o\|ko\)$/{s@^.*/@@;s@\..*$@@;p};d'
    Da dem nicht so ist, könntest du das mal ausprobieren.
    Auf freedesktop.org/wiki/Openchrome/ ist auch was zu deaktivierten Module wegen Abstürze zu finden.

    Mich würden ja auch die Ausgaben ausgeführt unter openSUSE Leap 42.3 interessieren.

    Für den Inhalt des Beitrages 124010 haftet ausdrücklich der jeweilige Autor: tomfa-ng