Script um verbindung zu OpenVPN Server aufzubauen

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Script um verbindung zu OpenVPN Server aufzubauen gibt es 50 Antworten auf 6 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Script um verbindung zu OpenVPN Server aufzubauen

    Hallo,

    ich habe ein kleines Script geschrieben, welches eine Verbindung zu einem OpenVPN Server aufbauen soll und danach Netzlaufwerke mounten soll.
    Das Problem ist, dass ich das Konsolenfenster nicht schließen kann, wenn ich die Verbindung aufrecht erhalten will.
    Mit nohup klappt es überhaupt nicht mehr. Da ich hier noch nicht mal in der Lage bin das Passwort für den sudo Befehl eingeben kann.
    Wie muss ich das Script verändern, sodass sich eine Abfrage für das Passwort öffnet und nach Eingabe wieder schließt und die Verbindung aufgebaut und die Laufwerke gemountet sind.
    Vielen Dank.

    Shell-Script

    1. #!/bin/bash
    2. sudo openvpn --config /etc/openvpn/User1.conf
    3. sudo mount -a

    Für den Inhalt des Beitrages 124029 haftet ausdrücklich der jeweilige Autor: wacken

  • @wacken, 2 Dinge!
    1. sudo ist bei opensuse verpönt! Es wurde in der Vergangenheit bereits mehrere Male darauf hingewiesen, das man sudo in opensusue nicht benutzen soll! Stattdessen soll man su benutzen. Und komme mir jetzt nicht mit dem Argument, "wieso es geht doch", und ja es geht, aber es geht nicht immer mit dem richtigen Ergebnis!

    2. nohup funktioniert, wenn man es richtig anwendet!

    Für den Inhalt des Beitrages 124035 haftet ausdrücklich der jeweilige Autor: Z_O_O_M

  • Das ist ja nicht das was ich möchte.
    Ich möchte das Script einfach per klick auf ausführen ausführen und nicht noch per Konsole aufrufen.

    Wenn ich das wie folgt mache geht es auch nicht:

    Shell-Script

    1. #!/bin/bash
    2. su
    3. "nohup openvpn --config /etc/openvpn/User1.conf &"
    4. "nohup mount -a &"
    5. exit

    Für den Inhalt des Beitrages 124043 haftet ausdrücklich der jeweilige Autor: wacken

  • Das Hilft auch nicht. Ich vermute, dass das Script gar nicht so weit abgearbeitet wird. Nach der Eingabe des Passworts bekomme ich folgende Ausgabe:

    Quellcode

    1. Passwort:
    2. linux-k7nn:/home/User1/Schreibtisch #
    Wenn ich das Konsolenfenster schließen möchte bekomme ich jedoch die Meldung, dass noch ein Prozess ausgeführt wird: bash

    Für den Inhalt des Beitrages 124045 haftet ausdrücklich der jeweilige Autor: wacken

  • Warum willst du ein Spasswort eingeben?
    Das geht einfacher ohne.
    Einfach die Mounts in die fstab eintragen mit der Option users,noauto
    Dann kannst du die Mounts als User erledigen.

    Das Gezeter mit Spasswort, Terminal und Background kannst du schon machen.
    Dann wirst du nohup und disown brauchen.

    Eine schlichte User- Systemd- Unit würde das eleganter erledigen.
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 124046 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • Berichtigung schrieb:

    Warum willst du ein Spasswort eingeben?
    Das geht einfacher ohne.
    Einfach die Mounts in die fstab eintragen mit der Option users,noauto
    Dann kannst du die Mounts als User erledigen.

    Das Gezeter mit Spasswort, Terminal und Background kannst du schon machen.
    Dann wirst du nohup und disown brauchen.

    Eine schlichte User- Systemd- Unit würde das eleganter erledigen.
    Die noauto verhindert doch ein automatisches Einhängen. Da ich die Laufwerke, wenn ich Zuhause bin gerne automatisch eingehängt haben möchte und nur wenn ich die VPN Verbindung habe muss ich diese manuell mounten.
    Aber prinzipiell kann ich auf die Eingabe von einem Passwort verzichten.
    Was meinst du mit User- Systemd- Unit.
    disown muss ich mir mal angucken.

    Für den Inhalt des Beitrages 124052 haftet ausdrücklich der jeweilige Autor: wacken