noVNC remote desktop einrichten.

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema noVNC remote desktop einrichten. gibt es 36 Antworten auf 4 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Nur das gemacht:
    Remote Access with VNC | Reference | openSUSE Leap 15
    Natürlich schon geschaut, das die Firewall nicht dazwischenfunkt.......

    Das ergibt:





    Gnome funktioniert nicht, aber Icewm und Plasma
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 124393 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Also ich verstehe das nicht :(. Ich mache das doch gleich.

    Opensuse neu installiert.
    Alle updates installiert.
    Auf KDM umgestellt.
    Firewall deaktiviert.

    Also:
    1. Start YaST › Network Services › Remote Administration (VNC).
    2. Check Allow Remote Administration Without Session Management.
    3. Activate Enable access using a web browser if you plan to access the VNC session in a Web browser window.
    Firewall ist bei mir einfach deaktiviert.
    Also es sieht so aus wie bei Figure 4.7


    Ausgeloggt. (Ich war eigentlich nie bei allen versuchen eingeloggt man weiß ja nie)

    Neu gebootet.


    Und dann direkt auf
    192.168.5.146:5801

    Dann kommt bei mir
    Bild 1.
    Bild 2.
    aber dann, immer wieder Bild1.



    Bei Bild 1 kann ich bei passwort und token was eingeben oder auch nicht, wird irgendwie ignoriert.

    Und bei Bild 2 zumindest wird da nur ein User und richtiges Passwort erlaubt.

    Soll ich mal auf ein
    192.168.0.XXX

    Netz wechseln ? Aber das kanns ja nicht sein ?

    Mitt­ler­wei­le auch alle möglichen Browser probiert damit plugin etwas blockiert. Aber da habe ich eigentlich auch nichts installiert.

    Für den Inhalt des Beitrages 124406 haftet ausdrücklich der jeweilige Autor: lopder

  • lopder schrieb:

    Bei Bild 1 kann ich bei passwort und token was eingeben oder auch nicht, wird irgendwie ignoriert.
    Brauchst du nicht, nur IP und Port und connect.


    lopder schrieb:

    Und bei Bild 2 zumindest wird da nur ein User und richtiges Passwort erlaubt.
    Username und Passwort, wobei der User nicht angemeldet sein darf......
    Erstell doch einfach einmal einen neuen User auf dem Server und versuch es damit.

    Ansonsten:
    Versuch es doch einfach statt mit VNC mit teamviewer. Ist zwar proprietär und benutzt den eigenen Server, aber...........
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 124409 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Sauerland schrieb:

    Erstell doch einfach einmal einen neuen User auf dem Server und versuch es damit.
    Auf die Idee kam ich schon brachte aber nichts.

    Sauerland schrieb:

    Username und Passwort, wobei der User nicht angemeldet sein darf......
    Ja ist mir klar es ist sogar niemand eingeloggt. Der Rechner läuft mit dem logginscreen.


    Ja derzeit arbeite ich mit dem Teamviewer, aber eigentlich wollte ich davon weg :rolleyes: :whistling:

    Das komische ist ja ich kann mich nur nicht einloggen. Aber über webbrowser ein shutdown geht :D
    Oder wenn username und passwort nicht stimmt wird mir das auch angezeigt.

    Für den Inhalt des Beitrages 124452 haftet ausdrücklich der jeweilige Autor: lopder

  • Quellcode

    1. ## Path: Desktop/Display manager
    2. ## Description: settings to generate a proper displaymanager config
    3. ## Type: yesno
    4. ## Default: no
    5. #
    6. # Allow remote access (XDMCP) to your display manager (xdm/kdm/gdm). Please note
    7. # that a modified kdm or xdm configuration, e.g. by KDE control center
    8. # will not be changed. For gdm, values will be updated after change.
    9. # XDMCP service should run only on trusted networks and you have to disable
    10. # firewall for interfaces, where you want to provide this service.
    11. #
    12. DISPLAYMANAGER_REMOTE_ACCESS="yes"
    13. ## Type: yesno
    14. ## Default: no
    15. #
    16. # Allow remote access of the user root to your display manager. Note
    17. # that root can never login if DISPLAYMANAGER_SHUTDOWN is "auto" and
    18. # System/Security/Permissions/PERMISSION_SECURITY is "paranoid"
    19. #
    20. DISPLAYMANAGER_ROOT_LOGIN_REMOTE="yes"
    21. ## Type: yesno
    22. ## Default: yes
    23. #
    24. # Let the displaymanager start a local Xserver.
    25. # Set to "no" for remote-access only.
    26. # Set to "no" on architectures without any Xserver (e.g. s390/s390x).
    27. #
    28. DISPLAYMANAGER_STARTS_XSERVER="yes"
    29. ## Type: yesno
    30. ## Default: no
    31. #
    32. # TCP port 6000 of Xserver. When set to "no" (default) Xserver is
    33. # started with "-nolisten tcp". Only set this to "yes" if you really
    34. # need to. Remote X service should run only on trusted networks and
    35. # you have to disable firewall for interfaces, where you want to
    36. # provide this service. Use ssh X11 port forwarding whenever possible.
    37. #
    38. DISPLAYMANAGER_XSERVER_TCP_PORT_6000_OPEN="no"
    39. ## Type: string
    40. ## Default:
    41. #
    42. # Define the user whom should get logged in without request. If string
    43. # is empty, display standard login dialog.
    44. #
    45. DISPLAYMANAGER_AUTOLOGIN=""
    46. ## Type: yesno
    47. ## Default: no
    48. #
    49. # Allow all users to login without password, but ask for the user, if
    50. # DISPLAYMANAGER_AUTOLOGIN is empty.
    51. #
    52. DISPLAYMANAGER_PASSWORD_LESS_LOGIN="no"
    53. ## Type: yesno
    54. ## Default: no
    55. #
    56. # Display a combobox for Active Directory domains.
    57. #
    58. DISPLAYMANAGER_AD_INTEGRATION="no"
    59. ## Type: string(Xorg)
    60. ## Path: Desktop/Display manager
    61. ## Default: "Xorg"
    62. #
    63. DISPLAYMANAGER_XSERVER="Xorg"
    64. DISPLAYMANAGER="sddm"
    65. ## Path: Desktop/Display manager
    66. ## Description: settings to generate a proper displaymanager config
    67. ## Config: kdm
    68. ## Type: string
    69. ## Default:
    70. #
    71. # Defines extra Server Arguments given to the kdm display manager when
    72. # starting a local display. Useful to override e.g. the -dpi setting.
    73. #
    74. DISPLAYMANAGER_KDM_LOCALARGS=""
    75. ## Type: yesno
    76. ## Default: yes
    77. #
    78. # Allow local access of the user root to your display manager. Note
    79. # that root can never login if DISPLAYMANAGER_SHUTDOWN is "auto" and
    80. # System/Security/Permissions/PERMISSION_SECURITY is "paranoid".
    81. # This settings currently works only with KDM.
    82. #
    83. DISPLAYMANAGER_ROOT_LOGIN_LOCAL="yes"
    Alles anzeigen
    Wieso steht da immer noch
    DISPLAYMANAGER="sddm" ?

    Wenn ich aber systemctl status display-manager.service aufrufe:

    Quellcode

    1. display-manager.service - X Display Manager
    2. Loaded: loaded (/usr/lib/systemd/system/display-manager.service; enabled; vendor preset: enabled)
    3. Active: active (running) since Mon 2018-09-03 22:09:44 CEST; 36min ago
    4. Process: 1691 ExecStart=/usr/lib/X11/display-manager start (code=exited, status=0/SUCCESS)
    5. Main PID: 1737 (kdm)
    6. Tasks: 11 (limit: 4915)
    7. CGroup: /system.slice/display-manager.service
    8. ├─1737 /usr/bin/kdm
    9. └─1779 /usr/bin/Xorg -br :0 vt7 -nolisten tcp -auth /var/lib/kdm/AuthFiles/A:0-ZnowXa

    Für den Inhalt des Beitrages 124456 haftet ausdrücklich der jeweilige Autor: lopder

  • Hallo

    So nochmal. Vielleicht kann mir jemand beim Übersetzten helfen.
    Auf der Seite:
    Remote Access with VNC | Reference | openSUSE Leap 15


    Quellcode

    1. 4.3.3 Configuring One-time VNC Sessions #
    2. You can skip this section, if you do not need or want to modify the default configuration.
    3. One-time VNC sessions are started via the systemd socket xvnc.socket.
    4. By default it offers six configuration blocks: three for VNC viewers (vnc1 to vnc3),
    5. and three serving a JavaScript client (vnchttpd1 to vnchttpd3).
    6. By default only vnc1 and vnchttpd1 are active.

    Ich gehe mal davon aus das mit xvnc.socket Die Konfigurationsdatei gemeint ist. Ist das richtg ?
    Das ist eine normale Textdatei ist das richtig ?

    Weiter steht da das: "By default it offers six configuration blocks ..". Ich gehe davon aus das damit gemeint ist, das in dieser Konfigurationsdatei 6 Blocke mit Konfigurationen vorhanden ist.

    Ist das richtig ? Also es sollte in der dieser Textdatei, wenn ich sie öffne schon 6 Konfigruationsabschnitte existieren. Richtig ?


    Meine xvnc.socket Textdatei sieht so aus.

    Quellcode

    1. [Unit]
    2. Description=Xvnc Server
    3. [Socket]
    4. ListenStream=5901
    5. Accept=yes
    6. [Install]
    7. WantedBy=sockets.target
    Fehlt da jetzt was ? Oder wie ist der Text aus der Doku richtig zuverstehen ? Also ich hätte jetzt mehr erwartet.



    Gut hier habe ichs auch nochmal auf Deutsch.
    Suse Doc: Administrationshandbuch - Einmalige VNC-Sitzungen - July 24 2013

    Aber auch da frage ich mich und wo sind jetzt diese sechs Konfigurationsblöcke ?

    Gut ich habe auch gelesen das wenn ich mit der "default configuration" zufrieden bin ich darana nichts ändern muss.
    Aber wenn sie gar nicht existiert ist es ja auch ein Problem.

    Grüße

    Für den Inhalt des Beitrages 124605 haftet ausdrücklich der jeweilige Autor: lopder