Monitoreinstellung auf Terra Mobile 2300 unter Leap 15.0

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Monitoreinstellung auf Terra Mobile 2300 unter Leap 15.0 gibt es 12 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Monitoreinstellung auf Terra Mobile 2300 unter Leap 15.0

    Ich bräuchte mal wieder Hilfe!
    Ich versuche auf einem alten Terra Mobile 2300 Leap 15.0 einzurichten. Vorher war XP drauf. Nach der Installation, die einwandfrei durchlief hatte ich nur eine Auflösung von 800 x 600 zur Verfügung. Was anderes kann ich auch nicht unter Systemeinstellungen - Anzeige und Monitor auswählen.
    Habe dann versucht nach dieser Anleitung vorzugehen. Bei 4. fehlt mir Driver Status: xxx is active

    Quellcode

    1. hwinfo --gfx
    2. 21: PCI(AGP) 100.0: 0300 VGA compatible controller (VGA)
    3. [Created at pci.378]
    4. Unique ID: VCu0.gZLhgySda_4
    5. Parent ID: vSkL.uvrveDpO5n6
    6. SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
    7. SysFS BusID: 0000:01:00.0
    8. Hardware Class: graphics card
    9. Model: "Silicon Integrated 771/671 PCIE VGA Display Adapter"
    10. Vendor: pci 0x1039 "Silicon Integrated Systems Corp."
    11. Device: pci 0x6351 "771/671 PCIE VGA Display Adapter"
    12. SubVendor: pci 0x1558 "CLEVO/KAPOK Computer"
    13. SubDevice: pci 0x0801
    14. Revision: 0x10
    15. Memory Range: 0xc0000000-0xcfffffff (ro,non-prefetchable)
    16. Memory Range: 0xd8000000-0xd801ffff (rw,non-prefetchable)
    17. I/O Ports: 0x9000-0x9fff (rw)
    18. Memory Range: 0x000c0000-0x000dffff (rw,non-prefetchable,disabled)
    19. IRQ: 9 (no events)
    20. I/O Ports: 0x3c0-0x3df (rw)
    21. Module Alias: "pci:v00001039d00006351sv00001558sd00000801bc03sc00i00"
    22. Config Status: cfg=no, avail=yes, need=no, active=unknown
    23. Attached to: #18 (PCI bridge)
    24. Primary display adapter: #21
    Alles anzeigen
    xrandr ergibt:

    Quellcode

    1. xrandr: Failed to get size of gamma for output default
    2. Screen 0: minimum 640 x 480, current 640 x 480, maximum 640 x 480
    3. default connected primary 640x480+0+0 0mm x 0mm
    4. 640x480 73.00*
    lspci -nnk:

    Quellcode

    1. lspci -nnk
    2. 00:00.0 Host bridge [0600]: Silicon Integrated Systems [SiS] 671MX [1039:0671]
    3. Subsystem: CLEVO/KAPOK Computer Device [1558:0801]
    4. Kernel driver in use: agpgart-sis
    5. 00:01.0 PCI bridge [0604]: Silicon Integrated Systems [SiS] AGP Port (virtual PCI-to-PCI bridge) [1039:0003]
    6. Kernel modules: shpchp
    7. 00:02.0 ISA bridge [0601]: Silicon Integrated Systems [SiS] SiS968 [MuTIOL Media IO] [1039:0968] (rev 01)
    8. Subsystem: CLEVO/KAPOK Computer Device [1558:0801]
    9. 00:02.5 IDE interface [0101]: Silicon Integrated Systems [SiS] 5513 IDE Controller [1039:5513] (rev 01)
    10. Subsystem: CLEVO/KAPOK Computer Device [1558:0801]
    11. Kernel driver in use: pata_sis
    12. Kernel modules: pata_sis, pata_acpi, ata_generic
    13. 00:03.0 USB controller [0c03]: Silicon Integrated Systems [SiS] USB 1.1 Controller [1039:7001] (rev 0f)
    14. Subsystem: CLEVO/KAPOK Computer Device [1558:0801]
    15. Kernel driver in use: ohci-pci
    16. Kernel modules: ohci_pci
    17. 00:03.1 USB controller [0c03]: Silicon Integrated Systems [SiS] USB 1.1 Controller [1039:7001] (rev 0f)
    18. Subsystem: CLEVO/KAPOK Computer Device [1558:0801]
    19. Kernel driver in use: ohci-pci
    20. Kernel modules: ohci_pci
    21. 00:03.3 USB controller [0c03]: Silicon Integrated Systems [SiS] USB 2.0 Controller [1039:7002]
    22. Subsystem: CLEVO/KAPOK Computer Device [1558:0801]
    23. Kernel driver in use: ehci-pci
    24. Kernel modules: ehci_pci
    25. 00:04.0 Ethernet controller [0200]: Silicon Integrated Systems [SiS] 191 Gigabit Ethernet Adapter [1039:0191] (rev 02)
    26. Subsystem: CLEVO/KAPOK Computer Device [1558:0801]
    27. Kernel driver in use: sis190
    28. Kernel modules: sis190
    29. 00:05.0 IDE interface [0101]: Silicon Integrated Systems [SiS] SATA Controller / IDE mode [1039:1183] (rev 03)
    30. Subsystem: CLEVO/KAPOK Computer Device [1558:0801]
    31. Kernel driver in use: sata_sis
    32. Kernel modules: sata_sis, pata_acpi, ata_generic
    33. 00:06.0 PCI bridge [0604]: Silicon Integrated Systems [SiS] PCI-to-PCI bridge [1039:000a]
    34. Kernel driver in use: pcieport
    35. Kernel modules: shpchp
    36. 00:07.0 PCI bridge [0604]: Silicon Integrated Systems [SiS] PCI-to-PCI bridge [1039:000a]
    37. Kernel driver in use: pcieport
    38. Kernel modules: shpchp
    39. 00:09.0 FLASH memory [0501]: ENE Technology Inc ENE PCI Memory Stick Card Reader Controller [1524:0730]
    40. Subsystem: CLEVO/KAPOK Computer Device [1558:0801]
    41. 00:09.1 SD Host controller [0805]: ENE Technology Inc ENE PCI SmartMedia / xD Card Reader Controller [1524:0750]
    42. Subsystem: CLEVO/KAPOK Computer Device [1558:0801]
    43. Kernel driver in use: sdhci-pci
    44. Kernel modules: sdhci_pci
    45. 00:09.3 FLASH memory [0501]: ENE Technology Inc ENE PCI Secure Digital / MMC Card Reader Controller [1524:0751]
    46. Subsystem: CLEVO/KAPOK Computer Device [1558:0801]
    47. Kernel driver in use: sdhci-pci
    48. Kernel modules: sdhci_pci
    49. 00:0f.0 Audio device [0403]: Silicon Integrated Systems [SiS] Azalia Audio Controller [1039:7502]
    50. Subsystem: CLEVO/KAPOK Computer Device [1558:0801]
    51. Kernel driver in use: snd_hda_intel
    52. Kernel modules: snd_hda_intel
    53. 01:00.0 VGA compatible controller [0300]: Silicon Integrated Systems [SiS] 771/671 PCIE VGA Display Adapter [1039:6351] (rev 10)
    54. Subsystem: CLEVO/KAPOK Computer Device [1558:0801]
    Alles anzeigen

    Laut Datenblatt beträgt die Auflösung 1280 x 800 ( WXGA )

    Habe mal diese xorg.conf erstellt. Vorlage habe ich hier gefunden. Damit bekomme ich zwar dann eine Auflösung von 1280x800 eingestellt, wenn ich aber mit dem Mauszeiger an den Rand des Bildschirms komme verschiebt sich der Bildschirminhalt vertikal und es werden Mauszeigeartefakte auf dem Rest des Bildschirms Angezeigt. Auch wenn ich auf das Anwendungsmenü gehe springt die Anzeige.

    Quellcode

    1. Section "Device"
    2. Identifier "Generic Video Card"
    3. VendorName "Silicon Integrated Systems [SiS]"
    4. BoardName "771/671 PCIE VGA Display Adapter"
    5. Busid "PCI:1:0:0"
    6. Driver "vesa"
    7. Screen 0
    8. Option "UseFBDev" "true"
    9. Option "DPMS"
    10. Option "ShadowFB"
    11. Option "MaxXFBMem"
    12. VideoRam 262016
    13. Option "RenderAccel" "true"
    14. Option "AllowGLXWithComposite" "true"
    15. Option "backingstore" "true"
    16. Option "AddARGBGLXVisuals" "True"
    17. EndSection
    18. Section "Monitor"
    19. Identifier "Configured Monitor"
    20. Vendorname "Generic LCD Display"
    21. Modelname "LCD Panel 1280x800"
    22. HorizSync 31.5 - 50.0
    23. VertRefresh 56.0 - 65.0
    24. modeline "1280x800@60" 83.46 1280 1344 1480 1680 800 801 804 828 -hsync +vsync
    25. Gamma 1.0
    26. EndSection
    27. Section "Screen"
    28. Identifier "Default Screen"
    29. Monitor "Configured Monitor"
    30. Device "Configured Video Device"
    31. Defaultdepth 24
    32. SubSection "Display"
    33. Viewport 0 0
    34. Depth 24
    35. Virtual 1280 800
    36. Modes "1280x800@60"
    37. EndSubSection
    38. EndSection
    39. Section "Module"
    40. Load "dri"
    41. Load "dbe" # Double-Buffering Extension
    42. Load "v4l" # Video for Linux
    43. Load "extmod"
    44. Load "type1"
    45. Load "freetype"
    46. Load "glx" # 3D layer
    47. Load "GLcore"
    48. Load "i2c"
    49. Load "bitmap"
    50. Load "ddc"
    51. Load "int10"
    52. Load "vbe"
    53. Load "speedo"
    54. Load "record"
    55. Load "dri2"
    56. EndSection
    57. Section "DRI"
    58. Mode 0666
    59. EndSection
    Alles anzeigen
    Würde mich sehr freuen wenn mir da jemand weiterhelfen könnte! Ich hoffe ich habe alle wichtigen Informationen dazu aufgelistet.

    Für den Inhalt des Beitrages 124932 haftet ausdrücklich der jeweilige Autor: Georg

  • Sauerland schrieb:

    Richte mal eine xorg.conf in /etc/X11 ein.

    im ersten Post habe ich den Inhalt der xorg.conf am Schluss als Code aufgeführt. Mit dem hatte ich dann die Probleme mit den Artefakten usw. Wie sollte den die xorg.conf sinnvollerweise aussehen? Oder habe ich da was falsch verstanden?

    Für den Inhalt des Beitrages 124969 haftet ausdrücklich der jeweilige Autor: Georg