Generic Desktop mit Obenbox-WM: xdg-su systemweit durch gnomesu ersetzen?

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Generic Desktop mit Obenbox-WM: xdg-su systemweit durch gnomesu ersetzen? gibt es 2 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • Generic Desktop mit Obenbox-WM: xdg-su systemweit durch gnomesu ersetzen?

    Hallo Community,

    ich habe heute Tumbleweed mit Openbox-WM installiert, in dem ich während der Installation Generic-Desktop und das X-Window-Schema ausgewählt und zusätzlich Openbox installiert habe. Und wenn ich jetzt versuche YaST2 über das Desktop-Menü oder den tint2-Launcher-Button zu starten, erfolgt die Authentifizierung durch das Programm xdg-su. Ich habe bereits gnomesu installiert und wenn ich im Terminal oder in gmrun gnomesu /sbin/yast2 eingebe, kann ich mich damit auch problemlos authentifizieren und YaST2 starten. Ich würde das System nun gerne so konfigurieren, dass gnomesu auch dann zur Authentifizierung benutzt wird, wenn ich YaST2 über das Desktop-Menü oder den tint2-Launcher-Button starte, weiss allerdings nicht, wo ich die entsprechenden Einstellungen vornehmen kann?

    Für den Inhalt des Beitrages 125643 haftet ausdrücklich der jeweilige Autor: xds

  • Damit es mit Tint2 wie gewünscht funktioniert, kannst du (als Root/su) die Datei /usr/share/applications/YaST.desktop anpassen.

    Quellcode

    1. cat /usr/share/applications/YaST.desktop
    2. [Desktop Entry]
    3. Type=Application
    4. Categories=Settings;System;X-SuSE-Core-System;X-SuSE-ControlCenter-System;X-GNOME-SystemSettings;
    5. Name=YaST
    6. Icon=yast
    7. GenericName=Administrator Settings
    8. #Exec=/usr/bin/xdg-su -c /sbin/yast2
    9. Exec=/usr/bin/gnomesu -c /sbin/yast2
    10. Encoding=UTF-8
    11. Comment=Manage system-wide settings
    Alles anzeigen

    Für das „Desktop-Menü” wirst du wohl, als Anwender, die Datei menu.xml von Openbox anpassen müssen. Eventuell zu finden unter ~/.config.

    Für den Inhalt des Beitrages 125644 haftet ausdrücklich der jeweilige Autor: tomfa-ng