Probleme beim WLAN einrichten

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Probleme beim WLAN einrichten gibt es 27 Antworten auf 3 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Probleme beim WLAN einrichten

    Ich habe folgendes Problem:

    Ich bekomme das WLAN im Laptop nicht zu laufen. Laut Hardware-Info ist ein Realtek WLAN-Adapter drin. Hier mal die Hardware-Infos:

    802.11n WLAN Adapter
    Alter eindeutiger Schlüssel: w_iQ.oEB3gTj7lo5
    Bus: USB
    Eindeutiger Schlüssel: xnLL.IYqr9NExU03
    Gerät: 802.11n WLAN Adapter
    Gerätekennung: 241673
    Hersteller-ID: 199642
    Hersteller: Realtek Semiconductor Corp.
    Hwcfg-Bus: usb
    Kernel-Treiber: btusb
    Klasse (Spez.):
    Klasse: Bluetooth-Gerät
    Modell: Realtek 802.11n WLAN Adapter
    Ressourcen

    baud

    speed: 12000000
    Sysfs-ID:/devices/pci0000:00/0000:00:15.0/usb1/1-4/1.4:1.1

    Syfs-ID: 1.4:1.1

    Treiber

    Aktiv: ja

    modprobe: ja

    modules

    modprobe btusb

    Treiber: btusb

    Version: 2.0

    hotplug: usb

    modalias: usb:v0BDApB009d0200dcE0dsc01dp01icE0isc01ip01in01

    Übergeordnete eindeutige ID: k4bc.ZEYWNM3UrzF


    Unter YAST in den Netzwerkeinstellungen ist folgendes eingestellt (nur wo etwas eingetragen ist, habe ich aufgeführt):


    Reiter Globale Optionen

    Allgemeine Netzwerkeinstellungen
    Methode für den Netzaufbau: NetworkManager-Dienst


    IPv6-Protokoll-Einstellungen
    IPv6 aktivieren, Haken gesetzt

    Optionen für DHCP-Client
    Zu sendender Hostname: Auto
    Standart-Route über DHCP ändern, Haken gesetzt
    (diese Einstellungen sind ausgegraut, kann dort nichts ändern)

    Reiter Übersicht
    Hier ist der Ethernet Controller aufgeführt, der auch funzt. Alles ist ausgegraut, kann hier auch nichts ändern.
    Auch nicht Hinzufügen, Bearbeiten oder Löschen

    Reiter Hostname/DNS
    Unter Hostname ist linux-icbs eingetragen, unter Domänenname fritz.box
    &Hostnamen über DHCP setzen: nein
    Unter Domänensuche ist fritz.box eingetragen

    Reiter Routing
    Hier ist nirgendwo etwas eingetragen. Das einzige Feld, in dem ich was ändern kann, ist Gerät.

    In der Taskleiste unter Netzwerke habe ich eine Wireless Netzwerkverbindung hinzugefügt.

    Reiter WiFi
    Die SSID ist eingetragen, der Modus steht auf Infrastruktur, unter BSSID steht nichts (weiß ehrlich gesagt auch nicht, was da rein soll).
    Geklonte MAC-Adresse steht auf Zufällig und MTU auf Automatisch.

    Reiter WiFi-Sicherheit
    Bei Sicherheit ist WPA/WPA2 Personal, wie auch in der Fritzbox, eingetragen. Passwort ist auch eingetragen.

    IPv4 und IPv6 stehen auf Automatisch, bei IPv6 ist die Privatspäre auf Standart.

    Unter den Diensten habe ich Bluetooth aktiviert, da der WLAN Adapter unter Bluetooth-Geräte eingetragen ist.

    Das Laptop ist ein HP 15-da0001ng.

    Ich bin, was Linux angeht, absoluter Neuling und ein WLAN habe ich bisher auch noch nie eingerichtet.
    Wie bekomme ich das WLAN zum laufen? Habe zwar schon einige Themen durchforstet, konnte da aber nichts hilfreiches für mich finden.
    Vielleicht kann mir jemand von Euch dabei helfen.

    Falls Quellcodes benötigt werden, muss ich um etwas Nachsicht bitten, da ich erstaml rausfinden muss, wie ich da rankomme.
    Notfalls ist schon die nächste Frage vorprogrammiert. Ich hoffe jedenfalls, das Ihr mit meinen Angaben schon mal etwas anfangen könnt.

    Für den Inhalt des Beitrages 125763 haftet ausdrücklich der jeweilige Autor: OldenBiker

  • Schauen wir doch zuerst, welche Netzwerkkarte genau verbaut ist.
    Dazu öffnest du die "Konsole" und kopiert dort folgenden Befehl ein:

    Quellcode

    1. /sbin/lspci -nnk | grep -EiA3 net
    Die Ausgabe (das Ergebnis) kopierst du wieder und fügst dieses hier als Antwort mit Code Tags ein.

    Du bittest um Nachsicht, kein Problem (-:

    Erklärung zu Code Tag:
    Diese werden genutzt, um die Ergebnisse von Befehlen hier zu posten.
    Ist besser lesbar als normaler Text.
    Wenn du auf "Antworten" gehst, siehst du über dem Textfeld einige Symbole.
    Das Symbol "</>" sind die Code Tags - wenn dein Mauszeiger dort drauf steht, wird "Code" angezeigt.
    Ein Klick darauf öffnet das Code Tag Fenster, in welches du deinen Befehl inkl. Ergebnis kopierst.

    Ich hoffe, Dass war verständlich (-:
    Zitat Albert Einstein:
    "Zwei Dinge sind unendlich, das Universum und die menschliche Dummheit,
    aber bei dem Universum bin ich mir noch nicht ganz sicher."

    Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von sterun ()

    Für den Inhalt des Beitrages 125767 haftet ausdrücklich der jeweilige Autor: sterun

  • Hier denn mal der Qellcode. Muss zwar zugeben, daß ich noch nicht viel damit anfangen kann, bin aber lernfähig.

    Quellcode

    1. britta@linux-izbs:~> /sbin/lspci -nnk | grep -EiA3 net
    2. 01:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)
    3. Subsystem: Hewlett-Packard Company Device [103c:84ab]
    4. Kernel driver in use: r8169
    5. Kernel modules: r8169
    6. 02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. Device [10ec:d723]
    7. Subsystem: Hewlett-Packard Company Device [103c:8319]
    8. britta@linux-izbs:~>

    Für den Inhalt des Beitrages 125771 haftet ausdrücklich der jeweilige Autor: OldenBiker

  • Wenn du vorübergehend das LAN-Kabel benutzen könntest, wäre das schon mal gut.

    Wenn dann das Internet geht, mach erst einmal ein Update.
    Denn dein Wlan Chip wird von dem Leap-Kernel nicht unterstützt, da musst du noch aus meinem Repo ein Kernel-Modul sowie die Firmware installieren.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 125773 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Schon mal Danke. Wie installiere ich das fehlende? Bin ja noch nicht so bewandert mit Linux.
    Das Sytem soll jedenfalls auf dem aktuellsten Stand sein. Hab eben noch mal nach Aktualisierungen
    suchen lassen.
    Per Kabel komme ich ins Netz, das ist nicht das Problem. Ich muss nur wissen, wie ich an das Kernel-Modul
    und die Firmware komme.

    Für den Inhalt des Beitrages 125784 haftet ausdrücklich der jeweilige Autor: OldenBiker

  • Als root:

    Quellcode

    1. zypper ar -f https://download.opensuse.org/repositories/home:/Sauerland/openSUSE_Leap_15.0_Update/ Sauerland

    Quellcode

    1. zypper in -f rtlwifi_new-extended-kmp-default kernel-firmware
    Das sollte den Treiber (das kmp) und die Firmware aus meinem Repo installieren.

    Bei der Firmware musst du evtl. dem Repowechsel zustimmen.

    Danach neu starten.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 125785 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Mag vielleicht 'ne blöde Frage sein, aber bevor mir irgend was was quer läuft,
    frage ich lieber nach.

    Die Quellcodes muss ich in die Konsole eingeben oder muss ich noch was installieren?

    Für den Inhalt des Beitrages 125786 haftet ausdrücklich der jeweilige Autor: OldenBiker

  • OldenBiker schrieb:

    Die Quellcodes muss ich in die Konsole eingeben oder muss ich noch was installieren?
    Ja, in der Konsole eingeben und ausführen.
    Der erste Befehl fügt das Repositorium (Online Paketdepot) vom Sauerländer hinzu, mit dem zweiten Befehl installierst du die angegebenen Pakete inklusive Abhängigkeiten.

    Für den Inhalt des Beitrages 125788 haftet ausdrücklich der jeweilige Autor: tomfa-ng