KDE-Skalierungsproblem mit nVIDIA Driver auf ThinkPad P52

Hinweis: In dem Thema KDE-Skalierungsproblem mit nVIDIA Driver auf ThinkPad P52 gibt es 3 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • Hi,
    nach einer frischen Installation von Leap 15.0 auf einem ThinkPad P52 mit Driver nvidia-glG04 (390.87) skaliert der Plasma Desktop viel zu groß, konkret 143x144 dpi auf dem 15,6" Display mit 1920x1080 pixel.
    Der zuvor installierte Nouveau Driver skalierte korrekt mit 96x96 dpi, was die normale Skalierung für diese Auflösung darstellt.


    Was ich schon probiert habe:
    a) Skalierung lässt sich in den nVIDIA X Server Settings nicht verändern - zumindest habe ich dort keine Möglichkeit gefunden.
    b) Configure Desktop, Display and Monitor, Scale Display: Dort steht die Skalierungsstufe bereits auf der kleinsten Einheit 1 - es kann nur noch weiter vergrößert werden.
    c) Mir scheint /etc/X11/xorg.conf.d/50-monitor.conf die richtige Stelle für das DPI Setting zu sein, aber folgende Settings haben nicht gefruchtet:
    DisplaySize 341 191 # 96 DPI @ 1920x1080 # alternativ...
    Option "DPI" "96x96"


    Für einen Hinweis wäre ich dankbar.


    Grafiksettings sind wie folgt:

    Code
    ~> xrandr
    Invalid MIT-MAGIC-COOKIE-1 keyScreen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
    DP-0 disconnected (normal left inverted right x axis y axis)
    DP-1 disconnected (normal left inverted right x axis y axis)
    HDMI-0 disconnected (normal left inverted right x axis y axis)
    DP-2 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
    1920x1080 60.03*+ 47.99
    DP-3 disconnected (normal left inverted right x axis y axis)
    DP-4 disconnected (normal left inverted right x axis y axis)
    Code
    ~> xdpyinfo | grep -C 1 resolution
    Invalid MIT-MAGIC-COOKIE-1 key dimensions: 1920x1080 pixels (341x191 millimeters)
    resolution: 143x144 dots per inch
    depths (7): 24, 1, 4, 8, 15, 16, 32

    Für den Inhalt des Beitrages 127423 haftet ausdrücklich der jeweilige Autor: moebius91

  • Selbst ist der Mann ;-)
    Die Lösung ist ein Eintrag in die /etc/sddm.conf:


    Code
    [X11]
    # Arguments passed to the X server invocation
    ServerArguments=-nolisten tcp -dpi 96

    Für den Inhalt des Beitrages 127451 haftet ausdrücklich der jeweilige Autor: moebius91