Update Probleme mit (Tumbleweed) zypper dup

Hinweis: In dem Thema Update Probleme mit (Tumbleweed) zypper dup gibt es 18 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Hallo zusammen,


    Ich benutze Opensuse Tumbleweed. Seit Mitte Dezember habe ich beim Updaten mit sudo zypper dup folgendes Problem (bzw. Probleme):


    Und so weiter. Ich kann leider nicht alles posten, da dadurch die 10000-Zeichen Begrenzung überschritten wird.
    Wie man sehen kann sind also einige Abhängigkeiten arg schief geraten. Aufgrund früherer Erfahrungen habe ich die konservative Variante gewählt, die alten Pakete erst einmal beizubehalten.
    Nach einigen frustrierten Versuchen des Updatens habe ich mit sudo zypper up vor einigen Tagen die meisten Pakete aktualisiert.
    Das Problem, insbesondere mit dem Nextcloud-Client bleibt aber bestehen.
    Das Kommando zypper lr -d ergibt die folgende Konfiguration der Repositories:


    Code
    # | Alias | Name | Aktiviert | GPG-Überprüfung | Aktualisierung | Priorität | Typ | URI | Dienst
    --+----------------------------------------+---------------------------------+-----------+-----------------+----------------+-----------+--------+---------------------------------------------------------------------------+-------
    1 | download.nvidia.com-tumbleweed | nVidia Graphics Drivers | Ja | (r ) Ja | Ja | 99 | rpm-md | https://download.nvidia.com/opensuse/tumbleweed |
    2 | isv_TUXEDO | isv:TUXEDO (openSUSE_Leap_15.0) | Ja | (r ) Ja | Nein | 99 | rpm-md | http://download.opensuse.org/repositories/isv:/TUXEDO/openSUSE_Leap_15.0/ |
    3 | opensuse-guide.org-openSUSE_Tumbleweed | libdvdcss repository | Ja | (r ) Ja | Ja | 99 | rpm-md | http://opensuse-guide.org/repo/openSUSE_Tumbleweed/ |
    4 | packman.inode.at-openSUSE_Tumbleweed | Packman Repository | Ja | (r ) Ja | Ja | 20 | rpm-md | http://packman.inode.at/suse/openSUSE_Tumbleweed/ |
    5 | repo-non-oss | openSUSE-Tumbleweed-Non-Oss | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/tumbleweed/repo/non-oss/ |
    6 | repo-nvidia-tuxedo | TUXEDO Computers - 15.0 NVIDIA | Ja | (r ) Ja | Ja | 99 | rpm-md | http://nvidia.tuxedocomputers.com/opensuse/15.0 |
    7 | repo-oss | openSUSE-Tumbleweed-Oss | Ja | (r ) Ja | Ja | 70 | rpm-md | http://download.opensuse.org/tumbleweed/repo/oss/ |
    8 | repo-update | openSUSE-Tumbleweed-Update | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/update/tumbleweed/ |

    Wie soll ich mit den fehlenden Updates umgehen / gibt es eine Lösung für diese Situation?
    Vielen Dank im Voraus schon einmal.

    Für den Inhalt des Beitrages 128087 haftet ausdrücklich der jeweilige Autor: elranjit

  • Wie soll ich mit den fehlenden Updates umgehen / gibt es eine Lösung für diese Situation?

    Poste mal:


    Code
    zypper se -si php

    Du hast eine Sperre bei php 7.2, das es bei Tumbleweed anscheinend nicht mehr gibt.........

  • Für den Inhalt des Beitrages 128089 haftet ausdrücklich der jeweilige Autor: elranjit

  • Für den Inhalt des Beitrages 128093 haftet ausdrücklich der jeweilige Autor: elranjit

  • Da hat aber einer schon die Sperre bei php7 entfernt........


    Und mit der Liste keine Probleme?
    Das wundert mich.



    Übrigens:
    Warum Tumbleweed und dann wird eh die Hälfte gegen ein Update gesperrt?
    Da würde ich Leap 15.0 installieren........

  • Und mit der Liste keine Probleme?
    Das wundert mich.

    Hm, Du meinst ob ich aufgrund der vielen Sperren bisher Probleme hatte? Nein, tatsächlich noch nicht. Das meiste sind einfach nur Anwendungen, die ich partout nicht brauche, die mir aber früher penetrant angeboten wurden...

    Warum Tumbleweed und dann wird eh die Hälfte gegen ein Update gesperrt?

    Bisher funktionierte es hervorragend. Wie gesagt die meisten Pakete in der Liste sind meiner Ansicht nach unnötig.


    Kann es sein, dass das php gesperrt ist, weil der Nextcloud-Client den eine Version kleiner als 7.3.0 benötigt? Das gibt ja die Meldung aus.
    ...
    Oder: Was bedeutet die Meldung eigentlich? Dass er ein php < 7.3.0 braucht aber nicht mehr hat?

    Für den Inhalt des Beitrages 128095 haftet ausdrücklich der jeweilige Autor: elranjit

  • Ich hänge mich mal rein, obwohl ich leider nichts zur Lösung beitragen kann.
    Aber vielleicht hilft mein Beitrag zur Klärung des Problems. :rolleyes:


    Lustigerweise wollte ich soeben auch mal mit der Nextcloud spielen.


    Code
    zypper se -si php
    Repository-Daten werden geladen...
    Installierte Pakete werden gelesen...
    Keine passenden Objekte gefunden.


    Okay. Vorher habe ich vermutlich auch kein php gebraucht. :/


    Code
    zypper ll
    Es sind keine Paketsperren definiert.


    Wenn ich versuche, Nextcloud erstmals (also kein Update!) zu installieren kommt:


    Code
    sudo zypper in nextcloud
    Repository-Daten werden geladen...
    Installierte Pakete werden gelesen...
    Paketabhängigkeiten werden aufgelöst...
    Problem: mod_php_any < 7.3.0 benötigt von nextcloud-14.0.4-2.1.noarch wird nirgends zur Verfügung gestellt
    Lösung 1: nextcloud-14.0.4-2.1.noarch nicht installieren
    Lösung 2: nextcloud-14.0.4-

    Das oben fehlende php sollte doch jetzt automatisch mit eingebunden werden, wenn es dieses denn gäbe, oder? :whistling:


    Irgendwie vermute ich, daß man bei Tumbleweed etwas hinterher (nicht aktuell) ist, und sich das Problem irgendwann (in ferner Zukunft) von selbst lösen wird.
    Die Nadeln mit denen Tumbleweed gestrickt wird, sind wohl doch zurzeit recht heiß.


    Seit "ewiger" Zeit bin ich eigentlich glücklich mit Tumbleweed. Und jetzt das.
    Es scheint mir ähnlich meinem Problem mit Back in Time zu sein.
    Mein aus den Quellen selbstgebautes BIT funktioniert, das aus den Tumbleweed-Repos immer noch nicht. <X

  • Danke an Euch. Ich denke die Lösung liegt auf der Hand. Trick 17: Warten, bis nextcloud nachzieht.
    Oder?
    Dann würde ich das Thema schließen.

    Für den Inhalt des Beitrages 128098 haftet ausdrücklich der jeweilige Autor: elranjit