Bootloader (Yast2) meldet Fehler

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Bootloader (Yast2) meldet Fehler gibt es 24 Antworten auf 3 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Moin,
    ich hoffe es ist Aussagekräftig.
    Erklärung zu lsblk: sda = SSD 850 EVO
    sdb = SSD mSATA M.2 860 EVO
    sdg = USB LW
    Gruß
    Bilder
    • Grafik1.png

      136,01 kB, 856×833, 9 mal angesehen
    • Grafik2.png

      159,2 kB, 945×948, 3 mal angesehen

    Für den Inhalt des Beitrages 128272 haftet ausdrücklich der jeweilige Autor: hjfunke

  • Moin, anbei die gewünschten Informationen.
    Erklärung zu den Festplatten:
    sda = SSD 850 EVO 500 GB
    sdb = SSD 860 EVO 250 GB mSATA M.2
    sdg = USB LW

    Gruß
    Bilder
    • Screenshot1.png

      138,55 kB, 945×948, 2 mal angesehen
    • Screenshot2.png

      158,44 kB, 945×948, 2 mal angesehen

    Für den Inhalt des Beitrages 128273 haftet ausdrücklich der jeweilige Autor: hjfunke

  • Das kannst du aber auch per copy/paste und Code-Tags machen, siehe meine Signatur hier unter diesem Beitrag.....

    Ich würde mal das 2. resume= in der /etc/default/grub entfernen, einmal reicht.
    In dieser Zeile: GRUB_CMDLINE_LINUX_DEFAULT=
    Danach als root:

    Quellcode

    1. grub2-mkconfig -o /boot/grub2/grub.cfg
    Und wenn das jetzt Code-Tags wären, könnte ich dir die Zeile auch posten.......
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 128274 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Habe ich ausgeführt, ohne Erfolg. Der Bootloader bringt immer noch den gleichen Fehler. Habe den Text kopiert:
    In /usr/share/YaST2/modules/BootStorage.rb:198:in 'stage1_disks for' :


    def stage1_disks_for(device)
    # Usually we want just the ancestors, but in the upgrade case
    # we may start with just 1 of multipath wires and have to
    # traverse descendants to find the Y2Storage::Multipath to use.
    component = [device] + device.ancestors + device.descendants


    Vielleicht sagt es dir was.

    Für den Inhalt des Beitrages 128276 haftet ausdrücklich der jeweilige Autor: hjfunke

  • So, leider funktioniert das mit dem Kopieren und Einfügen im Code-Tag nicht wie es soll. Es ist eine lange Zeile, die sich nicht umbrechen lässt. So habe ich eine Textdatei erstellt.
    Sorry, mit den Code-Tags muss ich noch üben.

    Edit Sauerland:
    Hab ich denn mal.....

    Quellcode

    1. hfunke@linux-T430:~> su
    2. Passwort:
    3. linux-T430:/home/hfunke # cat /etc/default/grub
    4. # If you change this file, run 'grub2-mkconfig -o /boot/grub2/grub.cfg' afterwards to update
    5. # /boot/grub2/grub.cfg.
    6. # Uncomment to set your own custom distributor. If you leave it unset or empty, the default
    7. # policy is to determine the value from /etc/os-release
    8. GRUB_DISTRIBUTOR=
    9. GRUB_DEFAULT=saved
    10. GRUB_HIDDEN_TIMEOUT=0
    11. GRUB_HIDDEN_TIMEOUT_QUIET=true
    12. GRUB_TIMEOUT=8
    13. # GRUB_CMDLINE_LINUX_DEFAULT="resume=/dev/disk/by-uuid/f69b27b3-b7cb-4a78-ac3b-a11c74827499 splash=silent quiet s
    14. howopts resume=/dev/disk/by-uuid/f69b27b3-b7cb-4a78-ac3b-a11c74827499 splash=silent quiet showopts"
    15. GRUB_CMDLINE_LINUX=""
    16. # Uncomment to automatically save last booted menu entry in GRUB2 environment
    17. # variable `saved_entry'
    18. # GRUB_SAVEDEFAULT="true"
    19. #Uncomment to enable BadRAM filtering, modify to suit your needs
    20. # This works with Linux (no patch required) and with any kernel that obtains
    21. # the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
    22. # GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"
    23. #Uncomment to disable graphical terminal (grub-pc only)
    24. GRUB_TERMINAL="gfxterm"
    25. # The resolution used on graphical terminal
    26. #note that you can use only modes which your graphic card supports via VBE
    27. # you can see them in real GRUB with the command `vbeinfo'
    28. GRUB_GFXMODE="auto"
    29. # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    30. # GRUB_DISABLE_LINUX_UUID=true
    31. #Uncomment to disable generation of recovery mode menu entries
    32. # GRUB_DISABLE_LINUX_RECOVERY="true"
    33. #Uncomment to get a beep at grub start
    34. # GRUB_INIT_TUNE="480 440 1"
    35. GRUB_BACKGROUND=
    36. GRUB_THEME=/boot/grub2/themes/openSUSE/theme.txt
    37. SUSE_BTRFS_SNAPSHOT_BOOTING="true"
    38. GRUB_DISABLE_OS_PROBER="false"
    39. GRUB_ENABLE_CRYPTODISK="n"
    40. GRUB_CMDLINE_XEN_DEFAULT="vga=gfx-1024x768x16 vga=gfx-1024x768x16"
    Alles anzeigen
    Dateien
    • Grub.txt

      (2,1 kB, 1 mal heruntergeladen, zuletzt: )

    Für den Inhalt des Beitrages 128281 haftet ausdrücklich der jeweilige Autor: hjfunke


  • GRUB_CMDLINE_LINUX=""
    Das löschen


    # GRUB_CMDLINE_LINUX_DEFAULT="resume=/dev/disk/by-uuid/f69b27b3-b7cb-4a78-ac3b-a11c74827499 splash=silent quiet s
    howopts resume=/dev/disk/by-uuid/f69b27b3-b7cb-4a78-ac3b-a11c74827499 splash=silent quiet showopts"
    Dort das # löschen und die Zeile abändern zu:

    Quellcode

    1. GRUB_CMDLINE_LINUX_DEFAULT="resume=/dev/disk/by-uuid/f69b27b3-b7cb-4a78-ac3b-a11c74827499 splash=silent quiet showopts"

    Danach als root:

    Quellcode

    1. grub2-mkconfig -o /boot/grub2/grub.cfg
    Zum Thema Code-Tags:

    Die komplette Ausgabe mit der Maus in der Konsole markieren---rechtsklick----kopieren.
    Dann hier auf Antwort klicken----aus der oberen Leiste den </> Knopf klicken---in das neu erscheinende Fenster rechtsklick----einfügen. Danach ok klicken.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 128283 haftet ausdrücklich der jeweilige Autor: Sauerland