OpenSUSE - neuer Rechner - SSDs - Erfahrung

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema OpenSUSE - neuer Rechner - SSDs - Erfahrung gibt es 3 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • OpenSUSE - neuer Rechner - SSDs - Erfahrung

    Hallo zusammen,

    Kurz vor Weihnachten 2018 habe ich meinen Acer-PC ausrangiert - zu viele Fehler, zB shutdown funktionierte nicht mehr, ich konnte daher
    immer nur per reboot arbeiten, sobald der PC "Beep" von sich gab, ausschalten - sehr umständlich. SystemBoot hat nach Änderungen zB der Boot-Reihenfolge
    nicht mehr reagiert.
    Fzit: Neuer PC muss her. Mein Sohn hat mir einen CSL Hannover zusammengestellt und dann dort bestellt.

    Quellcode

    1. inxi -F
    2. Resuming in non X mode: xdpyinfo not found. For package install advice run: inxi --recommends
    3. System: Host: localhost Kernel: 4.12.14-lp150.12.45-default x86_64 bits: 64 Desktop: KDE Plasma 5.12.6
    4. Distro: openSUSE Leap 15.0
    5. Machine: Device: desktop System: CSL- & KG product: A0000001 serial: PCCSL2018038241
    6. Mobo: ASUSTeK model: TUF B450-PLUS GAMING v: Rev X.0x serial: 180937167304657
    7. UEFI: American Megatrends v: 0409 date: 08/24/2018
    8. CPU: Hexa core AMD Ryzen 5 2600 Six-Core (-HT-MCP-) cache: 3072 KB
    9. clock speeds: max: 3400 MHz 1: 1550 MHz 2: 1550 MHz 3: 1550 MHz 4: 1550 MHz 5: 1550 MHz 6: 1550 MHz
    10. 7: 1550 MHz 8: 1550 MHz 9: 3400 MHz 10: 1550 MHz 11: 1550 MHz 12: 1550 MHz
    11. Graphics: Card: NVIDIA GP106 [GeForce GTX 1060 6GB]
    12. Display Server: x11 (X.org 1.19.6 ) drivers: nouveau (unloaded: modesetting,fbdev,nv,vesa)
    13. tty size: 148x62 Advanced Data: N/A for root
    14. Audio: Card-1 Advanced Micro Devices [AMD] Family 17h (Models 00h-0fh) HD Audio Controller
    15. driver: snd_hda_intel
    16. Card-2 NVIDIA GP106 High Definition Audio Controller driver: snd_hda_intel
    17. Sound: Advanced Linux Sound Architecture v: k4.12.14-lp150.12.45-default
    18. Network: Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
    19. IF: eth0 state: up speed: 1000 Mbps duplex: full mac: 40:b0:76:0b:96:a6
    20. Drives: HDD Total Size: 9001.8GB (16.6% used)
    21. ID-1: /dev/sda model: Samsung_SSD_860 size: 500.1GB
    22. ID-2: /dev/sdb model: ST4000DM004 size: 4000.8GB
    23. ID-3: /dev/sdd model: CT500MX500SSD1 size: 500.1GB
    24. ID-4: /dev/sde model: ST4000DM000 size: 4000.8GB
    25. Partition: ID-1: / size: 25G used: 6.8G (30%) fs: ext4 dev: /dev/sda11
    26. ID-2: swap-1 size: 15.86GB used: 0.00GB (0%) fs: swap dev: /dev/sde1
    27. Sensors: None detected - is lm-sensors installed and configured?
    28. Info: Processes: 247 Uptime: 0:32 Memory: 1825.4/16022.1MB Init: systemd runlevel: 5
    29. Client: Shell (bash) inxi: 2.3.40
    Alles anzeigen

    Nur daß ihr mal einiges über den PC erfahrt.

    In diesem PC ist eine 500 GB SSD eingebaut, die wurde ergänzt durch meine SSD aus dem Acer-PC.
    Für Daten sind noch 2 normale HDs eingebaut.

    Und nun kommt der Punkt, warum ich das hier überhaupt schreibe:
    Alle Installationen auf den SSDs, zB WIndows10, ArchLinux, Mageia, PCLinuxOS, Fedora, KUbuntu usw.
    starten in einem irren Tempo, was ich bisher so noch nie erlebt habe.

    Nun sollte noch OpenSUSE dazukommen, doch wegen des Installers und der Boot-Geschichte wollte ich die normale Installation umgehen.
    In diesem Forum habe ich schon einige Artikel gelesen, in denen über Boot-Probleme geschrieben wurde.

    Also habe ich einen anderen Weg gewählt - mit Erfolg.

    Alle Vorgänge im root-Modus - Linux-Distribution Mageia ist der Ausgangspunkt.

    1. Die openSUSE-Leap-15.0-KDE-Live-x86_64-Current.iso kommt darin vor.
    mount -o loop openSUSE-Leap-15.0-KDE-Live-x86_64-Current.iso /home/~/iso

    cd /home/~/iso/LiveOS

    Dort sitzt ein squashfs.img
    2. mount -o loop squashfs.img /home/~/disk
    cd /home/~/disk/LiveOS
    Dort sitzr ein rootfs.img
    3. mount -o loop rootfs.img /home/~/part

    Nun benötige ich eine freie Partition auf SSD 1, sie ist ca.25 GB groß.
    Diese mounte ich nun
    mount /dev/sda3 /mnt

    Für alle weiteren Aktionen nutze ich mc (Midnight Commander),
    Nun kopiere ich alle Verzeichnisse auf /home/~/part auf /mnt
    Dort sitzt am Ende ein komplettes OpenSUSE-System.

    4. cd /mnt
    mount -t proc proc /mnt/proc
    mount --rbind /sys /mnt/sys
    mount --rbind /dev /mnt/dev
    chroot /mnt /bin/bash
    export PS1="(chroot) $PS1"

    Nun bin ich also im OpenSUSE-System und muss nur 4 Dinge tun:
    zypper up
    grub2-mkconfig -o /boot/grub2/grub.cfg
    passwd

    Die Boot-Partition (Bootloader von ArchLinux) mounte ich kurz in der chroot-Umgebung auf /mnt
    Dann kopiere ich den grub.cfg-Eintrag aus OpenSUSE in die grub.cfg unter /mnt/grub
    Da hilft mir wieder mc.

    Danach umount /mnt
    exit
    cd
    umount -l /mnt/dev{/shm,/pts,}
    umount -l /mnt/sys
    umount -R /mnt

    Nun steige ich aus Mageia aus und reboote das System.

    Dann zeigt mir der Bootloader OpenSUSE-Leap15,
    das klicke ich an, und das System startet ohne Probleme.
    Ich lande auf dem Desktop im Verzeichnis /home/linux.

    Links oben sehe ich den Installer, den ich nun nicht mehr benötige.

    In Yast erstelle ich einen neuen User, bearbeite die /etc/group

    reboot
    Login-Screen mit den Usern linux und ~ (mein Login-Name)
    Ich klicke meinen an, gebe das Passwort ein und lande auf dem Desktop.

    Damit ist die Installation fertig, alles was dann kommt, muss jede/r nach und nach selbst erledigen,
    das brauche ich hier nicht mehr zu schreiben.

    Nur was ich grundsätzlich damit sagen will:
    Die Alternativ-Installation nutze ich bei anderen Distributionen schon länger,
    daher ist dieser Weg für mich kein neuer.

    Ich hoffe, damit dem einen oder anderen eine Anregung geben zu können für eine Alternative
    bei der Installation von OpenSUSE.

    Viel Spaß damit.
    Ich bin jedenfalls sehr zufrieden.

    Gruß
    Manfred

    Für den Inhalt des Beitrages 129170 haftet ausdrücklich der jeweilige Autor: ManfredB

  • Hast du dein Problem schon gelöst? Wenn nicht, dann Schau mal auf Google oder YouTube nach, bestimmt kannst du da etwas Passendes für dich finden. Vor kurzer Zeit hatte ich so ein ähnliches Problem und auf Google habe ich ein paar Seiten gefunden, wo die Leute da, mir alles gründlich erklärt haben.
    Liebe Grüße.
    Jeder von uns hat nur ein Leben.

    Für den Inhalt des Beitrages 129365 haftet ausdrücklich der jeweilige Autor: Kamel92

  • Kamel92 schrieb:

    Hast du dein Problem schon gelöst? Wenn nicht, dann Schau mal auf Google oder YouTube nach, bestimmt kannst du da etwas Passendes für dich finden. Vor kurzer Zeit hatte ich so ein ähnliches Problem und auf Google habe ich ein paar Seiten gefunden, wo die Leute da, mir alles gründlich erklärt haben.
    Liebe Grüße.
    Was soll das?
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 129369 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Moin zusammen,

    ich würde sagen TROLL Alarm.

    auf gehts, lasst uns spielen :smilie_hops_092: ... aber seid vorsichtig, TROLLE sind immer so schnell kaputtgespielt. *gnihihihihi*
    Viele Grüße,
    T.

    Für den Inhalt des Beitrages 129370 haftet ausdrücklich der jeweilige Autor: Tamerlain