Leap 15.0: WLAN mit ath10k verbindet sich sehr langsam

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Leap 15.0: WLAN mit ath10k verbindet sich sehr langsam gibt es 18 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • @Sauerland: Ich hab dein firmware-Paket installiert, ohne erkennbare Veränderung. Ich hab dann wie von dir beschrieben einen Auszug von journalctl erstellt, siehe Anhang (Netzwerknamen sind maskiert). Nur ein Eintrag ist mir als eventuell problematisch aufgefallen:
    link_config: autonegotiation is unset or enabled, the speed and duplex are not writable.
    Diese Meldung gab's anscheinend auch schon bei anderen, jedoch bin ich aus den google-Treffern nicht so richtig schlau geworden.

    @Kanonentux: In der resolv.conf stand nichts bedenkliches, insgesamt nur zwei Zeilen. Eine mit "search localdomain" und eine mit einem nameserver. Umbenennen und Neustarten hat wie erwartet nichts geändert. In Anlehnung daran hab ich im Networkmanager den Eintrag meines WLAN-Netzes gelöscht und neu angelegt, aber leider auch ohne Erfolg.

    In der Zwischenzeit hab ich scherzeshalber von Networkmanager auf wicked umgestellt und geschaut, ob ich es darüber verbunden kriege – erfolglos. Mir ist aber nach einem Neustart aufgefallen, dass wicked UND Networkmanager beide parallel liefen (mittels systemctl status bzw. ps -fe | grep -E "wicked|Network" überprüft). Und das, obwohl in Yast -> Dienste der Start von Networkmanager korrekt auf Manuell gestellt war.

    Jetzt habe ich wieder auf Networkmanager gestellt, und die WLAN-Verbindung krieg ich gar nicht mehr aktiviert, egal, wie oft ich die Antenne aus- und wieder einschalte. Ich habe jedoch einen Trick gefunden: Wenn ich, während Networkmanager versucht, sich mit dem WLAN zu verbinden, ein LAN-Kabel einstecke, verbindet sich NetworkManager zunächst per LAN mit dem Router, und 1-2s später auch per WLAN mit selbigem! Ich habe also sozusagen das berühmte WLAN-Kabel gefunden :D

    Kurz gefasst: Ich bin noch ratloser als zuvor. Habt ihr noch weitere Ideen?
    Dateien
    • journal-debug.txt

      (32,04 kB, 1 mal heruntergeladen, zuletzt: )

    Für den Inhalt des Beitrages 130530 haftet ausdrücklich der jeweilige Autor: Eldrad Ulthran

  • Eldrad Ulthran schrieb:

    Ich hab mal per iwlist scan wlan0 die Kanalbelegung angeschaut, dort treten zwei Einträge auf dem von mir verwendeten Kanal auf.
    Ist bei mir auch so.

    Auch wenn es nicht den allg. Sicherheitsrichtlinien entspricht, so teste trotzdem einmal folgende Einstellungen.
    Im Network Manager vorhandene WLAN-Verbindungen löschen
    In KWallet, unter Network Management, alles löschen
    Dann netconfig update -f
    Neue WLAN-Verbindung im Network Manager einrichten mit diesen Einstellungen:
    Networkmanager - Allgemeine Einstellungen - die ersten beiden Häkchen setzen
    Networkmanager - WiFi-Sicherheit - Passwort nur für alle Benutzer speichern (unverschlüsselt)
    Und deine restlichen Daten
    KWallet - bei Aufforderung ein leeres PWD (also keins)
    Wenn auch das nichts bringt, würde ich über einen neuen WLAN-Stick nachdenken.
    Zitat Albert Einstein:
    "Zwei Dinge sind unendlich, das Universum und die menschliche Dummheit,
    aber bei dem Universum bin ich mir noch nicht ganz sicher."

    Für den Inhalt des Beitrages 130532 haftet ausdrücklich der jeweilige Autor: sterun

  • Hab ich ausprobiert, ich kann mich immer noch nicht verbinden. Aber das hat meinen "Trick" mit dem LAN-Kabel kaputt gemacht, jetzt komm ich gar nicht mehr rein. Solange ich nicht verbunden bin, zeigt iwlist wlan1 scan nur einen Kanal 100 an, so wie früher auch. Erst im verbundenen Zustand zeigte dies zwei Verbindungen an.

    Ich hab mal journalctl mitlaufen lassen bei den scheiternden Verbindungsversuchen, es fängt an mit dem Einschalten der Antenne:

    Quellcode

    1. <info> [1552599967.8155] manager: rfkill: WiFi hardware radio set enabled
    2. Starting Load/Save RF Kill Switch Status...
    3. Started Load/Save RF Kill Switch Status.
    4. IPv6: ADDRCONF(NETDEV_UP): wlan1: link is not ready
    5. <info> [1552599968.5716] audit: op="radio-control" arg="wireless-enabled:1" pid=2868 uid=1000 result="success"
    6. <info> [1552599968.5719] manager: rfkill: WiFi now enabled by radio killswitch
    7. <info> [1552599968.6571] sup-iface[0x5610688bd970,wlan1]: supports 5 scan SSIDs
    8. <info> [1552599968.6605] device (wlan1): supplicant interface state: starting -> ready
    9. <info> [1552599968.6607] device (wlan1): state change: unavailable -> disconnected (reason 'supplicant-available', sys-iface-state: 'managed')
    10. IPv6: ADDRCONF(NETDEV_UP): wlan1: link is not ready
    11. Opening menu at 88 15
    12. QQuickView(0x560ee955ce90) must be a top level window.
    13. <info> [1552599978.0468] device (wlan1): Activation: starting connection 'REDACTED' (a87f45f6-0c9f-4e97-b80c-c806318f61a0)
    14. <info> [1552599978.0469] audit: op="connection-activate" uuid="a87f45f6-0c9f-4e97-b80c-c806318f61a0" name="REDACTED" pid=4256 uid=1000 result="success"
    15. <info> [1552599978.0471] device (wlan1): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed')
    16. <info> [1552599978.0472] manager: NetworkManager state is now CONNECTING
    17. <info> [1552599978.0503] device (wlan1): set-hw-addr: reset MAC address to 58:00:E3:E6:4D:17 (preserve)
    18. IPv6: ADDRCONF(NETDEV_UP): wlan1: link is not ready
    19. <info> [1552599978.0589] device (wlan1): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
    20. <info> [1552599978.0591] device (wlan1): Activation: (wifi) access point 'REDACTED' has security, but secrets are required.
    21. <info> [1552599978.0591] device (wlan1): state change: config -> need-auth (reason 'none', sys-iface-state: 'managed')
    22. <info> [1552599978.0629] device (wlan1): state change: need-auth -> prepare (reason 'none', sys-iface-state: 'managed')
    23. <info> [1552599978.0631] device (wlan1): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
    24. <info> [1552599978.0633] device (wlan1): Activation: (wifi) connection 'REDACTED' has security, and secrets exist. No new secrets needed.
    25. <info> [1552599978.0633] Config: added 'ssid' value 'REDACTED'
    26. <info> [1552599978.0633] Config: added 'scan_ssid' value '1'
    27. <info> [1552599978.0633] Config: added 'bgscan' value 'simple:30:-80:86400'
    28. <info> [1552599978.0634] Config: added 'key_mgmt' value 'WPA-PSK'
    29. <info> [1552599978.0634] Config: added 'psk' value '<hidden>'
    30. networkmanager-qt: virtual void NetworkManager::ActiveConnectionPrivate::propertyChanged(const QString&, const QVariant&) Unhandled property "StateFlags"
    31. networkmanager-qt: virtual void NetworkManager::ActiveConnectionPrivate::propertyChanged(const QString&, const QVariant&) Unhandled property "StateFlags"
    32. networkmanager-qt: virtual void NetworkManager::ActiveConnectionPrivate::propertyChanged(const QString&, const QVariant&) Unhandled property "StateFlags"
    33. plasma-nm: Unhandled active connection state change: 1
    34. <info> [1552599978.1163] device (wlan1): supplicant interface state: ready -> disconnected
    35. <info> [1552599978.1240] device (wlan1): supplicant interface state: disconnected -> inactive
    36. <info> [1552599978.1298] device (wlan1): supplicant interface state: inactive -> scanning
    37. <warn> [1552600003.3340] device (wlan1): Activation: (wifi) association took too long, failing activation
    38. <info> [1552600003.3341] device (wlan1): state change: config -> failed (reason 'ssid-not-found', sys-iface-state: 'managed')
    39. <info> [1552600003.3347] manager: NetworkManager state is now DISCONNECTED
    40. <warn> [1552600003.3371] device (wlan1): Activation: failed for connection 'REDACTED'
    41. <info> [1552600003.3380] device (wlan1): supplicant interface state: scanning -> disconnected
    42. <info> [1552600003.3392] device (wlan1): state change: failed -> disconnected (reason 'none', sys-iface-state: 'managed')
    43. IPv6: ADDRCONF(NETDEV_UP): wlan1: link is not ready
    44. <info> [1552600003.3445] device (wlan1): set-hw-addr: set MAC address to 8E:3A:00:78:C5:A5 (scanning)
    45. IPv6: ADDRCONF(NETDEV_UP): wlan1: link is not ready
    46. <info> [1552600003.3684] device (wlan1): supplicant interface state: disconnected -> disabled
    47. <info> [1552600003.4145] device (wlan1): supplicant interface state: disabled -> disconnected
    Alles anzeigen
    Die Fehlermeldung "ssid-not-found" ist Quatsch, der eingetragene Name (gelöscht) stimmt. Mich macht die Meldung "association took too long" etwas stutzig. Ist vielleicht irgendwo die Wartezeit zu gering eingestellt, und der Verbindungsversuch wird einfach zu schnell abgebrochen? Ich weiß ja nicht, wie lange so ne O2-Box tatsächlich braucht…

    Wenn ich das Netzwerk auf sichtbar stelle, erscheint es seltsamerweise trotzdem nicht in der Networkmanager-Liste der verfügbaren Netzwerke 0.o

    Es handelt sich hier um die eingebaute WLAN-PCI-Karte des Laptops, also keine USB-Antenne.

    Für den Inhalt des Beitrages 130575 haftet ausdrücklich der jeweilige Autor: Eldrad Ulthran

  • Wie @Sauerland schon vorschlug, wäre ein neuer Kernel einen Versuch wert, zumal es auch weitere Änderungen bzgl. ath10k geben soll.
    Hier nur ein Beispiel:
    Linux's Qualcomm Ath10k Driver Getting WoWLAN, WCN3990 Support - Phoronix
    Ich gehe stark davon aus, dass du weißt, wie das Repo eingebunden wird.
    Da jedoch auch andere mitlesen, trotzdem der Befehl:

    Quellcode

    1. zypper ar -f -p 20 https://download.opensuse.org/repositories/Kernel:/stable/standard/ kernel:stable
    Und

    Quellcode

    1. zypper -vv dup --allow-vendor-change --from kernel:stable
    Ich drück' dir die Daumen ...
    Zitat Albert Einstein:
    "Zwei Dinge sind unendlich, das Universum und die menschliche Dummheit,
    aber bei dem Universum bin ich mir noch nicht ganz sicher."

    Für den Inhalt des Beitrages 130587 haftet ausdrücklich der jeweilige Autor: sterun

  • Die stable-Kernel hätte ich am liebsten vermieden, weil sie auf diesem Laptop ziemlich nervig sind: Alle 2-3 Tage kommt ein Kernel-Update, wonach immer der Bumblebee-Treiber neu kompiliert werden muss. Das führt dazu, dass der Boot-Vorgang sehr häufig 1-2 Minuten dauert und nicht nur ca. 10s.
    Aber es scheint wohl kein Weg darum zu führen.

    Mit dem neuen 5.0-Kernel (Sauerlands firmware-Paket ist auch ersetzt durch das aus dem Repo) funktioniert das WLAN wieder einwandfrei, ich habe auch keine "link not ready"-Meldungen mehr. Die Passworteinstellungen "für alle User gespeichert" habe ich auch zurückgesetzt.

    Vielen Dank an alle Beteiligten für die Zeit und Hilfe!

    Für den Inhalt des Beitrages 130589 haftet ausdrücklich der jeweilige Autor: Eldrad Ulthran

  • Neu

    Aktuell fehlt glibc 2.29, um auf die Pakete aus diesem Repo zu updaten (in den Standard-Repos ist 2.26). Aber was würde mir das Bumblebee-kernel-stable-Repo denn bringen? Bumblebee läuft aktuell aus Index of /repositories/X11:/Bumblebee/openSUSE_Leap_15.0 ohne Probleme. Und dass bei jedem Kernel-Update dkms einspringt und den Treiber beim Booten neu kompiliert, lässt sich ja nicht vermeiden.

    Für den Inhalt des Beitrages 130641 haftet ausdrücklich der jeweilige Autor: Eldrad Ulthran

  • Neu

    Eldrad Ulthran schrieb:

    Und dass bei jedem Kernel-Update dkms einspringt und den Treiber beim Booten neu kompiliert, lässt sich ja nicht vermeiden.
    Das geht so lange gut, bis es eine Änderung im kernel gibt, die das bumblebee-kmp betreffen.......
    Aber ich würde das so lange so machen.

    Und ja, kernel:stable baut gegen factory und damit zur Zeit gegen glibc 2.29, das würde ich jetzt nicht gerade versuchen.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 130642 haftet ausdrücklich der jeweilige Autor: Sauerland